[PATCH v2 29/41] 9p: adapt to breakup of struct file_lock

2024-01-25 Thread Jeff Layton
Most of the existing APIs have remained the same, but subsystems that access file_lock fields directly need to reach into struct file_lock_core now. Signed-off-by: Jeff Layton --- fs/9p/vfs_file.c | 39 +++ 1 file changed, 19 insertions(+), 20 deletions(-)

[PATCH v2 28/41] filelock: convert seqfile handling to use file_lock_core

2024-01-25 Thread Jeff Layton
Reduce some pointer manipulation by just using file_lock_core where we can and only translate to a file_lock when needed. Signed-off-by: Jeff Layton --- fs/locks.c | 71 +++--- 1 file changed, 36 insertions(+), 35 deletions(-) diff --git

[PATCH v2 22/41] filelock: clean up locks_delete_block internals

2024-01-25 Thread Jeff Layton
Rework the internals of locks_delete_block to use struct file_lock_core (mostly just for clarity's sake). The prototype is not changed. Signed-off-by: Jeff Layton --- fs/locks.c | 15 --- 1 file changed, 8 insertions(+), 7 deletions(-) diff --git a/fs/locks.c b/fs/locks.c index

[PATCH v2 17/41] filelock: make locks_{insert,delete}_global_locks take file_lock_core arg

2024-01-25 Thread Jeff Layton
Convert these functions to take a file_lock_core instead of a file_lock. Signed-off-by: Jeff Layton --- fs/locks.c | 18 +- 1 file changed, 9 insertions(+), 9 deletions(-) diff --git a/fs/locks.c b/fs/locks.c index effe84f954f9..ad4bb9cd4c9d 100644 --- a/fs/locks.c +++

[PATCH v2 21/41] filelock: convert fl_blocker to file_lock_core

2024-01-25 Thread Jeff Layton
Both locks and leases deal with fl_blocker. Switch the fl_blocker pointer in struct file_lock_core to point to the file_lock_core of the blocker instead of a file_lock structure. Signed-off-by: Jeff Layton --- fs/locks.c | 16 include/linux/filelock.h

[PATCH v2 10/41] filelock: split common fields into struct file_lock_core

2024-01-25 Thread Jeff Layton
In a future patch, we're going to split file leases into their own structure. Since a lot of the underlying machinery uses the same fields move those into a new file_lock_core, and embed that inside struct file_lock. For now, add some macros to ensure that we can continue to build while the

[PATCH v2 27/41] filelock: convert locks_translate_pid to take file_lock_core

2024-01-25 Thread Jeff Layton
Signed-off-by: Jeff Layton --- fs/locks.c | 20 ++-- 1 file changed, 10 insertions(+), 10 deletions(-) diff --git a/fs/locks.c b/fs/locks.c index 0491d621417d..e8afdd084245 100644 --- a/fs/locks.c +++ b/fs/locks.c @@ -2169,17 +2169,17 @@ EXPORT_SYMBOL_GPL(vfs_test_lock); * *

[PATCH v2 41/41] filelock: split leases out of struct file_lock

2024-01-25 Thread Jeff Layton
Add a new struct file_lease and move the lease-specific fields from struct file_lock to it. Convert the appropriate API calls to take struct file_lease instead, and convert the callers to use them. There is zero overlap between the lock manager operations for file locks and the ones for file

[PATCH v2 40/41] filelock: remove temporary compatability macros

2024-01-25 Thread Jeff Layton
Everything has been converted to access fl_core fields directly, so we can now drop these. Signed-off-by: Jeff Layton --- include/linux/filelock.h | 16 1 file changed, 16 deletions(-) diff --git a/include/linux/filelock.h b/include/linux/filelock.h index

[PATCH v2 39/41] smb/server: adapt to breakup of struct file_lock

2024-01-25 Thread Jeff Layton
Most of the existing APIs have remained the same, but subsystems that access file_lock fields directly need to reach into struct file_lock_core now. Signed-off-by: Jeff Layton --- fs/smb/server/smb2pdu.c | 45 ++--- fs/smb/server/vfs.c | 15

[PATCH v2 38/41] smb/client: adapt to breakup of struct file_lock

2024-01-25 Thread Jeff Layton
Most of the existing APIs have remained the same, but subsystems that access file_lock fields directly need to reach into struct file_lock_core now. Signed-off-by: Jeff Layton --- fs/smb/client/cifsglob.h | 1 - fs/smb/client/cifssmb.c | 9 +++--- fs/smb/client/file.c | 75

[PATCH v2 37/41] ocfs2: adapt to breakup of struct file_lock

2024-01-25 Thread Jeff Layton
Most of the existing APIs have remained the same, but subsystems that access file_lock fields directly need to reach into struct file_lock_core now. Signed-off-by: Jeff Layton --- fs/ocfs2/locks.c | 13 ++--- fs/ocfs2/stack_user.c | 3 +-- 2 files changed, 7 insertions(+), 9

[PATCH v2 36/41] nfsd: adapt to breakup of struct file_lock

2024-01-25 Thread Jeff Layton
Most of the existing APIs have remained the same, but subsystems that access file_lock fields directly need to reach into struct file_lock_core now. Signed-off-by: Jeff Layton --- fs/nfsd/filecache.c| 4 +-- fs/nfsd/netns.h| 1 - fs/nfsd/nfs4callback.c | 2 +-

[PATCH v2 35/41] nfs: adapt to breakup of struct file_lock

2024-01-25 Thread Jeff Layton
Most of the existing APIs have remained the same, but subsystems that access file_lock fields directly need to reach into struct file_lock_core now. Signed-off-by: Jeff Layton --- fs/nfs/delegation.c | 4 ++-- fs/nfs/file.c | 23 +++ fs/nfs/nfs3proc.c | 2 +-

[PATCH v2 34/41] lockd: adapt to breakup of struct file_lock

2024-01-25 Thread Jeff Layton
Most of the existing APIs have remained the same, but subsystems that access file_lock fields directly need to reach into struct file_lock_core now. Signed-off-by: Jeff Layton --- fs/lockd/clnt4xdr.c | 14 +- fs/lockd/clntlock.c | 2 +- fs/lockd/clntproc.c | 62

[PATCH v2 33/41] gfs2: adapt to breakup of struct file_lock

2024-01-25 Thread Jeff Layton
Most of the existing APIs have remained the same, but subsystems that access file_lock fields directly need to reach into struct file_lock_core now. Signed-off-by: Jeff Layton --- fs/gfs2/file.c | 17 - 1 file changed, 8 insertions(+), 9 deletions(-) diff --git a/fs/gfs2/file.c

[PATCH v2 32/41] dlm: adapt to breakup of struct file_lock

2024-01-25 Thread Jeff Layton
Most of the existing APIs have remained the same, but subsystems that access file_lock fields directly need to reach into struct file_lock_core now. Signed-off-by: Jeff Layton --- fs/dlm/plock.c | 45 ++--- 1 file changed, 22 insertions(+), 23

[PATCH v2 31/41] ceph: adapt to breakup of struct file_lock

2024-01-25 Thread Jeff Layton
Most of the existing APIs have remained the same, but subsystems that access file_lock fields directly need to reach into struct file_lock_core now. Signed-off-by: Jeff Layton --- fs/ceph/locks.c | 75 + 1 file changed, 38 insertions(+),

[PATCH v2 30/41] afs: adapt to breakup of struct file_lock

2024-01-25 Thread Jeff Layton
Most of the existing APIs have remained the same, but subsystems that access file_lock fields directly need to reach into struct file_lock_core now. Signed-off-by: Jeff Layton --- fs/afs/flock.c | 55 +++--- fs/afs/internal.h | 1 -

[PATCH v2 20/41] filelock: convert __locks_insert_block, conflict and deadlock checks to use file_lock_core

2024-01-25 Thread Jeff Layton
Have both __locks_insert_block and the deadlock and conflict checking functions take a struct file_lock_core pointer instead of a struct file_lock one. Also, change posix_locks_deadlock to return bool. Signed-off-by: Jeff Layton --- fs/locks.c | 134

[PATCH v2 26/41] filelock: convert locks_insert_lock_ctx and locks_delete_lock_ctx

2024-01-25 Thread Jeff Layton
Have these functions take a file_lock_core pointer instead of a file_lock. Signed-off-by: Jeff Layton --- fs/locks.c | 44 ++-- 1 file changed, 22 insertions(+), 22 deletions(-) diff --git a/fs/locks.c b/fs/locks.c index 03985cfb7eff..0491d621417d 100644

[PATCH v2 25/41] filelock: convert locks_wake_up_blocks to take a file_lock_core pointer

2024-01-25 Thread Jeff Layton
Have locks_wake_up_blocks take a file_lock_core pointer, and fix up the callers to pass one in. Signed-off-by: Jeff Layton --- fs/locks.c | 14 +++--- 1 file changed, 7 insertions(+), 7 deletions(-) diff --git a/fs/locks.c b/fs/locks.c index 6182f5c5e7b4..03985cfb7eff 100644 ---

[PATCH v2 24/41] filelock: make assign_type helper take a file_lock_core pointer

2024-01-25 Thread Jeff Layton
Have assign_type take struct file_lock_core instead of file_lock. Signed-off-by: Jeff Layton --- fs/locks.c | 10 +- 1 file changed, 5 insertions(+), 5 deletions(-) diff --git a/fs/locks.c b/fs/locks.c index 647a778d2c85..6182f5c5e7b4 100644 --- a/fs/locks.c +++ b/fs/locks.c @@ -439,13

[PATCH v2 23/41] filelock: reorganize locks_delete_block and __locks_insert_block

2024-01-25 Thread Jeff Layton
Rename the old __locks_delete_block to __locks_unlink_lock. Rename change old locks_delete_block function to __locks_delete_block and have it take a file_lock_core. Make locks_delete_block a simple wrapper around __locks_delete_block. Also, change __locks_insert_block to take struct

[PATCH v2 19/41] filelock: make __locks_delete_block and __locks_wake_up_blocks take file_lock_core

2024-01-25 Thread Jeff Layton
Convert __locks_delete_block and __locks_wake_up_blocks to take a struct file_lock_core pointer. While we could do this in another way, we're going to need to add a file_lock() helper function later anyway, so introduce and use it now. Signed-off-by: Jeff Layton --- fs/locks.c | 45

[PATCH v2 18/41] filelock: convert locks_{insert,delete}_global_blocked

2024-01-25 Thread Jeff Layton
Have locks_insert_global_blocked and locks_delete_global_blocked take a struct file_lock_core pointer. Signed-off-by: Jeff Layton --- fs/locks.c | 13 ++--- 1 file changed, 6 insertions(+), 7 deletions(-) diff --git a/fs/locks.c b/fs/locks.c index ad4bb9cd4c9d..d6d47612527c 100644 ---

[PATCH v2 16/41] filelock: convert posix_owner_key to take file_lock_core arg

2024-01-25 Thread Jeff Layton
Convert posix_owner_key to take struct file_lock_core pointer, and fix up the callers to pass one in. Signed-off-by: Jeff Layton --- fs/locks.c | 8 1 file changed, 4 insertions(+), 4 deletions(-) diff --git a/fs/locks.c b/fs/locks.c index bd0cfee230ae..effe84f954f9 100644 ---

[PATCH v2 15/41] filelock: make posix_same_owner take file_lock_core pointers

2024-01-25 Thread Jeff Layton
Change posix_same_owner to take struct file_lock_core pointers, and convert the callers to pass those in. Signed-off-by: Jeff Layton --- fs/locks.c | 16 1 file changed, 8 insertions(+), 8 deletions(-) diff --git a/fs/locks.c b/fs/locks.c index a0d6fc0e043a..bd0cfee230ae

[PATCH v2 14/41] filelock: convert more internal functions to use file_lock_core

2024-01-25 Thread Jeff Layton
Convert more internal fs/locks.c functions to take and deal with struct file_lock_core instead of struct file_lock: - locks_dump_ctx_list - locks_check_ctx_file_list - locks_release_private - locks_owner_has_blockers Signed-off-by: Jeff Layton --- fs/locks.c | 51

[PATCH v2 13/41] filelock: convert some internal functions to use file_lock_core instead

2024-01-25 Thread Jeff Layton
Convert some internal fs/locks.c function to take and deal with struct file_lock_core instead of struct file_lock: - locks_init_lock_heads - locks_alloc_lock - locks_init_lock Signed-off-by: Jeff Layton --- fs/locks.c | 16 1 file changed, 8 insertions(+), 8 deletions(-) diff

[PATCH v2 12/41] filelock: have fs/locks.c deal with file_lock_core directly

2024-01-25 Thread Jeff Layton
Convert fs/locks.c to access fl_core fields direcly rather than using the backward-compatability macros. Most of this was done with coccinelle, with a few by-hand fixups. Signed-off-by: Jeff Layton --- fs/locks.c | 479

[PATCH v2 11/41] filelock: add coccinelle scripts to move fields to struct file_lock_core

2024-01-25 Thread Jeff Layton
This patch creates two ".cocci" semantic patches in a top level cocci/ directory. These patches were used to help generate several of the following patches. We can drop this patch or move the files to a more appropriate location before merging. Signed-off-by: Jeff Layton ---

[PATCH v2 05/41] nfsd: rename fl_type and fl_flags variables in nfsd4_lock

2024-01-25 Thread Jeff Layton
In later patches we're going to introduce some macros with names that clash with the variable names here. Rename them. Signed-off-by: Jeff Layton --- fs/nfsd/nfs4state.c | 24 1 file changed, 12 insertions(+), 12 deletions(-) diff --git a/fs/nfsd/nfs4state.c

[PATCH v2 09/41] filelock: drop the IS_* macros

2024-01-25 Thread Jeff Layton
These don't add a lot of value over just open-coding the flag check. Suggested-by: NeilBrown Signed-off-by: Jeff Layton --- fs/locks.c | 32 +++- 1 file changed, 15 insertions(+), 17 deletions(-) diff --git a/fs/locks.c b/fs/locks.c index 1eceaa56e47f..87212f86eca9

[PATCH v2 08/41] afs: rename fl_type variable in afs_next_locker

2024-01-25 Thread Jeff Layton
In later patches we're going to introduce macros that conflict with the variable name here. Rename it. Signed-off-by: Jeff Layton --- fs/afs/flock.c | 6 +++--- 1 file changed, 3 insertions(+), 3 deletions(-) diff --git a/fs/afs/flock.c b/fs/afs/flock.c index 9c6dea3139f5..e7feaf66bddf 100644

[PATCH v2 07/41] 9p: rename fl_type variable in v9fs_file_do_lock

2024-01-25 Thread Jeff Layton
In later patches, we're going to introduce some macros that conflict with the variable name here. Rename it. Signed-off-by: Jeff Layton --- fs/9p/vfs_file.c | 6 +++--- 1 file changed, 3 insertions(+), 3 deletions(-) diff --git a/fs/9p/vfs_file.c b/fs/9p/vfs_file.c index

[PATCH v2 06/41] lockd: rename fl_flags and fl_type variables in nlmclnt_lock

2024-01-25 Thread Jeff Layton
In later patches we're going to introduce some macros with names that clash with the variable names here. Rename them. Signed-off-by: Jeff Layton --- fs/lockd/clntproc.c | 20 ++-- 1 file changed, 10 insertions(+), 10 deletions(-) diff --git a/fs/lockd/clntproc.c

[PATCH v2 04/41] nfs: rename fl_flags variable in nfs4_proc_unlck

2024-01-25 Thread Jeff Layton
In later patches we're going to introduce some temporary macros with names that clash with the variable name here. Rename it. Signed-off-by: Jeff Layton --- fs/nfs/nfs4proc.c | 10 +- fs/nfs/nfs4state.c | 16 2 files changed, 13 insertions(+), 13 deletions(-) diff

[PATCH v2 03/41] dlm: rename fl_flags variable in dlm_posix_unlock

2024-01-25 Thread Jeff Layton
In later patches we're going to introduce some temporary macros with names that clash with the variable name here. Rename it. Signed-off-by: Jeff Layton --- fs/dlm/plock.c | 4 ++-- 1 file changed, 2 insertions(+), 2 deletions(-) diff --git a/fs/dlm/plock.c b/fs/dlm/plock.c index

[PATCH v2 02/41] filelock: rename fl_pid variable in lock_get_status

2024-01-25 Thread Jeff Layton
In later patches we're going to introduce some macros that will clash with the variable name here. Rename it. Signed-off-by: Jeff Layton --- fs/locks.c | 8 1 file changed, 4 insertions(+), 4 deletions(-) diff --git a/fs/locks.c b/fs/locks.c index cc7c117ee192..1eceaa56e47f 100644 ---

[PATCH v2 01/41] filelock: rename some fields in tracepoints

2024-01-25 Thread Jeff Layton
In later patches we're going to introduce some macros with names that clash with fields here. To prevent problems building, just rename the fields in the trace entry structures. Signed-off-by: Jeff Layton --- include/trace/events/filelock.h | 76 - 1 file

[PATCH v2 00/41] filelock: split struct file_lock into file_lock and file_lease structs

2024-01-25 Thread Jeff Layton
Long ago, file locks used to hang off of a singly-linked list in struct inode. Because of this, when leases were added, they were added to the same list and so they had to be tracked using the same sort of structure. Several years ago, we added struct file_lock_context, which allowed us to use

[PATCH v3] virtio_net: Support RX hash XDP hint

2024-01-25 Thread Liang Chen
The RSS hash report is a feature that's part of the virtio specification. Currently, virtio backends like qemu, vdpa (mlx5), and potentially vhost (still a work in progress as per [1]) support this feature. While the capability to obtain the RSS hash has been enabled in the normal path, it's

Re: [PATCH v2 1/3] virtio_net: Preserve virtio header before XDP program execution

2024-01-25 Thread Liang Chen
On Wed, Jan 24, 2024 at 5:08 PM Xuan Zhuo wrote: > > On Wed, 24 Jan 2024 16:57:19 +0800, Liang Chen > wrote: > > The xdp program may overwrite the inline virtio header. To ensure the > > integrity of the virtio header, it is saved in a data structure that > > wraps both the xdp_buff and the

Re: [PATCH v1 3/5] kbuild/modpost: integrate klp-convert

2024-01-25 Thread Lukas Hruska
There is also a typo in Makefile which causes a modules.livepatch file to be created in kernel sources even in case of building an external module. > diff --git a/Makefile b/Makefile > index 2fdd8b40b7e0..459b9c9fe0a8 100644 > --- a/Makefile > +++ b/Makefile > @@ -1185,6 +1185,7 @@ PHONY +=

Re: [PATCH net-next v1] vsock/test: print type for SOCK_SEQPACKET

2024-01-25 Thread Stefano Garzarella
On Wed, Jan 24, 2024 at 10:32:55PM +0300, Arseniy Krasnov wrote: SOCK_SEQPACKET is supported for virtio transport, so do not interpret such type of socket as unknown. Signed-off-by: Arseniy Krasnov --- tools/testing/vsock/vsock_diag_test.c | 2 ++ 1 file changed, 2 insertions(+) Yeah, LGTM!

<    1   2