[PATCH] staging: lustre: use linux headers

2015-02-09 Thread Asaf Vertz
WARNING: Use #include instead of WARNING: Use #include instead of WARNING: Use #include instead of Signed-off-by: Asaf Vertz --- .../staging/lustre/lnet/klnds/o2iblnd/o2iblnd.h|2 +- .../lustre/lnet/klnds/socklnd/socklnd_lib-linux.h |2 +- .../lustre/lustre/libcfs/linux/linux

[PATCH] staging: lustre: use linux headers

2015-02-09 Thread Asaf Vertz
WARNING: Use #include linux/uaccess.h instead of asm/uaccess.h WARNING: Use #include linux/statfs.h instead of asm/statfs.h WARNING: Use #include linux/kgdb.h instead of asm/kgdb.h Signed-off-by: Asaf Vertz asaf.ve...@tandemg.com --- .../staging/lustre/lnet/klnds/o2iblnd/o2iblnd.h|2

[PATCH] staging: lustre: lnet: fix space prohibited before that '++'

2015-02-01 Thread Asaf Vertz
Fixed a coding style error, space prohibited before that '++' Signed-off-by: Asaf Vertz --- drivers/staging/lustre/lnet/selftest/console.c | 28 1 files changed, 14 insertions(+), 14 deletions(-) diff --git a/drivers/staging/lustre/lnet/selftest/console.c b/drivers

[PATCH] staging: lustre: osc: fix space prohibited after that '!'

2015-02-01 Thread Asaf Vertz
Fixed a coding style error, space prohibited after that '!' Signed-off-by: Asaf Vertz --- drivers/staging/lustre/lustre/osc/osc_lock.c | 12 ++-- 1 files changed, 6 insertions(+), 6 deletions(-) diff --git a/drivers/staging/lustre/lustre/osc/osc_lock.c b/drivers/staging/lustre

[PATCH] staging: lustre: lnet: fix space prohibited before that '++'

2015-02-01 Thread Asaf Vertz
Fixed a coding style error, space prohibited before that '++' Signed-off-by: Asaf Vertz asaf.ve...@tandemg.com --- drivers/staging/lustre/lnet/selftest/console.c | 28 1 files changed, 14 insertions(+), 14 deletions(-) diff --git a/drivers/staging/lustre/lnet/selftest

[PATCH] staging: lustre: osc: fix space prohibited after that '!'

2015-02-01 Thread Asaf Vertz
Fixed a coding style error, space prohibited after that '!' Signed-off-by: Asaf Vertz asaf.ve...@tandemg.com --- drivers/staging/lustre/lustre/osc/osc_lock.c | 12 ++-- 1 files changed, 6 insertions(+), 6 deletions(-) diff --git a/drivers/staging/lustre/lustre/osc/osc_lock.c b

[PATCH] scsi: 3w-9xxx: fix format string warnings

2015-01-21 Thread Asaf Vertz
]: (warning) %d in format string (no. 11) requires 'int' but the argument type is 'unsigned int'. Signed-off-by: Asaf Vertz --- drivers/scsi/3w-9xxx.c | 20 ++-- 1 files changed, 10 insertions(+), 10 deletions(-) diff --git a/drivers/scsi/3w-9xxx.c b/drivers/scsi/3w-9xxx.c index

[PATCH] usb: gadget: zero: fix format string warnings

2015-01-21 Thread Asaf Vertz
is 'unsigned int' Signed-off-by: Asaf Vertz --- drivers/usb/gadget/function/f_sourcesink.c | 20 ++-- 1 files changed, 10 insertions(+), 10 deletions(-) diff --git a/drivers/usb/gadget/function/f_sourcesink.c b/drivers/usb/gadget/function/f_sourcesink.c index 80be25b..e07c50c

[PATCH] hwmon: abx500: fix format string warnings

2015-01-21 Thread Asaf Vertz
is 'unsigned long'. [drivers/hwmon/abx500.c:242]: (warning) %ld in format string (no. 1) requires 'long' but the argument type is 'unsigned long'. Signed-off-by: Asaf Vertz --- drivers/hwmon/abx500.c |6 +++--- 1 files changed, 3 insertions(+), 3 deletions(-) diff --git a/drivers/hwmon/abx500.c b

[PATCH] usb: gadget: zero: fix format string warnings

2015-01-21 Thread Asaf Vertz
is 'unsigned int' Signed-off-by: Asaf Vertz asaf.ve...@tandemg.com --- drivers/usb/gadget/function/f_sourcesink.c | 20 ++-- 1 files changed, 10 insertions(+), 10 deletions(-) diff --git a/drivers/usb/gadget/function/f_sourcesink.c b/drivers/usb/gadget/function/f_sourcesink.c index

[PATCH] hwmon: abx500: fix format string warnings

2015-01-21 Thread Asaf Vertz
is 'unsigned long'. [drivers/hwmon/abx500.c:242]: (warning) %ld in format string (no. 1) requires 'long' but the argument type is 'unsigned long'. Signed-off-by: Asaf Vertz asaf.ve...@tandemg.com --- drivers/hwmon/abx500.c |6 +++--- 1 files changed, 3 insertions(+), 3 deletions(-) diff --git a/drivers

[PATCH] scsi: 3w-9xxx: fix format string warnings

2015-01-21 Thread Asaf Vertz
]: (warning) %d in format string (no. 11) requires 'int' but the argument type is 'unsigned int'. Signed-off-by: Asaf Vertz asaf.ve...@tandemg.com --- drivers/scsi/3w-9xxx.c | 20 ++-- 1 files changed, 10 insertions(+), 10 deletions(-) diff --git a/drivers/scsi/3w-9xxx.c b

[PATCH] mmc: block: fix format string warning

2015-01-20 Thread Asaf Vertz
Fixed the following warning (reported by cppcheck): [drivers/mmc/card/block.c:2149]: (warning) %d in format string (no. 1) requires 'int' but the argument type is 'unsigned int'. Signed-off-by: Asaf Vertz --- drivers/mmc/card/block.c |2 +- 1 files changed, 1 insertions(+), 1 deletions

[PATCH] staging: iio: tsl2583: fix format string warnings

2015-01-20 Thread Asaf Vertz
' but the argument type is 'unsigned int'. [drivers/staging/iio/light/tsl2583.c:695]: (warning) %d in format string (no. 3) requires 'int' but the argument type is 'unsigned int'. Signed-off-by: Asaf Vertz --- drivers/staging/iio/light/tsl2583.c |2 +- 1 files changed, 1 insertions(+), 1 deletions(-) diff

[PATCH] staging: iio: tsl2x7x_core: fix format string warnings

2015-01-20 Thread Asaf Vertz
' but the argument type is 'unsigned int'. [drivers/staging/iio/light/tsl2x7x_core.c:1150]: (warning) %d in format string (no. 3) requires 'int' but the argument type is 'unsigned int'. Signed-off-by: Asaf Vertz --- drivers/staging/iio/light/tsl2x7x_core.c |2 +- 1 files changed, 1

[PATCH] staging: iio: tsl2x7x_core: fix format string warnings

2015-01-20 Thread Asaf Vertz
' but the argument type is 'unsigned int'. [drivers/staging/iio/light/tsl2x7x_core.c:1150]: (warning) %d in format string (no. 3) requires 'int' but the argument type is 'unsigned int'. Signed-off-by: Asaf Vertz asaf.ve...@tandemg.com --- drivers/staging/iio/light/tsl2x7x_core.c |2 +- 1

[PATCH] staging: iio: tsl2583: fix format string warnings

2015-01-20 Thread Asaf Vertz
' but the argument type is 'unsigned int'. [drivers/staging/iio/light/tsl2583.c:695]: (warning) %d in format string (no. 3) requires 'int' but the argument type is 'unsigned int'. Signed-off-by: Asaf Vertz asaf.ve...@tandemg.com --- drivers/staging/iio/light/tsl2583.c |2 +- 1 files changed, 1 insertions

[PATCH] mmc: block: fix format string warning

2015-01-20 Thread Asaf Vertz
Fixed the following warning (reported by cppcheck): [drivers/mmc/card/block.c:2149]: (warning) %d in format string (no. 1) requires 'int' but the argument type is 'unsigned int'. Signed-off-by: Asaf Vertz asaf.ve...@tandemg.com --- drivers/mmc/card/block.c |2 +- 1 files changed, 1

[PATCH] staging: iio: ad5933: fix format string warnings

2015-01-19 Thread Asaf Vertz
) requires 'int' but the argument type is 'unsigned int'. [drivers/staging/iio/impedance-analyzer/ad5933.c:367]: (warning) %d in format string (no. 4) requires 'int' but the argument type is 'unsigned int'. Signed-off-by: Asaf Vertz --- drivers/staging/iio/impedance-analyzer/ad5933.c |4 ++-- 1

[PATCH] staging: iio: ad5933: fix format string warnings

2015-01-19 Thread Asaf Vertz
) requires 'int' but the argument type is 'unsigned int'. [drivers/staging/iio/impedance-analyzer/ad5933.c:367]: (warning) %d in format string (no. 4) requires 'int' but the argument type is 'unsigned int'. Signed-off-by: Asaf Vertz asaf.ve...@tandemg.com --- drivers/staging/iio/impedance-analyzer

[PATCH] staging: wlan-ng: hfa384x_usb: fix sparse endianness warnings

2015-01-17 Thread Asaf Vertz
-off-by: Asaf Vertz --- drivers/staging/wlan-ng/hfa384x.h |4 ++-- drivers/staging/wlan-ng/hfa384x_usb.c |2 +- 2 files changed, 3 insertions(+), 3 deletions(-) diff --git a/drivers/staging/wlan-ng/hfa384x.h b/drivers/staging/wlan-ng/hfa384x.h index 20d146b..964a662 100644

[PATCH] staging: wlan-ng: hfa384x_usb: fix sparse endianness warnings

2015-01-17 Thread Asaf Vertz
Signed-off-by: Asaf Vertz asaf.ve...@tandemg.com --- drivers/staging/wlan-ng/hfa384x.h |4 ++-- drivers/staging/wlan-ng/hfa384x_usb.c |2 +- 2 files changed, 3 insertions(+), 3 deletions(-) diff --git a/drivers/staging/wlan-ng/hfa384x.h b/drivers/staging/wlan-ng/hfa384x.h index 20d146b

[PATCH] e1000: fix time comparison

2015-01-07 Thread Asaf Vertz
To be future-proof and for better readability the time comparisons are modified to use time_after_eq() instead of plain, error-prone math. Signed-off-by: Asaf Vertz --- drivers/net/ethernet/intel/e1000/e1000_ethtool.c |3 ++- 1 files changed, 2 insertions(+), 1 deletions(-) diff --git

[PATCH] e1000: fix time comparison

2015-01-07 Thread Asaf Vertz
To be future-proof and for better readability the time comparisons are modified to use time_after_eq() instead of plain, error-prone math. Signed-off-by: Asaf Vertz asaf.ve...@tandemg.com --- drivers/net/ethernet/intel/e1000/e1000_ethtool.c |3 ++- 1 files changed, 2 insertions(+), 1

[PATCH] rsxx: fix time comparison

2015-01-06 Thread Asaf Vertz
To be future-proof and for better readability the time comparisons are modified to use time_before() instead of plain, error-prone math. Signed-off-by: Asaf Vertz --- drivers/block/rsxx/core.c |9 + 1 files changed, 5 insertions(+), 4 deletions(-) diff --git a/drivers/block/rsxx

[PATCH] dm bufio: fix time comparison

2015-01-06 Thread Asaf Vertz
To be future-proof and for better readability the time comparison modified to use time_after_eq() instead of plain, error-prone math. Signed-off-by: Asaf Vertz --- drivers/md/dm-bufio.c |3 ++- 1 files changed, 2 insertions(+), 1 deletions(-) diff --git a/drivers/md/dm-bufio.c b/drivers/md

[PATCH] dm bufio: fix time comparison

2015-01-06 Thread Asaf Vertz
To be future-proof and for better readability the time comparison modified to use time_after_eq() instead of plain, error-prone math. Signed-off-by: Asaf Vertz asaf.ve...@tandemg.com --- drivers/md/dm-bufio.c |3 ++- 1 files changed, 2 insertions(+), 1 deletions(-) diff --git a/drivers/md

[PATCH] rsxx: fix time comparison

2015-01-06 Thread Asaf Vertz
To be future-proof and for better readability the time comparisons are modified to use time_before() instead of plain, error-prone math. Signed-off-by: Asaf Vertz asaf.ve...@tandemg.com --- drivers/block/rsxx/core.c |9 + 1 files changed, 5 insertions(+), 4 deletions(-) diff --git

[PATCH] crypto: omap-des: fix BUG_ON condition

2015-01-05 Thread Asaf Vertz
dd->total is unsigned so it won't do any good to check for negative value after subtracting instead of that we should check if the subtracted value is bigger than him This was partially found by using a static code analysis program called cppcheck. Signed-off-by: Asaf Vertz --- driv

[PATCH] crypto: omap-des: fix BUG_ON condition

2015-01-05 Thread Asaf Vertz
dd-total is unsigned so it won't do any good to check for negative value after subtracting instead of that we should check if the subtracted value is bigger than him This was partially found by using a static code analysis program called cppcheck. Signed-off-by: Asaf Vertz asaf.ve

[PATCH v2] staging: rtl8723au: core: fixing "foo * bar" should be "foo *bar"

2014-12-16 Thread Asaf Vertz
Fixed a coding style error, "foo * bar" should be "foo *bar" Signed-off-by: Asaf Vertz --- Changes in v2: - fix ugly multiline arguments to the functions drivers/staging/rtl8723au/core/rtw_efuse.c | 32 ++- 1 files changed, 7 insertions(+), 2

[PATCH] staging: rtl8723au: core: fixing "foo * bar" should be "foo *bar"

2014-12-16 Thread Asaf Vertz
Fixed a coding style error, "foo * bar" should be "foo *bar" Signed-off-by: Asaf Vertz --- drivers/staging/rtl8723au/core/rtw_efuse.c | 12 ++-- 1 files changed, 6 insertions(+), 6 deletions(-) diff --git a/drivers/staging/rtl8723au/core/rtw_efuse.c b/drivers/st

[PATCH] staging: rtl8723au: core: fixing foo * bar should be foo *bar

2014-12-16 Thread Asaf Vertz
Fixed a coding style error, foo * bar should be foo *bar Signed-off-by: Asaf Vertz asaf.ve...@tandemg.com --- drivers/staging/rtl8723au/core/rtw_efuse.c | 12 ++-- 1 files changed, 6 insertions(+), 6 deletions(-) diff --git a/drivers/staging/rtl8723au/core/rtw_efuse.c b/drivers

[PATCH v2] staging: rtl8723au: core: fixing foo * bar should be foo *bar

2014-12-16 Thread Asaf Vertz
Fixed a coding style error, foo * bar should be foo *bar Signed-off-by: Asaf Vertz asaf.ve...@tandemg.com --- Changes in v2: - fix ugly multiline arguments to the functions drivers/staging/rtl8723au/core/rtw_efuse.c | 32 ++- 1 files changed, 7 insertions(+), 25

[PATCH] usb: host: max3421-hcd: use time_after()

2014-12-14 Thread Asaf Vertz
To be future-proof and for better readability the time comparisons are modified to use time_after() instead of plain, error-prone math. Signed-off-by: Asaf Vertz --- drivers/usb/host/max3421-hcd.c |3 ++- 1 files changed, 2 insertions(+), 1 deletions(-) diff --git a/drivers/usb/host

[PATCH] cirrus: cs89x0: fix time comparison

2014-12-14 Thread Asaf Vertz
To be future-proof and for better readability the time comparisons are modified to use time_before, time_after, and time_after_eq instead of plain, error-prone math. Signed-off-by: Asaf Vertz --- drivers/net/ethernet/cirrus/cs89x0.c | 27 ++- 1 files changed, 14

[PATCH] cirrus: cs89x0: fix time comparison

2014-12-14 Thread Asaf Vertz
To be future-proof and for better readability the time comparisons are modified to use time_before, time_after, and time_after_eq instead of plain, error-prone math. Signed-off-by: Asaf Vertz asaf.ve...@tandemg.com --- drivers/net/ethernet/cirrus/cs89x0.c | 27 ++- 1

[PATCH] usb: host: max3421-hcd: use time_after()

2014-12-14 Thread Asaf Vertz
To be future-proof and for better readability the time comparisons are modified to use time_after() instead of plain, error-prone math. Signed-off-by: Asaf Vertz asaf.ve...@tandemg.com --- drivers/usb/host/max3421-hcd.c |3 ++- 1 files changed, 2 insertions(+), 1 deletions(-) diff --git

[PATCH] media: stb0899_drv: use time_after()

2014-12-13 Thread Asaf Vertz
To be future-proof and for better readability the time comparisons are modified to use time_after() instead of plain, error-prone math. Signed-off-by: Asaf Vertz --- drivers/media/dvb-frontends/stb0899_drv.c |7 --- 1 files changed, 4 insertions(+), 3 deletions(-) diff --git a/drivers

[PATCH] media: stb0899_drv: use time_after()

2014-12-13 Thread Asaf Vertz
To be future-proof and for better readability the time comparisons are modified to use time_after() instead of plain, error-prone math. Signed-off-by: Asaf Vertz asaf.ve...@tandemg.com --- drivers/media/dvb-frontends/stb0899_drv.c |7 --- 1 files changed, 4 insertions(+), 3 deletions

[PATCH] fbdev: vgastate: remove trailing whitespaces

2014-12-11 Thread Asaf Vertz
Fixed a coding style error, trailing whitespace. Signed-off-by: Asaf Vertz --- drivers/video/vgastate.c | 82 +++--- 1 files changed, 41 insertions(+), 41 deletions(-) diff --git a/drivers/video/vgastate.c b/drivers/video/vgastate.c index b91c466

[PATCH] fbdev: vgastate: remove trailing whitespaces

2014-12-11 Thread Asaf Vertz
Fixed a coding style error, trailing whitespace. Signed-off-by: Asaf Vertz asaf.ve...@tandemg.com --- drivers/video/vgastate.c | 82 +++--- 1 files changed, 41 insertions(+), 41 deletions(-) diff --git a/drivers/video/vgastate.c b/drivers/video

Re: [PATCH] dma: imx-sdma: fix indentation

2014-12-10 Thread Asaf Vertz
On 12/11/2014 06:50 AM, Vinod Koul wrote: > On Wed, Dec 10, 2014 at 10:00:36AM +0200, Asaf Vertz wrote: >> Fixed a coding style error, switch and case should be at the same indent > Please use the right subsystem name for the patches what subsystem name I should have used? I used

[PATCH] crypto: ux500: fix checkpatch errors

2014-12-10 Thread Asaf Vertz
Fixed a coding style error, code indent should use tabs where possible Signed-off-by: Asaf Vertz --- drivers/crypto/ux500/cryp/cryp_core.c |8 1 files changed, 4 insertions(+), 4 deletions(-) diff --git a/drivers/crypto/ux500/cryp/cryp_core.c b/drivers/crypto/ux500/cryp

[PATCH] dma: imx-sdma: fix indentation

2014-12-10 Thread Asaf Vertz
Fixed a coding style error, switch and case should be at the same indent Signed-off-by: Asaf Vertz --- drivers/dma/imx-sdma.c | 18 +- 1 files changed, 9 insertions(+), 9 deletions(-) diff --git a/drivers/dma/imx-sdma.c b/drivers/dma/imx-sdma.c index 88afc48..8729877 100644

Re: [PATCH] dma: imx-sdma: fix indentation

2014-12-10 Thread Asaf Vertz
On 12/11/2014 06:50 AM, Vinod Koul wrote: On Wed, Dec 10, 2014 at 10:00:36AM +0200, Asaf Vertz wrote: Fixed a coding style error, switch and case should be at the same indent Please use the right subsystem name for the patches what subsystem name I should have used? I used the one from

[PATCH] dma: imx-sdma: fix indentation

2014-12-10 Thread Asaf Vertz
Fixed a coding style error, switch and case should be at the same indent Signed-off-by: Asaf Vertz asaf.ve...@tandemg.com --- drivers/dma/imx-sdma.c | 18 +- 1 files changed, 9 insertions(+), 9 deletions(-) diff --git a/drivers/dma/imx-sdma.c b/drivers/dma/imx-sdma.c index

[PATCH] crypto: ux500: fix checkpatch errors

2014-12-10 Thread Asaf Vertz
Fixed a coding style error, code indent should use tabs where possible Signed-off-by: Asaf Vertz asaf.ve...@tandemg.com --- drivers/crypto/ux500/cryp/cryp_core.c |8 1 files changed, 4 insertions(+), 4 deletions(-) diff --git a/drivers/crypto/ux500/cryp/cryp_core.c b/drivers

[PATCH v2] input: edt-ft5x06: fixed a macro coding style issue

2014-12-09 Thread Asaf Vertz
Fixed a coding style error, macros with complex values should be enclosed in parentheses. Signed-off-by: Asaf Vertz --- Changes in v2: - use do {...} while (0) instead of {...} drivers/input/touchscreen/edt-ft5x06.c |4 +++- 1 files changed, 3 insertions(+), 1 deletions(-) diff --git

[PATCH v2] input: edt-ft5x06: fixed a macro coding style issue

2014-12-09 Thread Asaf Vertz
Fixed a coding style error, macros with complex values should be enclosed in parentheses. Signed-off-by: Asaf Vertz asaf.ve...@tandemg.com --- Changes in v2: - use do {...} while (0) instead of {...} drivers/input/touchscreen/edt-ft5x06.c |4 +++- 1 files changed, 3 insertions(+), 1

Re: [PATCH] input: edt-ft5x06: fixed a macro coding style issue

2014-12-08 Thread Asaf Vertz
On 12/09/2014 08:44 AM, Joe Perches wrote: > On Tue, 2014-12-09 at 08:34 +0200, Asaf Vertz wrote: >> Fixed a coding style error, macros with complex values should be >> enclosed in parentheses. >> >> -#define EDT_ATTR_CHECKSET(name, reg) \ >> +#d

[PATCH] input: edt-ft5x06: fixed a macro coding style issue

2014-12-08 Thread Asaf Vertz
Fixed a coding style error, macros with complex values should be enclosed in parentheses. Signed-off-by: Asaf Vertz --- drivers/input/touchscreen/edt-ft5x06.c |5 +++-- 1 files changed, 3 insertions(+), 2 deletions(-) diff --git a/drivers/input/touchscreen/edt-ft5x06.c b/drivers/input

[PATCH] input: edt-ft5x06: fixed a macro coding style issue

2014-12-08 Thread Asaf Vertz
Fixed a coding style error, macros with complex values should be enclosed in parentheses. Signed-off-by: Asaf Vertz asaf.ve...@tandemg.com --- drivers/input/touchscreen/edt-ft5x06.c |5 +++-- 1 files changed, 3 insertions(+), 2 deletions(-) diff --git a/drivers/input/touchscreen/edt-ft5x06

Re: [PATCH] input: edt-ft5x06: fixed a macro coding style issue

2014-12-08 Thread Asaf Vertz
On 12/09/2014 08:44 AM, Joe Perches wrote: On Tue, 2014-12-09 at 08:34 +0200, Asaf Vertz wrote: Fixed a coding style error, macros with complex values should be enclosed in parentheses. -#define EDT_ATTR_CHECKSET(name, reg) \ +#define EDT_ATTR_CHECKSET(name, reg) { \ if (pdata-name