Re: [REPOST PATCH 1/4] slab: factor out calculate nr objects in cache_estimate

2013-09-08 Thread Joonsoo Kim
On Fri, Sep 06, 2013 at 03:48:04PM +, Christoph Lameter wrote: > On Fri, 6 Sep 2013, Joonsoo Kim wrote: > > > } > > *num = nr_objs; > > - *left_over = slab_size - nr_objs*buffer_size - mgmt_size; > > + *left_over = slab_size - (nr_objs * buffer_size) - mgmt_size; > > } > > What

Re: [REPOST PATCH 1/4] slab: factor out calculate nr objects in cache_estimate

2013-09-08 Thread Joonsoo Kim
On Fri, Sep 06, 2013 at 03:48:04PM +, Christoph Lameter wrote: On Fri, 6 Sep 2013, Joonsoo Kim wrote: } *num = nr_objs; - *left_over = slab_size - nr_objs*buffer_size - mgmt_size; + *left_over = slab_size - (nr_objs * buffer_size) - mgmt_size; } What is the point

Re: [REPOST PATCH 1/4] slab: factor out calculate nr objects in cache_estimate

2013-09-06 Thread Christoph Lameter
On Fri, 6 Sep 2013, Joonsoo Kim wrote: > } > *num = nr_objs; > - *left_over = slab_size - nr_objs*buffer_size - mgmt_size; > + *left_over = slab_size - (nr_objs * buffer_size) - mgmt_size; > } What is the point of this change? Drop it. -- To unsubscribe from this list:

Re: [REPOST PATCH 1/4] slab: factor out calculate nr objects in cache_estimate

2013-09-06 Thread Christoph Lameter
On Fri, 6 Sep 2013, Joonsoo Kim wrote: } *num = nr_objs; - *left_over = slab_size - nr_objs*buffer_size - mgmt_size; + *left_over = slab_size - (nr_objs * buffer_size) - mgmt_size; } What is the point of this change? Drop it. -- To unsubscribe from this list: send the

[REPOST PATCH 1/4] slab: factor out calculate nr objects in cache_estimate

2013-09-05 Thread Joonsoo Kim
This logic is not simple to understand so that making separate function helping readability. Additionally, we can use this change in the following patch which implement for freelist to have another sized index in according to nr objects. Signed-off-by: Joonsoo Kim diff --git a/mm/slab.c

[REPOST PATCH 1/4] slab: factor out calculate nr objects in cache_estimate

2013-09-05 Thread Joonsoo Kim
This logic is not simple to understand so that making separate function helping readability. Additionally, we can use this change in the following patch which implement for freelist to have another sized index in according to nr objects. Signed-off-by: Joonsoo Kim iamjoonsoo@lge.com diff

[PATCH 1/4] slab: factor out calculate nr objects in cache_estimate

2013-09-02 Thread Joonsoo Kim
This logic is not simple to understand so that making separate function helping readability. Additionally, we can use this change in the following patch which implement for freelist to have another sized index in according to nr objects. Signed-off-by: Joonsoo Kim diff --git a/mm/slab.c

[PATCH 1/4] slab: factor out calculate nr objects in cache_estimate

2013-09-02 Thread Joonsoo Kim
This logic is not simple to understand so that making separate function helping readability. Additionally, we can use this change in the following patch which implement for freelist to have another sized index in according to nr objects. Signed-off-by: Joonsoo Kim iamjoonsoo@lge.com diff