Re: [PATCH v3 4/5] input: Add MediaTek PMIC keys support

2017-08-29 Thread Chen Zhong
Hi Andi, Sorry for that, i deleted some prefix since the namings will be such long. If this should be consistent, I'll check and modify them in the next version. Thank you. On Tue, 2017-08-29 at 16:34 +0900, Andi Shyti wrote: > Hi Chen, > > what I would ask you is to be consistent with the

Re: [PATCH v3 4/5] input: Add MediaTek PMIC keys support

2017-08-29 Thread Chen Zhong
Hi Andi, Sorry for that, i deleted some prefix since the namings will be such long. If this should be consistent, I'll check and modify them in the next version. Thank you. On Tue, 2017-08-29 at 16:34 +0900, Andi Shyti wrote: > Hi Chen, > > what I would ask you is to be consistent with the

Re: [PATCH v3 4/5] input: Add MediaTek PMIC keys support

2017-08-29 Thread Andi Shyti
Hi Chen, what I would ask you is to be consistent with the naming, if your driver is called mtk-pmic, then all your functions and global variables should be named accordingly as mtk_pmic or MTK_PMIC. Please check in between the lines for real examples: > +#define PWRKEY_RST_EN_MASK 0x1 >

Re: [PATCH v3 4/5] input: Add MediaTek PMIC keys support

2017-08-29 Thread Andi Shyti
Hi Chen, what I would ask you is to be consistent with the naming, if your driver is called mtk-pmic, then all your functions and global variables should be named accordingly as mtk_pmic or MTK_PMIC. Please check in between the lines for real examples: > +#define PWRKEY_RST_EN_MASK 0x1 >

Re: [PATCH v3 4/5] input: Add MediaTek PMIC keys support

2017-08-28 Thread Chen Zhong
On Mon, 2017-08-28 at 09:57 -0700, Dmitry Torokhov wrote: > Hi Chen, > > On Fri, Aug 25, 2017 at 02:32:32PM +0800, Chen Zhong wrote: > > +static int mtk_pmic_key_setup(struct mtk_pmic_keys *keys, > > + struct pmic_keys_info *info) > > +{ > > + int ret; > > + > > + info->keys = keys;

Re: [PATCH v3 4/5] input: Add MediaTek PMIC keys support

2017-08-28 Thread Chen Zhong
On Mon, 2017-08-28 at 09:57 -0700, Dmitry Torokhov wrote: > Hi Chen, > > On Fri, Aug 25, 2017 at 02:32:32PM +0800, Chen Zhong wrote: > > +static int mtk_pmic_key_setup(struct mtk_pmic_keys *keys, > > + struct pmic_keys_info *info) > > +{ > > + int ret; > > + > > + info->keys = keys;

Re: [PATCH v3 4/5] input: Add MediaTek PMIC keys support

2017-08-28 Thread Dmitry Torokhov
Hi Chen, On Fri, Aug 25, 2017 at 02:32:32PM +0800, Chen Zhong wrote: > +static int mtk_pmic_key_setup(struct mtk_pmic_keys *keys, > + struct pmic_keys_info *info) > +{ > + int ret; > + > + info->keys = keys; > + > + ret = regmap_update_bits(keys->regmap,

Re: [PATCH v3 4/5] input: Add MediaTek PMIC keys support

2017-08-28 Thread Dmitry Torokhov
Hi Chen, On Fri, Aug 25, 2017 at 02:32:32PM +0800, Chen Zhong wrote: > +static int mtk_pmic_key_setup(struct mtk_pmic_keys *keys, > + struct pmic_keys_info *info) > +{ > + int ret; > + > + info->keys = keys; > + > + ret = regmap_update_bits(keys->regmap,

[PATCH v3 4/5] input: Add MediaTek PMIC keys support

2017-08-25 Thread Chen Zhong
This patch add support to handle MediaTek PMIC MT6397/MT6323 key interrupts including pwrkey and homekey, also add setting for long press key shutdown behavior. Signed-off-by: Chen Zhong --- drivers/input/keyboard/Kconfig |9 +

[PATCH v3 4/5] input: Add MediaTek PMIC keys support

2017-08-25 Thread Chen Zhong
This patch add support to handle MediaTek PMIC MT6397/MT6323 key interrupts including pwrkey and homekey, also add setting for long press key shutdown behavior. Signed-off-by: Chen Zhong --- drivers/input/keyboard/Kconfig |9 + drivers/input/keyboard/Makefile|1 +