Re: [PATCH] exfat: retain 'VolumeFlags' properly

2020-07-30 Thread Tetsuhiro Kohada
On 2020/07/30 15:59, Namjae Jeon wrote: Ping.. Hi Tetsuhiro, Thank you for your reply. On 2020/07/15 19:06, Tetsuhiro Kohada wrote: It looks complicated. It would be better to simply set/clear VOLUME DIRTY bit. I think exfat_set_vol_flags() gets a little complicated, because it needs

RE: [PATCH] exfat: retain 'VolumeFlags' properly

2020-07-30 Thread Namjae Jeon
> Ping.. Hi Tetsuhiro, > > On 2020/07/15 19:06, Tetsuhiro Kohada wrote: > >> It looks complicated. It would be better to simply set/clear VOLUME DIRTY > >> bit. > > > > I think exfat_set_vol_flags() gets a little complicated, because it > > needs the followings (with bit operation) > > a)

Re: [PATCH] exfat: retain 'VolumeFlags' properly

2020-07-30 Thread Tetsuhiro Kohada
Ping.. On 2020/07/15 19:06, Tetsuhiro Kohada wrote: It looks complicated. It would be better to simply set/clear VOLUME DIRTY bit. I think exfat_set_vol_flags() gets a little complicated, because it needs the followings (with bit operation)  a) Set/Clear VOLUME_DIRTY.  b) Set MEDIA_FAILUR.

Re: [PATCH] exfat: retain 'VolumeFlags' properly

2020-07-15 Thread Tetsuhiro Kohada
Also, rename ERR_MEDIUM to MED_FAILURE. I think that MEDIA_FAILURE looks better. I think so too. If so, should I change VOL_DIRTY to VOLUME_DIRTY? Yes, maybe. OK. I'll rename both in v2. - p_boot->vol_flags = cpu_to_le16(new_flag); + p_boot->vol_flags =

RE: [PATCH] exfat: retain 'VolumeFlags' properly

2020-07-14 Thread Namjae Jeon
> Thanks for your reply. > > > > Also, rename ERR_MEDIUM to MED_FAILURE. > > I think that MEDIA_FAILURE looks better. > > I think so too. > If so, should I change VOL_DIRTY to VOLUME_DIRTY? Yes, maybe. > > > > -int exfat_set_vol_flags(struct super_block *sb, unsigned short > > > new_flag) > > >

RE: [PATCH] exfat: retain 'VolumeFlags' properly

2020-07-13 Thread kohada.tetsuh...@dc.mitsubishielectric.co.jp
Thanks for your reply. > > Also, rename ERR_MEDIUM to MED_FAILURE. > I think that MEDIA_FAILURE looks better. I think so too. If so, should I change VOL_DIRTY to VOLUME_DIRTY? > > -int exfat_set_vol_flags(struct super_block *sb, unsigned short > > new_flag) > > +int exfat_set_vol_flags(struct

RE: [PATCH] exfat: retain 'VolumeFlags' properly

2020-07-12 Thread Namjae Jeon
Hi Tetsuhiro, > Retain ActiveFat, MediaFailure and ClearToZero fields. > And, never clear VolumeDirty, if it is dirty at mount. > > In '3.1.13.3 Media Failure Field' of exfat specification says ... > If, upon mounting a volume, the value of this field is 1, implementations > which scan the