Re: [GIT PULL] LIBNVDIMM update for v5.18

2022-03-30 Thread pr-tracker-bot
The pull request you sent on Tue, 29 Mar 2022 13:54:41 -0700: > git://git.kernel.org/pub/scm/linux/kernel/git/nvdimm/nvdimm > tags/libnvdimm-for-5.18 has been merged into torvalds/linux.git: https://git.kernel.org/torvalds/c/ee96dd9614f1c139e719dd2f296acbed7f1ab4b8 Thank you! --

Re: [PATCH v11 1/8] dax: Introduce holder for dax_device

2022-03-30 Thread Darrick J. Wong
On Wed, Mar 30, 2022 at 08:49:29AM -0700, Christoph Hellwig wrote: > On Wed, Mar 30, 2022 at 06:58:21PM +0800, Shiyang Ruan wrote: > > As the code I pasted before, pmem driver will subtract its ->data_offset, > > which is byte-based. And the filesystem who implements ->notify_failure() > > will

Re: [PATCH v11 7/8] xfs: Implement ->notify_failure() for XFS

2022-03-30 Thread Christoph Hellwig
On Wed, Mar 30, 2022 at 11:16:10PM +0800, Shiyang Ruan wrote: > > > +#if IS_ENABLED(CONFIG_MEMORY_FAILURE) && IS_ENABLED(CONFIG_FS_DAX) > > > > No real need for the IS_ENABLED. Also any reason to even build this > > file if the options are not set? It seems like > > xfs_dax_holder_operations

Re: [PATCH v11 1/8] dax: Introduce holder for dax_device

2022-03-30 Thread Christoph Hellwig
On Wed, Mar 30, 2022 at 06:58:21PM +0800, Shiyang Ruan wrote: > As the code I pasted before, pmem driver will subtract its ->data_offset, > which is byte-based. And the filesystem who implements ->notify_failure() > will calculate the offset in unit of byte again. > > So, leave its function

Re: [PATCH v11 7/8] xfs: Implement ->notify_failure() for XFS

2022-03-30 Thread Shiyang Ruan
在 2022/3/30 14:00, Christoph Hellwig 写道: @@ -1892,6 +1893,8 @@ xfs_free_buftarg( list_lru_destroy(>bt_lru); blkdev_issue_flush(btp->bt_bdev); + if (btp->bt_daxdev) + dax_unregister_holder(btp->bt_daxdev, btp->bt_mount); fs_put_dax(btp->bt_daxdev);

Re: [PATCH v11 1/8] dax: Introduce holder for dax_device

2022-03-30 Thread Shiyang Ruan
在 2022/3/30 18:13, Christoph Hellwig 写道: On Wed, Mar 30, 2022 at 06:03:01PM +0800, Shiyang Ruan wrote: Because I am not sure if the offset between each layer is page aligned. For example, when pmem dirver handles ->memory_failure(), it should subtract its ->data_offset when it calls

Re: [PATCH v11 1/8] dax: Introduce holder for dax_device

2022-03-30 Thread Christoph Hellwig
On Wed, Mar 30, 2022 at 06:03:01PM +0800, Shiyang Ruan wrote: > > Because I am not sure if the offset between each layer is page aligned. For > example, when pmem dirver handles ->memory_failure(), it should subtract its > ->data_offset when it calls dax_holder_notify_failure(). If they aren't,

Re: [PATCH v11 1/8] dax: Introduce holder for dax_device

2022-03-30 Thread Shiyang Ruan
在 2022/3/30 13:41, Christoph Hellwig 写道: On Wed, Mar 16, 2022 at 09:46:07PM +0800, Shiyang Ruan wrote: Forgive me if this has been discussed before, but since dax_operations are in terms of pgoff and nr pages and memory_failure() is in terms of pfns what was the rationale for making the

Re: [PATCH v6 3/6] mm: rmap: introduce pfn_mkclean_range() to cleans PTEs

2022-03-30 Thread Christoph Hellwig
On Wed, Mar 30, 2022 at 03:31:37PM +0800, Muchun Song wrote: > I saw Shiyang is ready to rebase onto this patch. So should I > move it to linux/mm.h or let Shiyang does? Good question. I think Andrew has this series in -mm and ready to go to Linus, so maybe it is best if we don't change too

Re: [PATCH v6 3/6] mm: rmap: introduce pfn_mkclean_range() to cleans PTEs

2022-03-30 Thread Muchun Song
On Wed, Mar 30, 2022 at 1:47 PM Christoph Hellwig wrote: > > On Tue, Mar 29, 2022 at 09:48:50PM +0800, Muchun Song wrote: > > + * * Return the start of user virtual address at the specific offset within > > Double "*" here. Thanks for pointing out this. > > Also Shiyang has been wanting a quite

Re: [PATCH v11 5/8] mm: move pgoff_address() to vma_pgoff_address()

2022-03-30 Thread Shiyang Ruan
在 2022/3/30 13:46, Christoph Hellwig 写道: On Sun, Feb 27, 2022 at 08:07:44PM +0800, Shiyang Ruan wrote: Since it is not a DAX-specific function, move it into mm and rename it to be a generic helper. FYI, there is a patch in -mm and linux-next: "mm: rmap: introduce pfn_mkclean_range() to

Re: [PATCH v11 7/8] xfs: Implement ->notify_failure() for XFS

2022-03-30 Thread Christoph Hellwig
> @@ -1892,6 +1893,8 @@ xfs_free_buftarg( > list_lru_destroy(>bt_lru); > > blkdev_issue_flush(btp->bt_bdev); > + if (btp->bt_daxdev) > + dax_unregister_holder(btp->bt_daxdev, btp->bt_mount); > fs_put_dax(btp->bt_daxdev); > > kmem_free(btp); > @@ -1939,6