Re: [PATCH] scsi: qedi: fix missing return error code check on call to qedi_setup_int

2017-02-28 Thread Rangankar, Manish
On 28/02/17 4:32 PM, "Colin King" wrote: >From: Colin Ian King > >The call to qedi_setup_int is not updating the return code rc yet rc >is being checked for an error. Fix this by assigning rc to the return >code from the call to

Re: [PATCH] scsi: qedi: select UIO

2017-01-11 Thread Rangankar, Manish
On 11/01/17 9:40 AM, "Martin K. Petersen" wrote: >> "Ewan" == Ewan D Milne writes: > >Ewan> Randy posted a similar patch back in December but I don't think >Ewan> there was ever a reply to Christoph's question about why qedi >Ewan> depends on

Re: [PATCH] scsi: qedi: return via va_end to match corresponding va_start

2016-12-22 Thread Rangankar, Manish
On 16/12/16 7:40 PM, "Colin King" wrote: >From: Colin Ian King > >Although on most systems va_end is a no-op, it is good practice >to use va_end on the function return path, especially since the >va_start documenation states: > > "Each

Re: [PATCH] [v2] scsi: qedi: fix build error without DEBUG_FS

2017-03-03 Thread Rangankar, Manish
On 02/03/17 8:28 PM, "Arnd Bergmann" wrote: >Without CONFIG_DEBUG_FS, we run into a link error: > >drivers/scsi/qedi/qedi_iscsi.o: In function `qedi_ep_poll': >qedi_iscsi.c:(.text.qedi_ep_poll+0x134): undefined reference to >`do_not_recover' >drivers/scsi/qedi/qedi_iscsi.o: In

Re: [PATCH] scsi: qedi: fix another spelling mistake: "alloction" -> "allocation"

2017-07-03 Thread Rangankar, Manish
On 03/07/17 3:54 PM, "Colin King" wrote: >From: Colin Ian King > >Trivial fix to spelling mistake in QEDF_ERR message. I should have >also included this in a previous fix, but I only just spotted this one. > >Signed-off-by: Colin Ian King

Re: [PATCH] qla4xxx: fix spelling mistake: "Tempalate" -> "Template"

2017-04-25 Thread Rangankar, Manish
On 26/04/17 3:07 AM, "Colin King" wrote: >From: Colin Ian King > >trivial fix to spelling mistake in DEBUG2 debug message > >Signed-off-by: Colin Ian King >--- > drivers/scsi/qla4xxx/ql4_init.c | 2 +- > 1 file

Re: [PATCH] scsi: qedi: Remove comparison of u16 idx with zero.

2017-06-26 Thread Rangankar, Manish
On 24/06/17 9:54 PM, "Christos Gkekas" wrote: >Variable idx is defined as u16 thus statement (idx < 0) is >always false and should be removed. > >Signed-off-by: Christos Gkekas >--- > drivers/scsi/qedi/qedi_fw.c | 4 ++-- > 1 file changed, 2

Re: [PATCH 0/7] Enable iSCSI offload drivers to use information from iface.

2017-06-14 Thread Rangankar, Manish
On 13/06/17 10:19 PM, "Robert LeBlanc" wrote: >On Wed, Jun 7, 2017 at 12:30 PM, Robert LeBlanc >wrote: >> On Wed, Jun 7, 2017 at 10:28 AM, Chris Leech wrote: >>> On Tue, Jun 06, 2017 at 12:07:10PM -0600, Robert LeBlanc wrote:

Re: [PATCH] scsi: qedi: Delete redundant variables

2017-10-15 Thread Rangankar, Manish
On 14/10/17 5:47 PM, "Christos Gkekas" wrote: >Remove redundant variables in quedi_fw.c that are set but not used. > >Signed-off-by: Christos Gkekas >--- > drivers/scsi/qedi/qedi_fw.c | 17 + > 1 file changed, 1 insertion(+), 16

Re: [PATCH] bnx2i: Clean up unused pointers in bnx2i_hwi

2017-09-10 Thread Rangankar, Manish
On 10/09/17 5:48 PM, "Christos Gkekas" wrote: >Pointers bnx2i_cmd are set but never used, so they can be removed. > >Signed-off-by: Christos Gkekas >--- > drivers/scsi/bnx2i/bnx2i_hwi.c | 10 -- > 1 file changed, 10 deletions(-) > >diff

Re: [PATCH] scsi: bnx2i: bnx2i_hwi: use swap macro in bnx2i_send_iscsi_nopout

2017-11-13 Thread Rangankar, Manish
On 04/11/17 1:28 AM, "Gustavo A. R. Silva" wrote: >Make use of the swap macro and remove unnecessary variable tmp. >This makes the code easier to read and maintain. > >This code was detected with the help of Coccinelle. > >Signed-off-by: Gustavo A. R. Silva

Re: [PATCH] qedi: Fix a possible sleep-in-atomic bug in qedi_process_tmf_resp

2017-12-13 Thread Rangankar, Manish
On 13/12/17 2:41 PM, "Jia-Ju Bai" wrote: >The driver may sleep under a spinlock. >The function call path is: >qedi_cpu_offline (acquire the spinlock) > qedi_fp_process_cqes >qedi_mtask_completion > qedi_process_tmf_resp >kzalloc(GFP_KERNEL) --> may

Re: [PATCH] scsi: qla4xxx: Convert timers to use timer_setup()

2017-11-01 Thread Rangankar, Manish
On 25/10/17 3:37 PM, "Kees Cook" wrote: >In preparation for unconditionally passing the struct timer_list pointer >to >all timer callbacks, switch to using the new timer_setup() and >from_timer() >to pass the timer pointer explicitly. > >Cc:

RE: [PATCH] scsi: qla4xxx: add error handling for try_module_get

2018-06-12 Thread Rangankar, Manish
> -Original Message- > From: Zhouyang Jia > Sent: Tuesday, June 12, 2018 10:18 AM > Cc: Zhouyang Jia ; Dept-Eng QLogic Storage > Upstream ; James E.J. Bottomley > ; Martin K. Petersen ; > linux-s...@vger.kernel.org; linux-kernel@vger.kernel.org > Subject: [PATCH] scsi: qla4xxx: add

Re: [PATCH 5/6] scsi: qedi: fix building with LTO

2018-02-04 Thread Rangankar, Manish
On 02/02/18 6:42 PM, "Arnd Bergmann" wrote: >When link-time optimizations are enabled, qedi fails to build because >of mismatched prototypes: > >drivers/scsi/qedi/qedi_gbl.h:27:37: error: type of 'qedi_dbg_fops' does >not match original declaration [-Werror=lto-type-mismatch] >

Re: [PATCH 1/9] scsi: qla4xxx: Use zeroing allocator rather than allocator/memset

2018-01-01 Thread Rangankar, Manish
On 30/12/17 8:58 PM, "Himanshu Jha" wrote: >Use dma_zalloc_coherent instead of dma_alloc_coherent followed by memset >0. > >Generated-by: scripts/coccinelle/api/alloc/kzalloc-simple.cocci > >Suggested-by: Luis R. Rodriguez >Signed-off-by:

Re: [PATCH 3/9] scsi: qedi: Use zeroing allocator instead of allocator/memset

2018-01-01 Thread Rangankar, Manish
On 30/12/17 8:58 PM, "Himanshu Jha" wrote: >Use dma_zalloc_coherent instead of dma_alloc_coherent followed by memset >0. > >Generated-by: scripts/coccinelle/api/alloc/kzalloc-simple.cocci > >Suggested-by: Luis R. Rodriguez >Signed-off-by:

Re: [PATCH 9/9] scsi: bnx2i: Use zeroing allocator rather than allocator/memset

2018-01-01 Thread Rangankar, Manish
On 30/12/17 8:58 PM, "Himanshu Jha" wrote: >Use dma_zalloc_coherent instead of dma_alloc_coherent followed by >memset 0. > >Generated-by: scripts/coccinelle/api/alloc/kzalloc-simple.cocci > >Suggested-by: Luis R. Rodriguez >Signed-off-by:

RE: [PATCH] scsi: qla4xxx: NULL check before some freeing functions is not needed.

2018-12-02 Thread Rangankar, Manish
> -Original Message- > From: Thomas Meyer > Sent: Monday, December 3, 2018 2:22 AM > To: Dept-Eng QLogic Storage Upstream upstr...@cavium.com>; j...@linux.vnet.ibm.com; > martin.peter...@oracle.com; linux-s...@vger.kernel.org; linux- > ker...@vger.kernel.org > Subject: [PATCH] scsi:

RE: [PATCH] scsi: qedf: NULL check before some freeing functions is not needed.

2018-12-02 Thread Rangankar, Manish
> -Original Message- > From: Thomas Meyer > Sent: Monday, December 3, 2018 2:22 AM > To: Dept-Eng QLogic Storage Upstream upstr...@cavium.com>; j...@linux.vnet.ibm.com; > martin.peter...@oracle.com; linux-s...@vger.kernel.org; linux- > ker...@vger.kernel.org > Subject: [PATCH] scsi:

Re: [PATCH] scsi: qedi: Delete redundant variables

2017-10-15 Thread Rangankar, Manish
On 14/10/17 5:47 PM, "Christos Gkekas" wrote: >Remove redundant variables in quedi_fw.c that are set but not used. > >Signed-off-by: Christos Gkekas >--- > drivers/scsi/qedi/qedi_fw.c | 17 + > 1 file changed, 1 insertion(+), 16 deletions(-) > >diff --git

Re: [PATCH] scsi: qla4xxx: Convert timers to use timer_setup()

2017-11-01 Thread Rangankar, Manish
On 25/10/17 3:37 PM, "Kees Cook" wrote: >In preparation for unconditionally passing the struct timer_list pointer >to >all timer callbacks, switch to using the new timer_setup() and >from_timer() >to pass the timer pointer explicitly. > >Cc: qlogic-storage-upstr...@qlogic.com >Cc: "James E.J.

Re: [PATCH] scsi: bnx2i: bnx2i_hwi: use swap macro in bnx2i_send_iscsi_nopout

2017-11-13 Thread Rangankar, Manish
On 04/11/17 1:28 AM, "Gustavo A. R. Silva" wrote: >Make use of the swap macro and remove unnecessary variable tmp. >This makes the code easier to read and maintain. > >This code was detected with the help of Coccinelle. > >Signed-off-by: Gustavo A. R. Silva >--- >

Re: [PATCH 5/6] scsi: qedi: fix building with LTO

2018-02-04 Thread Rangankar, Manish
On 02/02/18 6:42 PM, "Arnd Bergmann" wrote: >When link-time optimizations are enabled, qedi fails to build because >of mismatched prototypes: > >drivers/scsi/qedi/qedi_gbl.h:27:37: error: type of 'qedi_dbg_fops' does >not match original declaration [-Werror=lto-type-mismatch] > extern const

Re: [PATCH 1/9] scsi: qla4xxx: Use zeroing allocator rather than allocator/memset

2018-01-01 Thread Rangankar, Manish
On 30/12/17 8:58 PM, "Himanshu Jha" wrote: >Use dma_zalloc_coherent instead of dma_alloc_coherent followed by memset >0. > >Generated-by: scripts/coccinelle/api/alloc/kzalloc-simple.cocci > >Suggested-by: Luis R. Rodriguez >Signed-off-by: Himanshu Jha >--- > drivers/scsi/qla4xxx/ql4_init.c |

Re: [PATCH 3/9] scsi: qedi: Use zeroing allocator instead of allocator/memset

2018-01-01 Thread Rangankar, Manish
On 30/12/17 8:58 PM, "Himanshu Jha" wrote: >Use dma_zalloc_coherent instead of dma_alloc_coherent followed by memset >0. > >Generated-by: scripts/coccinelle/api/alloc/kzalloc-simple.cocci > >Suggested-by: Luis R. Rodriguez >Signed-off-by: Himanshu Jha >--- > drivers/scsi/qedi/qedi_main.c |

Re: [PATCH 9/9] scsi: bnx2i: Use zeroing allocator rather than allocator/memset

2018-01-01 Thread Rangankar, Manish
On 30/12/17 8:58 PM, "Himanshu Jha" wrote: >Use dma_zalloc_coherent instead of dma_alloc_coherent followed by >memset 0. > >Generated-by: scripts/coccinelle/api/alloc/kzalloc-simple.cocci > >Suggested-by: Luis R. Rodriguez >Signed-off-by: Himanshu Jha >--- > drivers/scsi/bnx2i/bnx2i_hwi.c |

Re: [PATCH] scsi: qedi: fix another spelling mistake: "alloction" -> "allocation"

2017-07-03 Thread Rangankar, Manish
On 03/07/17 3:54 PM, "Colin King" wrote: >From: Colin Ian King > >Trivial fix to spelling mistake in QEDF_ERR message. I should have >also included this in a previous fix, but I only just spotted this one. > >Signed-off-by: Colin Ian King >--- > drivers/scsi/qedi/qedi_fw.c | 2 +- > 1 file

Re: [PATCH] bnx2i: Clean up unused pointers in bnx2i_hwi

2017-09-10 Thread Rangankar, Manish
On 10/09/17 5:48 PM, "Christos Gkekas" wrote: >Pointers bnx2i_cmd are set but never used, so they can be removed. > >Signed-off-by: Christos Gkekas >--- > drivers/scsi/bnx2i/bnx2i_hwi.c | 10 -- > 1 file changed, 10 deletions(-) > >diff --git a/drivers/scsi/bnx2i/bnx2i_hwi.c

Re: [PATCH] qedi: Fix a possible sleep-in-atomic bug in qedi_process_tmf_resp

2017-12-13 Thread Rangankar, Manish
On 13/12/17 2:41 PM, "Jia-Ju Bai" wrote: >The driver may sleep under a spinlock. >The function call path is: >qedi_cpu_offline (acquire the spinlock) > qedi_fp_process_cqes >qedi_mtask_completion > qedi_process_tmf_resp >kzalloc(GFP_KERNEL) --> may sleep > >To fix it,

RE: [PATCH] scsi: qla4xxx: NULL check before some freeing functions is not needed.

2018-12-02 Thread Rangankar, Manish
> -Original Message- > From: Thomas Meyer > Sent: Monday, December 3, 2018 2:22 AM > To: Dept-Eng QLogic Storage Upstream upstr...@cavium.com>; j...@linux.vnet.ibm.com; > martin.peter...@oracle.com; linux-s...@vger.kernel.org; linux- > ker...@vger.kernel.org > Subject: [PATCH] scsi:

RE: [PATCH] scsi: qedf: NULL check before some freeing functions is not needed.

2018-12-02 Thread Rangankar, Manish
> -Original Message- > From: Thomas Meyer > Sent: Monday, December 3, 2018 2:22 AM > To: Dept-Eng QLogic Storage Upstream upstr...@cavium.com>; j...@linux.vnet.ibm.com; > martin.peter...@oracle.com; linux-s...@vger.kernel.org; linux- > ker...@vger.kernel.org > Subject: [PATCH] scsi:

RE: [PATCH] scsi: qla4xxx: add error handling for try_module_get

2018-06-12 Thread Rangankar, Manish
> -Original Message- > From: Zhouyang Jia > Sent: Tuesday, June 12, 2018 10:18 AM > Cc: Zhouyang Jia ; Dept-Eng QLogic Storage > Upstream ; James E.J. Bottomley > ; Martin K. Petersen ; > linux-s...@vger.kernel.org; linux-kernel@vger.kernel.org > Subject: [PATCH] scsi: qla4xxx: add

Re: [PATCH] scsi: qedi: Remove comparison of u16 idx with zero.

2017-06-26 Thread Rangankar, Manish
On 24/06/17 9:54 PM, "Christos Gkekas" wrote: >Variable idx is defined as u16 thus statement (idx < 0) is >always false and should be removed. > >Signed-off-by: Christos Gkekas >--- > drivers/scsi/qedi/qedi_fw.c | 4 ++-- > 1 file changed, 2 insertions(+), 2 deletions(-) > >diff --git

Re: [PATCH 0/7] Enable iSCSI offload drivers to use information from iface.

2017-06-14 Thread Rangankar, Manish
On 13/06/17 10:19 PM, "Robert LeBlanc" wrote: >On Wed, Jun 7, 2017 at 12:30 PM, Robert LeBlanc >wrote: >> On Wed, Jun 7, 2017 at 10:28 AM, Chris Leech wrote: >>> On Tue, Jun 06, 2017 at 12:07:10PM -0600, Robert LeBlanc wrote: This patchset enables iSCSI offload drivers to have access to

Re: [PATCH] scsi: qedi: fix missing return error code check on call to qedi_setup_int

2017-02-28 Thread Rangankar, Manish
On 28/02/17 4:32 PM, "Colin King" wrote: >From: Colin Ian King > >The call to qedi_setup_int is not updating the return code rc yet rc >is being checked for an error. Fix this by assigning rc to the return >code from the call to qedi_setup_int. > >Signed-off-by: Colin Ian King >--- >

Re: [PATCH] scsi: qedi: select UIO

2017-01-11 Thread Rangankar, Manish
On 11/01/17 9:40 AM, "Martin K. Petersen" wrote: >> "Ewan" == Ewan D Milne writes: > >Ewan> Randy posted a similar patch back in December but I don't think >Ewan> there was ever a reply to Christoph's question about why qedi >Ewan> depends on uio. > >I did queue up Randy's patch to shut up

Re: [PATCH] qla4xxx: fix spelling mistake: "Tempalate" -> "Template"

2017-04-25 Thread Rangankar, Manish
On 26/04/17 3:07 AM, "Colin King" wrote: >From: Colin Ian King > >trivial fix to spelling mistake in DEBUG2 debug message > >Signed-off-by: Colin Ian King >--- > drivers/scsi/qla4xxx/ql4_init.c | 2 +- > 1 file changed, 1 insertion(+), 1 deletion(-) > >diff --git

Re: [PATCH] [v2] scsi: qedi: fix build error without DEBUG_FS

2017-03-03 Thread Rangankar, Manish
On 02/03/17 8:28 PM, "Arnd Bergmann" wrote: >Without CONFIG_DEBUG_FS, we run into a link error: > >drivers/scsi/qedi/qedi_iscsi.o: In function `qedi_ep_poll': >qedi_iscsi.c:(.text.qedi_ep_poll+0x134): undefined reference to >`do_not_recover' >drivers/scsi/qedi/qedi_iscsi.o: In function

Re: [PATCH] scsi: qedi: return via va_end to match corresponding va_start

2016-12-22 Thread Rangankar, Manish
On 16/12/16 7:40 PM, "Colin King" wrote: >From: Colin Ian King > >Although on most systems va_end is a no-op, it is good practice >to use va_end on the function return path, especially since the >va_start documenation states: > > "Each invocation of va_start() must be matched by a