cron job: media_tree daily build: ERRORS

2018-07-09 Thread Hans Verkuil
This message is generated daily by a cron job that builds media_tree for the kernels and architectures in the list below. Results of the daily build of media_tree: date: Tue Jul 10 05:00:11 CEST 2018 media-tree git hash:666e994aa2278e948e2492ee9d81b4df241e7222 media_build

[PATCH v6 00/17] media: imx: Switch to subdev notifiers

2018-07-09 Thread Steve Longerbeam
This patchset converts the imx-media driver and its dependent subdevs to use subdev notifiers. There are a couple shortcomings in v4l2-core that prevented subdev notifiers from working correctly in imx-media: 1. v4l2_async_notifier_fwnode_parse_endpoint() treats a fwnode endpoint that is not

Re: [PATCH] media: i2c: ov5640: Re-work MIPI startup sequence

2018-07-09 Thread Steve Longerbeam
Hi Jacopo, I tested this patch on the i.MX6Q SabreSD with the OV5640 module. It fixes the LP-11 timeout at stream on, but the captured images are completely blank/black. Steve On 07/06/2018 04:00 AM, Jacopo Mondi wrote: From: Jacopo Mondi Rework the MIPI interface startup sequence with the

Re: [PATCH -next v3 2/2] media: ov772x: use SCCB helpers

2018-07-09 Thread Sebastian Reichel
Hi, On Mon, Jul 09, 2018 at 06:14:43PM +0200, Wolfram Sang wrote: > > static int ov772x_read(struct i2c_client *client, u8 addr) > > { > > - int ret; > > - u8 val; > > - > > - ret = i2c_master_send(client, , 1); > > - if (ret < 0) > > - return ret; > > - ret =

Re: [PATCH -next v3 2/2] media: ov772x: use SCCB helpers

2018-07-09 Thread Wolfram Sang
> static int ov772x_read(struct i2c_client *client, u8 addr) > { > - int ret; > - u8 val; > - > - ret = i2c_master_send(client, , 1); > - if (ret < 0) > - return ret; > - ret = i2c_master_recv(client, , 1); > - if (ret < 0) > - return ret; > - > -

Re: [PATCH -next v3 1/2] i2c: add SCCB helpers

2018-07-09 Thread Wolfram Sang
Hi, yes! From a first look this nails it for me. Thanks for doing it. Minor comments follow... > +#if 0 > + /* > + * sccb_xfer not needed yet, since there is no driver support currently. > + * Just showing how it should be done if we ever need it. > + */ > + if

[PATCH -next v3 1/2] i2c: add SCCB helpers

2018-07-09 Thread Akinobu Mita
This adds Serial Camera Control Bus (SCCB) helpers (sccb_is_available, sccb_read_byte, and sccb_write_byte) that are intended to be used by some of Omnivision sensor drivers. The ov772x driver is going to use these helpers. It was previously only worked with the i2c controller drivers that

[PATCH -next v3 2/2] media: ov772x: use SCCB helpers

2018-07-09 Thread Akinobu Mita
Convert ov772x register access to use SCCB helpers. Cc: Peter Rosin Cc: Sebastian Reichel Cc: Wolfram Sang Cc: Jacopo Mondi Cc: Laurent Pinchart Cc: Hans Verkuil Cc: Sakari Ailus Cc: Mauro Carvalho Chehab Signed-off-by: Akinobu Mita --- drivers/media/i2c/ov772x.c | 20

[PATCH -next v3 0/2] introduce SCCB helpers

2018-07-09 Thread Akinobu Mita
This patchset introduces Serial Camera Control Bus (SCCB) helper functions and convert ov772x driver to use the helpers. * v3 - Rewrite the helpers based on the code provided by Wolfram - Convert ov772x driver to use SCCB helpers v2 - Convert all helpers into static inline functions, and remove

Re: [RFC] Make entity to interface links immutable

2018-07-09 Thread Shuah Khan
Hi Mauro and Hans, On 07/02/2018 03:41 AM, Mauro Carvalho Chehab wrote: > Em Mon, 2 Jul 2018 10:18:37 +0200 > Hans Verkuil escreveu: > >> While working on v4l2-compliance I noticed that entity to interface links >> have just the MEDIA_LNK_FL_ENABLED flag set. >> >> Shouldn't we also set the

Re: [PATCHv5 11/12] media-ioc-enum-links.rst: improve pad index description

2018-07-09 Thread Hans Verkuil
On 09/07/18 15:10, Laurent Pinchart wrote: > Hi Hans, > > Thank you for the patch. > > On Friday, 29 June 2018 14:43:30 EEST Hans Verkuil wrote: >> From: Hans Verkuil >> >> Make it clearer that the index starts at 0, and that it won't change >> since future new pads will be added at the end. >>

Re: [PATCHv5 08/12] ad9389b/adv7511: set proper media entity function

2018-07-09 Thread Hans Verkuil
On 09/07/18 15:04, Laurent Pinchart wrote: > Hi Hans, > > Thank you for the patch. > > On Friday, 29 June 2018 14:43:27 EEST Hans Verkuil wrote: >> From: Hans Verkuil >> >> These two drivers both have function MEDIA_ENT_F_DV_ENCODER. >> >> Signed-off-by: Hans Verkuil >> Acked-by: Sakari Ailus

Re: [PATCHv5 05/12] media: rename MEDIA_ENT_F_DTV_DECODER to MEDIA_ENT_F_DV_DECODER

2018-07-09 Thread Hans Verkuil
On 09/07/18 15:00, Laurent Pinchart wrote: > Hello, > > On Friday, 29 June 2018 20:40:49 EEST Ezequiel Garcia wrote: >> On 29 June 2018 at 08:43, Hans Verkuil wrote: >>> From: Hans Verkuil >>> >>> The use of 'DTV' is very confusing since it normally refers to Digital >>> TV e.g. DVB etc. >>>

Re: [PATCH] v4l2-ctrls: add v4l2_ctrl_request_hdl_find/put/ctrl_find functions

2018-07-09 Thread Paul Kocialkowski
Hi, On Wed, 2018-07-04 at 17:38 +0200, Hans Verkuil wrote: > If a driver needs to find/inspect the controls set in a request then > it can use these functions. > > E.g. to check if a required control is set in a request use this in the > req_validate() implementation: > > int res =

Re: [PATCHv5 01/12] media: add 'index' to struct media_v2_pad

2018-07-09 Thread Hans Verkuil
On 09/07/18 14:55, Laurent Pinchart wrote: > Hi Hans, > > Thank you for the patch. > > On Friday, 29 June 2018 14:43:20 EEST Hans Verkuil wrote: >> From: Hans Verkuil >> >> The v2 pad structure never exposed the pad index, which made it impossible >> to call the MEDIA_IOC_SETUP_LINK ioctl,

Re: [PATCHv5 12/12] media-ioc-enum-entities.rst/-g-topology.rst: clarify ID/name usage

2018-07-09 Thread Laurent Pinchart
Hi Hans, Thank you for the patch. On Friday, 29 June 2018 14:43:31 EEST Hans Verkuil wrote: > From: Hans Verkuil > > Mention that IDs should not be hardcoded in applications and that the > entity name must be unique within the media topology. > > Signed-off-by: Hans Verkuil > --- >

Re: [PATCHv5 11/12] media-ioc-enum-links.rst: improve pad index description

2018-07-09 Thread Laurent Pinchart
Hi Hans, Thank you for the patch. On Friday, 29 June 2018 14:43:30 EEST Hans Verkuil wrote: > From: Hans Verkuil > > Make it clearer that the index starts at 0, and that it won't change > since future new pads will be added at the end. > > Signed-off-by: Hans Verkuil > --- >

Re: [PATCHv5 10/12] media/i2c: add missing entity functions

2018-07-09 Thread Laurent Pinchart
Hi Hans, Thank you for the patch. On Friday, 29 June 2018 14:43:29 EEST Hans Verkuil wrote: > From: Hans Verkuil > > Several drivers in media/i2c do not set the entity function. > Correct this. > > Signed-off-by: Hans Verkuil > Acked-by: Sakari Ailus Reviewed-by: Laurent Pinchart > --- >

Re: [PATCHv5 09/12] adv7180/tvp514x/tvp7002: fix entity function

2018-07-09 Thread Laurent Pinchart
Hi Hans, Thank you for the patch. On Friday, 29 June 2018 14:43:28 EEST Hans Verkuil wrote: > From: Hans Verkuil > > The entity function was ORed with the flags field instead of > assigned to the function field. Correct this. > > Signed-off-by: Hans Verkuil > Acked-by: Sakari Ailus

Re: [PATCHv5 08/12] ad9389b/adv7511: set proper media entity function

2018-07-09 Thread Laurent Pinchart
Hi Hans, Thank you for the patch. On Friday, 29 June 2018 14:43:27 EEST Hans Verkuil wrote: > From: Hans Verkuil > > These two drivers both have function MEDIA_ENT_F_DV_ENCODER. > > Signed-off-by: Hans Verkuil > Acked-by: Sakari Ailus Reviewed-by: Laurent Pinchart As this patch is

Re: [PATCHv5 07/12] media.h: reorder video en/decoder functions

2018-07-09 Thread Laurent Pinchart
Hi Hans, Thank you for the patch. On Friday, 29 June 2018 14:43:26 EEST Hans Verkuil wrote: > From: Hans Verkuil > > Keep the function defines in numerical order: 0x6000 comes after > 0x2000, so move it back. > > Signed-off-by: Hans Verkuil Reviewed-by: Laurent Pinchart > --- >

Re: [PATCHv5 06/12] media.h: add MEDIA_ENT_F_DV_ENCODER

2018-07-09 Thread Laurent Pinchart
Hi Hans, Thank you for the patch. On Friday, 29 June 2018 14:43:25 EEST Hans Verkuil wrote: > From: Hans Verkuil > > Add a new function for digital video encoders such as HDMI transmitters. > > Signed-off-by: Hans Verkuil > Acked-by: Sakari Ailus > --- >

Re: [PATCHv5 05/12] media: rename MEDIA_ENT_F_DTV_DECODER to MEDIA_ENT_F_DV_DECODER

2018-07-09 Thread Laurent Pinchart
Hello, On Friday, 29 June 2018 20:40:49 EEST Ezequiel Garcia wrote: > On 29 June 2018 at 08:43, Hans Verkuil wrote: > > From: Hans Verkuil > > > > The use of 'DTV' is very confusing since it normally refers to Digital > > TV e.g. DVB etc. > > > > Instead use 'DV' (Digital Video), which nicely

Re: [PATCHv5 03/12] media: add flags field to struct media_v2_entity

2018-07-09 Thread Laurent Pinchart
Hi Hans, Thank you for the patch. On Friday, 29 June 2018 14:43:22 EEST Hans Verkuil wrote: > From: Hans Verkuil > > The v2 entity structure never exposed the entity flags, which made it > impossible to detect connector or default entities. > > It is really trivial to just expose this

Re: [PATCHv5 02/12] media-ioc-g-topology.rst: document new 'index' field

2018-07-09 Thread Laurent Pinchart
Hi Hans, Thank you for the patch. On Friday, 29 June 2018 14:43:21 EEST Hans Verkuil wrote: > From: Hans Verkuil > > Document the new struct media_v2_pad 'index' field. > > Signed-off-by: Hans Verkuil > Acked-by: Sakari Ailus > --- > .../media/uapi/mediactl/media-ioc-g-topology.rst |

Re: [PATCHv5 01/12] media: add 'index' to struct media_v2_pad

2018-07-09 Thread Laurent Pinchart
Hi Hans, Thank you for the patch. On Friday, 29 June 2018 14:43:20 EEST Hans Verkuil wrote: > From: Hans Verkuil > > The v2 pad structure never exposed the pad index, which made it impossible > to call the MEDIA_IOC_SETUP_LINK ioctl, which needs that information. > > It is really trivial to