[PATCH v1] [DVB][FRONTEND] Added a new ioctl for optimizing frontend property set operation

2017-09-14 Thread Satendra Singh Thakur
Hello Mr Chehab, Thanks for reviewing the patch. I have modified the patch as per your comments. Please check if it looks fine now. Signed-off-by: Satendra Singh Thakur --- drivers/media/dvb-core/dvb_frontend.c | 212 +-

cron job: media_tree daily build: WARNINGS

2017-09-14 Thread Hans Verkuil
This message is generated daily by a cron job that builds media_tree for the kernels and architectures in the list below. Results of the daily build of media_tree: date: Fri Sep 15 05:00:23 CEST 2017 media-tree git hash:1efdf1776e2253b77413c997bed862410e4b6aaf media_build

Re: [PATCH v2] v4l-ioctl: Fix typo on v4l_print_frmsizeenum

2017-09-14 Thread Laurent Pinchart
Hi Ricardo, Thank you for the patch. On Wednesday, 13 September 2017 10:35:52 EEST Ricardo Ribalda Delgado wrote: > max_width and max_height are swap with step_width and step_height. > > Signed-off-by: Ricardo Ribalda Delgado Reviewed-by: Laurent Pinchart

[PATCH] dma-buf: remove redundant initialization of sg_table

2017-09-14 Thread Colin King
From: Colin Ian King sg_table is being initialized and is never read before it is updated again later on, hence making the initialization redundant. Remove the initialization. Detected by clang scan-build: "warning: Value stored to 'sg_table' during its initialization

Re: [RFC] [DVB][FRONTEND] Added a new ioctl for optimizing frontend property set operation

2017-09-14 Thread Mauro Carvalho Chehab
Hi Satendra, Em Thu, 14 Sep 2017 05:59:27 -0400 Satendra Singh Thakur escreveu: > -For setting one frontend property , one FE_SET_PROPERTY ioctl is called > -Since, size of struct dtv_property is 72 bytes, this ioctl requires > ---allocating 72 bytes of memory in user

[no subject]

2017-09-14 Thread tmichael-tgs
<>

Re: [PATCH v3 1/2] dt-bindings: media: Add Cadence MIPI-CSI2 RX Device Tree bindings

2017-09-14 Thread Laurent Pinchart
Hi Maxime, Thank you for the patch. On Monday, 4 September 2017 16:03:34 EEST Maxime Ripard wrote: > The Cadence MIPI-CSI2 RX controller is a CSI2RX bridge that supports up to > 4 CSI-2 lanes, and can route the frames to up to 4 streams, depending on > the hardware implementation. > > It can

Re: [PATCH] [media] cec: GIVE_PHYSICAL_ADDR should respond to unregistered device

2017-09-14 Thread Hans Verkuil
On 09/14/2017 05:30 PM, Jose Abreu wrote: > > > On 14-09-2017 16:09, Hans Verkuil wrote: >> On 09/14/17 15:28, Jose Abreu wrote: >> >>> Actually, I have at least one more fix which I don't know if it's >>> valid and I didn't manage to actually write it in a nice way. >>> This one is for CEC 2.0.

Re: [PATCH] [media] cec: GIVE_PHYSICAL_ADDR should respond to unregistered device

2017-09-14 Thread Jose Abreu
On 14-09-2017 16:09, Hans Verkuil wrote: > On 09/14/17 15:28, Jose Abreu wrote: > >> Actually, I have at least one more fix which I don't know if it's >> valid and I didn't manage to actually write it in a nice way. >> This one is for CEC 2.0. My test equipment (which is certified) >> in some

[PATCH v2] [media] cec: Respond to unregisterd initiators, when applicable

2017-09-14 Thread Jose Abreu
Running CEC 1.4 compliance test we get the following error on test 11.1.6.2: "ERROR: The DUT did not broadcast a message to the unregistered device." Fix this by letting GIVE_PHYSICAL_ADDR message respond to unregistered device. Also, GIVE_DEVICE_VENDOR_ID and GIVE_FEATURES fall in the same

Re: [PATCH] [media] cec: GIVE_PHYSICAL_ADDR should respond to unregistered device

2017-09-14 Thread Hans Verkuil
On 09/14/17 15:28, Jose Abreu wrote: > Hi Hans, > > On 14-09-2017 14:10, Hans Verkuil wrote: >> On 09/14/17 13:33, Jose Abreu wrote: >>> Running CEC 1.4 compliance test we get the following error on test >>> 11.1.6.2: "ERROR: The DUT did not broadcast a >>> message to the unregistered device."

Re: [PATCH] [media] cec: GIVE_PHYSICAL_ADDR should respond to unregistered device

2017-09-14 Thread Jose Abreu
Hi Hans, On 14-09-2017 14:10, Hans Verkuil wrote: > On 09/14/17 13:33, Jose Abreu wrote: >> Running CEC 1.4 compliance test we get the following error on test >> 11.1.6.2: "ERROR: The DUT did not broadcast a >> message to the unregistered device." >> >> Fix this by letting GIVE_PHYSICAL_ADDR

Re: as3645a flash userland interface

2017-09-14 Thread Sylwester Nawrocki
On 09/14/2017 01:53 PM, Pavel Machek wrote: On Thu 2017-09-14 13:01:19, Sylwester Nawrocki wrote: On 09/14/2017 12:07 PM, Pavel Machek wrote: Isn't the V4L2 subdev/Media Controller API supposed to provide means for associating flash LEDs with camera sensors? You seem to be insisting on using

Re: [PATCH] [media] cec: GIVE_PHYSICAL_ADDR should respond to unregistered device

2017-09-14 Thread Hans Verkuil
On 09/14/17 13:33, Jose Abreu wrote: > Running CEC 1.4 compliance test we get the following error on test > 11.1.6.2: "ERROR: The DUT did not broadcast a > message to the unregistered device." > > Fix this by letting GIVE_PHYSICAL_ADDR message respond to unregistered > device. > > With this fix

Re: [RFC 3/5] media: get rid of get_property() callback

2017-09-14 Thread Michael Ira Krufky
On Thu, Sep 14, 2017 at 7:44 AM, Mauro Carvalho Chehab wrote: > Only lg2160 implement gets_property, but there's no need for that, > as no other driver calls this callback, as get_frontend() does the > same, and set_frontend() also calls lg2160 get_frontend(). > > So,

Re: [PATCH v3 2/2] v4l: cadence: Add Cadence MIPI-CSI2 RX driver

2017-09-14 Thread Maxime Ripard
On Tue, Sep 12, 2017 at 02:13:12PM -0500, Benoit Parrot wrote: > > > + /* > > > + * Create a static mapping between the CSI virtual channels > > > + * and the output stream. > > > + * > > > + * This should be enhanced, but v4l2 lacks the support for > > > + * changing that mapping

Re: [PATCH v3 2/2] v4l: cadence: Add Cadence MIPI-CSI2 RX driver

2017-09-14 Thread Maxime Ripard
Hi Benoit, Thanks for your comments, On Tue, Sep 12, 2017 at 01:23:39PM -0500, Benoit Parrot wrote: > > +static int csi2rx_probe(struct platform_device *pdev) > > +{ > > + struct v4l2_async_subdev **subdevs; > > + struct csi2rx_priv *csi2rx; > > + unsigned int i; > > + int ret; > > + > >

Re: as3645a flash userland interface

2017-09-14 Thread Pavel Machek
On Thu 2017-09-14 13:01:19, Sylwester Nawrocki wrote: > On 09/14/2017 12:07 PM, Pavel Machek wrote: > >>Isn't the V4L2 subdev/Media Controller API supposed to provide means > >>for associating flash LEDs with camera sensors? You seem to be insisting > >>on using the sysfs leds interface for that,

[RFC 1/5] media: stv0288: get rid of set_property boilerplate

2017-09-14 Thread Mauro Carvalho Chehab
This driver doesn't implement support for set_property(). Yet, it implements a boilerplate for it. Get rid of it. Signed-off-by: Mauro Carvalho Chehab --- drivers/media/dvb-frontends/stv0288.c | 7 --- 1 file changed, 7 deletions(-) diff --git

[RFC 4/5] media: friio-fe: get rid of set_property()

2017-09-14 Thread Mauro Carvalho Chehab
This callback is not actually doing anything but making it to return an error depending on the DTV frontend command. Well, that could break userspace for no good reason, and, if needed, should be implemented, instead, at set_frontend() callback. So, get rid of it. Signed-off-by: Mauro Carvalho

[RFC 2/5] media: stv6110: get rid of get_property hack

2017-09-14 Thread Mauro Carvalho Chehab
There's no reason why it would hardcode symbol rate to 15MBaud if get_property ops is not defined. Signed-off-by: Mauro Carvalho Chehab --- drivers/media/dvb-frontends/stv6110.c | 7 ++- 1 file changed, 2 insertions(+), 5 deletions(-) diff --git

[RFC 5/5] media: dvb_frontend: get rid of set_property() callback

2017-09-14 Thread Mauro Carvalho Chehab
Now that all clients of set_property() were removed, get rid of this callback. Signed-off-by: Mauro Carvalho Chehab --- drivers/media/dvb-core/dvb_frontend.c | 7 --- drivers/media/dvb-core/dvb_frontend.h | 2 -- 2 files changed, 9 deletions(-) diff --git

[RFC 3/5] media: get rid of get_property() callback

2017-09-14 Thread Mauro Carvalho Chehab
Only lg2160 implement gets_property, but there's no need for that, as no other driver calls this callback, as get_frontend() does the same, and set_frontend() also calls lg2160 get_frontend(). So, get rid of it. Signed-off-by: Mauro Carvalho Chehab ---

[PATCH] [media] cec: GIVE_PHYSICAL_ADDR should respond to unregistered device

2017-09-14 Thread Jose Abreu
Running CEC 1.4 compliance test we get the following error on test 11.1.6.2: "ERROR: The DUT did not broadcast a message to the unregistered device." Fix this by letting GIVE_PHYSICAL_ADDR message respond to unregistered device. With this fix we pass CEC 1.4 official compliance. Signed-off-by:

[PATCH] [media] rcar_drif: fix potential uninitialized variable use

2017-09-14 Thread Arnd Bergmann
Older compilers like gcc-4.6 may run into a case that returns an uninitialized variable from rcar_drif_enable_rx() if that function was ever called with an empty cur_ch_mask: drivers/media/platform/rcar_drif.c:658:2: error: ‘ret’ may be used uninitialized in this function [-Werror=uninitialized]

Re: as3645a flash userland interface

2017-09-14 Thread Sylwester Nawrocki
On 09/14/2017 12:07 PM, Pavel Machek wrote: Isn't the V4L2 subdev/Media Controller API supposed to provide means for associating flash LEDs with camera sensors? You seem to be insisting on using the sysfs leds interface for that, which is not a primary interface for camera flash AFAICT. > a)

Investi?ná príležitos?

2017-09-14 Thread Yi Tan
Ahoj, Obsah tejto správy je ve?mi dôverný. moje meno je Yi Tan, pracujem s bankou tu v Hongkongu. Rozhodla som sa, ?e vás budem kontaktova? za mo?nos? investova? do akéhoko?vek lukratívneho podnikania vo va?ej krajine, som ochotný ponúknu? 40% ako môj obchodný partner. Ak máte záujem,

[PATCH 8/8] [media] ttusb_dec: Delete four unwanted spaces

2017-09-14 Thread SF Markus Elfring
From: Markus Elfring Date: Wed, 13 Sep 2017 22:22:41 +0200 The script "checkpatch.pl" pointed information out like the following. ERROR: space prohibited after that open parenthesis '(' Thus fix affected source code places. Signed-off-by: Markus Elfring

[PATCH 7/8] [media] ttusb_dec: Add spaces for better code readability

2017-09-14 Thread SF Markus Elfring
From: Markus Elfring Date: Wed, 13 Sep 2017 22:12:07 +0200 The script "checkpatch.pl" pointed information out like the following. ERROR: spaces required around that '=' (ctx:VxV) Thus fix the affected source code places. Signed-off-by: Markus Elfring

[PATCH 6/8] [media] ttusb_dec: Reduce the scope for three variables in ttusb_dec_process_urb()

2017-09-14 Thread SF Markus Elfring
From: Markus Elfring Date: Wed, 13 Sep 2017 21:23:29 +0200 * Move the definition for the local variables "b", "d" and "length" into an if branch so that the corresponding setting will only be performed if a memory allocation succeeded in this function. *

[PATCH 5/8] [media] ttusb_dec: Move an assignment in ttusb_dec_probe()

2017-09-14 Thread SF Markus Elfring
From: Markus Elfring Date: Wed, 13 Sep 2017 20:32:25 +0200 Assign a pointer to a data structure member without using an intermediate local variable. Signed-off-by: Markus Elfring --- drivers/media/usb/ttusb-dec/ttusb_dec.c | 6

[PATCH 4/8] [media] ttusb_dec: Delete an error message for a failed memory allocation in ttusb_dec_probe()

2017-09-14 Thread SF Markus Elfring
From: Markus Elfring Date: Wed, 13 Sep 2017 20:10:39 +0200 Omit an extra message for a memory allocation failure in this function. Signed-off-by: Markus Elfring --- drivers/media/usb/ttusb-dec/ttusb_dec.c | 4 +--- 1 file changed,

[PATCH 3/8] [media] ttusb_dec: Improve a size determination in three functions

2017-09-14 Thread SF Markus Elfring
From: Markus Elfring Date: Wed, 13 Sep 2017 19:56:38 +0200 * The script "checkpatch.pl" pointed information out like the following. ERROR: do not use assignment in if condition Thus fix a few source code places. * Replace the specification of data structures

[PATCH 2/8] [media] ttusb_dec: Adjust five checks for null pointers

2017-09-14 Thread SF Markus Elfring
From: Markus Elfring Date: Wed, 13 Sep 2017 18:22:35 +0200 MIME-Version: 1.0 Content-Type: text/plain; charset=UTF-8 Content-Transfer-Encoding: 8bit The script “checkpatch.pl” pointed information out like the following. Comparison to NULL could be written … Thus

[PATCH 1/8] [media] ttusb_dec: Use common error handling code in ttusb_dec_init_dvb()

2017-09-14 Thread SF Markus Elfring
From: Markus Elfring Date: Wed, 13 Sep 2017 18:08:19 +0200 Add jump targets so that a bit of exception handling can be better reused at the end of this function. This issue was detected by using the Coccinelle software. Signed-off-by: Markus Elfring

[PATCH 0/8] [media] ttusb_dec: Fine-tuning for some function implementations

2017-09-14 Thread SF Markus Elfring
From: Markus Elfring Date: Thu, 14 Sep 2017 12:26:24 +0200 Some update suggestions were taken into account from static source code analysis. Markus Elfring (8): Use common error handling code in ttusb_dec_init_dvb() Adjust five checks for null pointers

Re: as3645a flash userland interface

2017-09-14 Thread Sakari Ailus
Hi Pavel and others, On 09/14/17 13:07, Pavel Machek wrote: > Hi! > >> What directory are the flash controls in? >> >> /sys/class/leds/led-controller:flash ? >> >> Could we arrange for something less generic, like >> >> /sys/class/leds/main-camera:flash ? > >

[PATCH] Staging: media: atomisp: Use kcalloc instead of kzalloc

2017-09-14 Thread Srishti Sharma
Use kcalloc instead of kzalloc to check for an overflow before multiplication. Done using the following semantic patch by coccinelle. http://coccinelle.lip6.fr/rules/kzalloc.cocci Signed-off-by: Srishti Sharma ---

Re: as3645a flash userland interface

2017-09-14 Thread Pavel Machek
Hi! > What directory are the flash controls in? > > /sys/class/leds/led-controller:flash ? > > Could we arrange for something less generic, like > > /sys/class/leds/main-camera:flash ? > >>> > >>>I'd rather avoid overcomplicating this. LED class device name pattern

[RFC] [DVB][FRONTEND] Added a new ioctl for optimizing frontend property set operation

2017-09-14 Thread Satendra Singh Thakur
-For setting one frontend property , one FE_SET_PROPERTY ioctl is called -Since, size of struct dtv_property is 72 bytes, this ioctl requires ---allocating 72 bytes of memory in user space ---allocating 72 bytes of memory in kernel space ---copying 72 bytes of data from user space to kernel space

Re: as3645a flash userland interface

2017-09-14 Thread Sylwester Nawrocki
Hi, On 09/13/2017 07:53 PM, Jacek Anaszewski wrote: On 09/12/2017 11:55 PM, Pavel Machek wrote: On Tue 2017-09-12 20:53:33, Jacek Anaszewski wrote: On 09/12/2017 12:36 PM, Pavel Machek wrote: What directory are the flash controls in? /sys/class/leds/led-controller:flash ? Could we

Re: [git:media_tree/master] media: adv7180: add missing adv7180cp, adv7180st i2c device IDs

2017-09-14 Thread Geert Uytterhoeven
On Wed, Sep 13, 2017 at 10:50 AM, Geert Uytterhoeven wrote: > On Thu, Jul 20, 2017 at 12:54 PM, Mauro Carvalho Chehab > wrote: >> This is an automatic generated email to let you know that the following >> patch were queued: >> >> Subject: media: