Re: [PATCH 1/7 v2] dmaengine: add a simple dma library

2012-01-31 Thread Guennadi Liakhovetski
Hi Vinod Thanks for your reply. On Tue, 31 Jan 2012, Vinod Koul wrote: On Mon, 2012-01-30 at 10:34 +0100, Guennadi Liakhovetski wrote: I don't still comprehend the need for a library on top of dmaengine which gain is just a library between clients and dmacs. Surely we don't want to

Re: [PATCH 2/2] mmc: sdhci-s3c: support the broken voltage.

2012-01-31 Thread Girish K S
On 31 January 2012 12:25, Jaehoon Chung jh80.ch...@samsung.com wrote: Samsung-SoC need to add the MMC_CAP2_BROKEN_VOLTAGE. Signed-off-by: Jaehoon Chung jh80.ch...@samsung.com Signed-off-by: Kyungmin Park kyungmin.p...@samsung.com ---  drivers/mmc/host/sdhci-s3c.c |    7 +++  1 files

Re: [PATCH 2/2] mmc: sdhci-s3c: support the broken voltage.

2012-01-31 Thread Jaehoon Chung
On 01/31/2012 07:32 PM, Girish K S wrote: On 31 January 2012 12:25, Jaehoon Chung jh80.ch...@samsung.com wrote: Samsung-SoC need to add the MMC_CAP2_BROKEN_VOLTAGE. Signed-off-by: Jaehoon Chung jh80.ch...@samsung.com Signed-off-by: Kyungmin Park kyungmin.p...@samsung.com ---

Re: [PATCH 1/7 v2] dmaengine: add a simple dma library

2012-01-31 Thread Shimoda, Yoshihiro
Hi Guennadi-san, 2012/01/27 17:48, Guennadi Liakhovetski wrote: Hi Shimoda-san On Fri, 27 Jan 2012, Shimoda, Yoshihiro wrote: [ snip ] 1. switch from using a tasklet to threaded IRQ, which allowed to I tested this driver on 2 environment, but it could not work correctly. - renesas_usbhs

RE: [RFC 1/2] mmc: davinci: Eliminate spurious interrupts

2012-01-31 Thread Rajashekhara, Sudhakar
Hi, On Tue, Jan 24, 2012 at 16:46:05, Ido Yariv wrote: The davinci mmc interrupt handler fills the fifo, as long as the DXRDY or DRRDY bits are set in the status register. If interrupts fire during this loop, they will be handled by the handler, but the interrupt controller will still

Re: [PATCH 1/2] mmc: core: Prevent I/O as soon as possible at card removal

2012-01-31 Thread Ulf Hansson
Adrian Hunter wrote: On 19/01/12 18:39, Ulf Hansson wrote: Once the card has been detected to be removed by the mmc_detect_card_removed function, schedule a new detect work immediately and without a delay to let a rescan remove the card device as soon a possible. This will sooner prevent

Re: [PATCH 0/2] Improve handling of card removal

2012-01-31 Thread Ulf Hansson
Adrian Hunter wrote: On 19/01/12 18:39, Ulf Hansson wrote: These patches is based upon the patch recently pushed to the mmc mailing list: mmc: core: Force a detect to handle non-properly removed cards According to Adrian Hunters comment about adding a CAP2 flag to enable this feature has been

Re: [PATCH 1/2] mmc: core: Prevent I/O as soon as possible at card removal

2012-01-31 Thread Adrian Hunter
On 31/01/12 14:54, Ulf Hansson wrote: Adrian Hunter wrote: On 19/01/12 18:39, Ulf Hansson wrote: Once the card has been detected to be removed by the mmc_detect_card_removed function, schedule a new detect work immediately and without a delay to let a rescan remove the card device as soon a

Re: [PATCH 0/2] Improve handling of card removal

2012-01-31 Thread Adrian Hunter
On 31/01/12 15:00, Ulf Hansson wrote: Adrian Hunter wrote: On 19/01/12 18:39, Ulf Hansson wrote: These patches is based upon the patch recently pushed to the mmc mailing list: mmc: core: Force a detect to handle non-properly removed cards According to Adrian Hunters comment about adding a

Re: [PATCH 1/2] mmc: core: Prevent I/O as soon as possible at card removal

2012-01-31 Thread Ulf Hansson
Adrian Hunter wrote: On 31/01/12 14:54, Ulf Hansson wrote: Adrian Hunter wrote: On 19/01/12 18:39, Ulf Hansson wrote: Once the card has been detected to be removed by the mmc_detect_card_removed function, schedule a new detect work immediately and without a delay to let a rescan remove the

Re: [PATCH 0/2] Improve handling of card removal

2012-01-31 Thread Ulf Hansson
Adrian Hunter wrote: On 31/01/12 15:00, Ulf Hansson wrote: Adrian Hunter wrote: On 19/01/12 18:39, Ulf Hansson wrote: These patches is based upon the patch recently pushed to the mmc mailing list: mmc: core: Force a detect to handle non-properly removed cards According to Adrian Hunters

[PATCH v3 1/6] mmc: sdhci-s3c: Remove usage of clk_type member in platform data

2012-01-31 Thread Thomas Abraham
SDHCI controllers on Exynos4 do not include the sdclk divider as per the sdhci controller specification. This case can be represented using the sdhci quirk SDHCI_QUIRK_NONSTANDARD_CLOCK instead of using an additional enum type definition 'clk_types'. Hence, usage of clk_type member in platform

[PATCH v3 0/6] mmc: sdhci-s3c: Rework platform data and add device tree support

2012-01-31 Thread Thomas Abraham
This patchset removes all uses of 'clk_type' member from the platform data of sdhci-s3c driver and adds device tree support for sdhci-s3c driver. In this patchset, all uses of 'clk_type' member from the platform data are removed from the sdhci-s3c driver and platform code. The clk_type is a SoC

[PATCH v3 2/6] arm: exynos4: use 'exynos4-sdhci' as device name for sdhci controllers

2012-01-31 Thread Thomas Abraham
With the addition of platform specific driver data in the sdhci driver for exynos4, the device name of sdhci controllers on exynos4 is changed accordingly. Cc: Kukjin Kim kgene@samsung.com Signed-off-by: Thomas Abraham thomas.abra...@linaro.org --- arch/arm/mach-exynos/clock.c

[PATCH v3 3/6] arm: samsung: remove all uses of clk_type member in sdhci platform data

2012-01-31 Thread Thomas Abraham
The sdhci driver is modified to be independent of clk_type member in the sdhci platform data. Hence, all usage of clk_type in platform code is removed. Cc: Kyungmin Park kyungmin.p...@samsung.com Cc: JeongHyeon Kim jh...@insignal.co.kr Cc: Kukjin Kim kgene@samsung.com Cc: Changhwan Youn

[PATCH v3 4/6] mmc: sdhci-s3c: derive transfer width host capability from max_width in platform data

2012-01-31 Thread Thomas Abraham
max_width member in platform data can be used to derive the mmc bus transfer width that can be supported by the controller. Signed-off-by: Thomas Abraham thomas.abra...@linaro.org --- drivers/mmc/host/sdhci-s3c.c |8 1 files changed, 8 insertions(+), 0 deletions(-) diff --git

[PATCH v3 5/6] mmc: sdhci-s3c: Keep a copy of platform data and use it

2012-01-31 Thread Thomas Abraham
The platform data is copied into driver's private data and the copy is used for all access to the platform data. This simpifies the addition of device tree support for the sdhci-s3c driver. Signed-off-by: Thomas Abraham thomas.abra...@linaro.org --- drivers/mmc/host/sdhci-s3c.c | 11

[PATCH v3 6/6] mmc: sdhci-s3c: Add device tree support

2012-01-31 Thread Thomas Abraham
Add device tree based discovery support for Samsung's sdhci controller Cc: Ben Dooks ben-li...@fluff.org Signed-off-by: Thomas Abraham thomas.abra...@linaro.org --- .../devicetree/bindings/mmc/samsung-sdhci.txt | 70 + drivers/mmc/host/sdhci-s3c.c | 148

Re: [PATCH v3 4/6] mmc: sdhci-s3c: derive transfer width host capability from max_width in platform data

2012-01-31 Thread Sergei Shtylyov
Hello. On 01/31/2012 08:56 PM, Thomas Abraham wrote: max_width member in platform data can be used to derive the mmc bus transfer width that can be supported by the controller. Signed-off-by: Thomas Abrahamthomas.abra...@linaro.org --- drivers/mmc/host/sdhci-s3c.c |8 1

Re: [PATCH 1/7 v2] dmaengine: add a simple dma library

2012-01-31 Thread Guennadi Liakhovetski
Hi Shimoda-san On Tue, 31 Jan 2012, Shimoda, Yoshihiro wrote: Hi Guennadi-san, 2012/01/27 17:48, Guennadi Liakhovetski wrote: Hi Shimoda-san On Fri, 27 Jan 2012, Shimoda, Yoshihiro wrote: [ snip ] 1. switch from using a tasklet to threaded IRQ, which allowed to I tested this

Re: [PATCH v2 0/2] patch set about the MXS-DMA

2012-01-31 Thread Huang Shijie
hi, patch 1: move the mxs dma header to a more common place. Beside the mx23/mx28, the apbh-dma is also used by MX50 and MX6Q. So move the mxs dma header file to a more common place, and rename it to mxs-dma.h patch 2: rewrite the last parameter of mxs_dma_prep_slave_sg().

Re: [PATCH 1/7 v2] dmaengine: add a simple dma library

2012-01-31 Thread Shimoda, Yoshihiro
Hi Guennadi-san, 2012/02/01 9:52, Guennadi Liakhovetski wrote: Hi Shimoda-san On Tue, 31 Jan 2012, Shimoda, Yoshihiro wrote: [ snip ] I investigaed the issue. I found out the renesas_usbhs driver may call tx_submit() in the callback() Well, actually, this is not something, that shdma

Re: [PATCH 1/2] mmc: core: Prevent I/O as soon as possible at card removal

2012-01-31 Thread Jaehoon Chung
Hi Ulf. On 02/01/2012 12:23 AM, Ulf Hansson wrote: Adrian Hunter wrote: On 31/01/12 14:54, Ulf Hansson wrote: Adrian Hunter wrote: On 19/01/12 18:39, Ulf Hansson wrote: Once the card has been detected to be removed by the mmc_detect_card_removed function, schedule a new detect work

[PATCH] mmci.c: CMD23 support

2012-01-31 Thread Saugata Das
From: Saugata Das saugata@linaro.org Support added for transmission of CMD23 during multi block read or write. In order to activate this feature, MMC_CAP_CMD23 flag needs to be enabled in the capabilities field. Note that CMD23 support is mandatory to support features like reliable write,

Re: [PATCH 1/7 v2] dmaengine: add a simple dma library

2012-01-31 Thread Vinod Koul
On Tue, 2012-01-31 at 09:59 +0100, Guennadi Liakhovetski wrote: Hi Vinod Thanks for your reply. On Tue, 31 Jan 2012, Vinod Koul wrote: On Mon, 2012-01-30 at 10:34 +0100, Guennadi Liakhovetski wrote: I don't still comprehend the need for a library on top of dmaengine which gain

Re: [PATCH v3] ARM: davinci: map default_queue to edma channels

2012-01-31 Thread Heiko Schocher
Hello Nori, Nori, Sekhar wrote: Hi Heiko, On Thu, Jan 19, 2012 at 12:35:21, Heiko Schocher wrote: Default queue is expected to be a low-priority queue. This way, long transfers on the default queue started by the codec engine will not cause audio defects. Signed-off-by: Heiko Schocher