[PATCH 3/7] AM3517: rename the i2c boardinfo to make it more readable

2010-04-20 Thread Stanley.Miao
There are three i2c buses on am3517, now rename these three boardinfo structure name to am3517evm_i2c1_boardinfo, am3517evm_i2c2_boardinfo, and am3517evm_i2c3_boardinfo, to make it more readable. Signed-off-by: Stanley.Miao stanley.m...@windriver.com --- arch/arm/mach-omap2/board-am3517evm.c |

[PATCH 6/7] omap: init the gpio pinmux for mmc

2010-04-20 Thread Stanley.Miao
There is two gpio for mmc use, one is for card detecting, another is used for checking write protect. Intialize its pinmux in case the bootloader doesn't set it. Signed-off-by: Stanley.Miao stanley.m...@windriver.com --- arch/arm/mach-omap2/devices.c |7 +++ 1 files changed, 7

[PATCH 7/7] omap hsmmc: fix the hsmmc driver for am3517.

2010-04-20 Thread Stanley.Miao
AM3517 don't have the register OMAP343X_CONTROL_PBIAS_LITE and the regulators like vmmc, so we set a noop set_power function for it. Signed-off-by: Stanley.Miao stanley.m...@windriver.com --- arch/arm/mach-omap2/hsmmc.c | 32 1 files changed, 24 insertions(+),

RE: DSS2 V4L2

2010-04-20 Thread Hiremath, Vaibhav
-Original Message- From: Gary Thomas [mailto:g...@mlbassoc.com] Sent: Monday, April 19, 2010 6:00 PM To: linux-omap@vger.kernel.org Cc: Tomi Valkeinen; Hiremath, Vaibhav Subject: DSS2 V4L2 I'm trying to get the DVSDK (3.01.00.03) working. It uses 2.6.32 + DSS2 + V4L2. What

Re: [PATCH 3/7] AM3517: rename the i2c boardinfo to make it more readable

2010-04-20 Thread stanley.miao
Felipe Balbi wrote: Hi, On Tue, Apr 20, 2010 at 08:33:28AM +0200, ext Stanley.Miao wrote: @@ -311,8 +311,8 @@ static void __init am3517_evm_init(void) /* RTC - S35390A */ am3517_evm_rtc_init(); - i2c_register_board_info(1, am3517evm_i2c_boardinfo, - ARRAY_SIZE(am3517evm_i2c_boardinfo)); +

RE: [PATCH 3/7] AM3517: rename the i2c boardinfo to make it more readable

2010-04-20 Thread Hiremath, Vaibhav
\ -Original Message- From: Stanley.Miao [mailto:stanley.m...@windriver.com] Sent: Tuesday, April 20, 2010 12:03 PM To: linux-omap@vger.kernel.org Cc: t...@atomide.com; Hiremath, Vaibhav; Govindarajan, Sriramakrishnan; Aggarwal, Anuj Subject: [PATCH 3/7] AM3517: rename the i2c

RE: [PATCH 3/7] AM3517: rename the i2c boardinfo to make it more readable

2010-04-20 Thread Hiremath, Vaibhav
-Original Message- From: Felipe Balbi [mailto:felipe.ba...@nokia.com] Sent: Tuesday, April 20, 2010 12:01 PM To: ext Stanley.Miao Cc: linux-omap@vger.kernel.org; t...@atomide.com; Hiremath, Vaibhav; Govindarajan, Sriramakrishnan; Aggarwal, Anuj Subject: Re: [PATCH 3/7] AM3517:

[PATCH 0/4] OMAP2+ PRCM: standardize PRCM macros

2010-04-20 Thread Paul Walmsley
Hello, This series standardizes the OMAP2+ PRCM register macro names to end in _SHIFT for bitshift counts and _MASK for bitmasks. This is already the case for many of the macros, but others were unconverted; this series finally fixes those and their users in mainline. These patches will cause

[PATCH 1/4] OMAP2 PRCM: convert OMAP2 PRCM macros to the _SHIFT/_MASK suffixes

2010-04-20 Thread Paul Walmsley
Fix all of the remaining OMAP2 PRCM register shift/bitmask macros that did not use the _SHIFT/_MASK suffixes to use them. This makes the use of these macros consistent. It is intended to reduce error, as code can be inspected visually by reviewers to ensure that bitshifts and bitmasks are used

[PATCH 2/4] OMAP3 PRCM: convert OMAP3 PRCM macros to the _SHIFT/_MASK suffixes

2010-04-20 Thread Paul Walmsley
Fix all of the remaining OMAP3 PRCM register shift/bitmask macros that did not use the _SHIFT/_MASK suffixes to use them. This makes the use of these macros consistent. It is intended to reduce error, as code can be inspected visually by reviewers to ensure that bitshifts and bitmasks are used

[PATCH 4/4] OMAP3: PM: PM_MPUGRPSEL writes should use GRPSEL macros, not EN macros

2010-04-20 Thread Paul Walmsley
Writes to the PM_*GRPSEL registers should use _GRPSEL_ macros, not _EN_ macros, to match the TRM and guard against inadvertent error. This patch should not cause any functional change. Signed-off-by: Paul Walmsley p...@pwsan.com Cc: Kevin Hilman khil...@deeprootsystems.com Cc: Jouni Högander

[PATCH 3/4] OMAP2+ PRCM: convert remaining PRCM macros to the _SHIFT/_MASK suffixes

2010-04-20 Thread Paul Walmsley
Fix all of the remaining PRCM register shift/bitmask macros that did not use the _SHIFT/_MASK suffixes to use them. This makes the use of these macros consistent. It is intended to reduce error, as code can be inspected visually by reviewers to ensure that bitshifts and bitmasks are used in the

[PATCH] Serial: Avoid enabling clocks when clock node is null.

2010-04-20 Thread Govindraj.R
This patch ensures that if a particular uart clock node was not acquired then do not proceed with enabling clock and device registration for that uart. Without this patch if uart_ick/fck value was null then it throw oops as below and boot will halt. 1Unable to handle kernel NULL pointer

RE: OMAP camera port connected to Davinci VPIF port

2010-04-20 Thread Hiremath, Vaibhav
-Original Message- From: linux-omap-ow...@vger.kernel.org [mailto:linux-omap- ow...@vger.kernel.org] On Behalf Of kshen Sent: Saturday, April 17, 2010 3:31 AM To: OMAP Linux discussion Subject: OMAP camera port connected to Davinci VPIF port Hi, On a board I'm working on, it

Re: Upstream linux-omap kernel on Nokia N900?

2010-04-20 Thread Roger Quadros
ext Tony Lindgren wrote: * Roger Quadros roger.quad...@nokia.com [100419 05:06]: Balbi Felipe (Nokia-D/Helsinki) wrote: Hi, On Mon, Apr 19, 2010 at 01:49:15PM +0200, ext Arnaud Ebalard wrote: Nokia N900 is shipped to users with a 2.6.28 omap kernel. Many patches for the hardware and various

Re: Upstream linux-omap kernel on Nokia N900?

2010-04-20 Thread Ameya Palande
On Tue, 2010-04-20 at 10:36 +0200, Quadros Roger (Nokia-D/Helsinki) wrote: ext Tony Lindgren wrote: * Roger Quadros roger.quad...@nokia.com [100419 05:06]: Balbi Felipe (Nokia-D/Helsinki) wrote: Hi, On Mon, Apr 19, 2010 at 01:49:15PM +0200, ext Arnaud Ebalard wrote: Nokia N900 is

Re: [PATCHv3 0/5] OMAP: RX51: Add LCD Panel Support for N900

2010-04-20 Thread Tomi Valkeinen
On Tue, 2010-04-20 at 14:53 +0200, Quadros Roger (Nokia-D/Helsinki) wrote: Hi Tomi, Quadros Roger (Nokia-D/Helsinki) wrote: Tomi, Resending the patchset. Checkpatch was not complaining at my end. Probably the mail server is mangling the patches. I will send a tarball separately.

Re: [PATCH] OMAP:ls037v7dw01: Included slab.h file required for kzalloc

2010-04-20 Thread Tomi Valkeinen
Hi, On Tue, 2010-04-20 at 11:44 +0200, ext hvaib...@ti.com wrote: From: Vaibhav Hiremath hvaib...@ti.com With recent kernel changes, without inclusion of slab.h kernel build fails with, CC drivers/video/omap2/displays/panel-sharp-ls037v7dw01.o

[PM-WIP-OPP][PATCH 2/2] omap: pm: opp: twl: use DIV_ROUND_UP

2010-04-20 Thread Nishanth Menon
From: Phil Carmody ext-phil.2.carm...@nokia.com kernel.h provides a function for DIV_ROUND_UP which should be used instead of replicating it in code. Cc: Ambresh K ambr...@ti.com Cc: Benoit Cousson b-cous...@ti.com Cc: Eduardo Valentin eduardo.valen...@nokia.com Cc: Kevin Hilman

[PM-WIP-OPP][PATCH 1/2 v2] omap3: pm: cpufreq: BUG_ON cleanup

2010-04-20 Thread Nishanth Menon
BUG_ON should not ideally contain a functional code. Ref: http://marc.info/?l=linux-kernelm=109391212925546w=2 To do this, we change the return of omap3_pm_init_opp from void to int and return back error value for caller to adequately handle further decisions. to reduce code duplication, the

[PATCH 0/3][V2] OMAP: IOMMU patches to support OMAP4 and TLB preservation support

2010-04-20 Thread Kanigeri, Hari
Following are the revised patches addressing the comments from Santosh, Felipe, and Hiroshi. The detailed changed list is: Hari Kanigeri(3): OMAP:iommu support for OMAP4 OMAP:iommu - missing check for TLB valid entry OMAP:iommu- add TLB preservation support

[PATCH 1/3][v2] OMAP:iommu support for OMAP4

2010-04-20 Thread Kanigeri, Hari
From 9a6f91b0c108fd010afdb6bddcae92579c87fcbd Mon Sep 17 00:00:00 2001 From: Hari Kanigeri h-kanige...@ti.com Date: Tue, 20 Apr 2010 12:03:03 -0500 Subject: [PATCH 1/3] OMAP:iommu support for OMAP4 This patch provides the iommu support for OMAP4 co-processors. This includes changes to

[PATCH 3/3][v2] OMAP:iommu- add TLB preservation support

2010-04-20 Thread Kanigeri, Hari
From 2cecc5abd54c7a139495d135260a6a66810318e8 Mon Sep 17 00:00:00 2001 From: Hari Kanigeri h-kanige...@ti.com Date: Tue, 20 Apr 2010 12:11:16 -0500 Subject: [PATCH 3/3] OMAP:iommu- add TLB preservation support This patch adds TLB preservation support to IOMMU module Signed-off-by: Hari Kanigeri

Re: [PATCH 1/3][v2] OMAP:iommu support for OMAP4

2010-04-20 Thread Felipe Contreras
On Wed, Apr 21, 2010 at 12:31 AM, Kanigeri, Hari h-kanige...@ti.com wrote: From 9a6f91b0c108fd010afdb6bddcae92579c87fcbd Mon Sep 17 00:00:00 2001 From: Hari Kanigeri h-kanige...@ti.com Date: Tue, 20 Apr 2010 12:03:03 -0500 Subject: [PATCH 1/3] OMAP:iommu support for OMAP4 This patch provides

RE: [PATCH 1/3][v2] OMAP:iommu support for OMAP4

2010-04-20 Thread Kanigeri, Hari
Felipe, -Original Message- From: Felipe Contreras [mailto:felipe.contre...@gmail.com] Sent: Tuesday, April 20, 2010 4:49 PM To: Kanigeri, Hari Cc: linux-omap@vger.kernel.org; Shilimkar, Santosh; Hiroshi DOYU; t...@atomide.com Subject: Re: [PATCH 1/3][v2] OMAP:iommu support for

RE: [PATCH 1/3][v2] OMAP:iommu support for OMAP4

2010-04-20 Thread Kanigeri, Hari
Felipe, -Original Message- From: Felipe Contreras [mailto:felipe.contre...@gmail.com] Sent: Tuesday, April 20, 2010 4:49 PM To: Kanigeri, Hari Cc: linux-omap@vger.kernel.org; Shilimkar, Santosh; Hiroshi DOYU; t...@atomide.com Subject: Re: [PATCH 1/3][v2] OMAP:iommu support for

[PATCH 0/4][V3] OMAP: IOMMU patches to support OMAP4 and TLB preservation support

2010-04-20 Thread Kanigeri, Hari
Following are the revised patches addressing the comments from Santosh, Felipe, and Hiroshi. The detailed changed list is: Hari Kanigeri (4) OMAP:iommu renamed omap3-iommu to omap-iommu OMAP:iommu support for OMAP4 OMAP:iommu - missing check for TLB valid entry

[PATCH 1/4] [v3]OMAP:iommu renamed omap3-iommu to omap-iommu

2010-04-20 Thread Kanigeri, Hari
From ea10f0d6550d521ff575e0ea03d5ca4fc258b80e Mon Sep 17 00:00:00 2001 From: Hari Kanigeri h-kanige...@ti.com Date: Tue, 20 Apr 2010 17:30:09 -0500 Subject: [PATCH 1/4] OMAP:iommu renamed omap3-iommu to omap-iommu This patch includes changes to omap3-iommu.c file to make it generic for all OMAPs.

[PATCH 2/4][v3] OMAP:iommu support for OMAP4

2010-04-20 Thread Kanigeri, Hari
From 9a2bcae7a2de6890884c23c45563eece1e6838de Mon Sep 17 00:00:00 2001 From: Hari Kanigeri h-kanige...@ti.com Date: Tue, 20 Apr 2010 17:39:18 -0500 Subject: [PATCH 2/4] OMAP:iommu support for OMAP4 This patch provides the iommu support for OMAP4 co-processors. Signed-off-by: Hari Kanigeri

[PATCH 3/4][v3] OMAP:iommu - missing check for TLB valid entry

2010-04-20 Thread Kanigeri, Hari
From 76471c57074ff5a816ad590aca64e3958ed487fa Mon Sep 17 00:00:00 2001 From: Hari Kanigeri h-kanige...@ti.com Date: Tue, 20 Apr 2010 12:08:26 -0500 Subject: [PATCH 3/4] OMAP:iommu - missing check for TLB valid entry Added the missing TLB valid entry setting for cam register Signed-off-by: Hari

[PATCH 2/5v3] DSPBRIDGE: Avoid errors if node handle is zero

2010-04-20 Thread Ernesto Ramos
As 'zero' can be a perfectly good id, it can be picked up as a NULL from userspace, avoid issues in API and user apps if node handle is zero. Signed-off-by: Ernesto Ramos erne...@ti.com --- drivers/dsp/bridge/pmgr/wcd.c |6 -- 1 files changed, 4 insertions(+), 2 deletions(-) diff --git

[PATCH 4/5v3] DSPBRIDGE: Use stream id instead of kernel address.

2010-04-20 Thread Ernesto Ramos
Send stream ids to the user instead of handles, then when the id is coming from user dspbridge can retrive the handle using id and avoid using invalid handles. Signed-off-by: Ernesto Ramos erne...@ti.com --- arch/arm/plat-omap/include/dspbridge/drv.h |5 +-

[PATCH 3/5v3] DSPBRIDGE: Use processor handle from context instead of user's.

2010-04-20 Thread Ernesto Ramos
Make sure dspbridge driver uses a valid processor handle by using the handle stored in process context. Signed-off-by: Ernesto Ramos erne...@ti.com --- drivers/dsp/bridge/pmgr/wcd.c | 56 - 1 files changed, 33 insertions(+), 23 deletions(-) diff --git

[PATCH 5/5v3] DSPBRIDGE: Avoid errors if stream id is zero

2010-04-20 Thread Ernesto Ramos
As 'zero' can be a perfectly good id, it can be picked up as a NULL from userspace, avoid issues in API and user apps if stream handle is zero. Signed-off-by: Ernesto Ramos erne...@ti.com --- drivers/dsp/bridge/pmgr/wcd.c |8 ++-- 1 files changed, 6 insertions(+), 2 deletions(-) diff

[PATCH 1/5v3] DSPBRIDGE: Use node id instead of kernel address

2010-04-20 Thread Ernesto Ramos
Use idr kernel library to send/receive node ids to the user instead of kernel address. This id will be use to access the node handles at the kernel side, if id does not match to any handle DSP error DSP_EHANDlE is returned. Signed-off-by: Ernesto Ramos erne...@ti.com ---

Re: [PATCH] MFD: TWL4030: changes for TRITON glitch fix

2010-04-20 Thread Kevin Hilman
Lesly A M lesl...@ti.com writes: Fix for TWL5030 Silicon Errata 27 28: 27 - VDD1, VDD2, may have glitches when their output value is updated. 28 - VDD1 and / or VDD2 DCDC clock may stop working when internal clock is switched from internal to external. Workaround

Re: [RFC] [PATCH 1/3] OMAP4: Keyboard Controller Support

2010-04-20 Thread Kevin Hilman
Arce, Abraham x0066...@ti.com writes: Keyboard controller for OMAP4 with built-in scanning algorithm. The following implementations are used: - matrix_keypac.c logic - hwmod framework - threaded irq Signed-off-by: Syed Rafiuddin rafiuddin.s...@ti.com Signed-off-by: Abraham Arce

Re: [PM-WIP-OPP][PATCH 1/2 v2] omap3: pm: cpufreq: BUG_ON cleanup

2010-04-20 Thread Kevin Hilman
Nishanth Menon n...@ti.com writes: BUG_ON should not ideally contain a functional code. Ref: http://marc.info/?l=linux-kernelm=109391212925546w=2 To do this, we change the return of omap3_pm_init_opp from void to int and return back error value for caller to adequately handle further

Re: [PM-WIP-OPP][PATCH 2/2] omap: pm: opp: twl: use DIV_ROUND_UP

2010-04-20 Thread Kevin Hilman
Nishanth Menon n...@ti.com writes: From: Phil Carmody ext-phil.2.carm...@nokia.com kernel.h provides a function for DIV_ROUND_UP which should be used instead of replicating it in code. Cc: Ambresh K ambr...@ti.com Cc: Benoit Cousson b-cous...@ti.com Cc: Eduardo Valentin

Re: [PM-WIP-OPP][PATCH 1/2 v2] omap3: pm: cpufreq: BUG_ON cleanup

2010-04-20 Thread Nishanth Menon
Kevin Hilman had written, on 04/20/2010 06:41 PM, the following: Nishanth Menon n...@ti.com writes: [..] Signed-off-by: Nishanth Menon n...@ti.com --- Ref: v1: https://patchwork.kernel.org/patch/86793/ v2 changes: removed BUG_ON entirely. instead have introduced int return

Re: [PATCHv3 00/22] OMAP3: PM: Smartreflex and voltage revamp

2010-04-20 Thread Kevin Hilman
Thara Gopinath th...@ti.com writes: The main motivations behind this patch series are the following 1. Making smartreflex a platform driver with omap-device layer. 2. Separating voltage specific code from smartreflex.c and other locations and consolidating them into voltage.c and

Re: [PATCHv3 0/2] OMAP3: PM: OMAP3630 support for smartreflex driver

2010-04-20 Thread Kevin Hilman
Thara Gopinath th...@ti.com writes: This patch series adds support for the updated 45nm smrtrelfex IP supported in OMAP3630 and OMAP4 in the smartreflex driver and adds support to enable smartreflex autocompensation for OMAP3630 using test nvalues. This patch series is based on the V3

[PM-WIP-OPP][PATCH 1/2 v3] omap3: pm: cpufreq: BUG_ON cleanup

2010-04-20 Thread Nishanth Menon
BUG_ON should not ideally contain a functional code. Ref: http://marc.info/?l=linux-kernelm=109391212925546w=2 To do this, we change the return of omap3_pm_init_opp from void to int and return back error value for caller to adequately handle further decisions. to reduce code duplication, the