Re: [PATCH 5/5 v4] mfd: omap: usb: Runtime PM support

2011-08-30 Thread Munegowda, Keshava
On Tue, Aug 30, 2011 at 2:17 AM, Kevin Hilman khil...@ti.com wrote: Kevin Hilman khil...@ti.com writes: Keshava Munegowda keshava_mgo...@ti.com writes: From: Keshava Munegowda keshava_mgo...@ti.com The usbhs core driver does not enable/disable the intefrace and fucntional clocks; These

[PATCH] mfd: Add PWM1 and PWM2 support to twl6030-pwm

2011-08-30 Thread Hemanth V
From: Hemanth V heman...@ti.com Date: Fri, 26 Aug 2011 10:49:29 +0530 Subject: [PATCH] Add PWM1 and PWM2 support to twl6030-pwm driver This patch adds support for PWM1/PWM2. TWL6030 PWM driver also supports Indicator LED PWM. Function pointers are defined for for init, enable, disable and

Re: [GIT PULL v2] OMAP: clock/powerdomain/clockdomain/hwmod: fixes for 3.1-rc

2011-08-30 Thread Paul Walmsley
Hi Tony, On Tue, 23 Aug 2011, Paul Walmsley wrote: The following changes since commit fcb8ce5cfe30ca9ca5c9a79cdfe26d1993e65e0c: Linux 3.1-rc3 (2011-08-22 11:42:53 -0700) are available in the git repository at: git://git.pwsan.com/linux-2.6 prcm-fixes-a-3.1rc Just checking up on

Re: How to handle named resources with DT?

2011-08-30 Thread Felipe Balbi
Hi, On Tue, Aug 30, 2011 at 12:29:12PM +1000, David Gibson wrote: So, I actually agree that in the long term getting resource names in the DT would be a generally good thing. But doing so is a *huge* change in one of the very core semantics of all the DT bindings. It's not something that

[PATCH 00/10] OMAP: DSS2: DSI: Initial DSI video mode support

2011-08-30 Thread Archit Taneja
This provided initial support for DSI Video Mode. The first 6 patches are not directly related to video mode, but they add required features and cleanup for supporting video mode cleanly. Support for a panel driver supporting video mode is not added yet since no OMAP platfrom support in mainline

[PATCH 01/10] OMAP: DSS2: Use MIPI DSI transacition types and commands from include/video/mipi_display.h

2011-08-30 Thread Archit Taneja
MIPI DSI Transaction types and DCS commands are currently defined as macros in dsi.c and panel-taal.c, remove these and replace them with enum members defined in include/video/mipi_display.h. Signed-off-by: Archit Taneja arc...@ti.com --- drivers/video/omap2/displays/panel-taal.c | 45

[PATCH 02/10] OMAP: DSS2: DSI: Represent L4 and VP as sources of VC instead of modes

2011-08-30 Thread Archit Taneja
The enum type dsi_vc_mode is a bit misleading as L4 slave port and video port are sources to VC rather than the mode of operation. Rename then enum type and its members. Merge dsi_vc_config_vp() and dsi_vc_config_l4() into a single function called dsi_vc_config_source() which takes dsi_vc_source

[PATCH 03/10] OMAP: DSS2: Create enum for DSI operation modes

2011-08-30 Thread Archit Taneja
Create an enum for DSI operation modes, use this to set the capabilities of the device in dsi_init_display(). Signed-off-by: Archit Taneja arc...@ti.com --- drivers/video/omap2/dss/dsi.c |7 --- include/video/omapdss.h |7 +++ 2 files changed, 11 insertions(+), 3

[PATCH 04/10] OMAP: DSS2: DSI: Introduce generic write functions

2011-08-30 Thread Archit Taneja
Intoduce enum dss_dsi_content_type to differentiate between DCS and generic content types. Introduce short and long packet write functions which use generic Processor-to-Peripheral transaction types. These are needed by some devices which may not support corresponding DCS commands. Create common

[PATCH 05/10] OMAP: DSS2: DSI: Remove functions dsi_vc_dcs_read_1() and dsi_vc_dcs_read_2()

2011-08-30 Thread Archit Taneja
Remove functions dsi_vc_dcs_read_1() and dsi_vc_dcs_read_2(), these are used when the panel is expected to return 1 and 2 bytes respecitvely. This was manily used for debugging purposes. These functions should be implemented in the panel driver if needed. Signed-off-by: Archit Taneja

[PATCH 06/10] OMAP: DSS2: DSI: Split dsi_vc_dcs_read() into 2 functions

2011-08-30 Thread Archit Taneja
Split dsi_vc_dcs_read() into the functions: - dsi_vc_dcs_send_read_request(): This is responsible for sending the short packet command with the read request. - dsi_vc_dcs_read_rx_fifo(): This parses the DSI RX fifo of the given virtual channel, identifies the type of data received, and fills a

[PATCH 07/10] OMAP: DSS2: DSI: Introduce generic read functions

2011-08-30 Thread Archit Taneja
Introduce read functions which use generic Processor-to-Peripheral transaction types. These are needed by some devices which may not support corresponding DCS commands. Add function dsi_vc_generic_send_read_request() which can send a short packet with 0, 1 or 2 bytes of request data and the

[PATCH 08/10] OMAP: DSS2: Clean up stallmode and io pad mode selection

2011-08-30 Thread Archit Taneja
Split the function dispc_set_parallel_interface_mode() into 2 separate functions called dispc_mgr_set_io_pad_mode() and dispc_mgr_enable_stallmode(). The current function tries to set 2 different modes(io pad mode and stall mode) based on a parameter omap_parallel_interface_mode which loosely

[PATCH 09/10] OMAP: DSS2: Create an enum for DSI pixel formats

2011-08-30 Thread Archit Taneja
Currently, DSI pixel info is only represented by the pixel size in bits using the pixel_size parameter in omap_dss_device struct's ctrl member. This is not sufficient information for DSI video mode usage, as two of the supported formats(RGB666 loosely packed, and RGB888) have the same pixel

[PATCH 10/10] OMAP: DSS2: DSI Video mode support

2011-08-30 Thread Archit Taneja
Add initial support for DSI video mode panels: - Add a new structure omap_dss_dsi_videomode_data in the member panel in omap_dss_device struct. This allows panel driver to configure dsi video_mode specific parameters. - Configure basic DSI video mode timing parameters: HBP, HFP, HSA, VBP, VFP,

[PATCH 1/3] ASoC: tpa6130a2: Model support cleanup

2011-08-30 Thread Peter Ujfalusi
Use the device name and driver_data to identify the TPA model supported by the driver. Board files should use either tpa6130a2 or tpa6140a2 as device name to specify the model in used on the specific board. Signed-off-by: Peter Ujfalusi peter.ujfal...@ti.com --- sound/soc/codecs/tpa6130a2.c |

[PATCH 0/3] ASoC: tpa6130a2: model handling cleanup

2011-08-30 Thread Peter Ujfalusi
Hello, Small cleanup for the tpa6130a2 driver for model handling: Remove the model_id from platform_data, and use the device name/device_data to distinguish between the supported models of TPA. Regards, Peter --- Peter Ujfalusi (3): ASoC: tpa6130a2: Model support cleanup OMAP: RX51: No need

[PATCH 2/3] OMAP: RX51: No need to configure the tpa_model

2011-08-30 Thread Peter Ujfalusi
The TPA driver now uses the name for model support. n900 has tpa61030a2 model of TPA. Signed-off-by: Peter Ujfalusi peter.ujfal...@ti.com --- arch/arm/mach-omap2/board-rx51-peripherals.c |1 - 1 files changed, 0 insertions(+), 1 deletions(-) diff --git

[PATCH 3/3] ASoC: tpa6130a2: Remove model_id from platform data

2011-08-30 Thread Peter Ujfalusi
The model_id is no longer needed within the platform_data for the TPA driver since the model of TPA specified with the device name (tpa6130a2/tpa6140a2). Signed-off-by: Peter Ujfalusi peter.ujfal...@ti.com --- include/sound/tpa6130a2-plat.h |6 -- sound/soc/codecs/tpa6130a2.c |5

Re: [RFC PATCH 3/3] OMAP: omap_device: Add a method to build an omap_device from a DT node

2011-08-30 Thread Cousson, Benoit
Kevin, Some self-review... On 8/22/2011 8:22 PM, Cousson, Benoit wrote: Add a notifier called during device_add phase. If a of_node is present, retrieve the hwmod entry in order to populate propely the omap_device typo structure. For the moment the resource from the device-tree are

Re: [PATCH 0/3] ASoC: tpa6130a2: model handling cleanup

2011-08-30 Thread Jarkko Nikula
On 08/30/2011 02:39 PM, Peter Ujfalusi wrote: Hello, Small cleanup for the tpa6130a2 driver for model handling: Remove the model_id from platform_data, and use the device name/device_data to distinguish between the supported models of TPA. Regards, Peter --- Peter Ujfalusi (3): ASoC:

GPIO chip select support

2011-08-30 Thread Ben Gamari
Thanks for the poke. I've been meaning to send this set out again anyways. This is the patch I am currently using (on top of v3.0). Conceptually it's quite similar to the first patches I sent out but some implementation details were slightly reworked to account for the generalization of the

[PATCH] mcspi: Add support for GPIO chip select lines

2011-08-30 Thread Ben Gamari
Many applications require more chip select lines than the board or processor allow. Introduce a mechanism to allow use of GPIO pins as chip select lines with the McSPI controller. To use this tionality, one simply provides a table mapping CS line numbers to GPIO numbers

[PATCH] beagledaq: Hack in cs_gpios

2011-08-30 Thread Ben Gamari
--- arch/arm/mach-omap2/board-omap3beagle.c |4 ++-- arch/arm/mach-omap2/devices.c | 15 +++ 2 files changed, 17 insertions(+), 2 deletions(-) diff --git a/arch/arm/mach-omap2/board-omap3beagle.c b/arch/arm/mach-omap2/board-omap3beagle.c index 67999da..481c1a9 100644

[PATCH 1/2] arm: omap: usb: Add mux initialization to ehci and ohci hwmods for omap4

2011-08-30 Thread Keshava Munegowda
From: Kishon Vijay Abraham kis...@ti.com For ehci and ohci hwmods, the omap4 mux initializations functions are included. Signed-off-by: Kishon Vijay Abraham kis...@ti.com Signed-off-by: Keshava Munegowda keshava_mgo...@ti.com --- arch/arm/mach-omap2/usb-host.c | 546

[PATCH 0/2] omap: usb: I/O pads initialization to ehci and ohci hwmods

2011-08-30 Thread Keshava Munegowda
From: Keshava Munegowda keshava_mgo...@ti.com These two patches performs the I/O pad mux initialization to ehci and ohci hwmods for both omap3 and omap4 SOCs. This patch series is based on 1. Runtime PM support of usbhs of omap3 and omap4 These patches are avilable at branch

[PATCH 2/2] arm: omap: usb: Add mux initialization to ehci and ohci hwmods for omap3

2011-08-30 Thread Keshava Munegowda
From: Keshava Munegowda keshava_mgo...@ti.com For ehci and ohci hwmods, the omap3 mux initializations functions are included. Signed-off-by: Keshava Munegowda keshava_mgo...@ti.com --- arch/arm/mach-omap2/usb-host.c | 692 ++- 1 files changed, 532

Re: [PATCH] usb: ehci: fix update qtd-token in qh_append_tds

2011-08-30 Thread Ming Lei
Hi Alan, Thanks for your comment. On Tue, Aug 30, 2011 at 12:33 AM, Alan Stern st...@rowland.harvard.edu wrote: Nevertheless, it remains true that you want to add a memory barrier instruction simply in order to speed up a cache writeback, not to force any sort of ordering.  This needs to be

[PATCH] usb: ehci: make HC see up-to-date qh/qtd descriptor ASAP

2011-08-30 Thread ming . lei
From: Ming Lei ming@canonical.com This patch introduces the helper of ehci_sync_mem to flush qtd/qh into memory immediately on some ARM, so that HC can see the up-to-date qtd/qh descriptor asap. This patch fixs one performance bug on ARM Cortex A9 dual core platform, which has been reported

Re: [PATCH] usb: ehci: make HC see up-to-date qh/qtd descriptor ASAP

2011-08-30 Thread Alan Stern
On Wed, 31 Aug 2011 ming@canonical.com wrote: From: Ming Lei ming@canonical.com This patch introduces the helper of ehci_sync_mem to flush qtd/qh into memory immediately on some ARM, so that HC can see the up-to-date qtd/qh descriptor asap. This patch fixs one performance bug on

Re: [PATCH] usb: ehci: make HC see up-to-date qh/qtd descriptor ASAP

2011-08-30 Thread Mark Salter
On Wed, 2011-08-31 at 00:03 +0800, ming@canonical.com wrote: +/* + * Writing to dma coherent memory on ARM may be delayed via L2 + * writing buffer, so introduce the helper which can flush L2 writing + * buffer into memory immediately, especially used to flush ehci + * descriptor to

[PATCH 1/2 RESEND] OMAP2+: pm: fix typos

2011-08-30 Thread Johan Hovold
Fix typos in comment and error message. Signed-off-by: Johan Hovold jhov...@gmail.com --- arch/arm/mach-omap2/pm.c |6 +++--- 1 files changed, 3 insertions(+), 3 deletions(-) diff --git a/arch/arm/mach-omap2/pm.c b/arch/arm/mach-omap2/pm.c index 3feb359..fd77cf4 100644 ---

[PATCH 2/2 RESEND] OMAP2+: pm: clean up error messages

2011-08-30 Thread Johan Hovold
Replace all printks with pr_err. Clean up error messages by adding missing whitespace, fixing capitalisations, removing double newlines, and reducing verbosity. Signed-off-by: Johan Hovold jhov...@gmail.com --- arch/arm/mach-omap2/pm.c | 18 -- 1 files changed, 8

Re: [PATCH 3/3] OMAP2+: voltage: clean up error messages

2011-08-30 Thread Johan Hovold
On Mon, Aug 29, 2011 at 02:15:49PM -0700, Kevin Hilman wrote: Hi Johan, Johan Hovold jhov...@gmail.com writes: Clean up error messages by adding missing whitespace, reducing excessive verbosity, and fixing a few language issues. Signed-off-by: Johan Hovold jhov...@gmail.com I've

Re: [PATCH] usb: ehci: make HC see up-to-date qh/qtd descriptor ASAP

2011-08-30 Thread Alan Stern
On Tue, 30 Aug 2011, Mark Salter wrote: On Wed, 2011-08-31 at 00:03 +0800, ming@canonical.com wrote: +/* + * Writing to dma coherent memory on ARM may be delayed via L2 + * writing buffer, so introduce the helper which can flush L2 writing + * buffer into memory immediately,

Re: [PATCH] usb: ehci: make HC see up-to-date qh/qtd descriptor ASAP

2011-08-30 Thread Will Deacon
On Tue, Aug 30, 2011 at 05:38:30PM +0100, Mark Salter wrote: On Wed, 2011-08-31 at 00:03 +0800, ming@canonical.com wrote: +/* + * Writing to dma coherent memory on ARM may be delayed via L2 + * writing buffer, so introduce the helper which can flush L2 writing + * buffer into memory

Re: [PATCH] usb: ehci: make HC see up-to-date qh/qtd descriptor ASAP

2011-08-30 Thread Greg KH
On Tue, Aug 30, 2011 at 06:26:42PM +0100, Will Deacon wrote: On Tue, Aug 30, 2011 at 05:38:30PM +0100, Mark Salter wrote: On Wed, 2011-08-31 at 00:03 +0800, ming@canonical.com wrote: +/* + * Writing to dma coherent memory on ARM may be delayed via L2 + * writing buffer, so

Re: [PATCH] usb: ehci: make HC see up-to-date qh/qtd descriptor ASAP

2011-08-30 Thread Will Deacon
On Tue, Aug 30, 2011 at 06:48:59PM +0100, Greg KH wrote: On Tue, Aug 30, 2011 at 06:26:42PM +0100, Will Deacon wrote: On Tue, Aug 30, 2011 at 05:38:30PM +0100, Mark Salter wrote: On Wed, 2011-08-31 at 00:03 +0800, ming@canonical.com wrote: +/* + * Writing to dma coherent memory

Re: [PATCH] usb: ehci: make HC see up-to-date qh/qtd descriptor ASAP

2011-08-30 Thread Mark Salter
On Tue, 2011-08-30 at 13:15 -0400, Alan Stern wrote: On Tue, 30 Aug 2011, Mark Salter wrote: On Wed, 2011-08-31 at 00:03 +0800, ming@canonical.com wrote: +/* + * Writing to dma coherent memory on ARM may be delayed via L2 + * writing buffer, so introduce the helper which can

Re: [RFC PATCH v2 0/6] TI81XX: Add clock and hwmod data

2011-08-30 Thread Paul Walmsley
On Tue, 23 Aug 2011, Hemant Pedanekar wrote: This patch set is the v2 of TI816X clock and hwmods patches sent earlier. The clock data is currently added only for TI816X, while minimal hwmod data common for TI816X and TI814X is added. This patch set depends on following patches:

Re: [PATCH 1/2] omap3: ISP: Fix the failure of CCDC capture during suspend/resume

2011-08-30 Thread Laurent Pinchart
Hi, On Wednesday 10 August 2011 16:03:12 Deepthy Ravi wrote: From: Abhilash K V abhilash...@ti.com While resuming from the suspended to memory state, occasionally CCDC fails to get enabled and thus fails to capture frames any more till the next suspend/resume is issued. This is a race

Re: [PATCH 1/2 RESEND] OMAP2+: pm: fix typos

2011-08-30 Thread Kevin Hilman
Johan Hovold jhov...@gmail.com writes: Fix typos in comment and error message. Signed-off-by: Johan Hovold jhov...@gmail.com Thanks, queuing for v3.2 (branch: for_3.2/pm-cleanup) Kevin --- arch/arm/mach-omap2/pm.c |6 +++--- 1 files changed, 3 insertions(+), 3 deletions(-) diff

Re: [PATCH 2/2 RESEND] OMAP2+: pm: clean up error messages

2011-08-30 Thread Kevin Hilman
Johan Hovold jhov...@gmail.com writes: Replace all printks with pr_err. Clean up error messages by adding missing whitespace, fixing capitalisations, removing double newlines, and reducing verbosity. Signed-off-by: Johan Hovold jhov...@gmail.com Thanks, queuing for v3.2 (branch:

Re: [PATCH 1/3] AM35x: voltage: Basic initialization

2011-08-30 Thread Kevin Hilman
Abhilash K V abhilash...@ti.com writes: From: Sanjeev Premi pr...@ti.com This patch adds the basic initialization of voltage layer for AM35x. Since AM35x doesn't support voltage scaling, Many functions have been defined to plug into existing voltage layer. Signed-off-by: Sanjeev Premi

Re: [PATCH 1/4] AM3517 : support for suspend/resume

2011-08-30 Thread Kevin Hilman
Abhilash K V abhilash...@ti.com writes: 1. Patch to disable dynamic sleep (as it is not supported on AM35xx). 2. Imported the unique suspend/resume sequence for AM3517, contained in the new file arch/arm/mach-omap2/sleep3517.S. 3. Added omap3517_ to symbol-names in sleep3517.S which

Re: [PATCH 3/4] pm34xx: Warning FIX related to ambiguous else loop

2011-08-30 Thread Kevin Hilman
Abhilash K V abhilash...@ti.com writes: From: Vaibhav Hiremath hvaib...@ti.com Fixes below warning - arch/arm/mach-omap2/pm34xx.c:1041: warning: suggest explicit braces to avoid ambiguous 'else This warning was introduced in [1/4], so I'd suggest just folding this fix into the

Re: [PATCH] usb: ehci: make HC see up-to-date qh/qtd descriptor ASAP

2011-08-30 Thread Chen Peter-B29397
On Aug 31, 2011, at 1:54 AM, Will Deacon wrote: On Tue, Aug 30, 2011 at 06:48:59PM +0100, Greg KH wrote: On Tue, Aug 30, 2011 at 06:26:42PM +0100, Will Deacon wrote: On Tue, Aug 30, 2011 at 05:38:30PM +0100, Mark Salter wrote: On Wed, 2011-08-31 at 00:03 +0800, ming@canonical.com wrote:

Re: [PATCH] usb: ehci: make HC see up-to-date qh/qtd descriptor ASAP

2011-08-30 Thread Ming Lei
On Wed, Aug 31, 2011 at 1:54 AM, Will Deacon will.dea...@arm.com wrote: Although this doesn't have anything to do with ordering; it's all to do with immediacy so I think we should try to avoiding using the term `barrier'. If this can be made part of the coherent DMA API, that might be the best

Re: Arm device tree wonder

2011-08-30 Thread Paul Walmsley
On Tue, 30 Aug 2011, Pierre Beaumon wrote: Also I believe one big arm problem is a lack of common infrastructure that lead to code duplication. Some machine try to do too much things. omap2 (mach-omap2 + plat-omap) is about 80 KSLOC over 400KSLOC (76 mach + plat directories). That 8 times

Re: How to handle named resources with DT?

2011-08-30 Thread David Gibson
On Tue, Aug 30, 2011 at 12:27:24PM +0300, Felipe Balbi wrote: Hi, On Tue, Aug 30, 2011 at 12:29:12PM +1000, David Gibson wrote: So, I actually agree that in the long term getting resource names in the DT would be a generally good thing. But doing so is a *huge* change in one of the