[RFC][BUG] arm/dts: OMAP3: set #interrupt-cells to two

2013-03-30 Thread Christoph Fritz
This patch sets gpio #interrupt-cells from a falsely acquired '1' to '2' referring to Documentation/devicetree/bindings/gpio/gpio-omap.txt: The first cell is the GPIO number. The second cell is used to specify flags: bits[3:0] trigger type and level flags: 1 =

AM3517 USB and OTG issues 3.9-rc1 kernel.

2013-03-30 Thread Marc Murphy
Hello All, I have a question about the updates/changes that have been made to the USB OTG support in the latest 3.9-rc1 kernel My platform is using an AM3517 processor and I am in the progress of moving from 3.6 to 3.9 kernel because I need some of the iio support in the latest 3.9 kernel. The

Re: [RFC][BUG] arm/dts: OMAP3: set #interrupt-cells to two

2013-03-30 Thread Javier Martinez Canillas
On Sat, Mar 30, 2013 at 9:21 AM, Christoph Fritz chf.fr...@googlemail.com wrote: This patch sets gpio #interrupt-cells from a falsely acquired '1' to '2' referring to Documentation/devicetree/bindings/gpio/gpio-omap.txt: The first cell is the GPIO number. The second cell is used

Re: [PATCH] RX-51: Add leds lp5523 names from Maemo 5 2.6.28 kernel

2013-03-30 Thread Pavel Machek
On Sun 2013-01-20 03:50:44, Pali Rohár wrote: Signed-off-by: Pali Rohár pali.ro...@gmail.com Reviewed-by: Pavel Machek pa...@ucw.cz -- (english) http://www.livejournal.com/~pavelmachek (cesky, pictures) http://atrey.karlin.mff.cuni.cz/~pavel/picture/horses/blog.html -- To unsubscribe from

Re: [PATCH] RX-51: Register twl4030-madc device

2013-03-30 Thread Pavel Machek
On Sun 2013-01-20 03:54:26, Pali Rohár wrote: Signed-off-by: Pali Rohár pali.ro...@gmail.com Reviewed-by: Pavel Machek pa...@ucw.cz -- (english) http://www.livejournal.com/~pavelmachek (cesky, pictures) http://atrey.karlin.mff.cuni.cz/~pavel/picture/horses/blog.html -- To unsubscribe from

Re: [PATCH] ADP1653 board code for Nokia RX-51

2013-03-30 Thread Pavel Machek
Hi! +static int __init rx51_camera_hw_init(void) +{ + int rval; + + rval = rx51_adp1653_init(); + if (rval) + return rval; + + return 0; +} return rx51_adp1653_init(). Or better yet, rename rx51_adp1653_init to rx51_camera_hw_init. Thanks for all the n900

Re: [PATCH] arm: omap: RX-51: ARM errata 430973 workaround

2013-03-30 Thread Pavel Machek
Hi! +u32 rx51_secure_dispatcher(u32 idx, u32 flag, u32 nargs, u32 arg1, u32 arg2, +u32 arg3, u32 arg4) +{ + u32 ret; + u32 param[5]; + + param[0] = nargs+1; + param[1] = arg1; + param[2] = arg2; + param[3] = arg3; + param[4] = arg4;

Re: [PATCH] arm: omap: RX-51: ARM errata 430973 workaround

2013-03-30 Thread Ивайло Димитров
Hi, Оригинално писмо От: Pavel Machek Относно: Re: [PATCH] arm: omap: RX-51: ARM errata 430973 workaround До: Pali Rohár Изпратено на: Събота, 2013, Март 30 20:36:54 EET Hi! +u32 rx51_secure_dispatcher(u32 idx, u32 flag, u32 nargs, u32 arg1, u32 arg2, +

[GIT PULL] ARM: OMAP2+: standardize integration for AES SHA/MD5 IP blocks for 3.10

2013-03-30 Thread Paul Walmsley
-BEGIN PGP SIGNED MESSAGE- Hash: SHA1 Hi Tony, The following changes since commit 78e52e026d288aad88b46bff0d94b05e145c4583: ARM: OMAP2+: clock data: Remove CK_* flags (2013-03-18 09:57:39 -0600) are available in the git repository at:

Re: [GIT PULL] ARM: OMAP2+: standardize integration for AES SHA/MD5 IP blocks for 3.9

2013-03-30 Thread Paul Walmsley
Hi Tony, On Mon, 4 Mar 2013, Tony Lindgren wrote: * Paul Walmsley p...@pwsan.com [130208 09:57]: For OMAP2+ SoCs, convert the SHA/MD5 and AES accelerator integration code and data to use hwmod and omap_device. This is a prerequisite for moving the hwmod code out of arch/arm.

[PATCH] Revert lockdep: check that no locks held at freeze time

2013-03-30 Thread Paul Walmsley
This reverts commit 6aa9707099c4b25700940eb3d016f16c4434360d. Commit 6aa970 causes problems with NFS root filesystems. The failures were noticed on OMAP2 and 3 boards during kernel init: [5.508148] [ BUG: swapper/0/1 still has locks held! ] [5.513610] 3.9.0-rc3-00344-ga937536 #1 Not

Re: LOCKDEP: 3.9-rc1: mount.nfs/4272 still has locks held!

2013-03-30 Thread Paul Walmsley
On Wed, 13 Mar 2013, Jeff Layton wrote: Of course, this is all a lot of work, and not something we can shove into the kernel for 3.9 at this point. In the meantime, while Mandeep's warning is correctly pointing out a problem, I think we ought to back it out until we can fix this properly.

Re: AM3517 USB and OTG issues 3.9-rc1 kernel.

2013-03-30 Thread Paul Walmsley
Hi, On Sat, 30 Mar 2013, Marc Murphy wrote: Hello All, I have a question about the updates/changes that have been made to the USB OTG support in the latest 3.9-rc1 kernel My platform is using an AM3517 processor and I am in the progress of moving from 3.6 to 3.9 kernel because I need

Re: [PATCH 2/8] ARM: OMAP2+: hwmod: Cleanup sidle/mstandby programming

2013-03-30 Thread Paul Walmsley
Hi On Wed, 20 Feb 2013, Santosh Shilimkar wrote: From: Rajendra Nayak rna...@ti.com _enable_wakeup() and _disable_wakeup() are expected to program the OCP_SYSCONFIG.ENAWAKEUP bit. These functions were originally intended to take care of everything needed for the IP block to wake up the

Re: [PATCH 3/8] ARM: OMAP2+: hwmod: Always have OCP_SYSCONFIG.ENAWAKEUP enabled

2013-03-30 Thread Paul Walmsley
On Wed, 20 Feb 2013, Santosh Shilimkar wrote: From: Rajendra Nayak rna...@ti.com Get rid of all complexities around when to enable OCP_SYSCONFIG.ENAWAKEUP. It should be safe to have this set *always* for all IP blocks which have this control. It should be a *dont care* when the IP is in

Re: [PATCH 6/8] SERIAL: OMAP: Remove the slave idle handling from the driver

2013-03-30 Thread Paul Walmsley
Hi On Wed, 20 Feb 2013, Santosh Shilimkar wrote: UART IP slave idle handling now taken care by runtime pm backend(hwmod layer) so remove the hackery from the driver. Tested-by: Vaibhav Bedia vaibhav.be...@ti.com Tested-by: Sourav Poddar sourav.pod...@ti.com Signed-off-by: Rajendra nayak

Re: [PATCH 1/8] ARM: OMAP2+: hwmod: Remove unused _HWMOD_WAKEUP_ENABLED flag

2013-03-30 Thread Paul Walmsley
On Wed, 20 Feb 2013, Santosh Shilimkar wrote: From: Rajendra Nayak rna...@ti.com _HWMOD_WAKEUP_ENABLED is currently unused across the hwmod framework. Just get rid of it, so we have one less flag to worry about. Tested-by: Vaibhav Bedia vaibhav.be...@ti.com Signed-off-by: Rajendra Nayak

Re: [PATCH 1/2] ARM: OMAP2+: AM33xx: hwmod: Add missing sysc definition to wdt1 entry

2013-03-30 Thread Paul Walmsley
On Fri, 29 Mar 2013, Vaibhav Hiremath wrote: This patch adds sysc definitions to the wdt1 hwmod entry, which in-turn makes sure that sysc idle bit-fields are configured to valid state on enable/disable callbacks. With the recent submitted patch from Santosh Shilimkar, ARM: OMAP2+: hwmod:

Re: [PATCH 2/2] ARM: OMAP2+: am335x: Change the wdt1 func clk src to per_32k clk

2013-03-30 Thread Paul Walmsley
On Fri, 29 Mar 2013, Vaibhav Hiremath wrote: WDT1 module can take one of the below clocks as input functional clock - - On-Chip 32K RC Osc [default/reset] - 32K from PRCM The On-Chip 32K RC Osc clock is not an accurate clock-source as per the design/spec, so as a result, for

Re: [PATCH 1/8] ARM: OMAP2+: hwmod: Remove unused _HWMOD_WAKEUP_ENABLED flag

2013-03-30 Thread Paul Walmsley
On Sun, 31 Mar 2013, Paul Walmsley wrote: On Wed, 20 Feb 2013, Santosh Shilimkar wrote: From: Rajendra Nayak rna...@ti.com _HWMOD_WAKEUP_ENABLED is currently unused across the hwmod framework. Just get rid of it, so we have one less flag to worry about. Tested-by: Vaibhav Bedia

Re: [RFC][PATCH 0/5] Introduce .get_voltage callback into voltdm

2013-03-30 Thread Paul Walmsley
Hi Mike, Kevin, On Wed, 3 Oct 2012, Mike Turquette wrote: From: Mike Turquette mturque...@linaro.org This series creates a new callback for struct voltagedomain, .get_voltage. This fetches the voltage from hardware, if possible, and returns it to the caller. We use this call to populate