Re: [Gta04-owner] [PATCH 08/14] twl4030_charger: allow max_current to be managed via sysfs.

2015-03-23 Thread jake42
Hello Neil, some suggestions: On 23.03.2015 00:20, NeilBrown wrote: From: NeilBrown ne...@suse.de diff --git a/Documentation/ABI/testing/sysfs-class-power-twl4030 b/Documentation/ABI/testing/sysfs-class-power-twl4030 new file mode 100644 index ..06092209d851 --- /dev/null +++

Re: [PATCH 2/3] clk: ti: Implement FAPLL set_rate for the synthesizer

2015-03-23 Thread Tero Kristo
On 03/23/2015 12:35 AM, Tony Lindgren wrote: We can pretty much get any rate out of the FAPLL because of the fractional divider. Let's first try just adjusting the post divider, and if that is not enough, then reprogram both the fractional divider and the post divider. Let's also add a define

[PATCH v2 0/8] gpio: omap: cleanup: get rid of system GPIO - GPIO offset converseations

2015-03-23 Thread grygorii.strashko
From: Grygorii Strashko grygorii.stras...@linaro.org Now in TI OMAP GPIO driver there are a lot of places where System GPIO number calculated and then converted to GPIO offset. What is worse is that in many place such conversation performed twice or even three times. But actually, we don't need

[PATCH v2 1/8] gpio: omap: convert omap_gpio_is_input() to use gpio offset

2015-03-23 Thread grygorii.strashko
From: Grygorii Strashko grygorii.stras...@linaro.org Convert omap_gpio_is_input() to use GPIO offset instead of mask and, in such way, make code simpler and remove few lines of code. Tested-by: Tony Lindgren t...@atomide.com Tested-by: Aaro Koskinen aaro.koski...@iki.fi Acked-by: Santosh

Re: [PATCH 21/35 linux-next] mfd: constify of_device_id array

2015-03-23 Thread Lee Jones
On Mon, 16 Mar 2015, Fabian Frederick wrote: of_device_id is always used as const. (See driver.of_match_table and open firmware functions) Signed-off-by: Fabian Frederick f...@skynet.be --- drivers/mfd/hi6421-pmic-core.c | 2 +- drivers/mfd/rk808.c| 2 +-

[PATCH v2 6/8] gpio: omap: get rid of GPIO_BIT() macro

2015-03-23 Thread grygorii.strashko
From: Grygorii Strashko grygorii.stras...@linaro.org Now OMAP GPIO driver prepared for GPIO_BIT() macro removing. Do it ;) Tested-by: Tony Lindgren t...@atomide.com Tested-by: Aaro Koskinen aaro.koski...@iki.fi Acked-by: Santosh Shilimkar ssant...@kernel.org Acked-by: Javier Martinez Canillas

[PATCH v2 8/8] gpio: omap: get rid of GPIO_INDEX() macro

2015-03-23 Thread grygorii.strashko
From: Grygorii Strashko grygorii.stras...@linaro.org Now OMAP GPIO driver prepared for GPIO_INDEX() macro removing. Do It ;) Tested-by: Tony Lindgren t...@atomide.com Tested-by: Aaro Koskinen aaro.koski...@iki.fi Acked-by: Santosh Shilimkar ssant...@kernel.org Acked-by: Javier Martinez Canillas

[PATCH v2 2/8] gpio: omap: simplify omap_set_gpio_dataout_x()

2015-03-23 Thread grygorii.strashko
From: Grygorii Strashko grygorii.stras...@linaro.org Both functions omap_set_gpio_dataout_reg() and omap_set_gpio_dataout_mask() accept GPIO offset as 'gpio' input parameter, so rename it to 'offset' and drop usage of GPIO_BIT() macro. Tested-by: Tony Lindgren t...@atomide.com Tested-by: Aaro

[PATCH v2 4/8] gpio: omap: drop 'gpio' param from omap_gpio_init_irq()

2015-03-23 Thread grygorii.strashko
From: Grygorii Strashko grygorii.stras...@linaro.org The 'gpio' parameter isn't needed any more as it duplicates 'offset' parameter, so drop it. Tested-by: Tony Lindgren t...@atomide.com Tested-by: Aaro Koskinen aaro.koski...@iki.fi Acked-by: Santosh Shilimkar ssant...@kernel.org Acked-by:

[PATCH v2 3/8] gpio: omap: convert debounce functions switch to use gpio offset

2015-03-23 Thread grygorii.strashko
From: Grygorii Strashko grygorii.stras...@linaro.org Convert debounce functions to use GPIO offset instead of system GPIO numbers. This allows to drop unneeded conversations between system GPIO - GPIO offset which are done in many places and many times. It is safe to do now because: - gpiolib

[PATCH v2 7/8] gpio: omap: get rid of omap_irq_to_gpio()

2015-03-23 Thread grygorii.strashko
From: Grygorii Strashko grygorii.stras...@linaro.org Now OMAP GPIO driver prepared for omap_irq_to_gpio() removing. Do it ;) Tested-by: Tony Lindgren t...@atomide.com Tested-by: Aaro Koskinen aaro.koski...@iki.fi Acked-by: Santosh Shilimkar ssant...@kernel.org Acked-by: Javier Martinez Canillas

[PATCH v2 5/8] gpio: omap: convert gpio irq functions to use GPIO offset

2015-03-23 Thread grygorii.strashko
From: Grygorii Strashko grygorii.stras...@linaro.org Convert GPIO IRQ functions to use GPIO offset instead of system GPIO numbers. This allows to drop unneeded conversations between system GPIO - GPIO offset which are done in many places and many times. It is safe to do now because: - gpiolib

[PATCH] EDMA: TI: fixed memory leak when terminating running transfers

2015-03-23 Thread Petr Kulhavy
If edma_terminate_all() was called while a transfer was running (i.e. after edma_execute() but before edma_callback()) the echan-edesc was not freed. This was due to the fact that a running transfer is on none of the vchan lists: desc_submitted, desc_issued, desc_completed (edma_execute() removes

Re: [PATCH 2/4] mmc: core: allow non-blocking form of mmc_claim_host

2015-03-23 Thread Ulf Hansson
On 23 March 2015 at 10:58, Ulf Hansson ulf.hans...@linaro.org wrote: On 24 February 2015 at 03:42, NeilBrown ne...@suse.de wrote: Change the handling for the 'abort' flag so that if it is set, but we can claim the host, then do the claim, rather than aborting. When the abort is async this

Re: [PATCHv5 27/35] ARM: dts: am33xx: add minimal l4 bus layout with control module support

2015-03-23 Thread Tero Kristo
On 03/21/2015 01:30 AM, Tony Lindgren wrote: * Suman Anna s-a...@ti.com [150320 16:24]: On 03/20/2015 05:35 PM, Tony Lindgren wrote: * Suman Anna s-a...@ti.com [150320 14:44]: On 03/20/2015 01:44 PM, Kristo, Tero wrote: + scm: scm@21 { +

Re: [PATCHv2] thermal: add omap3 support

2015-03-23 Thread Eduardo Valentin
On Sun, Jan 18, 2015 at 09:28:24PM +0100, Pavel Machek wrote: Add support for omap3430 sensor. Tested on Nokia N900. Fix help text to be closer to english. Ifdefs in ti-bandgap.h are not neccessary, as users have #ifdefs, already. Signed-off-by: Pavel Machek pa...@ucw.cz You need to

Re: [PATCH 2/3] clk: ti: Implement FAPLL set_rate for the synthesizer

2015-03-23 Thread Tony Lindgren
* Tero Kristo t-kri...@ti.com [150323 06:25]: On 03/23/2015 12:35 AM, Tony Lindgren wrote: +static u32 ti_fapll_synth_set_frac_rate(struct fapll_synth *synth, +unsigned long rate, +unsigned long parent_rate) +{ +u32

Re: [PATCHv2] thermal: add omap3 support

2015-03-23 Thread Pavel Machek
On Mon 2015-03-23 10:31:51, Eduardo Valentin wrote: On Sun, Jan 18, 2015 at 09:28:24PM +0100, Pavel Machek wrote: Add support for omap3430 sensor. Tested on Nokia N900. Fix help text to be closer to english. Ifdefs in ti-bandgap.h are not neccessary, as users have #ifdefs,

Re: Serious memory leak in TI EDMA driver (drivers/dma/edma.c)

2015-03-23 Thread Peter Ujfalusi
On 03/20/2015 11:53 PM, Petr Kulhavy wrote: Hi Peter, yes, that is one of the differences to the EVM that the SD card is on MMCSD1. This is due to the pin multiplexer and other peripherals we're using. Your patch is correct, however the edma_callback() is using the channel number

Re: Serious memory leak in TI EDMA driver (drivers/dma/edma.c)

2015-03-23 Thread Petr Kulhavy
Hi Peter, I've just posted a patch to the community, you should have received another email from me just a few minutes ago. Basically there should be a kfree in terminate_all() just before echan-edesc is set to NULL. The reason is that at that point the edesc is in none of the vchan lists

Re: [PATCHv2] thermal: add omap3 support

2015-03-23 Thread Pavel Machek
On Sat 2015-03-14 19:02:40, Pavel Machek wrote: On Fri 2015-03-13 12:53:45, Eduardo Valentin wrote: Hey Pavel, On Fri, Mar 13, 2015 at 01:09:35PM +0100, Pavel Machek wrote: Hi! I checked 4.0-rc3 and linux-next as of today, and can not see omap3 thermal support. Can you

Re: [PATCH v1.1 14/15] omap3isp: Add support for the Device Tree

2015-03-23 Thread Laurent Pinchart
Hi Sakari, Thank you for the patch. This looks good to me, except that there's one last bug I've spotted. Please see below. On Saturday 21 March 2015 00:05:04 Sakari Ailus wrote: Add the ISP device to omap3 DT include file and add support to the driver to use it. Also obtain information on

[PATCH V2 1/2] ARM: dts: DRA7: Add bandgap and related thermal nodes

2015-03-23 Thread Nishanth Menon
From: Keerthy j-keer...@ti.com Add bandgap and related thermal nodes. The patch adds 5 thermal sensors. Only one cooling device for mpu as of now. The sensors are the exact same on both dra72 and dra7. Introduce CPU, GPU, core nodes for the moment as they are direct reuse of OMAP5 entities.

[PATCH V2 0/2] DRA7/X15: Thermal dts patches

2015-03-23 Thread Nishanth Menon
- and it does- we dont hit the frequency throttling temps) (next-20150323 is broken for build currently). The patches are based on git://git.kernel.org/pub/scm/linux/kernel/git/tmlind/linux-omap.git branch: omap-for-v4.1/dt-v2 10709c0858d8 ARM: dts: Update Nanobone dts file Changes since V1: Based

[PATCH V2 2/2] ARM: dts: am57xx-beagle-x15: Add thermal map to include fan and tmp102

2015-03-23 Thread Nishanth Menon
BeagleBoard-X15 has capability for a fan and has an onboard TMP102 temperature sensor as well. This allows us to create a new thermal zone (called, un-imaginatively board), and allows us to use some active cooling as temperatures start edge upward in the system by creating a new alert temperature

Re: [PATCH v7 6/6] wlcore: remove wl12xx_platform_data

2015-03-23 Thread Eliad Peller
On Mon, Mar 23, 2015 at 10:21 AM, Sekhar Nori nsek...@ti.com wrote: On Wednesday 18 March 2015 10:08 PM, Eliad Peller wrote: Now that we have wlcore device-tree bindings in place (for both wl12xx and wl18xx), remove the legacy wl12xx_platform_data struct, and move its members into the

[GIT PULL] OMAP-GPMC driver updates for v4.1

2015-03-23 Thread Roger Quadros
Hi Arnd, Hi Olof, Based on Tony's request I will be sending you pull requests for OMAP-GPMC driver hence forth. I've sent this earlier on the 9th of March but had missed to copy Olof. Please pull in these OMAP-GPMC driver fixes for v4.1. Patches have been tested for GPMC-NAND on dra7-evm and

Re: [PATCH 3/4] mmc: sdio: support switching to 1-bit before turning off clocks

2015-03-23 Thread Ulf Hansson
On 24 February 2015 at 03:42, NeilBrown ne...@suse.de wrote: According to section 7.1.2 of http://www.sandisk.com/media/File/OEM/Manuals/SD_SDIO_specsv1.pdf In the case where the interrupt mechanism is used to wake the host while the card is in a low power state (i.e. no clocks),

Re: [PATCH 1/4] mmc: core: fold mmc_set_bus_width calls into sdio_enable_4bit_bus.

2015-03-23 Thread Ulf Hansson
On 24 February 2015 at 03:42, NeilBrown ne...@suse.de wrote: Every call to sdio_enable_4bit_bus is followed (on success) but a call /s /but / by to mmc_set_bus_width(). To simplify the code, include those calls directly in sdio_enable_4bit_bus(). Signed-off-by: NeilBrown n...@brown.name

Re: [PATCH 1/3] ARM: dts: OMAP5+: separate the cpu thermal zone definition from omap4

2015-03-23 Thread Tero Kristo
On 03/20/2015 11:54 PM, Eduardo Valentin wrote: On Fri, Mar 20, 2015 at 02:47:39PM -0500, Nishanth Menon wrote: From: Tero Kristo t-kri...@ti.com OMAP4 has a finer counter granularity, which allows for a delay of 1000ms in the thermal zone polling intervals. OMAP5/DRA7 have different counter

Re: [PATCH v7 6/6] wlcore: remove wl12xx_platform_data

2015-03-23 Thread Sekhar Nori
On Monday 23 March 2015 01:57 PM, Eliad Peller wrote: I was applying the whole series, but over v4.0-rc1 :) Its best to mention the baseline in cover-letter itself. check out again the cover-letter. you probably overlooked it :) I see it now :) Thanks, Sekhar -- To unsubscribe from this

Re: [PATCH v7 6/6] wlcore: remove wl12xx_platform_data

2015-03-23 Thread Sekhar Nori
+ Ido On Wednesday 18 March 2015 10:08 PM, Eliad Peller wrote: Now that we have wlcore device-tree bindings in place (for both wl12xx and wl18xx), remove the legacy wl12xx_platform_data struct, and move its members into the platform device data (that is passed to wlcore) Davinci 850 is the

Re: [PATCH v7 6/6] wlcore: remove wl12xx_platform_data

2015-03-23 Thread Eliad Peller
hi Sekhar, On Mon, Mar 23, 2015 at 9:51 AM, Sekhar Nori nsek...@ti.com wrote: + Ido On Wednesday 18 March 2015 10:08 PM, Eliad Peller wrote: Now that we have wlcore device-tree bindings in place (for both wl12xx and wl18xx), remove the legacy wl12xx_platform_data struct, and move its

Re: [PATCH v7 6/6] wlcore: remove wl12xx_platform_data

2015-03-23 Thread Sekhar Nori
On Monday 23 March 2015 01:36 PM, Eliad Peller wrote: hi Sekhar, On Mon, Mar 23, 2015 at 9:51 AM, Sekhar Nori nsek...@ti.com wrote: + Ido On Wednesday 18 March 2015 10:08 PM, Eliad Peller wrote: Now that we have wlcore device-tree bindings in place (for both wl12xx and wl18xx), remove the

Re: [PATCH 2/4] mmc: core: allow non-blocking form of mmc_claim_host

2015-03-23 Thread Ulf Hansson
On 24 February 2015 at 03:42, NeilBrown ne...@suse.de wrote: Change the handling for the 'abort' flag so that if it is set, but we can claim the host, then do the claim, rather than aborting. When the abort is async this just means that a race between aborting an allowing a claim is resolved

Re: [PATCH 02/14] twl4030_charger: use devres for power_supply_register and kzalloc.

2015-03-23 Thread Pavel Machek
On Mon 2015-03-23 10:20:28, NeilBrown wrote: From: NeilBrown ne...@suse.de Final allocations/registrations are now managed by devres. Signed-off-by: NeilBrown ne...@suse.de Patches 1,2: Acked-by: Pavel Machek pa...@ucw.cz -- (english) http://www.livejournal.com/~pavelmachek (cesky,

[PATCH 2/2] EDMA: TI: fixed wrongly initialized data parameter to the edma callback

2015-03-23 Thread Petr Kulhavy
The data parameter passed indirectly to the edma_callback() should be edma_chan and not the dma_chan. This bug was so far harmless since the offset of struct dma_chan within struct edma_chan is 0. However as soon as someone changes struct edma_chan this would cause troubles. Signed-off-by: Petr

Re: [PATCH 13/14] twl4030_charger: Increase current carefully while watching voltage.

2015-03-23 Thread Pavel Machek
Hi! The USB Battery Charging spec (BC1.2) suggests a dedicated charging port can deliver from 0.5 to 5.0A at between 4.75 and 5.25 volts. To choose the correct current voltage setting requires a trial and error approach: try to draw current and see if the voltage drops too low. Even

Re: [PATCH 0/2] Couple of DRA7 hwmod patches on Timers

2015-03-23 Thread Suman Anna
Hi Paul, Following are couple of DRA7 hwmod patches for the GPTimers. Patches based on 4.0-rc1. The first patch adds the data for timers 13 through 16, the DT nodes are already present, and when enabled without the hwmod data triggers a l3_noc interrupt and hangs the kernel boot [1]. The

Re: [PATCH 1/3] ARM: dts: OMAP5+: separate the cpu thermal zone definition from omap4

2015-03-23 Thread Nishanth Menon
On 03/23/2015 05:16 AM, Tero Kristo wrote: On 03/20/2015 11:54 PM, Eduardo Valentin wrote: On Fri, Mar 20, 2015 at 02:47:39PM -0500, Nishanth Menon wrote: From: Tero Kristo t-kri...@ti.com [...] Can't we simple change the polling value for the omap5 case and reuse the omap4 file? Hmm

Re: [PATCHv2] thermal: add omap3 support

2015-03-23 Thread Eduardo Valentin
On Mon, Mar 23, 2015 at 04:58:30PM +0100, Pavel Machek wrote: On Mon 2015-03-23 10:31:51, Eduardo Valentin wrote: On Sun, Jan 18, 2015 at 09:28:24PM +0100, Pavel Machek wrote: Add support for omap3430 sensor. Tested on Nokia N900. Fix help text to be closer to english.