From: Or Gerlitz <ogerl...@mellanox.com>
Date: Wed, 26 Jun 2013 17:22:11 +0300

> +             eqe->owner = 0x55;

Magic constant.  If this is how you will represent "Invalid Owner",
then make a macro for this value 0x55 expressing that.

> +     switch (synd) {
> +     case 0x1:

Please make descriptive macros instead of using magic constants.

> +#if defined(__LITTLE_ENDIAN)
> +     he_in.he = 0x0;
> +#elif defined(__BIG_ENDIAN)
> +     he_in.he = 0x80;
> +#else
> +#error Host endianness not defined
> +#endif

This endiannes bit needs a define, rather than just using a magic
constant.  And where you define this in a header file, you can do
the CPP ifdefs, rather than here.
--
To unsubscribe from this list: send the line "unsubscribe linux-rdma" in
the body of a message to majord...@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html

Reply via email to