Re: [PATCH] block devices: validate block device capacity

2014-02-03 Thread Christoph Hellwig
On Fri, Jan 31, 2014 at 03:20:17AM -0500, Mikulas Patocka wrote: So if you think you can support 16TiB devices and leave pgoff_t 32-bit, send a patch that does it. Until you make it, you should apply the patch that I sent, that prevents kernel lockups or data corruption when the user uses

[PATCH] target: Fix missing length check in spc_emulate_evpd_83()

2014-02-03 Thread Roland Dreier
From: Roland Dreier rol...@purestorage.com Commit fbfe858fea2a (target_core_spc: Include target device descriptor in VPD page 83) added a new length variable, but (due to a cut and paste mistake?) just checks scsi_name_len against 256 twice. Fix this to check scsi_target_len for overflow too.

[PATCH] trivial: scsi: Fix warning on make htmldocs caused by scsi_transport_srp.c

2014-02-03 Thread Masanari Iida
This patch fixed following warnings on make htmldocs. Warning(/drivers/scsi/scsi_transport_srp.c:819): No description found for parameter 'rport' Signed-off-by: Masanari Iida standby2...@gmail.com --- drivers/scsi/scsi_transport_srp.c | 2 ++ 1 file changed, 2 insertions(+) diff --git

Re: [PATCH] st: Do not rewind for SG_IO

2014-02-03 Thread Jeremy Linton
-BEGIN PGP SIGNED MESSAGE- Hash: SHA1 On 2/2/2014 5:42 AM, Hannes Reinecke wrote: This is due to the strictly sequential design udev has. Essentially udev spawns a worker for every device which gets created (= udev receives a uevent for). The part I fail to see in this

Re: [PATCH] trivial: scsi: Fix warning on make htmldocs caused by scsi_transport_srp.c

2014-02-03 Thread Bart Van Assche
On 02/03/14 15:34, Masanari Iida wrote: This patch fixed following warnings on make htmldocs. Warning(/drivers/scsi/scsi_transport_srp.c:819): No description found for parameter 'rport' Signed-off-by: Masanari Iida standby2...@gmail.com --- drivers/scsi/scsi_transport_srp.c | 2 ++ 1

Re: mpt2sas driver barfs when force removing a drive on 3.13.1

2014-02-03 Thread Joe Lawrence
On Fri, 31 Jan 2014 20:49:39 -0600 Matthew Thode prometheanf...@gentoo.org wrote: I decided to pull a drive while it was in use out of laziness (it was open via luks, but not in actual use). Got a fun trace as a result. Just thought you'd like to know :D Hi Matthew, The first trace looks

Re: [PATCH] st: Do not rewind for SG_IO

2014-02-03 Thread Hannes Reinecke
-BEGIN PGP SIGNED MESSAGE- Hash: SHA1 On 02/03/2014 03:50 PM, Jeremy Linton wrote: On 2/2/2014 5:42 AM, Hannes Reinecke wrote: This is due to the strictly sequential design udev has. Essentially udev spawns a worker for every device which gets created (= udev receives a uevent for).

Re: [PATCH] st: Do not rewind for SG_IO

2014-02-03 Thread Jeremy Linton
-BEGIN PGP SIGNED MESSAGE- Hash: SHA1 On 2/3/2014 9:06 AM, Hannes Reinecke wrote: That's due to udev. Udev is getting events for each device it should create a device node for. So for 'st' it'll get a series of events for 'stX', and another series of events for 'nstX'. Udev will treat

Re: [PATCH v2 2/2] ipr: Use pci_enable_msi_range() and pci_enable_msix_range()

2014-02-03 Thread Brian King
Acked-by: Brian King brk...@linux.vnet.ibm.com -- Brian King Power Linux I/O IBM Linux Technology Center -- To unsubscribe from this list: send the line unsubscribe linux-scsi in the body of a message to majord...@vger.kernel.org More majordomo info at

Re: [PATCH v2 1/2] ipr: Get rid of superfluous call to pci_disable_msi/msix()

2014-02-03 Thread Brian King
Acked-by: Brian King brk...@linux.vnet.ibm.com -- Brian King Power Linux I/O IBM Linux Technology Center -- To unsubscribe from this list: send the line unsubscribe linux-scsi in the body of a message to majord...@vger.kernel.org More majordomo info at

Re: [PATCH] target: Fix missing length check in spc_emulate_evpd_83()

2014-02-03 Thread Nicholas A. Bellinger
On Mon, 2014-02-03 at 00:35 -0800, Roland Dreier wrote: From: Roland Dreier rol...@purestorage.com Commit fbfe858fea2a (target_core_spc: Include target device descriptor in VPD page 83) added a new length variable, but (due to a cut and paste mistake?) just checks scsi_name_len against 256

[PATCH 10/12] scsi: use device_remove_file_self() instead of device_schedule_callback()

2014-02-03 Thread Tejun Heo
driver-core now supports synchrnous self-deletion of attributes and the asynchrnous removal mechanism is scheduled for removal. Use it instead of device_schedule_callback(). This makes delete behave synchronously. Signed-off-by: Tejun Heo t...@kernel.org Cc: James E.J. Bottomley

Re: [PATCH] block devices: validate block device capacity

2014-02-03 Thread Mikulas Patocka
On Mon, 3 Feb 2014, Christoph Hellwig wrote: On Fri, Jan 31, 2014 at 03:20:17AM -0500, Mikulas Patocka wrote: So if you think you can support 16TiB devices and leave pgoff_t 32-bit, send a patch that does it. Until you make it, you should apply the patch that I sent, that prevents

Re: [PATCH] st: Do not rewind for SG_IO

2014-02-03 Thread Kay Sievers
On Mon, Feb 3, 2014 at 4:08 PM, Jeremy Linton jlin...@tributary.com wrote: On 2/3/2014 9:06 AM, Hannes Reinecke wrote: That's due to udev. Udev is getting events for each device it should create a device node for. So for 'st' it'll get a series of events for 'stX', and another series of

Re: [PATCH] st: Do not rewind for SG_IO

2014-02-03 Thread James Bottomley
On Mon, 2014-02-03 at 21:51 +0100, Kay Sievers wrote: On Mon, Feb 3, 2014 at 4:08 PM, Jeremy Linton jlin...@tributary.com wrote: On 2/3/2014 9:06 AM, Hannes Reinecke wrote: That's due to udev. Udev is getting events for each device it should create a device node for. So for 'st' it'll get

Re: [PATCH] st: Do not rewind for SG_IO

2014-02-03 Thread Douglas Gilbert
On 14-02-03 10:08 AM, Jeremy Linton wrote: -BEGIN PGP SIGNED MESSAGE- Hash: SHA1 On 2/3/2014 9:06 AM, Hannes Reinecke wrote: That's due to udev. Udev is getting events for each device it should create a device node for. So for 'st' it'll get a series of events for 'stX', and another

Re: [PATCH] st: Do not rewind for SG_IO

2014-02-03 Thread Kay Sievers
On Mon, Feb 3, 2014 at 10:16 PM, Douglas Gilbert dgilb...@interlog.com wrote: On 14-02-03 10:08 AM, Jeremy Linton wrote: So whats wrong with the simple solution? You throw the ones for st away, and create the st handles from the nst worker. Doesn't seem to be any good solutions to

Re: [PATCH] st: Do not rewind for SG_IO

2014-02-03 Thread Jeremy Linton
On 2/3/2014 2:51 PM, Kay Sievers wrote: This is not simple and not going to happen. Sibling devices in /sys cannot have a relationship in udev, there are only parent/child dependencies. Ok.. so if we can't ignore all the spare device nodes in a given /sys entry for a given device. Why

[PATCH] target: Simplify command completion by removing CMD_T_FAILED flag

2014-02-03 Thread Roland Dreier
From: Roland Dreier rol...@purestorage.com The CMD_T_FAILED flag is set used in one place to record the result of a trivial test, and it is only tested once, few lines later. We might as well make the code simpler and easier to read by directly doing the test of success where we want to use it.

Re: [PATCH] st: Do not rewind for SG_IO

2014-02-03 Thread Kay Sievers
On Mon, Feb 3, 2014 at 10:58 PM, Jeremy Linton jlin...@tributary.com wrote: On 2/3/2014 2:51 PM, Kay Sievers wrote: This is not simple and not going to happen. Sibling devices in /sys cannot have a relationship in udev, there are only parent/child dependencies. Ok.. so if we can't

Re: [PATCH] bio_integrity_add_page: check for BIO_POOL_NONE before determining nr_vecs on slab

2014-02-03 Thread Martin K. Petersen
David == David Milburn dmilb...@redhat.com writes: David When enabling DIX T10-DIF-TYPE1-IP protection you can hit the David bip_vec full condition which fails to attach the integrity David metadata and returns 0 back to bio_integrity_prep() Looks like Kent accidentally broke this when he

Re: [PATCH v2 0/7] scsi_debug: several bug fixes and enable clustering support

2014-02-03 Thread Martin K. Petersen
Doug == Douglas Gilbert dgilb...@interlog.com writes: Doug The parts of this patch that I understand look fine. Perhaps Doug Martin should ack it, if he sees fit. Just had another look at the updated pieces. Patch series looks good to me. Reviewed-by: Martin K. Petersen