[PATCH] qla2xxx: Fixup looking for a space in the outstanding_cmds array in qla2x00_alloc_iocbs().

2014-03-07 Thread Saurav Kashyap
From: Chad Dupuis chad.dup...@qlogic.com Signed-off-by: Chad Dupuis chad.dup...@qlogic.com Signed-off-by: Saurav Kashyap saurav.kash...@qlogic.com --- drivers/scsi/qla2xxx/qla_iocb.c |2 +- 1 files changed, 1 insertions(+), 1 deletions(-) diff --git a/drivers/scsi/qla2xxx/qla_iocb.c

Re: [PATCH 0/2] target refcounting infrastructure fixes for usb

2014-03-07 Thread James Bottomley
On Thu, 2014-03-06 at 15:18 -0800, Sarah Sharp wrote: Hi James, Sorry for the extremely late ack. That's OK ... my original plan was to send them in the last merge window even without your ack, but that got a bit derailed, so I'll do it in this one with. These patches work fine when

Re: Slow I/O performance on SAS1064

2014-03-07 Thread markus
On Thu, Mar 06, 2014 at 12:51:27PM -0800, Mark Knecht wrote: On Wed, Mar 5, 2014 at 1:40 PM, markus mar...@kola.li wrote: On Wed, Mar 05, 2014 at 10:21:07AM -0800, Mark Knecht wrote: On Wed, Mar 5, 2014 at 9:50 AM, Markus mar...@kola.li wrote: SNIP I am not familiar with this message:

Re: [PATCH 2/3] Add EVPD page 0x83 to sysfs

2014-03-07 Thread Christoph Hellwig
On Thu, Mar 06, 2014 at 10:01:05AM +0100, Hannes Reinecke wrote: I am somewhat reluctant here. Adding separate flags like 'support_vpd_pg83' is a bit pointless, given that we might as well check for vpg_pg83. So the only 'proper' solution would be to add a bitmap of supported pages;

Re: [PATCH 1/6] target: Allocate se_dev_entrys in device list only when used

2014-03-07 Thread Christoph Hellwig
static int core_create_device_list_for_node(struct se_node_acl *nacl) { - struct se_dev_entry *deve; - int i; - - nacl-device_list = array_zalloc(TRANSPORT_MAX_LUNS_PER_TPG, - sizeof(struct se_dev_entry), GFP_KERNEL); + nacl-device_list =

Re: [PATCH 3/6] target: Change core_dev_del_lun to take a se_lun instead of unpacked_lun

2014-03-07 Thread Christoph Hellwig
On Thu, Mar 06, 2014 at 02:15:28PM -0800, Andy Grover wrote: +void core_dev_del_lun( struct se_portal_group *tpg, + struct se_lun *lun) { + pr_debug(%s_TPG[%u]_LUN[%u] - Deactivating %s Logical Unit from device object\n, tpg-se_tpg_tfo-get_fabric_name(), +

Re: [PATCH 2/3] Add EVPD page 0x83 to sysfs

2014-03-07 Thread Hannes Reinecke
On 03/07/2014 11:11 AM, Christoph Hellwig wrote: On Thu, Mar 06, 2014 at 10:01:05AM +0100, Hannes Reinecke wrote: I am somewhat reluctant here. Adding separate flags like 'support_vpd_pg83' is a bit pointless, given that we might as well check for vpg_pg83. So the only 'proper' solution

Re: [PATCH 2/3] Add EVPD page 0x83 to sysfs

2014-03-07 Thread James Bottomley
On Thu, 2014-03-06 at 10:01 +0100, Hannes Reinecke wrote: So the only 'proper' solution would be to add a bitmap of supported pages; however, this would be 256 bits = 32 bytes of additional space required for struct sdev. Which I'm a bit reluctant do to, as it'll be a sparse array in most

Re: [PATCH 5/6] target: Allocate se_luns only when used

2014-03-07 Thread Christoph Hellwig
- se_tpg-tpg_lun_list = array_zalloc(TRANSPORT_MAX_LUNS_PER_TPG, - sizeof(struct se_lun), GFP_KERNEL); + se_tpg-tpg_lun_list = kzalloc(TRANSPORT_MAX_LUNS_PER_TPG * sizeof(void*), +GFP_KERNEL); Again seems like the pointer array

Re: [PATCH 2/3] Add EVPD page 0x83 to sysfs

2014-03-07 Thread Christoph Hellwig
On Fri, Mar 07, 2014 at 02:40:00PM +0400, James Bottomley wrote: On Thu, 2014-03-06 at 10:01 +0100, Hannes Reinecke wrote: So the only 'proper' solution would be to add a bitmap of supported pages; however, this would be 256 bits = 32 bytes of additional space required for struct sdev.

Re: [PATCH 2/3] Add EVPD page 0x83 to sysfs

2014-03-07 Thread Christoph Hellwig
On Fri, Mar 07, 2014 at 11:35:34AM +0100, Hannes Reinecke wrote: Agree. But for now I'd like to keep it as it is (ie without bitmap); there is no real benefit for just the two pages we're exposing right now. Feel free to go ahead as-is. We'll probably have to change it again soon, but we

Re: [PATCH 2/3] Add EVPD page 0x83 to sysfs

2014-03-07 Thread Hannes Reinecke
On 03/07/2014 11:39 AM, James Bottomley wrote: On Thu, 2014-03-06 at 10:01 +0100, Hannes Reinecke wrote: So the only 'proper' solution would be to add a bitmap of supported pages; however, this would be 256 bits = 32 bytes of additional space required for struct sdev. Which I'm a bit

Re: [PATCH 2/3] Add EVPD page 0x83 to sysfs

2014-03-07 Thread James Bottomley
On Fri, 2014-03-07 at 02:43 -0800, Christoph Hellwig wrote: On Fri, Mar 07, 2014 at 02:40:00PM +0400, James Bottomley wrote: On Thu, 2014-03-06 at 10:01 +0100, Hannes Reinecke wrote: So the only 'proper' solution would be to add a bitmap of supported pages; however, this would be 256 bits

Re: [PATCH 2/3] Add EVPD page 0x83 to sysfs

2014-03-07 Thread James Bottomley
On Fri, 2014-03-07 at 11:51 +0100, Hannes Reinecke wrote: On 03/07/2014 11:39 AM, James Bottomley wrote: On Thu, 2014-03-06 at 10:01 +0100, Hannes Reinecke wrote: So the only 'proper' solution would be to add a bitmap of supported pages; however, this would be 256 bits = 32 bytes of

Re: [PATCH 2/3] Add EVPD page 0x83 to sysfs

2014-03-07 Thread Douglas Gilbert
On 14-03-07 12:01 PM, James Bottomley wrote: On Fri, 2014-03-07 at 11:51 +0100, Hannes Reinecke wrote: On 03/07/2014 11:39 AM, James Bottomley wrote: On Thu, 2014-03-06 at 10:01 +0100, Hannes Reinecke wrote: So the only 'proper' solution would be to add a bitmap of supported pages; however,

Re: [PATCH 2/3] Add EVPD page 0x83 to sysfs

2014-03-07 Thread Hannes Reinecke
On 03/07/2014 12:01 PM, James Bottomley wrote: On Fri, 2014-03-07 at 11:51 +0100, Hannes Reinecke wrote: On 03/07/2014 11:39 AM, James Bottomley wrote: On Thu, 2014-03-06 at 10:01 +0100, Hannes Reinecke wrote: So the only 'proper' solution would be to add a bitmap of supported pages; however,

[PATCH 2/2] bnx2fc: fix memory leak and potential NULL pointer dereference.

2014-03-07 Thread Maurizio Lombardi
If bnx2fc_allocate_hash_table() for some reasons fails, it is possible that the hash_tbl_segments or the hash_tbl_pbl pointers are NULL. In this case bnx2fc_free_hash_table() will panic the system. this patch also fixes a memory leak, the hash_tbl_segments pointer was never freed. Signed-off-by:

[PATCH 0/2] bnx2fc: fix memory leak and potential NULL pointer dereferences

2014-03-07 Thread Maurizio Lombardi
The first patch removes a unused variable from the bnx2fc_free_hash_table() function, it was already posted on the linux-scsi mailing list: http://www.spinics.net/lists/linux-scsi/msg72740.html but has not been picked up yet. The second patch fixes a memory leak and some NULL pointer

[PATCH 1/2] bnx2fc: remove unused variable hash_table_size

2014-03-07 Thread Maurizio Lombardi
hash_table_size is not used by the bnx2fc_free_hash_table() function. Signed-off-by: Maurizio Lombardi mlomb...@redhat.com --- drivers/scsi/bnx2fc/bnx2fc_hwi.c | 3 --- 1 file changed, 3 deletions(-) diff --git a/drivers/scsi/bnx2fc/bnx2fc_hwi.c b/drivers/scsi/bnx2fc/bnx2fc_hwi.c index

[PATCH UPDATED 4/9] firewire: don't use PREPARE_DELAYED_WORK

2014-03-07 Thread Tejun Heo
PREPARE_[DELAYED_]WORK() are being phased out. They have few users and a nasty surprise in terms of reentrancy guarantee as workqueue considers work items to be different if they don't have the same work function. firewire core-device and sbp2 have been been multiplexing work items with multiple

Re: [PATCH v5 3/3] scsi: async sd resume

2014-03-07 Thread Alan Stern
On Wed, 5 Mar 2014, Dan Williams wrote: async_schedule() sd resume work to allow disks and other devices to resume in parallel. This moves the entirety of scsi_device resume to an async context to ensure that scsi_device_resume() remains ordered with respect to the completion of the

Re: [PATCH 01/16] scsi_dh_alua: Improve error handling

2014-03-07 Thread Jeremy Linton
On 3/7/2014 1:12 AM, Hannes Reinecke wrote: Can you file a bug with bugzilla.novell.com and assign it to me? Thanks, its bug 867371 https://bugzilla.novell.com/show_bug.cgi?id=867371. -- To unsubscribe from this list: send the line unsubscribe linux-scsi in the body of a message to

[PATCH v15 0/3] PHY: Add APM X-Gene SoC 15Gbps Multi-purpose PHY support

2014-03-07 Thread Loc Ho
This patch adds support for APM X-Gene SoC 15Gbps Multi-purpose PHY. This is the physical layer interface for the corresponding host controller. This driver uses the PHY generic framework. v15: * Fix all check patch warning and re-run checkpatch to confirm v14: * Fix function xgene_phy_xlate to

[PATCH v15 1/3] Documentation: Add APM X-Gene SoC 15Gbps Multi-purpose PHY driver binding documentation

2014-03-07 Thread Loc Ho
This patch adds the APM X-Gene SoC 15Gbps Multi-purpose PHY driver binding documentation. Signed-off-by: Loc Ho l...@apm.com Signed-off-by: Tuan Phan tp...@apm.com Signed-off-by: Suman Tripathi stripa...@apm.com --- .../devicetree/bindings/phy/apm-xgene-phy.txt | 79

[PATCH v15 3/3] arm64: Add APM X-Gene SoC 15Gbps Multi-purpose PHY DTS entries

2014-03-07 Thread Loc Ho
This patch adds the DTS entries for the APM X-Gene SoC 15Gbps Multi-purpose PHY driver. The PHY for SATA controller 2 and 3 are enabled by default. Signed-off-by: Loc Ho l...@apm.com Signed-off-by: Tuan Phan tp...@apm.com Signed-off-by: Suman Tripathi stripa...@apm.com ---

[PATCH 7/6] target: Do not allocate device_list and tpg_lun_list arrays separately

2014-03-07 Thread Andy Grover
Instead of allocing these dynamically, include them in their parent structures. Signed-off-by: Andy Grover agro...@redhat.com --- drivers/target/target_core_device.c | 6 - drivers/target/target_core_tpg.c| 44 +++-- include/target/target_core_base.h |

Re: [PATCH 5/6] target: Allocate se_luns only when used

2014-03-07 Thread Andy Grover
On 03/07/2014 02:41 AM, Christoph Hellwig wrote: - se_tpg-tpg_lun_list = array_zalloc(TRANSPORT_MAX_LUNS_PER_TPG, - sizeof(struct se_lun), GFP_KERNEL); + se_tpg-tpg_lun_list = kzalloc(TRANSPORT_MAX_LUNS_PER_TPG * sizeof(void*), +

Re: [PATCH 3/6] target: Change core_dev_del_lun to take a se_lun instead of unpacked_lun

2014-03-07 Thread Andy Grover
On 03/07/2014 02:35 AM, Christoph Hellwig wrote: On Thu, Mar 06, 2014 at 02:15:28PM -0800, Andy Grover wrote: +void core_dev_del_lun( struct se_portal_group *tpg, + struct se_lun *lun) { + pr_debug(%s_TPG[%u]_LUN[%u] - Deactivating %s Logical Unit from

Re: [PATCH 5/6] target: Allocate se_luns only when used

2014-03-07 Thread Christoph Hellwig
On Fri, Mar 07, 2014 at 10:12:09AM -0800, Andy Grover wrote: I can't see how the synchronization can work without refcounting the lun structure. The lock just protectes the assignment, but you free it right after. What happens to how jsut dereferenced it under the lock but then uses it

Re: [PATCH 5/6] target: Allocate se_luns only when used

2014-03-07 Thread Andy Grover
On 03/07/2014 10:22 AM, Christoph Hellwig wrote: On Fri, Mar 07, 2014 at 10:12:09AM -0800, Andy Grover wrote: I can't see how the synchronization can work without refcounting the lun structure. The lock just protectes the assignment, but you free it right after. What happens to how jsut

Re: [PATCH 1/2] bnx2fc: remove unused variable hash_table_size

2014-03-07 Thread Eddie Wai
Looks good. Thanks. Acked-by: Eddie Wai eddie@broadcom.com On Fri, 2014-03-07 at 15:37 +0100, Maurizio Lombardi wrote: hash_table_size is not used by the bnx2fc_free_hash_table() function. Signed-off-by: Maurizio Lombardi mlomb...@redhat.com --- drivers/scsi/bnx2fc/bnx2fc_hwi.c | 3

Re: [PATCH 2/2] bnx2fc: fix memory leak and potential NULL pointer dereference.

2014-03-07 Thread Eddie Wai
Hello Maurizio, Thanks for looking into this. The patch looks good, but I would like to extend it with the following allocation failure portion to completely remove the memory leak. Please incorporate this into your next submission. Thanks, Eddie @@ -2020,7 +2026,7 @@ static int

Re: [PATCH 2/2] bnx2fc: fix memory leak and potential NULL pointer dereference.

2014-03-07 Thread Maurizio Lombardi
Hi Eddie, On Fri, Mar 07, 2014 at 11:21:45AM -0800, Eddie Wai wrote: Hello Maurizio, Thanks for looking into this. The patch looks good, but I would like to extend it with the following allocation failure portion to completely remove the memory leak. Please incorporate this into your next

Re: [PATCH 2/2] bnx2fc: fix memory leak and potential NULL pointer dereference.

2014-03-07 Thread Eddie Wai
On Sat, 2014-03-08 at 00:21 +0100, Maurizio Lombardi wrote: Hi Eddie, On Fri, Mar 07, 2014 at 11:21:45AM -0800, Eddie Wai wrote: Hello Maurizio, Thanks for looking into this. The patch looks good, but I would like to extend it with the following allocation failure portion to

Re: [PATCH v5 3/3] scsi: async sd resume

2014-03-07 Thread Dan Williams
On Fri, Mar 7, 2014 at 7:42 AM, Alan Stern st...@rowland.harvard.edu wrote: On Wed, 5 Mar 2014, Dan Williams wrote: async_schedule() sd resume work to allow disks and other devices to resume in parallel. This moves the entirety of scsi_device resume to an async context to ensure that

Re: [PATCH v5 3/3] scsi: async sd resume

2014-03-07 Thread Dan Williams
On Fri, 2014-03-07 at 10:42 -0500, Alan Stern wrote: #ifdef CONFIG_PM_SLEEP +#define do_pm_op(dev, op) \ + dev-driver ? dev-driver-pm ? \ + dev-driver-pm-op(dev) : 0 : 0 This will crash if dev-driver-pm-op is NULL. How about making it easier to read, too? #define

[PATCH] [RESEND][SCSI] ips: remove unused defines

2014-03-07 Thread Michael Opdenacker
This patch removes unused defines from drivers/scsi/ips.h - the min() macro is not used - the __iomem define is no longer needed to compile ips.c without warnings Signed-off-by: Michael Opdenacker michael.opdenac...@free-electrons.com --- drivers/scsi/ips.h | 8 1 file changed, 8