Re: OOPS: unplugging western digital passport drive

2016-01-05 Thread Alan Stern
On Tue, 5 Jan 2016, Stanisław Pitucha wrote: > Hi Alan, > I'm really sorry, I completely forgot the emails after return. > I just rechecked on 4.2.5-1 and I cannot reproduce the oops anymore. > (originally the issue was on 3.18.6-1) Plugging/unplugging the same drive > works just fine now. > >

Re: NMI watchdog: BUG: soft lockup - CPU#1 stuck for 22s! [kworker/1:1:29]

2016-01-05 Thread Sebastian Herbszt
I wrote: > Christoph Hellwig wrote: > > On Thu, Dec 31, 2015 at 06:04:15PM +0100, Sebastian Herbszt wrote: > > > I still get this on 4.4.0-rc7-1.g276c9f4-default. Since this did not > > > happen on 4.3 I checked the scsi changes and found the following commit: > > > > > > scsi: restart list

Re: NMI watchdog: BUG: soft lockup - CPU#1 stuck for 22s! [kworker/1:1:29]

2016-01-05 Thread Christoph Hellwig
On Tue, Jan 05, 2016 at 09:06:00PM +0100, Sebastian Herbszt wrote: > > I can give it a try but it will likely take a few days. > > > > [1] http://marc.info/?l=linux-scsi=144771953020415=2 > > Bart's patch mentioned above seems to fix my issue. Bart, can you resend that patch with a a

Re: kernel BUG at block/bio.c:1787! while initializing scsi_debug on ppc64 host

2016-01-05 Thread Eryu Guan
On Tue, Jan 05, 2016 at 06:58:25PM -0500, Martin K. Petersen wrote: > > "Eryu" == Eryu Guan writes: > > Eryu> Any updates on this? It's still reproducible with 4.4-rc8 kernel, > Eryu> and still blocks some of my tests :) > >

RE: [PATCH] ipr: fix out-of-bounds null overwrite

2016-01-05 Thread Seymour, Shane M
> len = snprintf(fname, 99, "%s", buf); > - fname[len-1] = '\0'; Since it appears that's the only time len is actually used in that function can you please remove the variable len completely as part of the patch? -- To unsubscribe from this list: send the line "unsubscribe linux-scsi"

[PATCH] ipr: fix out-of-bounds null overwrite

2016-01-05 Thread Insu Yun
Return value of snprintf is not bound by size value, 2nd argument. (https://www.kernel.org/doc/htmldocs/kernel-api/API-snprintf.html). Return value is number of printed chars, can be larger than 2nd argument. Therefore, it can write null byte out of bounds ofbuffer. Since snprintf puts null, it

Re: [PATCH v2 15/16] qla2xxx: Add bulk send for atio & ctio completion paths.

2016-01-05 Thread Christoph Hellwig
Hi Quinn , On Mon, Jan 04, 2016 at 06:27:58PM +, Quinn Tran wrote: > >in kernel/workqueue.c to be used beyond qla2xxx, or: > > QT> For every work element, the pool->lock is grabbed. Unless the lock > can be grab 1 time and the rest of the work elements piggy back on it then > it?s worth it

[PATCH] scsi: mvsas: fix indenting on return error code

2016-01-05 Thread Colin King
From: Colin Ian King The return code and error return is incorrectly indented which may cause some confusion as it appears at first sight to be associated with a device not ready error (with missing { } braces) rather than a DEV_IS_GONE() failure. The incorrect

Re: kernel BUG at block/bio.c:1787! while initializing scsi_debug on ppc64 host

2016-01-05 Thread Eryu Guan
On Fri, Dec 11, 2015 at 07:53:40PM +0800, Eryu Guan wrote: > Hi, > > I saw this kernel BUG_ON on 4.4-rc4 kernel, and this can be reproduced > easily on ppc64 host by: > > modprobe scsi_debug sector_size=512 physblk_exp=3 dev_size_mb=256 > > And I bisected to this commit > > commit

[PATCH 17/35] ocfs2: set bi_op to REQ_OP

2016-01-05 Thread mchristi
From: Mike Christie This patch has ocfs2 set the bio bi_op to a REQ_OP, and rq_flag_bits to bi_rw. This patch is compile tested only. Signed-off-by: Mike Christie --- fs/ocfs2/cluster/heartbeat.c | 11 +++ 1 file changed, 7 insertions(+), 4

[PATCH 18/35] pm: set bi_op to REQ_OP

2016-01-05 Thread mchristi
From: Mike Christie This patch has the pm swap code set the bio bi_op to a REQ_OP, and rq_flag_bits to bi_rw. This patch is compile tested only. Signed-off-by: Mike Christie --- kernel/power/swap.c | 31 +++ 1 file

[PATCH 22/35] drbd: set bi_op to REQ_OP

2016-01-05 Thread mchristi
From: Mike Christie This patch has drbd set the bio bi_op to a REQ_OP, and rq_flag_bits to bi_rw. Lars and Philip, I might have split this patch up a little weird. Thisi patch handles setting up the bio, and then patch 30

[PATCH 25/35] target: set bi_op to REQ_OP

2016-01-05 Thread mchristi
From: Mike Christie This patch has the target modules set the bio bi_op to a REQ_OP, and rq_flag_bits to bi_rw. This patch is compile tested only. Signed-off-by: Mike Christie --- drivers/target/target_core_iblock.c | 38

[PATCH 16/35] nilfs: set bi_op to REQ_OP

2016-01-05 Thread mchristi
From: Mike Christie This patch has nilfs set the bio bi_op to a REQ_OP, and rq_flag_bits to bi_rw. This patch is compile tested only. Signed-off-by: Mike Christie --- fs/nilfs2/segbuf.c | 18 ++ 1 file changed, 10 insertions(+), 8

[PATCH 00/35 v2] separate operations from flags in the bio/request structs

2016-01-05 Thread mchristi
point, we abused them so much we just made cmd_flags 64 bits, so we could add more. The following patches seperate the operation (read, write discard, flush, etc) from cmd_flags/bi_rw. This patchset was made against linux-next from today Jan 5 2016. (git tag next-20160105). v2. 1. Dropped arg

[PATCH 15/35] mpage: set bi_op to REQ_OP

2016-01-05 Thread mchristi
From: Mike Christie This patch has the mpage.c code set the bio bi_op to a REQ_OP, and rq_flag_bits to bi_rw. I have run xfstest with xfs, but I am not sure if I have stressed these code paths well. Signed-off-by: Mike Christie --- fs/mpage.c | 41

[PATCH 13/35] xfs: set bi_op to REQ_OP

2016-01-05 Thread mchristi
From: Mike Christie This patch has xfs set the bio bi_op to a REQ_OP, and rq_flag_bits to bi_rw. Note: I have run xfs tests on these btrfs patches. There were some failures with and without the patches. I have not had time to track down why xfstest fails without the

[PATCH 09/35] btrfs: update __btrfs_map_block for bi_op transition

2016-01-05 Thread mchristi
From: Mike Christie We no longer pass in a bitmap of rq_flag_bits bits to __btrfs_map_block. It will always be a REQ_OP, or the btrfs specific REQ_GET_READ_MIRRORS, so this drops the bit tests. Signed-off-by: Mike Christie --- fs/btrfs/extent-tree.c |

[PATCH 03/35] block, fs, mm, drivers: set bi_op to REQ_OP

2016-01-05 Thread mchristi
From: Mike Christie This patch converts the simple bi_rw use cases in the block, drivers, mm and fs code to use bi_op for a REQ_OP and bi_rw for rq_flag_bits. These should be simple one liner cases, so I just did them in one patch. The next patches handle the more

[PATCH 02/35] block: add REQ_OP definitions and bi_op/op fields

2016-01-05 Thread mchristi
From: Mike Christie The following patches separate the operation (write, read, discard, etc) from the flags in bi_rw/cmd_flags. This patch adds definitions for request/bio operations, adds fields to the request/bio to set them, and some temporary compat code so the

[PATCH 12/35] gfs2: set bi_op to REQ_OP

2016-01-05 Thread mchristi
From: Mike Christie This patch has gfs2 set the bio bi_op to a REQ_OP, and rq_flag_bits to bi_rw. This patch is compile tested only. v2: Bob, I did not add your signed off, because there was the gfs2_submit_bhs changes since last time you reviewed it. Signed-off-by: Mike

[PATCH 14/35] hfsplus: set bi_op to REQ_OP

2016-01-05 Thread mchristi
From: Mike Christie This patch has hfsplus set the bio bi_op to a REQ_OP, and rq_flag_bits to bi_rw. This patch is compile tested only. Signed-off-by: Mike Christie --- fs/hfsplus/hfsplus_fs.h | 2 +- fs/hfsplus/part_tbl.c | 5 +++--

[PATCH 26/35] block: set op to REQ_OP

2016-01-05 Thread mchristi
From: Mike Christie This patch converts the request related block layer code to set request->op to a REQ_OP and cmd_flags to rq_flag_bits. There is some tmp compat code when setting up cmd_flags so it still carries both the op and flags. It will be removed in in later

[PATCH 20/35] dm: pass dm stats data dir instead of bi_rw

2016-01-05 Thread mchristi
From: Mike Christie It looks like dm stats cares about the data direction (READ vs WRITE) and does not need the bio/request flags. Commands like REQ_FLUSH, REQ_DISCARD and REQ_WRITE_SAME are currently always set with REQ_WRITE, so the extra check for REQ_DISCARD in

[PATCH 24/35] xen: set bi_op to REQ_OP

2016-01-05 Thread mchristi
From: Mike Christie This patch has xen set the bio bi_op to a REQ_OP, and rq_flag_bits to bi_rw. This patch is compile tested only. Signed-off-by: Mike Christie --- drivers/block/xen-blkback/blkback.c | 29 + 1 file

[PATCH 28/35] blktrace: get op from req->op/bio->bi_op

2016-01-05 Thread mchristi
From: Mike Christie The bio and request struct now store the operation in bio->bi_op/request->op. This patch has blktrace not check bi_rw/cmd_flags. This patch is only compile tested. Signed-off-by: Mike Christie --- include/linux/blktrace_api.h |

[PATCH 29/35] ide cd: do not set REQ_WRITE on requests.

2016-01-05 Thread mchristi
From: Mike Christie The block layer will set the correct READ/WRITE operation flags/fields when creating a request, so there is not need for drivers to set the REQ_WRITE flag. This patch is compile tested only. Signed-off-by: Mike Christie ---

[PATCH 30/35] block, fs, drivers: do not test bi_rw for REQ_OPs

2016-01-05 Thread mchristi
From: Mike Christie We no longer use the bio->bi_rw field for REQ_OPs: REQ_WRITE, REQ_DISCARD, REQ_WRITE_SAME, so this patch stops checking for them in bi_rw and also removes the related compat code. Signed-off-by: Mike Christie --- block/bio.c

[PATCH 11/35] f2fs: set bi_op to REQ_OP

2016-01-05 Thread mchristi
From: Mike Christie This patch has f2fs set the bio bi_op to a REQ_OP, and rq_flag_bits to bi_rw. This patch is compile tested only. Signed-off-by: Mike Christie --- fs/f2fs/checkpoint.c| 10 ++ fs/f2fs/data.c | 33

[PATCH 27/35] drivers: set request op to REQ_OP

2016-01-05 Thread mchristi
From: Mike Christie This patch has the block driver use the request->op for REQ_OP operations and cmd_flags for rq_flag_bits. I have only tested scsi and rbd. Signed-off-by: Mike Christie --- drivers/block/loop.c | 6 +++---

[PATCH 23/35] md/raid: set bi_op to REQ_OP

2016-01-05 Thread mchristi
From: Mike Christie This patch has md/raid set the bio bi_op to a REQ_OP, and rq_flag_bits to bi_rw. This patch is compile tested only. Signed-off-by: Mike Christie --- drivers/md/bitmap.c | 2 +- drivers/md/dm-raid.c | 5 +++--

[PATCH 19/35] dm: set bi_op to REQ_OP

2016-01-05 Thread mchristi
From: Mike Christie This patch has dm set the bio bi_op to a REQ_OP, and rq_flag_bits to bi_rw. I did some basic dm tests, but I think this patch should be considered compile tested only. I have not tested all the dm targets and I did not stress every code path I have

[PATCH 21/35] bcache: set bi_op to REQ_OP

2016-01-05 Thread mchristi
From: Mike Christie This patch has bcache set the bio bi_op to a REQ_OP, and rq_flag_bits to bi_rw. This patch is compile tested only. Signed-off-by: Mike Christie --- drivers/md/bcache/btree.c | 2 ++ drivers/md/bcache/debug.c | 2 ++

[PATCH 04/35] fs: have submit_bh users pass in op and flags separately

2016-01-05 Thread mchristi
From: Mike Christie This has submit_bh users pass in the operation and flags separately, so we can setup the bio->bi_op and bio-bi_rw flags. Signed-off-by: Mike Christie --- drivers/md/bitmap.c | 4 ++-- fs/btrfs/check-integrity.c | 24

[PATCH 01/35] block/fs/drivers: remove rw argument from submit_bio

2016-01-05 Thread mchristi
From: Mike Christie This has callers of submit_bio/submit_bio_wait set the bio->bi_rw instead of passing it in. This makes that use the same as generic_make_request and how we set the other bio fields. Signed-off-by: Mike Christie --- block/bio.c

[PATCH 05/35] fs: have ll_rw_block users pass in op and flags separately

2016-01-05 Thread mchristi
From: Mike Christie This has ll_rw_block users pass in the operation and flags separately, so we can setup the bio->bi_op and bio-bi_rw flags. Signed-off-by: Mike Christie --- fs/buffer.c | 19 ++- fs/ext4/inode.c

[PATCH 07/35] btrfs: have submit_one_bio users setup bio bi_op

2016-01-05 Thread mchristi
From: Mike Christie This patch has btrfs's submit_one_bio callers set the bio->bi_op to a REQ_OP and the bi_rw to rq_flag_bits. The next patches will continue to convert btrfs, so submit_bio_hook and merge_bio_hook related code will be modified to take only the bio. I did

[PATCH 06/35] direct-io: set bi_op to REQ_OP

2016-01-05 Thread mchristi
From: Mike Christie This patch has the dio code set the bio bi_op to a REQ_OP. It also begins to convert btrfs's dio_submit_t related code, because of the submit_io callout use. In the btrfs_submit_direct change, I OR'd the op and flag back together. It is only temporary.

[PATCH 10/35] btrfs: don't pass rq_flag_bits if there is a bio

2016-01-05 Thread mchristi
From: Mike Christie The bio bi_op and bi_rw is now setup, so there is no need to pass around the rq_flag_bits bits too. Signed-off-by: Mike Christie --- fs/btrfs/compression.c | 9 - fs/btrfs/disk-io.c | 30 --

[PATCH 08/35] btrfs: set bi_op tp REQ_OP

2016-01-05 Thread mchristi
From: Mike Christie This patch has btrfs set the bio bi_op to a REQ_OP, and rq_flag_bits to bi_rw. Signed-off-by: Mike Christie --- fs/btrfs/check-integrity.c | 19 +-- fs/btrfs/compression.c | 4 fs/btrfs/disk-io.c |

Re: st driver doesn't seem to grok LTO partitioning

2016-01-05 Thread Laurence Oberman
Testing the patch here in the lab, it seems my firmware will need to be updated to support more than 1 partition. Looking into that now. [ 193.647807] st: Version 20160104, fixed bufsize 32768, s/g segs 256 [ 193.648992] st: Debugging enabled debug_flag = 1 [ 193.650907] st 0:0:0:0: Attached

MY LAST RESPONSE

2016-01-05 Thread Mr. Wang Zhiqiang
I am Mr. Wang Zhiqiang working with Wing Lung Bank Hong Kong; I have a highly mutual and legitimate Bequest for you to handle with me. This fund was deposited in our bank by an Oil Magnate who lived in Hong Kong for Twenty Eight years. He died along with his family during the Tsunami which

[PATCH 35/35] block, drivers, fs: rename REQ_FLUSH to REQ_PREFLUSH

2016-01-05 Thread mchristi
From: Mike Christie To avoid confusion between REQ_OP_FLUSH, which is handled by request_fn drivers, and upper layers requesting the block layer perform a flush sequence along with possibly a WRITE, this patch renames REQ_FLUSH to REQ_PREFLUSH. Signed-off-by: Mike Christie

[PATCH 34/35] block: add QUEUE_FLAGs for flush and fua

2016-01-05 Thread mchristi
From: Mike Christie The last patch added a REQ_OP_FLUSH for request_fn drivers and the next patch renames REQ_FLUSH to REQ_PREFLUSH which will be used by file systems and make_request_fn drivers. This leaves REQ_FLUSH/REQ_FUA defined for drivers to tell the block layer if

[PATCH 31/35] block, fs: remove old REQ definitions.

2016-01-05 Thread mchristi
From: Mike Christie We no longer use REQ_WRITE. REQ_WRITE_SAME and REQ_DISCARD, so this patch removes them. Signed-off-by: Mike Christie --- include/linux/blk_types.h | 19 +-- include/linux/fs.h | 21 +++--

[PATCH 33/35] block, drivers: add REQ_OP_FLUSH operation

2016-01-05 Thread mchristi
From: Mike Christie This adds a REQ_OP_FLUSH operation that is sent to request_fn based drivers by the block layer's flush code, instead of sending requests with the request->cmd_flags REQ_FLUSH bit set. For the following 3 flush related patches, I have not tested every

[PATCH 32/35] block: shrink bi_rw and bi_op

2016-01-05 Thread mchristi
From: Mike Christie There is no need for bi_op/op and bi_rw to be so large now, so this patch shrinks them. Signed-off-by: Mike Christie --- block/blk-core.c | 2 +- drivers/md/dm-flakey.c | 2 +- drivers/md/raid5.c | 13

Re: [PATCH 05/35] fs: have ll_rw_block users pass in op and flags separately

2016-01-05 Thread kbuild test robot
Hi Mike, [auto build test WARNING on next-20160105] [cannot apply to dm/for-next v4.4-rc8 v4.4-rc7 v4.4-rc6 v4.4-rc8] [if your patch is applied to the wrong git tree, please drop us a note to help improving the system] url: https://github.com/0day-ci/linux/commits/mchristi-redhat-com

Re: kernel BUG at block/bio.c:1787! while initializing scsi_debug on ppc64 host

2016-01-05 Thread Martin K. Petersen
> "Eryu" == Eryu Guan writes: Eryu> Any updates on this? It's still reproducible with 4.4-rc8 kernel, Eryu> and still blocks some of my tests :) http://git.kernel.org/cgit/linux/kernel/git/mkp/scsi.git/log/?h=4.4/scsi-fixes It just hasn't made it to Linus yet... --

Re: [PATCH 34/35] block: add QUEUE_FLAGs for flush and fua

2016-01-05 Thread kbuild test robot
Hi Mike, [auto build test ERROR on next-20160105] [cannot apply to dm/for-next v4.4-rc8 v4.4-rc7 v4.4-rc6 v4.4-rc8] [if your patch is applied to the wrong git tree, please drop us a note to help improving the system] url: https://github.com/0day-ci/linux/commits/mchristi-redhat-com/separate

Re: [PATCHv4 1/1] SCSI: hosts: update to use ida_simple for host_no management

2016-01-05 Thread Martin K. Petersen
> "Lee" == Lee Duncan writes: Lee> Do you need me to resubmit this patch now that it's accepted? Please resend. Thanks! -- Martin K. Petersen Oracle Linux Engineering -- To unsubscribe from this list: send the line "unsubscribe linux-scsi" in the body of a message

Re: [PATCH 35/35] block, drivers, fs: rename REQ_FLUSH to REQ_PREFLUSH

2016-01-05 Thread kbuild test robot
Hi Mike, [auto build test ERROR on next-20160105] [cannot apply to dm/for-next v4.4-rc8 v4.4-rc7 v4.4-rc6 v4.4-rc8] [if your patch is applied to the wrong git tree, please drop us a note to help improving the system] url: https://github.com/0day-ci/linux/commits/mchristi-redhat-com/separate

Re: [PATCH] scsi: mvsas: fix indenting on return error code

2016-01-05 Thread Tomas Henzl
On 5.1.2016 12:56, Colin King wrote: > From: Colin Ian King > > The return code and error return is incorrectly indented which > may cause some confusion as it appears at first sight to be associated > with a device not ready error (with missing { } braces) rather than >

[PATCH] scsi: imm: use new parport device model

2016-01-05 Thread Sudip Mukherjee
Modify imm driver to use the new parallel port device model. Signed-off-by: Sudip Mukherjee --- I usually submit checkpatch cleanup and other modifications while converting a driver to use parport device model. For this driver i hesitated. If you want I can send a series

[PATCH resend] scsi: imm: use new parport device model

2016-01-05 Thread Sudip Mukherjee
Modify imm driver to use the new parallel port device model. Signed-off-by: Sudip Mukherjee --- Resending as the first mail bounced back with the error: Delivery to the following recipient failed permanently: jbottom...@odin.com Looking at the MAINTAINERS file gives