[PATCH] lib: scatterlist: fix ifnullfree.cocci warnings

2016-03-22 Thread kbuild test robot
lib/sg_pool.c:152:3-18: WARNING: NULL check before freeing functions like kfree, debugfs_remove, debugfs_remove_recursive or usb_free_urb is not needed. Maybe consider reorganizing relevant code to avoid passing NULL values. lib/sg_pool.c:154:3-21: WARNING: NULL check before freeing functions

Re: [PATCH v2 5/5] lib: scatterlist: move SG pool code from SCSI driver to lib/sg_pool.c

2016-03-22 Thread kbuild test robot
Hi Ming, [auto build test WARNING on scsi/for-next] [also build test WARNING on v4.5 next-20160322] [if your patch is applied to the wrong git tree, please drop us a note to help improving the system] url: https://github.com/0day-ci/linux/commits/Ming-Lin/mempool-based-chained-scatterlist

Re: [PATCH v3 00/23] ncr5380: Eliminate macros, reduce code duplication, fix bugs etc

2016-03-22 Thread Finn Thain
On Tue, 22 Mar 2016, Ondrej Zary wrote: > Tested on HP C2502 (53C400A chip), Canon FG2-5202 (53C400 chip) and > DTC-3181L (DTCT-436P chip) ISA cards - everything works fine! > > Thanks. Thanks for testing, Ondrej. > > Tested-by: Ondrej Zary Hannes, would you

Re: [PATCH v3 00/23] ncr5380: Eliminate macros, reduce code duplication, fix bugs etc

2016-03-22 Thread Ondrej Zary
On Monday 21 March 2016 03:31:49 Finn Thain wrote: > > This patch series has more macro elimination and some tweaks to the > DMA hooks so that all the wrapper drivers can share the same core > DMA algorithm. This resolves the major discrepancies between the two > core drivers, which relate to

[PATCH v2 2/5] scsi: replace "mq" with "first_chunk" in SG functions

2016-03-22 Thread Ming Lin
From: Ming Lin Parameter "bool mq" is block driver specific. Change it to "first_chunk" to make it more generic. Signed-off-by: Ming Lin --- drivers/scsi/scsi_lib.c | 20 ++-- 1 file changed, 10 insertions(+), 10 deletions(-)

[PATCH v2 0/5] mempool based chained scatterlist alloc/free api

2016-03-22 Thread Ming Lin
From: Ming Lin The fist 4 patches make the SG related definitions/structs/functions in SCSI code generic and the last patch move it to lib/sg_pool.c. I still keep the macro "SG_MEMPOOL_NR" since it's used in 3 places. v2: - do modification in scsi code first then move

[PATCH v2 1/5] scsi: replace "scsi_data_buffer" with "sg_table" in SG functions

2016-03-22 Thread Ming Lin
From: Ming Lin Replace parameter "struct scsi_data_buffer" with "struct sg_table" in SG alloc/free functions to make them generic. Signed-off-by: Ming Lin --- drivers/scsi/scsi_lib.c | 41 +++-- 1 file

[PATCH v2 4/5] scsi: rename SCSI_MAX_{SG, SG_CHAIN}_SEGMENTS

2016-03-22 Thread Ming Lin
From: Ming Lin Rename SCSI_MAX_SG_SEGMENTS to SG_CHUNK_SIZE, which means the amount we fit into a single scatterlist chunk. Rename SCSI_MAX_SG_CHAIN_SEGMENTS to SG_MAX_SEGMENTS. Will move these 2 generic definitions to scatterlist.h later. Signed-off-by: Ming Lin

[PATCH v2 3/5] scsi: rename SG related struct and functions

2016-03-22 Thread Ming Lin
From: Ming Lin Rename SCSI specific struct and functions to more genenic names. Signed-off-by: Ming Lin --- drivers/scsi/scsi_lib.c | 52 - 1 file changed, 26 insertions(+), 26 deletions(-) diff

[PATCH v2 5/5] lib: scatterlist: move SG pool code from SCSI driver to lib/sg_pool.c

2016-03-22 Thread Ming Lin
From: Ming Lin Now it's ready to move the mempool based SG chained allocator code from SCSI driver to lib/sg_pool.c, which will be compiled only based on a Kconfig symbol CONFIG_SG_POOL. SCSI selects CONFIG_SG_POOL. Signed-off-by: Ming Lin ---

Re: [BUG] mpt2sas: driver init fails on kernel >=4.2 for 9211-8i IT

2016-03-22 Thread Matthias Prager
Hi Sreekanth, Am 22.03.2016 um 11:52 schrieb Sreekanth Reddy: > Hi Matthias, > > Thanks for providing detail explanation. > > Currently I am trying to reproduce this issue locally. I have used the > same HBA card but still I am not able to reproduce this issue on 4.5 > kernel. > > I will try

RE: [PATCH 1/1] scsi: storvsc: Support manual scan of FC hosts on Hyper-V

2016-03-22 Thread KY Srinivasan
> -Original Message- > From: KY Srinivasan > Sent: Sunday, March 20, 2016 11:59 AM > To: 'James Bottomley' ; Martin > K. Petersen > Cc: Christoph Hellwig ; gre...@linuxfoundation.org; >

[PATCH v3 1/3] scsi: make some Additional Sense strings more grep'able

2016-03-22 Thread Rasmus Villemoes
There's little point in breaking these strings over multiple lines. Signed-off-by: Rasmus Villemoes Reviewed-by: Hannes Reinecke --- drivers/scsi/constants.c | 27 +-- 1 file changed, 9 insertions(+), 18 deletions(-) diff --git

[PATCH v3 3/3] scsi: reduce CONFIG_SCSI_CONSTANTS=y impact by 8k

2016-03-22 Thread Rasmus Villemoes
On 64 bit, struct error_info has 6 bytes of padding, which amounts to over 4k of wasted space in the additional[] array. We could easily get rid of that by instead using separate arrays for the codes and the pointers. However, we can do even better than that and save an additional 6 bytes per

[PATCH v3 2/3] scsi: move Additional Sense Codes to separate file

2016-03-22 Thread Rasmus Villemoes
This is a purely mechanical move of the list of additional sense codes to a separate file, in preparation for reducing the impact of choosing CONFIG_SCSI_CONSTANTS=y by about 8k. Signed-off-by: Rasmus Villemoes Reviewed-by: Hannes Reinecke ---

[PATCH v3 0/3] scsi: reduce CONFIG_SCSI_CONSTANTS=y impact by 8k

2016-03-22 Thread Rasmus Villemoes
This is mostly identical to v2 sent in November, rebased (cleanly) to current mainline. The only change is that I've this time also updated the Kconfig help text in 3/3, since the 75 KB was a bit exaggerated. After these patches are applied, the impact of choosing CONFIG_SCSI_CONSTANTS=y is about

[GIT PULL] target updates for v4.6-rc1

2016-03-22 Thread Nicholas A. Bellinger
Hello Linus, Here are the target updates for v4.6-rc1 code. Please go ahead and pull from: git://git.kernel.org/pub/scm/linux/kernel/git/nab/target-pending.git for-next The highlights this round include: - Add target_alloc_session() w/ callback helper for doing se_session allocation +

Re: [PATCHv3] scsi: disable automatic target scan

2016-03-22 Thread Hannes Reinecke
On 03/21/2016 09:40 PM, Laurence Oberman wrote: > Hello Hannes > > Please share latest scripts and an example of how you are using them. > I have some scripts from last November, that you posted but I am sure they > have changed. > If not then I will modify them as appropriate, just let me know.

Re: [PATCH] mpt3sas: Don't overreach ioc->reply_post[] during initialization

2016-03-22 Thread Jens Axboe
On 03/18/2016 01:45 PM, Calvin Owens wrote: In _base_make_ioc_operational(), we walk ioc->reply_queue_list and pull a pointer out of successive elements of ioc->reply_post[] for each entry in that list if RDPQ is enabled. Since the code pulls the pointer for the next iteration at the bottom of

Re: [PATCH] scsi: ufs: select CONFIG_NLS

2016-03-22 Thread Arnd Bergmann
On Tuesday 22 March 2016 07:43:19 James Bottomley wrote: > > diff --git a/drivers/scsi/ufs/Kconfig b/drivers/scsi/ufs/Kconfig > > index 5f4530744e0a..097894a1fab5 100644 > > --- a/drivers/scsi/ufs/Kconfig > > +++ b/drivers/scsi/ufs/Kconfig > > @@ -37,6 +37,7 @@ config SCSI_UFSHCD > > depends

Re: [PATCH] sd: fixup capacity calculation for 4k drives

2016-03-22 Thread Ewan D. Milne
On Tue, 2016-03-22 at 08:14 +0100, Hannes Reinecke wrote: > On 03/22/2016 02:16 AM, Martin K. Petersen wrote: > >> "Hannes" == Hannes Reinecke writes: > > > > Hannes> in sd_read_capacity() the sdkp->capacity field changes its > > Hannes> meaning: after the call to

Re: [PATCH] scsi: ufs: select CONFIG_NLS

2016-03-22 Thread James Bottomley
On Thu, 2016-03-17 at 13:29 +0100, Arnd Bergmann wrote: > A recent change to ufshcd introduced a call to utf16s_to_utf8s, > a function that is provided by the NLS module, so we get a link > error when that is not present: > > drivers/scsi/built-in.o: In function `ufshcd_read_string_desc': >

RE: [PATCH] megaraid_sas: fix missing { }, nullify kbuff_arr[i] only when necessary

2016-03-22 Thread Sumit Saxena
> -Original Message- > From: Colin King [mailto:colin.k...@canonical.com] > Sent: Sunday, March 20, 2016 10:34 PM > To: Kashyap Desai; Sumit Saxena; James Bottomley; Martin K . Petersen; > megaraidlinux@avagotech.com; linux-scsi@vger.kernel.org > Cc: linux-ker...@vger.kernel.org >

Re: [BUG] mpt2sas: driver init fails on kernel >=4.2 for 9211-8i IT

2016-03-22 Thread Sreekanth Reddy
Hi Matthias, Thanks for providing detail explanation. Currently I am trying to reproduce this issue locally. I have used the same HBA card but still I am not able to reproduce this issue on 4.5 kernel. I will try for few more times and I will also try to get the diff between 4.1 to 4.5 kernels

RE: [PATCH] mpt3sas: Don't overreach ioc->reply_post[] during initialization

2016-03-22 Thread Chaitra Basappa
Martin, This patch is being reviewed , we shall get back with reviews by tomorrow. Thanks, Chaitra -Original Message- From: Martin K. Petersen [mailto:martin.peter...@oracle.com] Sent: Tuesday, March 22, 2016 6:00 AM To: Calvin Owens Cc: Sathya Prakash; Chaitra P B; Suganath Prabu

Re: [PATCH v2 0/3] scsi: reduce CONFIG_SCSI_CONSTANTS=y impact by 8k

2016-03-22 Thread Christoph Hellwig
On Tue, Mar 08, 2016 at 08:52:32PM +0100, Rasmus Villemoes wrote: > On Tue, Nov 24 2015, Rasmus Villemoes wrote: > > > This reduces the impact of choosing CONFIG_SCSI_CONSTANTS by about 8KB. > > > > ping? does anyone feel like picking these up? Please resend them

Re: [PATCH] sd: fixup capacity calculation for 4k drives

2016-03-22 Thread Hannes Reinecke
On 03/22/2016 02:16 AM, Martin K. Petersen wrote: >> "Hannes" == Hannes Reinecke writes: > > Hannes> in sd_read_capacity() the sdkp->capacity field changes its > Hannes> meaning: after the call to read_capacity_XX() it carries the > Hannes> _unscaled_ values, making the

Re: [PATCH] sd: fixup capacity calculation for 4k drives

2016-03-22 Thread Christoph Hellwig
Looks fine, Reviewed-by: Christoph Hellwig -- To unsubscribe from this list: send the line "unsubscribe linux-scsi" in the body of a message to majord...@vger.kernel.org More majordomo info at http://vger.kernel.org/majordomo-info.html