Re: [PATCH 1/6] blk-sysfs: Add 'chunk_sectors' to sysfs attributes

2016-07-20 Thread Christoph Hellwig
On Tue, Jul 19, 2016 at 03:20:34PM +0200, Hannes Reinecke wrote: > The queue limits already have a 'chunk_sectors' setting, so > we should be presenting it via sysfs. > > Signed-off-by: Hannes Reinecke Looks fine for 4.8 independent of any ZBC implications: Reviewed-by: Christoph

Re: [PATCH 5/6] block: Introduce BLKPREP_DONE

2016-07-20 Thread Christoph Hellwig
> +++ b/block/blk-core.c > @@ -2462,9 +2462,13 @@ struct request *blk_peek_request(struct request_queue > *q) > > rq = NULL; > break; > - } else if (ret == BLKPREP_KILL || ret == BLKPREP_INVALID) { > + } else if (ret ==

Re: [PATCH 1/3] block: add flag for single-threaded submission

2016-07-20 Thread Christoph Hellwig
On Tue, Jul 19, 2016 at 04:02:56PM +0200, Hannes Reinecke wrote: > Some devices (most notably SMR drives) support only > one I/O stream eg for ensuring ordered I/O submission. > This patch adds a new block queue flag > 'BLK_QUEUE_SINGLE' to support these devices. We'll need a blk-mq

Re: [PATCH 6/6] block: Add 'BLK_MQ_RQ_QUEUE_DONE' return value

2016-07-20 Thread Christoph Hellwig
On Tue, Jul 19, 2016 at 03:20:39PM +0200, Hannes Reinecke wrote: > Add a return value BLK_MQ_RQ_QUEUE_DONE to terminate a request > without error. NAK. You can just do a blk_mq_end_request on the request and return 0 from ->queue_rq. -- To unsubscribe from this list: send the line "unsubscribe

Delivery notification..(View the attachment for confirmation of your delivery address)

2016-07-20 Thread FedEx Courier Service
FedEx-Delivery Post.docx Description: MS-Word 2007 document

Re: [PATCH v2] scsi:libsas: fix oops caused by assigning a freed task to ->lldd_task

2016-07-20 Thread Martin K. Petersen
> "Wei" == Wei Fang writes: Wei> A freed task has been assigned to ->lldd_task when Wei> lldd_execute_task() failed in sas_ata_qc_issue(), and access of Wei> ->lldd_task will cause an oops: Applied to 4.8/scsi-queue. -- Martin K. Petersen Oracle Linux Engineering

Re: [patch] fnic: pci_dma_mapping_error() doesn't return an error code

2016-07-20 Thread Martin K. Petersen
> "Dan" == Dan Carpenter writes: Dan> pci_dma_mapping_error() returns true on error and false on success. Dan> Fixes: fd6ddfa4c1dd ('fnic: check pci_map_single() return value') Applied to 4.8/scsi-queue. -- Martin K. Petersen Oracle Linux Engineering -- To

Re: [PATCH 1/2] scsi: lpfc: avoid harmless comparison warning

2016-07-20 Thread Martin K. Petersen
> "Arnd" == Arnd Bergmann writes: Arnd> When building with -Wextra, we get a lot of warnings for the lpfc Arnd> driver concerning expressions that are always true, starting with: Applied to 4.8/scsi-queue. -- Martin K. Petersen Oracle Linux Engineering -- To

Re: [PATCH 2/2] fcoe: implement FIP VLAN responder

2016-07-20 Thread Martin K. Petersen
> "Hannes" == Hannes Reinecke writes: Hannes> When running in VN2VN mode there is no central instance which Hannes> would send out any FIP VLAN discovery notifications. So this Hannes> patch adds a new sysfs attribute 'fip_vlan_responder' which will Hannes> activate a FIP VLAN

Re: [PATCH 1/2] lpfc: call lpfc_sli_validate_fcp_iocb() with the hbalock held

2016-07-20 Thread Martin K. Petersen
> "Johannes" == Johannes Thumshirn writes: Johannes> Call lpfc_sli_validate_fcp_iocb() with the hbalock held, as Johannes> the pointer to iocbq is not guaranteed to still be valid after Johannes> looking it up. Applied to 4.8/scsi-queue. -- Martin K. Petersen

Re: [PATCH 1/2] fcoe: Rename 'fip_frame' to 'fip_vn2vn_notify_frame'

2016-07-20 Thread Martin K. Petersen
> "Hannes" == Hannes Reinecke writes: Hannes> Do not use a generic name to avoid confusions with other usages. Applied to 4.8/scsi-queue. -- Martin K. Petersen Oracle Linux Engineering -- To unsubscribe from this list: send the line "unsubscribe linux-scsi" in the body

Re: [PATCH v9] ibmvscsis: Initial commit of IBM VSCSI Tgt Driver

2016-07-20 Thread Nicholas A. Bellinger
On Wed, 2016-07-20 at 15:26 -0500, Bryant G. Ly wrote: > Hi Nic, > > < SNIP > > > > Note the deletion of drivers/scsi/libsrp.c + include/scsi/libsrp.h has > > been dropped from the above commit, as it looks like they where changes > > specific to your local tree. > > >

Re: [net-next v2 0/6] common library for Chelsio drivers

2016-07-20 Thread David Miller
From: "Nicholas A. Bellinger" Date: Wed, 20 Jul 2016 14:13:55 -0700 > DaveM, if you'd prefer to pick it up, I'm happy to drop it. There were review comments and changes requested. -- To unsubscribe from this list: send the line "unsubscribe linux-scsi" in the body of a

Re: [PATCH v3 5/7] iscsi-target: replace iscsi_initiatorname_tolower() with strtolower()

2016-07-20 Thread Markus Mayer
On 20 July 2016 at 14:17, Nicholas A. Bellinger wrote: > On Wed, 2016-07-20 at 14:16 -0700, Nicholas A. Bellinger wrote: >> On Fri, 2016-07-08 at 15:43 -0700, Markus Mayer wrote: >> > After introducing generic strtolower(), iscsi_initiatorname_tolower() is >> > no longer

Re: [PATCH v3 5/7] iscsi-target: replace iscsi_initiatorname_tolower() with strtolower()

2016-07-20 Thread Nicholas A. Bellinger
On Wed, 2016-07-20 at 14:16 -0700, Nicholas A. Bellinger wrote: > On Fri, 2016-07-08 at 15:43 -0700, Markus Mayer wrote: > > After introducing generic strtolower(), iscsi_initiatorname_tolower() is > > no longer needed. > > > > Signed-off-by: Markus Mayer > > --- > >

Re: [PATCH v3 5/7] iscsi-target: replace iscsi_initiatorname_tolower() with strtolower()

2016-07-20 Thread Nicholas A. Bellinger
On Fri, 2016-07-08 at 15:43 -0700, Markus Mayer wrote: > After introducing generic strtolower(), iscsi_initiatorname_tolower() is > no longer needed. > > Signed-off-by: Markus Mayer > --- > drivers/target/iscsi/iscsi_target_nego.c | 17 + > 1 file changed, 1

Re: [net-next v2 0/6] common library for Chelsio drivers

2016-07-20 Thread Nicholas A. Bellinger
Hi Varun & Co, On Sat, 2016-07-16 at 22:49 +0530, Varun Prakash wrote: > Hi, > > This patch series adds common library module(libcxgb.ko) > for Chelsio drivers to remove duplicate code. > > This series moves common iSCSI DDP Page Pod manager > code from cxgb4.ko to libcxgb.ko, earlier this

Re: Re [PATCH RFC]: LIO seems to use SCSI Allocation Length instead of SPDTL for calculating ResidualCount

2016-07-20 Thread Nicholas A. Bellinger
Hi Sumit, Apologies for the delayed response. Comments below.. On Sun, 2016-07-03 at 19:24 +0530, Sumit Rai wrote: > > From: Sumit Rai > > Subject: LIO seems to use SCSI Allocation Length instead of SPDTL for > > calculating ResidualCount > > Date: June 22, 2016 at

Re: [PATCH v3 0/7] lib: string: add functions to case-convert strings

2016-07-20 Thread Markus Mayer
On Wed, Jul 13, 2016 at 03:52:38PM -0700, Markus Mayer wrote: > On Sat, Jul 09, 2016 at 09:11:05PM -0700, Markus Mayer wrote: >> On 9 July 2016 at 20:13, Chris Metcalf wrote: >>> On 7/8/2016 6:43 PM, Markus Mayer wrote: This series introduces a family of generic

Re: [PATCH] tcm_fc: set and unset FCP_SPPF_TARG_FCN

2016-07-20 Thread Nicholas A. Bellinger
On Tue, 2016-07-19 at 15:01 +0200, Hannes Reinecke wrote: > When registering and unregistering as an target port we should > be setting the FC-4 service params correctly. > > Signed-off-by: Hannes Reinecke > --- > drivers/target/tcm_fc/tfc_sess.c | 2 ++ > 1 file changed, 2

Re: [PATCH] iscsi-target: fix panic when add the second TCP connection to iSCSI session

2016-07-20 Thread Nicholas A. Bellinger
Hi Feng & Co, Apologies for the delayed follow-up. On Tue, 2016-07-19 at 10:10 +0800, Feng Li wrote: > Okay, thanks. > > Anyone could help review this patch and merge into upstream? > Applied to target-pending/for-next, with a CC' to 3.14+ stable. Thanks Feng + Sumit for tracking this down.

Re: [PATCH v9] ibmvscsis: Initial commit of IBM VSCSI Tgt Driver

2016-07-20 Thread Bryant G. Ly
Hi Nic, < SNIP > > Note the deletion of drivers/scsi/libsrp.c + include/scsi/libsrp.h has > been dropped from the above commit, as it looks like they where changes > specific to your local tree. > Please have a quick look, and let me know if anything doesn't look >

Re: [PATCH v9] ibmvscsis: Initial commit of IBM VSCSI Tgt Driver

2016-07-20 Thread Nicholas A. Bellinger
Hi Michael, Bryant & Co, Apologies for the extended follow-up over the summer holiday. Comments below. On Tue, 2016-06-28 at 17:05 -0500, Michael Cyr wrote: > From: "Bryant G. Ly" > > This driver is a pick up of the old IBM VIO scsi Target Driver > that was

Re: [PATCH] target: Unsupported SCSI Opcode Fix

2016-07-20 Thread Nicholas A. Bellinger
On Thu, 2016-06-30 at 13:50 -0500, Bryant G. Ly wrote: > If a Simple command is sent with a failure, > target_setup_cmd_from_cdb returns with TCM_UNSUPPORTED_SCSI_OPCODE > or TCM_INVALID_CDB_FIELD. So in the cases where target_setup_cmd_from_cdb > returns an error, we never get far enough to call

Re: [dm-devel] dm-mq and end_clone_request()

2016-07-20 Thread Bart Van Assche
On 07/20/2016 07:27 AM, Mike Snitzer wrote: On Wed, Jul 20 2016 at 10:08am -0400, Mike Snitzer wrote: [ ... ] diff --git a/drivers/md/dm-rq.c b/drivers/md/dm-rq.c index 7a96618..347ff25 100644 --- a/drivers/md/dm-rq.c +++ b/drivers/md/dm-rq.c @@ -414,7 +414,7 @@ static void

Re: dm-mq and end_clone_request()

2016-07-20 Thread Mike Snitzer
On Wed, Jul 20 2016 at 1:37pm -0400, Bart Van Assche wrote: > On 07/20/2016 07:27 AM, Mike Snitzer wrote: > >On Wed, Jul 20 2016 at 10:08am -0400, > >Mike Snitzer wrote: > >[ ... ] > >diff --git a/drivers/md/dm-rq.c b/drivers/md/dm-rq.c > >index

Re: [PATCH v2] libata-scsi: fix read-only bits checking in ata_mselect_*()

2016-07-20 Thread Tejun Heo
So, just reverted this patch. On Wed, Jul 20, 2016 at 06:59:23AM +0800, tom.t...@gmail.com wrote: > From: Tom Yan > > Commit 7780081c1f04 ("libata-scsi: Set information sense field for > invalid parameter") changed how ata_mselect_*() make sure read-only > bits are not

Re: [PATCH v2] libata-scsi: fix read-only bits checking in ata_mselect_*()

2016-07-20 Thread Tejun Heo
On Wed, Jul 20, 2016 at 06:59:23AM +0800, tom.t...@gmail.com wrote: > From: Tom Yan > > Commit 7780081c1f04 ("libata-scsi: Set information sense field for > invalid parameter") changed how ata_mselect_*() make sure read-only > bits are not modified. The new implementation

Re: [PATCH v4] libata-scsi: better style in ata_msense_*()

2016-07-20 Thread Tejun Heo
On Wed, Jul 20, 2016 at 04:39:28AM +0800, tom.t...@gmail.com wrote: > From: Tom Yan > > `changeable` is the "version" of mode page requested by the user. > It will be less confusing/misleading if we do not check it > "together" with the setting bits of the drive. > > Not to

Re: [PATCH v4] libata-scsi: minor cleanup in ata_mselect_*()

2016-07-20 Thread Tejun Heo
On Wed, Jul 20, 2016 at 05:11:50AM +0800, tom.t...@gmail.com wrote: > From: Tom Yan > > 1. Removed a repeated bit masking in ata_mselect_control() > 2. Moved `wce`/`d_sense` assignment below the page validity checks > 3. Added/Removed empty lines where appropriate > >

GOOD DAY!!!

2016-07-20 Thread a . victima . lara
I am Mr.Saeed Bin Salem Executive Director and Chief Financial Officer of the National Commercial Bank Libya.I have a secured business suggestion for you reply me on my email: saeedbi...@qq.com -- To unsubscribe from this list: send the line "unsubscribe linux-scsi" in the body of a message to

Re: [PATCH 2/5] sd: Implement new RESET_WP provisioning mode

2016-07-20 Thread Hannes Reinecke
On 07/20/2016 02:49 AM, Damien Le Moal wrote: > Hi Hannes, > > On 7/19/16 22:25, Hannes Reinecke wrote: >> We can map the RESET WRITE POINTER command onto a 'discard' >> request. >> >> Signed-off-by: Hannes Reinecke >> --- >> drivers/scsi/sd.c | 65 >>

Re: dm-mq and end_clone_request()

2016-07-20 Thread Mike Snitzer
On Wed, Jul 20 2016 at 10:08am -0400, Mike Snitzer wrote: > On Tue, Jul 19 2016 at 6:57pm -0400, > Bart Van Assche wrote: > > > Hello Mike, > > > > If I run a fio data integrity test against kernel v4.7-rc7 then I > > see often that fio reports

Re: [PATCH v5 4/8] char: rpmb: provide a user space interface

2016-07-20 Thread Paul Gortmaker
[RE: [PATCH v5 4/8] char: rpmb: provide a user space interface] On 20/07/2016 (Wed 09:02) Winkler, Tomas wrote: > > > > On Mon, Jul 18, 2016 at 4:27 PM, Tomas Winkler > > wrote: > > > The user space API is achieved via two synchronous IOCTL. > > > Simplified one,

Re: dm-mq and end_clone_request()

2016-07-20 Thread Mike Snitzer
On Tue, Jul 19 2016 at 6:57pm -0400, Bart Van Assche wrote: > Hello Mike, > > If I run a fio data integrity test against kernel v4.7-rc7 then I > see often that fio reports I/O errors if a path is removed despite > queue_if_no_path having been set in

Re: [PATCH 1/4] scsi: bnx2fc: convert per-CPU thread to kworker

2016-07-20 Thread Johannes Thumshirn
On Wed, Jul 20, 2016 at 02:07:19PM +0200, Sebastian Andrzej Siewior wrote: > On 07/20/2016 01:04 PM, Johannes Thumshirn wrote: > > Hi Sebastian, > > Hi Johannes, > > > I've tried to test your series and unfortunately I encountered the following > > oops. > thanks for testing. > … > > > > I'll

Re: [PATCH 1/4] scsi: bnx2fc: convert per-CPU thread to kworker

2016-07-20 Thread Sebastian Andrzej Siewior
On 07/20/2016 01:04 PM, Johannes Thumshirn wrote: > Hi Sebastian, Hi Johannes, > I've tried to test your series and unfortunately I encountered the following > oops. thanks for testing. … > > I'll try to narrow it down to the specific patch, but currently I'm a bit > busy, sorry. I looked over

Re: [PATCH v2 2/3] xen-scsiback: Rename jump labels in scsiback_device_action()

2016-07-20 Thread Juergen Gross
On 20/07/16 13:34, SF Markus Elfring wrote: > From: Markus Elfring > Date: Wed, 20 Jul 2016 13:03:16 +0200 > > * Adjust jump targets according to the Linux coding style convention. > > * A bit of refactoring for the control flow > > Suggested-by: Jürgen Groß

Re: [PATCH v2 1/3] xen-scsiback: Delete an unnecessary check before the function call "kfree"

2016-07-20 Thread Juergen Gross
On 20/07/16 13:30, SF Markus Elfring wrote: > From: Markus Elfring > Date: Tue, 19 Jul 2016 15:42:19 +0200 > > The kfree() function tests whether its argument is NULL and then > returns immediately. Thus the test around the call is not needed. > > This issue was

Re: [PATCH v2 3/3] xen-scsiback: Pass a failure indication as a constant

2016-07-20 Thread Juergen Gross
On 20/07/16 13:36, SF Markus Elfring wrote: > From: Markus Elfring > Date: Wed, 20 Jul 2016 13:12:33 +0200 > > Pass the constant "FAILED" in a function call directly instead of > using an intialisation for a local variable. > > Signed-off-by: Markus Elfring

[PATCH v2 3/3] xen-scsiback: Pass a failure indication as a constant

2016-07-20 Thread SF Markus Elfring
From: Markus Elfring Date: Wed, 20 Jul 2016 13:12:33 +0200 Pass the constant "FAILED" in a function call directly instead of using an intialisation for a local variable. Signed-off-by: Markus Elfring --- v2: Rebased on source files

[PATCH v2 2/3] xen-scsiback: Rename jump labels in scsiback_device_action()

2016-07-20 Thread SF Markus Elfring
From: Markus Elfring Date: Wed, 20 Jul 2016 13:03:16 +0200 * Adjust jump targets according to the Linux coding style convention. * A bit of refactoring for the control flow Suggested-by: Jürgen Groß Signed-off-by: Markus Elfring

[PATCH v2 1/3] xen-scsiback: Delete an unnecessary check before the function call "kfree"

2016-07-20 Thread SF Markus Elfring
From: Markus Elfring Date: Tue, 19 Jul 2016 15:42:19 +0200 The kfree() function tests whether its argument is NULL and then returns immediately. Thus the test around the call is not needed. This issue was detected by using the Coccinelle software. Signed-off-by:

[PATCH v2 0/3] xen-scsiback: Fine-tuning for scsiback_device_action()

2016-07-20 Thread SF Markus Elfring
From: Markus Elfring Date: Wed, 20 Jul 2016 13:20:04 +0200 Further update suggestions were taken into account after a patch was applied from static source code analysis. Markus Elfring (3): Delete an unnecessary check before the function call "kfree" Rename

Re: [PATCH 1/4] scsi: bnx2fc: convert per-CPU thread to kworker

2016-07-20 Thread Johannes Thumshirn
On Tue, Jul 05, 2016 at 06:08:46PM +0200, Sebastian Andrzej Siewior wrote: > The driver creates its own per-CPU threads which are updated based on CPU > hotplug events. It is also possible to use kworkers and remove some of the > infrastructure get the same job done while saving a few lines of

Re: [v2] cxl: remove dead Kconfig options

2016-07-20 Thread Michael Ellerman
On Mon, 2016-18-07 at 04:52:57 UTC, Andrew Donnellan wrote: > Remove the CXL_KERNEL_API and CXL_EEH Kconfig options, as they were only > needed to coordinate the merging of the cxlflash driver. Also remove the > stub implementation of cxl_perst_reloads_same_image() in cxlflash which is > only used

RE: [PATCH v5 4/8] char: rpmb: provide a user space interface

2016-07-20 Thread Winkler, Tomas
> > On Mon, Jul 18, 2016 at 4:27 PM, Tomas Winkler > wrote: > > The user space API is achieved via two synchronous IOCTL. > > Simplified one, RPMB_IOC_REQ_CMD, were read result cycles is > performed > > by the framework on behalf the user and second, RPMB_IOC_SEQ_CMD >

HDD Unrecovered readerror issue

2016-07-20 Thread Dmitry Monakhov
Drive:WDC WD1003FZEX-00MK2A0 I have got this in logs: ata1.00: failed command: READ FPDMA QUEUED ata1.00: cmd 60/a0:a0:f0:c0:c5/00:00:04:00:00/40 tag 20 ncq 81920 in res 41/40:00:88:c1:c5/00:00:04:00:00/00 Emask 0x409 (media error) ata1.00: status: { DRDY ERR } ata1.00: error: { UNC } ata1.00: