Re: [PATCH 0/2] Two refactoring patches for the qla2xxx driver

2018-11-28 Thread Martin K. Petersen
Bart, > The two patches in this series make the qla2xxx driver source code > easier to read without changing the driver functionality. Please > consider these patches for kernel v4.21. I applied patch #1. #2 had conflicts, please rebase. Thanks! -- Martin K. Petersen Oracle Linux

Re: [PATCH v2 0/9] qedi bug fixes

2018-11-28 Thread Martin K. Petersen
Nilesh, > Please consider below patch set for next 'scsi-fixes' submission. Some of these smelled more like features than bug fixes. So I applied the series to 4.21/scsi-queue. -- Martin K. Petersen Oracle Linux Engineering

Re: [PATCH 01/23] zfcp: make DIX experimental, disabled, and independent of DIF

2018-11-28 Thread Martin K. Petersen
Steffen, As I said, I don't have a problem with having module parameters. > There's one more important thing that has performance impact: We need to > pack payload and protection data into the same queue of limited > length. So for the worst case with DIX, we have to use half the size for >

Re: [PATCH v4 7/7] target: use printf width specifier for t10_wwn field dumps

2018-11-28 Thread Lee Duncan
On 11/28/18 5:01 PM, David Disseldorp wrote: > From: Bart Van Assche > > The existing for loops step over null-terminators for right-padding. > Padding can be achieved in a much simpler way using printf width > specifiers. > > Signed-off-by: David Disseldorp > --- >

Re: [PATCH v4 6/7] target: remove hardcoded T10 Vendor ID in INQUIRY response

2018-11-28 Thread Lee Duncan
On 11/28/18 5:01 PM, David Disseldorp wrote: > Use the value stored in t10_wwn.vendor, which defaults to "LIO-ORG", but > can be reconfigured via the vendor_id ConfigFS attribute. > > Signed-off-by: David Disseldorp > --- > drivers/target/target_core_spc.c | 8 +--- > 1 file changed, 5

Re: [PATCH v4 5/7] target: add device vendor_id configfs attribute

2018-11-28 Thread Lee Duncan
On 11/28/18 5:01 PM, David Disseldorp wrote: > The vendor_id attribute will allow for the modification of the T10 > Vendor Identification string returned in inquiry responses. Its value > can be viewed and modified via the ConfigFS path at: > target/core/$backstore/$name/wwn/vendor_id > >

Re: [PATCH v4 4/7] target: consistently null-terminate t10_wwn.revision

2018-11-28 Thread Lee Duncan
On 11/28/18 5:01 PM, David Disseldorp wrote: > The pscsi_set_inquiry_info() codepath doesn't currently explicitly > null-terminate t10_wwn.revision. > Add an extra byte to the t10_wwn.model buffer and perform null string > termination in all cases. > > Signed-off-by: David Disseldorp > --- >

Re: [PATCH v4 3/7] target: consistently null-terminate t10_wwn.model

2018-11-28 Thread Lee Duncan
On 11/28/18 5:01 PM, David Disseldorp wrote: > The pscsi_set_inquiry_info() and emulate_model_alias_store() codepaths > don't currently explicitly null-terminate t10_wwn.model. > Add an extra byte to the t10_wwn.model buffer and perform null string > termination in all cases. > >

Re: [PATCH v4 2/7] target: consistently null-terminate t10_wwn.vendor

2018-11-28 Thread Lee Duncan
On 11/28/18 5:01 PM, David Disseldorp wrote: > In preparation for supporting user provided vendor strings, add an extra > byte to t10_wwn.vendor which will ensure null string termination when an > eight byte vendor string is provided by the user. > > Signed-off-by: David Disseldorp > --- >

Re: [PATCH v4 2/7] target: consistently null-terminate t10_wwn.vendor

2018-11-28 Thread Ly, Bryant
> On Nov 28, 2018, at 7:01 PM, David Disseldorp wrote: > > In preparation for supporting user provided vendor strings, add an extra > byte to t10_wwn.vendor which will ensure null string termination when an > eight byte vendor string is provided by the user. > > Signed-off-by: David

Re: [PATCH v4 1/7] target: use consistent left-aligned ASCII INQUIRY data

2018-11-28 Thread Ly, Bryant
> On Nov 28, 2018, at 7:01 PM, David Disseldorp wrote: > > spc5r17.pdf specifies: > 4.3.1 ASCII data field requirements > ASCII data fields shall contain only ASCII printable characters (i.e., > code values 20h to 7Eh) and may be terminated with one or more ASCII > null (00h) characters.

Re: [PATCH v4 1/7] target: use consistent left-aligned ASCII INQUIRY data

2018-11-28 Thread Lee Duncan
On 11/28/18 5:01 PM, David Disseldorp wrote: > spc5r17.pdf specifies: > 4.3.1 ASCII data field requirements > ASCII data fields shall contain only ASCII printable characters (i.e., > code values 20h to 7Eh) and may be terminated with one or more ASCII > null (00h) characters. > ASCII

Re: [PATCH v4 6/7] target: remove hardcoded T10 Vendor ID in INQUIRY response

2018-11-28 Thread Ly, Bryant
> On Nov 28, 2018, at 7:01 PM, David Disseldorp wrote: > > Use the value stored in t10_wwn.vendor, which defaults to "LIO-ORG", but > can be reconfigured via the vendor_id ConfigFS attribute. > > Signed-off-by: David Disseldorp > --- > drivers/target/target_core_spc.c | 8 +--- > 1 file

Re: [PATCH v4 5/7] target: add device vendor_id configfs attribute

2018-11-28 Thread Ly, Bryant
> On Nov 28, 2018, at 7:01 PM, David Disseldorp wrote: > > The vendor_id attribute will allow for the modification of the T10 > Vendor Identification string returned in inquiry responses. Its value > can be viewed and modified via the ConfigFS path at: >

Re: [PATCH v4 3/7] target: consistently null-terminate t10_wwn.model

2018-11-28 Thread Ly, Bryant
> On Nov 28, 2018, at 7:01 PM, David Disseldorp wrote: > > The pscsi_set_inquiry_info() and emulate_model_alias_store() codepaths > don't currently explicitly null-terminate t10_wwn.model. > Add an extra byte to the t10_wwn.model buffer and perform null string > termination in all cases. > >

Re: [PATCH v4 4/7] target: consistently null-terminate t10_wwn.revision

2018-11-28 Thread Ly, Bryant
> On Nov 28, 2018, at 7:01 PM, David Disseldorp wrote: > > The pscsi_set_inquiry_info() codepath doesn't currently explicitly > null-terminate t10_wwn.revision. > Add an extra byte to the t10_wwn.model buffer and perform null string > termination in all cases. > > Signed-off-by: David

Re: [PATCH v2 8/9] qedi: Move LL2 producer index processing in BH.

2018-11-28 Thread Lee Duncan
On 11/21/18 1:25 AM, Nilesh Javali wrote: > From: Manish Rangankar > > 1. Removed logic to update HW producer index in interrupt context. > 2. Update HW producer index after UIO ring and buffer gets initialized. > > Signed-off-by: Manish Rangankar > --- > drivers/scsi/qedi/qedi_main.c | 31

Re: [PATCH v2 7/9] qedi: add module param to set ping packet size

2018-11-28 Thread Lee Duncan
On 11/21/18 1:25 AM, Nilesh Javali wrote: > Default packet size is 0x400. > For jumbo packets set to 0x2400. > > Signed-off-by: Nilesh Javali > --- > drivers/scsi/qedi/qedi.h | 1 - > drivers/scsi/qedi/qedi_main.c | 13 + > 2 files changed, 9 insertions(+), 5 deletions(-) > >

Re: [PATCH v2 6/9] qedi: Add packet filter in light L2 Rx path.

2018-11-28 Thread Lee Duncan
On 11/21/18 1:25 AM, Nilesh Javali wrote: > From: Manish Rangankar > > Add packet filter to avoid unnecessary packet processing in iscsiuio. > > Signed-off-by: Manish Rangankar > --- > drivers/scsi/qedi/qedi_main.c | 24 > 1 file changed, 24 insertions(+) > > diff

Re: [PATCH v2 5/9] qedi: Check for session online before getting iSCSI TLV data.

2018-11-28 Thread Lee Duncan
On 11/21/18 1:25 AM, Nilesh Javali wrote: > From: Manish Rangankar > > The kernel panic was observed after switch side perturbation, > > BUG: unable to handle kernel NULL pointer dereference at (null) > IP: [] strcmp+0x20/0x40 > PGD 0 Oops: [#1] SMP > CPU: 8 PID: 647 Comm:

Re: [PATCH v2 3/9] qedi: Replace PAGE_SIZE with QEDI_PAGE_SIZE

2018-11-28 Thread Lee Duncan
On 11/21/18 1:25 AM, Nilesh Javali wrote: > Use QEDI_PAGE_SIZE for enablement of module on systems with 64K page size. > > Signed-off-by: Nilesh Javali > --- > drivers/scsi/qedi/qedi_main.c | 16 +--- > 1 file changed, 9 insertions(+), 7 deletions(-) > > diff --git

Re: [PATCH v2 2/9] qedi: Fix spelling mistake "OUSTANDING" -> "OUTSTANDING"

2018-11-28 Thread Lee Duncan
On 11/21/18 1:25 AM, Nilesh Javali wrote: > Fix trivial spelling mistake within macro definition. > > Signed-off-by: Nilesh Javali > --- > drivers/scsi/qedi/qedi.h | 4 ++-- > drivers/scsi/qedi/qedi_main.c | 2 +- > 2 files changed, 3 insertions(+), 3 deletions(-) > > diff --git

Re: [PATCH v2 1/9] qedi: Cleanup redundant QEDI_PAGE_SIZE macro definition

2018-11-28 Thread Lee Duncan
On 11/21/18 1:25 AM, Nilesh Javali wrote: > Remove redundant macro definition. > > Signed-off-by: Nilesh Javali > --- > drivers/scsi/qedi/qedi.h | 2 -- > 1 file changed, 2 deletions(-) > > diff --git a/drivers/scsi/qedi/qedi.h b/drivers/scsi/qedi/qedi.h > index a6f96b3..e966855 100644 > ---

Re: [PATCH v2 4/9] qedi: Allocate IRQs based on msix_cnt

2018-11-28 Thread Lee Duncan
On 11/21/18 1:25 AM, Nilesh Javali wrote: > The driver load on some systems failed with error, > [0004:01:00.5]:[qedi_request_msix_irq:2524]:8: request_irq failed. > > Allocate the IRQs based on MSIX count obtained from qed module > instead of number of queues. > > Signed-off-by: Nilesh Javali

[PATCH v4 3/7] target: consistently null-terminate t10_wwn.model

2018-11-28 Thread David Disseldorp
The pscsi_set_inquiry_info() and emulate_model_alias_store() codepaths don't currently explicitly null-terminate t10_wwn.model. Add an extra byte to the t10_wwn.model buffer and perform null string termination in all cases. dev_set_t10_wwn_model_alias() continues to truncate at the same length to

[PATCH v4 7/7] target: use printf width specifier for t10_wwn field dumps

2018-11-28 Thread David Disseldorp
From: Bart Van Assche The existing for loops step over null-terminators for right-padding. Padding can be achieved in a much simpler way using printf width specifiers. Signed-off-by: David Disseldorp --- drivers/target/target_core_device.c | 35 ---

[PATCH v4 6/7] target: remove hardcoded T10 Vendor ID in INQUIRY response

2018-11-28 Thread David Disseldorp
Use the value stored in t10_wwn.vendor, which defaults to "LIO-ORG", but can be reconfigured via the vendor_id ConfigFS attribute. Signed-off-by: David Disseldorp --- drivers/target/target_core_spc.c | 8 +--- 1 file changed, 5 insertions(+), 3 deletions(-) diff --git

[PATCH v4 4/7] target: consistently null-terminate t10_wwn.revision

2018-11-28 Thread David Disseldorp
The pscsi_set_inquiry_info() codepath doesn't currently explicitly null-terminate t10_wwn.revision. Add an extra byte to the t10_wwn.model buffer and perform null string termination in all cases. Signed-off-by: David Disseldorp --- drivers/target/target_core_device.c | 6 --

[PATCH v4 5/7] target: add device vendor_id configfs attribute

2018-11-28 Thread David Disseldorp
The vendor_id attribute will allow for the modification of the T10 Vendor Identification string returned in inquiry responses. Its value can be viewed and modified via the ConfigFS path at: target/core/$backstore/$name/wwn/vendor_id "LIO-ORG" remains the default value, which is set when the

[PATCH v4 2/7] target: consistently null-terminate t10_wwn.vendor

2018-11-28 Thread David Disseldorp
In preparation for supporting user provided vendor strings, add an extra byte to t10_wwn.vendor which will ensure null string termination when an eight byte vendor string is provided by the user. Signed-off-by: David Disseldorp --- drivers/target/target_core_device.c | 6 --

[PATCH v4 0/7] target: user configurable T10 Vendor ID

2018-11-28 Thread David Disseldorp
This patchset allows for the modification of the T10 Vendor Identification string returned in the SCSI INQUIRY response, via the target/core/$backstore/$name/wwn/vendor_id ConfigFS path. Changes since v3: - perform explicit null termination of t10_wwn vendor, model and revision fields. -

[PATCH v4 1/7] target: use consistent left-aligned ASCII INQUIRY data

2018-11-28 Thread David Disseldorp
spc5r17.pdf specifies: 4.3.1 ASCII data field requirements ASCII data fields shall contain only ASCII printable characters (i.e., code values 20h to 7Eh) and may be terminated with one or more ASCII null (00h) characters. ASCII data fields described as being left-aligned shall have any

Re: [PATCH 0/3] target: drop unneeded pi_prot_format and get_fabric_name()

2018-11-28 Thread Martin K. Petersen
David, > This patchset removes unneeded se_dev_attrib.pi_prot_format and > fabric_ops.get_fabric_name() struct members. Removal of the latter > allowed for further cleanup due to the fact that all fabric modules > except iscsi_target_mod provide matching strings for fabric_ops.name > and

Re: [PATCH 2/2] qla2xxx: Split the __qla2x00_abort_all_cmds() function

2018-11-28 Thread Madhani, Himanshu
> On Nov 27, 2018, at 3:04 PM, Bart Van Assche wrote: > > External Email > > Nesting in __qla2x00_abort_all_cmds() is way too deep. Reduce the nesting > level by introducing a helper function. This patch does not change any > functionality. > > Cc: Himanshu Madhani > Signed-off-by: Bart Van

Re: [PATCH 1/2] qla2xxx: Introduce a switch/case statement in qlt_xmit_tm_rsp()

2018-11-28 Thread Madhani, Himanshu
> On Nov 27, 2018, at 3:04 PM, Bart Van Assche wrote: > > External Email > > This patch improves code readability but does not change any > functionality. > > Cc: Himanshu Madhani > Signed-off-by: Bart Van Assche > --- > drivers/scsi/qla2xxx/qla_target.c | 14 +++--- > 1 file

Re: [PATCH] scsi: lpfc: fix block guard enablement on SLI3 adapters

2018-11-28 Thread Martin K. Petersen
Martin, > Since f44ac12f1dcc, BG enablement is tracked with the > LPFC_SLI3_BG_ENABLED bit, which is set in lpfc_get_cfgparam before > lpfc_sli_config_sli_port() is called. The bit shouldn't be cleared > before checking the feature. Based on problem analysis by David Bond. Applied to

Re: [PATCH v3 3/4] target: add device vendor_id configfs attribute

2018-11-28 Thread Bart Van Assche
On Wed, 2018-11-28 at 17:44 +0100, David Disseldorp wrote: > Hi Bart, > > On Wed, 28 Nov 2018 08:36:19 -0800, Bart Van Assche wrote: > > > Maybe I'm missing something, but why is zeroing of unused bytes in these > > functions > > necessary? Would the following be correct if all strings in

Re: [PATCH v3 3/4] target: add device vendor_id configfs attribute

2018-11-28 Thread David Disseldorp
Hi Bart, On Wed, 28 Nov 2018 08:36:19 -0800, Bart Van Assche wrote: > Maybe I'm missing something, but why is zeroing of unused bytes in these > functions > necessary? Would the following be correct if all strings in struct t10_wwn > would be > '\0'-terminated? Your patch looks good to me.

Re: [PATCH v3 3/4] target: add device vendor_id configfs attribute

2018-11-28 Thread Bart Van Assche
On Wed, 2018-11-28 at 17:28 +0100, David Disseldorp wrote: > On Wed, 28 Nov 2018 08:08:30 -0800, Bart Van Assche wrote: > > > > Just a follow up here. I think it's safer to retain strncpy() in this > > > function for the purpose of zero filling. scsi_dump_inquiry() and > > >

Re: [PATCH v3 3/4] target: add device vendor_id configfs attribute

2018-11-28 Thread David Disseldorp
On Wed, 28 Nov 2018 08:08:30 -0800, Bart Van Assche wrote: > > Just a follow up here. I think it's safer to retain strncpy() in this > > function for the purpose of zero filling. scsi_dump_inquiry() and > > target_stat_lu_vend_show() walk the entire length of the t10_wwn.vendor > > buffer. > >

Re: [PATCH v3 3/4] target: add device vendor_id configfs attribute

2018-11-28 Thread Bart Van Assche
On Wed, 2018-11-28 at 16:37 +0100, David Disseldorp wrote: > On Tue, 20 Nov 2018 19:00:57 +0100, David Disseldorp wrote: > > > > > + strncpy(buf, page, sizeof(buf)); > > > > > > Isn't strncpy() deprecated? How about using strlcpy() instead? > > > > Will change to use strlcpy in the

Re: [PATCH v3 3/4] target: add device vendor_id configfs attribute

2018-11-28 Thread David Disseldorp
On Tue, 20 Nov 2018 19:00:57 +0100, David Disseldorp wrote: > > > + strncpy(buf, page, sizeof(buf)); > > > > Isn't strncpy() deprecated? How about using strlcpy() instead? > > Will change to use strlcpy in the next round. Just a follow up here. I think it's safer to retain strncpy() in

Hello My Beloved One

2018-11-28 Thread Aisha Gaddafi
Assalamu alaikum, I came across your e-mail contact prior a private search while in need of a trusted person. My name is Mrs. Aisha Gaddafi, a single Mother and a Widow with three Children. I am the only biological Daughter of late Libyan President (Late Colonel Muammar Gaddafi)I have a