Re: [PATCH 1/3] scsi_dh_alua: Do not modify the interval value for retries

2017-04-28 Thread Bart Van Assche
On Fri, 2017-04-28 at 15:06 +0200, Martin Wilck wrote: > @@ -886,7 +883,7 @@ static bool alua_rtpg_queue(struct alua_port_group *pg, > force = true; > } > if (pg->rtpg_sdev == NULL) { > - pg->interval = 0; > + pg->interval = 2; >

Re: [PATCH 2/3] scsi_dh_alua: Do not retry for unmapped device

2017-04-28 Thread Bart Van Assche
On Fri, 2017-04-28 at 15:06 +0200, Martin Wilck wrote: > From: Hannes Reinecke > > If a device becomes unmapped on the target we should be returning > SCSI_DH_DEV_OFFLINED. > > Signed-off-by: Hannes Reinecke > Reviewed-by: Martin Wilck Hello

[PATCH V2 12/12] hpsa: bump driver version

2017-04-28 Thread Don Brace
Reviewed-by: Scott Benesh Reviewed-by: Scott Teel Reviewed-by: Kevin Barnett Signed-off-by: Don Brace --- drivers/scsi/hpsa.c |2 +- 1 file changed, 1 insertion(+), 1 deletion(-)

[PATCH V2 11/12] hpsa: remove abort handler

2017-04-28 Thread Don Brace
- simplify the driver - there are a lot of quirky racy conditions not handled - causes more aborts/resets when the number of commands to be aborted is large, such as in multi-path fail-overs. - has been turned off in our internal driver since 8/31/2015 Reviewed-by: Scott Benesh

[PATCH V2 07/12] hpsa: cleanup reset handler

2017-04-28 Thread Don Brace
- mark device state sooner. Reviewed-by: Scott Benesh Reviewed-by: Scott Teel Reviewed-by: Kevin Barnett Signed-off-by: Don Brace --- drivers/scsi/hpsa.c | 59

[PATCH V2 10/12] hpsa: send ioaccel requests with 0 length down raid path

2017-04-28 Thread Don Brace
- Block I/O requests with 0 length transfers which go down the ioaccel path. This causes lockup issues down in the basecode. - These issues have been fixed, but there are customers who are experiencing the issues when running older firmware. Reviewed-by: Scott Benesh

Re: [PATCH v2 07/21] crypto: shash, caam: Make use of the new sg_map helper function

2017-04-28 Thread Herbert Xu
On Fri, Apr 28, 2017 at 10:53:45AM -0600, Logan Gunthorpe wrote: > > > On 28/04/17 12:30 AM, Herbert Xu wrote: > > You are right. Indeed the existing code looks buggy as they > > don't take sg->offset into account when doing the kmap. Could > > you send me some patches that fix these problems

Re: [PATCH v2 07/21] crypto: shash, caam: Make use of the new sg_map helper function

2017-04-28 Thread Logan Gunthorpe
On 28/04/17 12:30 AM, Herbert Xu wrote: > You are right. Indeed the existing code looks buggy as they > don't take sg->offset into account when doing the kmap. Could > you send me some patches that fix these problems first so that > they can be easily backported? Ok, I think the only buggy

[PATCH V2 06/12] hpsa: correct resets on retried commands

2017-04-28 Thread Don Brace
- call scsi_done when the command completes. Reviewed-by: Scott Benesh Reviewed-by: Scott Teel Reviewed-by: Kevin Barnett Signed-off-by: Don Brace --- drivers/scsi/hpsa.c |2 +- 1

[PATCH V2 08/12] hpsa: correct queue depth for externals

2017-04-28 Thread Don Brace
- queue depth assignment not in correct place, had no effect. Reviewed-by: Scott Benesh Reviewed-by: Scott Teel Reviewed-by: Kevin Barnett Signed-off-by: Don Brace ---

[PATCH V2 09/12] hpsa: separate monitor events from rescan worker

2017-04-28 Thread Don Brace
From: Scott Teel create new worker thread to monitor controller events - both the rescan and event monitor workers can cause a rescan to occur however for multipath we have found that we need to respond faster than the normal scheduled rescan interval for path

[PATCH V2 00/12] hpsa updates

2017-04-28 Thread Don Brace
These patches are based on Linus's tree These patches are for: - RedHat BZ: 1404073 - [HPE 7.3 Bug] multipath failover not reliable - Multipath failover support in general. The changes are: - update identify physical device structure - align with FW - stop getting enclosure info for

[PATCH V2 05/12] hpsa: rescan later if reset in progress

2017-04-28 Thread Don Brace
- schedule another scan. - mark current scan as completed Reviewed-by: Scott Benesh Reviewed-by: Scott Teel Reviewed-by: Kevin Barnett Signed-off-by: Don Brace ---

[PATCH V2 02/12] hpsa: do not get enclosure info for external devices

2017-04-28 Thread Don Brace
external shelves do not support BMICs. Reviewed-by: Scott Benesh Reviewed-by: Scott Teel Reviewed-by: Kevin Barnett Signed-off-by: Don Brace --- drivers/scsi/hpsa.c |5 + 1

[PATCH V2 01/12] hpsa: update identify physical device structure

2017-04-28 Thread Don Brace
- align with latest spec. - added __attribute((aligned(512))) Reviewed-by: Scott Teel Reviewed-by: Scott Benesh Reviewed-by: Kevin Barnett Signed-off-by: Don Brace ---

[PATCH V2 03/12] hpsa: update reset handler

2017-04-28 Thread Don Brace
Use the return from TUR as a check for the device state. Reviewed-by: Scott Benesh Reviewed-by: Scott Teel Reviewed-by: Kevin Barnett Signed-off-by: Don Brace --- drivers/scsi/hpsa.c |

[PATCH V2 04/12] hpsa: do not reset enclosures

2017-04-28 Thread Don Brace
Prevent enclosure resets. Reviewed-by: Scott Benesh Reviewed-by: Scott Teel Reviewed-by: Kevin Barnett Signed-off-by: Don Brace --- drivers/scsi/hpsa.c |3 +++ 1 file changed, 3

Re: [PATCH] target: fixup error message in target_tg_pt_gp_tg_pt_gp_id_store()

2017-04-28 Thread Bart Van Assche
On Fri, 2017-04-28 at 10:04 +0200, Hannes Reinecke wrote: > When setting up an ALUA target port group with an invalid ID the > error message > > kstrtoul() returned -22 for tg_pt_gp_id > > is displayed, which is not really helpful. > Convert it to something sane. > And while we're at it, join

Re: [PATCH v3 3/4] sd: Make synchronize cache upon shutdown asynchronous

2017-04-28 Thread James Bottomley
On Wed, 2017-04-26 at 18:53 +, Bart Van Assche wrote: > On Tue, 2017-04-18 at 08:56 -0700, James Bottomley wrote: > > The priority has got to be the removal we've been ordered to do > > rather > > than waiting around to see if the transport comes back so we can > > send a > > final flush. > >

[PATCH] cciss: use memdup_user

2017-04-28 Thread Geliang Tang
Use memdup_user() helper instead of open-coding to simplify the code. Signed-off-by: Geliang Tang --- drivers/block/cciss.c | 12 +++- 1 file changed, 3 insertions(+), 9 deletions(-) diff --git a/drivers/block/cciss.c b/drivers/block/cciss.c index

Re: [PATCH v3] lpfc: Fix panic on BFS configuration.

2017-04-28 Thread Ewan D. Milne
On Thu, 2017-04-27 at 15:08 -0700, jsmart2...@gmail.com wrote: > From: James Smart > > To select the appropriate shost template, the driver is issuing > a mailbox command to retrieve the wwn. Turns out the sending of > the command precedes the reset of the function. On

Re: [PATCH v2 07/21] crypto: shash, caam: Make use of the new sg_map helper function

2017-04-28 Thread Logan Gunthorpe
On 28/04/17 11:51 AM, Herbert Xu wrote: > On Fri, Apr 28, 2017 at 10:53:45AM -0600, Logan Gunthorpe wrote: >> >> >> On 28/04/17 12:30 AM, Herbert Xu wrote: >>> You are right. Indeed the existing code looks buggy as they >>> don't take sg->offset into account when doing the kmap. Could >>> you

Re: [PATCH 1/3] scsi_dh_alua: Do not modify the interval value for retries

2017-04-28 Thread Martin Wilck
On Fri, 2017-04-28 at 18:35 +, Bart Van Assche wrote: > On Fri, 2017-04-28 at 15:06 +0200, Martin Wilck wrote: > > @@ -886,7 +883,7 @@ static bool alua_rtpg_queue(struct > > alua_port_group *pg, > >   force = true; > >   } > >   if (pg->rtpg_sdev == NULL) { > > -

Re: [PATCH 3/3] scsi_dh_alua: do not call BUG_ON when updating port group

2017-04-28 Thread Bart Van Assche
On Fri, 2017-04-28 at 15:06 +0200, Martin Wilck wrote: > diff --git a/drivers/scsi/device_handler/scsi_dh_alua.c > b/drivers/scsi/device_handler/scsi_dh_alua.c > index 501855bde633..274fb49d0801 100644 > --- a/drivers/scsi/device_handler/scsi_dh_alua.c > +++

Re: [PATCH 2/3] scsi_dh_alua: Do not retry for unmapped device

2017-04-28 Thread Martin Wilck
Hi Bart, On Fri, 2017-04-28 at 18:42 +, Bart Van Assche wrote: > On Fri, 2017-04-28 at 15:06 +0200, Martin Wilck wrote: > > From: Hannes Reinecke > > > > If a device becomes unmapped on the target we should be returning > > SCSI_DH_DEV_OFFLINED. > > > > Signed-off-by: Hannes

Re: BUG: KASAN: use-after-free in scsi_exit_rq

2017-04-28 Thread t...@kernel.org
(cc'ing Jan) Hello, Bart. On Fri, Apr 21, 2017 at 09:49:17PM +, Bart Van Assche wrote: > On Thu, 2017-04-20 at 15:18 -0600, Scott Bauer wrote: > > [ 642.638860] BUG: KASAN: use-after-free in scsi_exit_rq+0xf3/0x120 at > > addr 8802b7fedf00 > > [ 642.639362] Read of size 1 by task

[PATCH] MegaRAID SAS: Raidcard hotswap wouldn't work if the device's fd is held in userspace

2017-04-28 Thread Zhou Zhengping
When a scsi_device is unpluged from scsi controller, if the scsi_device is still be used by application layer,it won't be released until users release it. In this case, scsi_device_remove just set the scsi_device's state to be SDEV_DEL. But if you plug the disk just before the old scsi_device

[PATCH v8 12/15] scsi: mpt3sas: Replace PCI pool old API

2017-04-28 Thread Romain Perier
The PCI pool API is deprecated. This commit replaces the PCI pool old API by the appropriate function with the DMA pool API. Signed-off-by: Romain Perier Reviewed-by: Peter Senna Tschudin --- drivers/scsi/mpt3sas/mpt3sas_base.c | 73

[PATCH v8 15/15] PCI: Remove PCI pool macro functions

2017-04-28 Thread Romain Perier
Now that all the drivers use dma pool API, we can remove the macro functions for PCI pool. Signed-off-by: Romain Perier Reviewed-by: Peter Senna Tschudin --- include/linux/pci.h | 9 - 1 file changed, 9 deletions(-) diff --git

[PATCH v8 09/15] scsi: csiostor: Replace PCI pool old API

2017-04-28 Thread Romain Perier
The PCI pool API is deprecated. This commit replaces the PCI pool old API by the appropriate function with the DMA pool API. It also updates the name of some variables and the content of comments, accordingly. Signed-off-by: Romain Perier Reviewed-by: Peter Senna

[PATCH v8 14/15] scsi: pmcraid: Replace PCI pool old API

2017-04-28 Thread Romain Perier
The PCI pool API is deprecated. This commit replaces the PCI pool old API by the appropriate function with the DMA pool API. Signed-off-by: Romain Perier Acked-by: Peter Senna Tschudin Tested-by: Peter Senna Tschudin

[PATCH v8 13/15] scsi: mvsas: Replace PCI pool old API

2017-04-28 Thread Romain Perier
The PCI pool API is deprecated. This commit replaces the PCI pool old API by the appropriate function with the DMA pool API. Signed-off-by: Romain Perier Reviewed-by: Peter Senna Tschudin --- drivers/scsi/mvsas/mv_init.c | 6 +++---

[PATCH v8 10/15] scsi: lpfc: Replace PCI pool old API

2017-04-28 Thread Romain Perier
The PCI pool API is deprecated. This commit replaces the PCI pool old API by the appropriate function with the DMA pool API. It also updates some comments, accordingly. Signed-off-by: Romain Perier Reviewed-by: Peter Senna Tschudin ---

[PATCH v8 08/15] scsi: be2iscsi: Replace PCI pool old API

2017-04-28 Thread Romain Perier
The PCI pool API is deprecated. This commit replaces the PCI pool old API by the appropriate function with the DMA pool API. Signed-off-by: Romain Perier Acked-by: Peter Senna Tschudin Tested-by: Peter Senna Tschudin

[PATCH v8 11/15] scsi: megaraid: Replace PCI pool old API

2017-04-28 Thread Romain Perier
The PCI pool API is deprecated. This commit replaces the PCI pool old API by the appropriate function with the DMA pool API. Signed-off-by: Romain Perier Reviewed-by: Peter Senna Tschudin Acked-by: Sumit Saxena

[PATCH v8 06/15] mlx5: Replace PCI pool old API

2017-04-28 Thread Romain Perier
The PCI pool API is deprecated. This commit replaces the PCI pool old API by the appropriate function with the DMA pool API. Signed-off-by: Romain Perier Reviewed-by: Peter Senna Tschudin Acked-by: Doug Ledford

Re: [PATCH] MegaRAID SAS: Raidcard hotswap wouldn't work if the device's fd is held in userspace

2017-04-28 Thread Hannes Reinecke
On 04/28/2017 11:43 AM, Zhou Zhengping wrote: > When a scsi_device is unpluged from scsi controller, if the > scsi_device is still be used by application layer,it won't be > released until users release it. In this case, scsi_device_remove just set > the scsi_device's state to be SDEV_DEL. But

Re: Thanks reply,

2017-04-28 Thread Edward Boamah
-- Handle project with me,let us partner. Kindly get back to me for more details. Regards, Edward Boamah.

[PATCH 1/3] scsi_dh_alua: Do not modify the interval value for retries

2017-04-28 Thread Martin Wilck
From: Hannes Reinecke We shouldn't modify the interval value, as the struct is accessed from different devices and hence we might end up scheduling too early. Signed-off-by: Hannes Reinecke Reviewed-by: Martin Wilck ---

[PATCH 0/3] failover fixes for scsi_dh_alua

2017-04-28 Thread Martin Wilck
Here are 3 fixes we came up with at SUSE to fix problems we encountered in multipath failover tests. Feedback welcome. Best regards, Martin Hannes Reinecke (2): scsi_dh_alua: Do not modify the interval value for retries scsi_dh_alua: Do not retry for unmapped device Martin Wilck (1):

[PATCH 3/3] scsi_dh_alua: do not call BUG_ON when updating port group

2017-04-28 Thread Martin Wilck
alua_rtpg() can race with alua_bus_detach(). The assertion that alua_dh_data *h->sdev must be non-NULL is not guaranteed because alua_bus_detach sets this field to NULL before removing the entry from the port group's dh_list. This happens when a device is about to be removed, so don't BUG out but

[PATCH 2/3] scsi_dh_alua: Do not retry for unmapped device

2017-04-28 Thread Martin Wilck
From: Hannes Reinecke If a device becomes unmapped on the target we should be returning SCSI_DH_DEV_OFFLINED. Signed-off-by: Hannes Reinecke Reviewed-by: Martin Wilck --- drivers/scsi/device_handler/scsi_dh_alua.c | 9 ++--- 1 file changed, 6

[PATCH v8 07/15] wireless: ipw2200: Replace PCI pool old API

2017-04-28 Thread Romain Perier
The PCI pool API is deprecated. This commit replaces the PCI pool old API by the appropriate function with the DMA pool API. Signed-off-by: Romain Perier Reviewed-by: Peter Senna Tschudin --- drivers/net/wireless/intel/ipw2x00/ipw2200.c |

[PATCH v8 05/15] mlx4: Replace PCI pool old API

2017-04-28 Thread Romain Perier
The PCI pool API is deprecated. This commit replaces the PCI pool old API by the appropriate function with the DMA pool API. Signed-off-by: Romain Perier Acked-by: Peter Senna Tschudin Tested-by: Peter Senna Tschudin

[PATCH v8 03/15] IB/mthca: Replace PCI pool old API

2017-04-28 Thread Romain Perier
The PCI pool API is deprecated. This commit replaces the PCI pool old API by the appropriate function with the DMA pool API. Signed-off-by: Romain Perier Acked-by: Peter Senna Tschudin Tested-by: Peter Senna Tschudin

[PATCH v8 02/15] dmaengine: pch_dma: Replace PCI pool old API

2017-04-28 Thread Romain Perier
The PCI pool API is deprecated. This commit replaces the PCI pool old API by the appropriate function with the DMA pool API. Signed-off-by: Romain Perier Acked-by: Peter Senna Tschudin Tested-by: Peter Senna Tschudin

[PATCH v8 00/15] Replace PCI pool by DMA pool API

2017-04-28 Thread Romain Perier
by the dma pool API and remove the defines. Changes in v8: - Rebased series onto next-20170428 Changes in v7: - Rebased series onto next-20170416 - Added Acked-by, Tested-by and Reviwed-by tags Changes in v6: - Fixed an issue reported by kbuild test robot about changes in DAC960 - Removed patches

[PATCH v8 04/15] net: e100: Replace PCI pool old API

2017-04-28 Thread Romain Perier
The PCI pool API is deprecated. This commit replaces the PCI pool old API by the appropriate function with the DMA pool API. Signed-off-by: Romain Perier Acked-by: Peter Senna Tschudin Acked-by: Jeff Kirsher

[PATCH v8 01/15] block: DAC960: Replace PCI pool old API

2017-04-28 Thread Romain Perier
The PCI pool API is deprecated. This commit replaces the PCI pool old API by the appropriate function with the DMA pool API. Signed-off-by: Romain Perier Acked-by: Peter Senna Tschudin Tested-by: Peter Senna Tschudin

[Bug 195607] New: Megaraid_sas raidcard hotswap wouldn't work if hold the fd of block devcie in user space

2017-04-28 Thread bugzilla-daemon
https://bugzilla.kernel.org/show_bug.cgi?id=195607 Bug ID: 195607 Summary: Megaraid_sas raidcard hotswap wouldn't work if hold the fd of block devcie in user space Product: SCSI Drivers Version: 2.5 Kernel Version: 3.10.0

[no subject]

2017-04-28 Thread администратор
внимания; Ваши сообщения превысил лимит памяти, который составляет 5 Гб, определенных администратором, который в настоящее время работает на 10.9GB, Вы не сможете отправить или получить новую почту, пока вы повторно не проверить ваш почтовый ящик почты. Чтобы восстановить работоспособность

Re: [PATCH v2 07/21] crypto: shash, caam: Make use of the new sg_map helper function

2017-04-28 Thread Herbert Xu
On Thu, Apr 27, 2017 at 09:45:57AM -0600, Logan Gunthorpe wrote: > > > On 26/04/17 09:56 PM, Herbert Xu wrote: > > On Tue, Apr 25, 2017 at 12:20:54PM -0600, Logan Gunthorpe wrote: > >> Very straightforward conversion to the new function in the caam driver > >> and shash library. > >> > >>

[PATCH RFC] scsi: wait sd probing in manual scan

2017-04-28 Thread Peng Tao
We have a guest init programe trying to mount a device after doing scsi host scan at boot time. Occasionally it fails to find the device when mounting. After digging a bit, it seems the root cause is sd async_schedule probing. With async probing, there is no guarantee of device readiness when

[PATCH] target: fixup error message in target_tg_pt_gp_alua_access_type_store()

2017-04-28 Thread Hannes Reinecke
When setting up a target the error message: Unable to do set ##_name ALUA state on non valid tg_pt_gp ID: 0 is displayed. Apparently concatenation doesn't work in a string; one should be using implicit string concatenation here. Signed-off-by: Hannes Reinecke Reviewed-by: Bart

[PATCH] target: fixup error message in target_tg_pt_gp_tg_pt_gp_id_store()

2017-04-28 Thread Hannes Reinecke
When setting up an ALUA target port group with an invalid ID the error message kstrtoul() returned -22 for tg_pt_gp_id is displayed, which is not really helpful. Convert it to something sane. And while we're at it, join the messages onto a single line. Signed-by: Hannes Reinecke

Re: [PATCH 09/12] hpsa: separate monitor events from heartbeat worker

2017-04-28 Thread Martin Wilck
On Thu, 2017-04-27 at 21:10 +, Don Brace wrote: > > - > > The new worker thread duplicates code from hpsa_rescan_ctlr_worker. > > I > > find this a bit irritating. Could you maybe use just a single > > worker, > > and just check using time stamps whether the "big" heartbeat needs > > to > > be