[PATCH v2] virtio_scsi: Reject commands when virtqueue is broken

2017-01-13 Thread Eric Farman
In the case of a graceful set of detaches, where the virtio-scsi-ccw disk is removed from the guest prior to the controller, the guest behaves quite normally. Specifically, the detach gets us into sd_sync_cache to issue a Synchronize Cache(10) command, which immediately fails (and is retried a

[PATCH v2] virtio_scsi: Reject commands when virtqueue is broken

2017-01-13 Thread Eric Farman
While doing some disruptive testing with QEMU/KVM, I have encountered some guest problems during hot unplug of virtio-scsi devices depending on the order of operations in which they are performed. The following notes describe my setup (s390x), and how I'm able to reproduce the error and test the

Re: iscsi_trx going into D state

2017-01-13 Thread Robert LeBlanc
Laurance, I'm really starting to think that the stars aligned with the phase of the moon or something when I reproduced this in my lab before because I've been unable to reproduce it on Infiniband the last two days. The problem with this issue is that it is so hard to trigger, but causes a lot of

Re: fix data transfer size caculation for special payload requests

2017-01-13 Thread Jens Axboe
On Fri, Jan 13 2017, Christoph Hellwig wrote: > Hi all, > > the first two fixes fix a regression in 4.10-rc1 where the data transfer > size for discard commands wasn't set properly, leading to hangs with > Hyper-V VMs. The use the new data transfer size helper added in patch 1 > more widely.

Re: [PATCH 09/11] qla2xxx: Add Dual mode support in the driver

2017-01-13 Thread Madhani, Himanshu
On 1/11/17, 11:51 AM, "Bart Van Assche" wrote: >On 12/23/2016 08:23 PM, Himanshu Madhani wrote: >> -#define QLA_TGT_MODE_ENABLED() (ql2x_ini_mode != QLA2XXX_INI_MODE_ENABLED) >> +#define QLA_TGT_MODE_ENABLED() \ >> +((ql2x_ini_mode != QLA2XXX_INI_MODE_ENABLED)

Re: [PATCH 4/4] sd: remove __data_len hack for WRITE SAME

2017-01-13 Thread Sagi Grimberg
Looks good, Reviewed-by: Sagi Grimberg -- To unsubscribe from this list: send the line "unsubscribe linux-scsi" in the body of a message to majord...@vger.kernel.org More majordomo info at http://vger.kernel.org/majordomo-info.html

Re: [PATCH 3/4] nvme: use blk_rq_payload_bytes

2017-01-13 Thread Sagi Grimberg
This looks good, Reviewed-by: Sagi Grimberg -- To unsubscribe from this list: send the line "unsubscribe linux-scsi" in the body of a message to majord...@vger.kernel.org More majordomo info at http://vger.kernel.org/majordomo-info.html

Re: [PATCH 2/4] scsi: use blk_rq_payload_bytes

2017-01-13 Thread Sagi Grimberg
Looks good, Reviewed-by: Sagi Grimberg -- To unsubscribe from this list: send the line "unsubscribe linux-scsi" in the body of a message to majord...@vger.kernel.org More majordomo info at http://vger.kernel.org/majordomo-info.html

Re: [PATCH 1/4] block: add blk_rq_payload_bytes

2017-01-13 Thread Sagi Grimberg
Add a helper to calculate the actual data transfer size for special payload requests. Signed-off-by: Christoph Hellwig --- include/linux/blkdev.h | 13 + 1 file changed, 13 insertions(+) diff --git a/include/linux/blkdev.h b/include/linux/blkdev.h index

Re: [PATCH] ibmvscsis: fix sleeping in interrupt context

2017-01-13 Thread Bart Van Assche
On Wed, 2017-01-11 at 13:16 -0600, Bryant G. Ly wrote: > Currently, dma_alloc_coherent is being called with a GFP_KERNEL > flag which allows it to sleep in an interrupt context, need to > change to GFP_ATOMIC. This patch has been queued for kernel v4.10. Thanks for the patch. Bart.-- To

Re: [PATCH] ibmvscsis: Fix max transfer length

2017-01-13 Thread Bart Van Assche
On Wed, 2017-01-11 at 13:52 -0600, Bryant G. Ly wrote: > Current code incorrectly calculates the max transfer length, since > it is assuming a 4k page table, but ppc64 all run on 64k page tables. This patch has been queued for kernel v4.10. Thanks for the patch. Bart.-- To unsubscribe from this

[LSF/MM ATTEND] storage topics plus container filesystems and IMA

2017-01-13 Thread James Bottomley
I'd like to attend LSF/MM mostly to participate in the storage topics discussion, but also because containers is starting to need some features from the VFS. Hopefully the container uid shifting is mostly sorted out by the superblock user namespace, and I should have patches to demonstrate this

RE: [bug report] scsi: megaraid_sas: Add the Support for SAS3.5 Generic Megaraid Controllers Capabilities

2017-01-13 Thread Sasikumar PC
Hi Dan, I will fix the static checker warning Thanks sasi -Original Message- From: Dan Carpenter [mailto:dan.carpen...@oracle.com] Sent: Friday, January 13, 2017 7:51 AM To: sasikumar...@broadcom.com Cc: megaraidlinux@broadcom.com; linux-scsi@vger.kernel.org Subject: [bug report]

RE: [bug report] scsi: megaraid_sas: Dynamic Raid Map Changes for SAS3.5 Generic Megaraid Controllers

2017-01-13 Thread Sasikumar PC
Hi Dan, I will fix the static checker warning Thanks sasi -Original Message- From: Dan Carpenter [mailto:dan.carpen...@oracle.com] Sent: Thursday, January 12, 2017 2:09 PM To: sasikumar...@broadcom.com; Tomas Henzl Cc: megaraidlinux@broadcom.com; linux-scsi@vger.kernel.org Subject:

RE: [bug report] scsi: megaraid_sas: SAS3.5 Generic Megaraid Controllers Stream Detection and IO Coalescing

2017-01-13 Thread Sasikumar PC
Hi Dan, I will fix the static checker warning Thanks sasi -Original Message- From: Dan Carpenter [mailto:dan.carpen...@oracle.com] Sent: Thursday, January 12, 2017 1:50 PM To: sasikumar...@broadcom.com Cc: megaraidlinux@broadcom.com; linux-scsi@vger.kernel.org Subject: [bug report]

Re: [PATCH 08/11] qla2xxx: Add framework for Async fabric discovery.

2017-01-13 Thread Madhani, Himanshu
On 1/11/17, 12:08 PM, "Bart Van Assche" wrote: >On 12/23/2016 08:23 PM, Himanshu Madhani wrote: >> +sess->logout_completed = 0; >> +be_sid[0] = sess->d_id.b.domain; >> +be_sid[1] = sess->d_id.b.area; >> +be_sid[2] = sess->d_id.b.al_pa; > >Hello

Re: [LSF/MM TOPIC][LSF/MM ATTEND] multipath redesign

2017-01-13 Thread Hannes Reinecke
On 01/13/2017 05:07 PM, Mike Snitzer wrote: > On Fri, Jan 13 2017 at 10:56am -0500, > Hannes Reinecke wrote: > >> On 01/12/2017 06:29 PM, Benjamin Marzinski wrote: [ .. ] >>> While I've daydreamed of rewriting the multipath tools multiple times, >>> and having nothing aginst you

[PATCH] csiostor: switch to pci_alloc_irq_vectors

2017-01-13 Thread Christoph Hellwig
And get automatic MSI-X affinity for free. Signed-off-by: Christoph Hellwig --- drivers/scsi/csiostor/csio_hw.h | 4 +- drivers/scsi/csiostor/csio_init.c | 9 +-- drivers/scsi/csiostor/csio_isr.c | 127 +- 3 files changed, 51

[PATCH] be2iscsi: switch to pci_alloc_irq_vectors

2017-01-13 Thread Christoph Hellwig
And get automatic MSI-X affinity for free. Signed-off-by: Christoph Hellwig --- drivers/scsi/be2iscsi/be_main.c | 127 +--- drivers/scsi/be2iscsi/be_main.h | 2 - 2 files changed, 42 insertions(+), 87 deletions(-) diff --git

Re: [LSF/MM TOPIC][LSF/MM ATTEND] multipath redesign

2017-01-13 Thread Mike Snitzer
On Fri, Jan 13 2017 at 10:56am -0500, Hannes Reinecke wrote: > On 01/12/2017 06:29 PM, Benjamin Marzinski wrote: > > On Thu, Jan 12, 2017 at 09:27:40AM +0100, Hannes Reinecke wrote: > >> On 01/11/2017 11:23 PM, Mike Snitzer wrote: > >>> On Wed, Jan 11 2017 at 4:44am -0500, > >>>

Re: [dm-devel] [LSF/MM TOPIC][LSF/MM ATTEND] multipath redesign

2017-01-13 Thread Hannes Reinecke
On 01/12/2017 06:29 PM, Benjamin Marzinski wrote: > On Thu, Jan 12, 2017 at 09:27:40AM +0100, Hannes Reinecke wrote: >> On 01/11/2017 11:23 PM, Mike Snitzer wrote: >>> On Wed, Jan 11 2017 at 4:44am -0500, >>> Hannes Reinecke wrote: >>> Hi all, I'd like to attend

Re: [LSF/MM TOPIC][LSF/MM ATTEND] NAPI polling for block drivers

2017-01-13 Thread Johannes Thumshirn
On Wed, Jan 11, 2017 at 08:13:02AM -0700, Jens Axboe wrote: > On 01/11/2017 08:07 AM, Jens Axboe wrote: > > On 01/11/2017 06:43 AM, Johannes Thumshirn wrote: > >> Hi all, > >> > >> I'd like to attend LSF/MM and would like to discuss polling for block > >> drivers. > >> > >> Currently there is

Re: [PATCH] Set elsiocb contexts to NULL after freeing it

2017-01-13 Thread Johannes Thumshirn
[+Cc James S. I'm sorry] On Tue, Jan 10, 2017 at 12:05:54PM +0100, Johannes Thumshirn wrote: > Set the elsiocb contexts to NULL after freeing as others depend on it. > > Signed-off-by: Johannes Thumshirn > --- > drivers/scsi/lpfc/lpfc_els.c | 2 ++ > 1 file changed, 2

Re: iscsi_trx going into D state

2017-01-13 Thread Laurence Oberman
- Original Message - > From: "Robert LeBlanc" > To: "Laurence Oberman" > Cc: "Doug Ledford" , "Nicholas A. Bellinger" > , "Zhu Lingshan" > , "linux-rdma" ,

[GIT PULL] SCSI fixes for 4.10-rc3

2017-01-13 Thread James Bottomley
The major fix is the bfa firmware, since the latest 10Gb cards fail probing with the current firmware. The rest is a set of minor fixes: one missed Kconfig dependency causing randconfig failures, a missed error return on an error leg, a change for how multiqueue waits on a blocked device and a

RE: [PATCH 3/4] hpsa: remove coalescing settings for ioaccel2

2017-01-13 Thread Don Brace
> -Original Message- > From: Hannes Reinecke [mailto:h...@suse.de] > Sent: Thursday, October 27, 2016 4:04 AM > To: Don Brace ; j...@linux.vnet.ibm.com; John > Hall ; Kevin Barnett > ; Mahesh Rajashekhara >

[bug report] scsi: megaraid_sas: Add the Support for SAS3.5 Generic Megaraid Controllers Capabilities

2017-01-13 Thread Dan Carpenter
Hello Sasikumar Chandrasekaran, This is a semi-automatic email about new static checker warnings. The patch 9581ebebbe35: "scsi: megaraid_sas: Add the Support for SAS3.5 Generic Megaraid Controllers Capabilities" from Jan 10, 2017, leads to the following Smatch complaint:

Re: [PATCH v2] scsi: qla4xxx: Use dma_pool_zalloc

2017-01-13 Thread Javali, Nilesh
On 02/01/17, 11:10 AM, "Souptick Joarder" wrote: >Hi Nilesh, > >On Thu, Dec 22, 2016 at 5:42 PM, Souptick Joarder >wrote: >> We should use dma_pool_zalloc instead of dma_pool_alloc/memset >> >> Signed-off-by: Souptick joarder

Re: [PATCH 2/4] scsi: use blk_rq_payload_bytes

2017-01-13 Thread Hannes Reinecke
On 01/13/2017 12:29 PM, Christoph Hellwig wrote: > Without that we'll pass a wrong payload size in cmd->sdb, which > can lead to hangs with drivers that need the total transfer size. > > Signed-off-by: Christoph Hellwig > Reported-by: Chris Valean >

Re: [PATCH 4/4] sd: remove __data_len hack for WRITE SAME

2017-01-13 Thread Hannes Reinecke
On 01/13/2017 12:29 PM, Christoph Hellwig wrote: > Now that we have the blk_rq_payload_bytes helper available to determine > the actual I/O size we don't need to mess around with __data_len for > WRITE SAME. > > Signed-off-by: Christoph Hellwig > --- > drivers/scsi/sd.c | 17

Re: [PATCH 1/4] block: add blk_rq_payload_bytes

2017-01-13 Thread Hannes Reinecke
On 01/13/2017 12:29 PM, Christoph Hellwig wrote: > Add a helper to calculate the actual data transfer size for special > payload requests. > > Signed-off-by: Christoph Hellwig > --- > include/linux/blkdev.h | 13 + > 1 file changed, 13 insertions(+) > > diff --git

[PATCH 4/4] sd: remove __data_len hack for WRITE SAME

2017-01-13 Thread Christoph Hellwig
Now that we have the blk_rq_payload_bytes helper available to determine the actual I/O size we don't need to mess around with __data_len for WRITE SAME. Signed-off-by: Christoph Hellwig --- drivers/scsi/sd.c | 17 + 1 file changed, 1 insertion(+), 16 deletions(-)

[PATCH 2/4] scsi: use blk_rq_payload_bytes

2017-01-13 Thread Christoph Hellwig
Without that we'll pass a wrong payload size in cmd->sdb, which can lead to hangs with drivers that need the total transfer size. Signed-off-by: Christoph Hellwig Reported-by: Chris Valean Reported-by: Dexuan Cui Fixes: f9d03f96

[PATCH 3/4] nvme: use blk_rq_payload_bytes

2017-01-13 Thread Christoph Hellwig
The new blk_rq_payload_bytes generalizes the payload length hacks that nvme_map_len did before. Signed-off-by: Christoph Hellwig --- drivers/nvme/host/fc.c | 5 ++--- drivers/nvme/host/nvme.h | 8 drivers/nvme/host/pci.c | 19 ---

[PATCH 1/4] block: add blk_rq_payload_bytes

2017-01-13 Thread Christoph Hellwig
Add a helper to calculate the actual data transfer size for special payload requests. Signed-off-by: Christoph Hellwig --- include/linux/blkdev.h | 13 + 1 file changed, 13 insertions(+) diff --git a/include/linux/blkdev.h b/include/linux/blkdev.h index

fix data transfer size caculation for special payload requests

2017-01-13 Thread Christoph Hellwig
Hi all, the first two fixes fix a regression in 4.10-rc1 where the data transfer size for discard commands wasn't set properly, leading to hangs with Hyper-V VMs. The use the new data transfer size helper added in patch 1 more widely. -- To unsubscribe from this list: send the line "unsubscribe

[Bug 191381] LIO ignores XCOPY source and destination descriptor IDs

2017-01-13 Thread bugzilla-daemon
https://bugzilla.kernel.org/show_bug.cgi?id=191381 David Disseldorp changed: What|Removed |Added Status|NEW |RESOLVED

[PATCH] scsi: bfa: Remove redundant memset before memcpy

2017-01-13 Thread Shyam Saini
The region set by the call to memset, immediately overwritten by the subsequent call to memcpy and thus makes the memset redundant Signed-off-by: Shyam Saini --- drivers/scsi/bfa/bfa_ioc.c | 1 - 1 file changed, 1 deletion(-) diff --git a/drivers/scsi/bfa/bfa_ioc.c

[PATCH] scsi: megaraid: Remove redundant memset before memcpy

2017-01-13 Thread Shyam Saini
The region set by the call to memset, immediately overwritten by the subsequent call to memcpy and thus makes the memset redundant Signed-off-by: Shyam Saini --- drivers/scsi/megaraid/megaraid_sas_fusion.c | 2 -- 1 file changed, 2 deletions(-) diff --git

[PATCH] scsi: qla4xxx: Remove redundant memset before memcpy

2017-01-13 Thread Shyam Saini
The region set by the call to memset, immediately overwritten by the subsequent call to memcpy and thus makes the memset redundant Signed-off-by: Shyam Saini --- drivers/scsi/qla4xxx/ql4_os.c | 1 - 1 file changed, 1 deletion(-) diff --git

[PATCH] scsi: qla4xxx: Remove redundant memset before memcpy

2017-01-13 Thread Shyam Saini
The region set by the call to memset, immediately overwritten by the subsequent call to memcpy and thus makes the memset redundant Signed-off-by: Shyam Saini --- drivers/scsi/bfa/bfa_ioc.c | 1 - drivers/scsi/megaraid/megaraid_sas_fusion.c | 2 --

Re: [PATCH 05/15] dm: remove incomple BLOCK_PC support

2017-01-13 Thread Christoph Hellwig
On Thu, Jan 12, 2017 at 05:28:45PM -0500, Mike Snitzer wrote: > What is "incomplete" about request-based DM's BLOCK_PC support? BLOCK_PC requests are always aomething issued by the driver itself (for a broad defintion of the driver, aka everything under the block layer that works together is a

Re: [PATCH] libfc: Fix variable name in fc_set_wwpn

2017-01-13 Thread Johannes Thumshirn
On Fri, Jan 13, 2017 at 11:40:01AM +0800, Fam Zheng wrote: > The parameter name should be wwpn instead of wwnn. > > Signed-off-by: Fam Zheng > --- Yup, looks good Acked-by: Johannes Thumshirn -- Johannes Thumshirn