[PATCH] powerpc: fix giveup_vsx to save registers correctly

2008-07-11 Thread Michael Neuling
giveup_vsx didn't save the FPU and VMX regsiters. Change it to be like giveup_fpr/altivec which save these registers. Also update call sites where FPU and VMX are already saved to use the original giveup_vsx (renamed to __giveup_vsx). Signed-off-by: Michael Neuling [EMAIL PROTECTED] --- benh:

Re: Making __copy_tofrom_user more readable for powerpc (arch/powerpc/lib/copy_32.S)

2008-07-11 Thread Arnd Bergmann
On Friday 11 July 2008, prodyut hazarika wrote: I have a version which just keeps a count of bytes copied till any fault happened. Then for any exception, I just substract this value from the total number of bytes to be copied, and store in r3 and return back. This is the common fixup code for

Re: [RFC] (almost) booting allyesconfig -- please don't poke super-io without request_region

2008-07-11 Thread Hans de Goede
Jean Delvare wrote: Hi Hans, hi Milton, snip One could make a superio driver, and create sub-devices for the IR, I2C, floppy, parallel, etc nodes. There have been proposals to do this, and this would indeed be a very good idea, but unfortunately nobody took the time to implement this

Re: [PATCH -next-20080709] fixup stop_machine use cpu mask vs ftrace

2008-07-11 Thread Ingo Molnar
* Milton Miller [EMAIL PROTECTED] wrote: Hi Rusty, Ingo. Rusty's patch [PATCH 3/3] stop_machine: use cpu mask rather than magic numbers didn't find kernel/trace/ftrace.c in -next, causing an immediate almost NULL pointer dereference in ftrace_dynamic_init. Rusty - what's going on here?

Re: [PATCH][RT][PPC64] Fix preempt unsafe paths accessing per_cpu variables

2008-07-11 Thread Sebastien Dugue
Hi Chirag, On Wed, 9 Jul 2008 21:35:43 +0530 Chirag Jog [EMAIL PROTECTED] wrote: Hi, This patch fixes various paths in the -rt kernel on powerpc64 where per_cpu variables are accessed in a preempt unsafe way. When a power box with -rt kernel is booted, multiple BUG messages are

Re: [PATCH -next-20080709] fixup stop_machine use cpu mask vs ftrace

2008-07-11 Thread Ingo Molnar
* Ingo Molnar [EMAIL PROTECTED] wrote: * Milton Miller [EMAIL PROTECTED] wrote: Hi Rusty, Ingo. Rusty's patch [PATCH 3/3] stop_machine: use cpu mask rather than magic numbers didn't find kernel/trace/ftrace.c in -next, causing an immediate almost NULL pointer dereference in

Re: [PATCH 1/4] kdump : add support for ibm, dynamic-reconfiguration-memory for kexec/kdump

2008-07-11 Thread Chandru
On Friday 11 July 2008 03:57:53 Nathan Fontenot wrote: Hello Chandru, static int __init early_init_dt_scan_drconf_memory(unsigned long node) { - cell_t *dm, *ls; + cell_t *dm, *ls, *endp, *usm; unsigned long l, n, flags; u64 base, size, lmb_size; + char buf[32],

Re: [PATCH -next-20080709] fixup stop_machine use cpu mask vs ftrace

2008-07-11 Thread Rusty Russell
On Friday 11 July 2008 17:46:03 Ingo Molnar wrote: * Milton Miller [EMAIL PROTECTED] wrote: Hi Rusty, Ingo. Rusty's patch [PATCH 3/3] stop_machine: use cpu mask rather than magic numbers didn't find kernel/trace/ftrace.c in -next, causing an immediate almost NULL pointer dereference in

[PATCH 1/4][V2] powerpc : add support for linux, usable-memory properties for drconf memory

2008-07-11 Thread Chandru
Scan for linux,usable-memory properties in case of dynamic reconfiguration memory. Support for kexec/kdump. Signed-off-by: Chandru Siddalingappa [EMAIL PROTECTED] --- Patch applies on linux-next tree (patch-v2.6.26-rc9-next-20080711.gz) arch/powerpc/kernel/prom.c | 40

OF next: microblaze movement

2008-07-11 Thread Michal Simek
Hi All, Can you review OF files which I have in microblaze pack for linux-next? Patch is available at http://kerneltrap.org/mailarchive/linux-kernel/2008/7/8/2387284 Thanks, Michal Simek ___ Linuxppc-dev mailing list Linuxppc-dev@ozlabs.org

Re: [PATCH] [V2] powerpc: Xilinx: PS2: driver updates based on review

2008-07-11 Thread Grant Likely
On Thu, Jul 10, 2008 at 12:34:43PM -0700, John Linn wrote: Review comments were incorporated to improve the driver. 1. Some data was eliminated that was not needed. 2. Renaming of variables for clarity. 3. Removed unneeded type casting. 4. Changed to use dev_err rather than other I/O. 5.

[PATCH] of/i2c: don't pass -1 to irq_dispose_mapping, otherwise kernel will oops

2008-07-11 Thread Anton Vorontsov
Firstly kernel warns at set_irq_chip, and then dies completely: Trying to install chip for IRQ-1 [ cut here ] Badness at c00463b0 [verbose debug info unavailable] NIP: c00463b0 LR: c00463b0 CTR: c0158e80 REGS: cf821cd0 TRAP: 0700 Not tainted

Re: [PATCH 1/2] Convert i2c-mpc from a platform driver into a of_platform driver, V4

2008-07-11 Thread Grant Likely
On Thu, Jul 10, 2008 at 12:36:58PM -0400, Timur Tabi wrote: On Jul 9, 2008, at 1:22 PM, Grant Likely wrote: On Mon, Jun 30, 2008 at 5:01 PM, Jon Smirl [EMAIL PROTECTED] wrote: Convert i2c-mpc to an of_platform driver. Utilize the code in drivers/of-i2c.c to make i2c modules dynamically

Re: [PATCH] of/i2c: don't pass -1 to irq_dispose_mapping, otherwise kernel will oops

2008-07-11 Thread Anton Vorontsov
On Fri, Jul 11, 2008 at 09:48:59PM +0400, Anton Vorontsov wrote: Firstly kernel warns at set_irq_chip, and then dies completely: Trying to install chip for IRQ-1 [ cut here ] Badness at c00463b0 [verbose debug info unavailable] [..] Unable to handle kernel paging

Re: [PATCH] of/i2c: don't pass -1 to irq_dispose_mapping, otherwise kernel will oops

2008-07-11 Thread Grant Likely
On Fri, Jul 11, 2008 at 09:48:59PM +0400, Anton Vorontsov wrote: Firstly kernel warns at set_irq_chip, and then dies completely: Trying to install chip for IRQ-1 diff --git a/drivers/of/of_i2c.c b/drivers/of/of_i2c.c index b2ccdcb..95a24de 100644 --- a/drivers/of/of_i2c.c +++

Re: [PATCH 1/2] Convert i2c-mpc from a platform driver into a of_platform driver, V4

2008-07-11 Thread Anton Vorontsov
On Fri, Jul 11, 2008 at 12:12:14PM -0600, Grant Likely wrote: On Thu, Jul 10, 2008 at 12:36:58PM -0400, Timur Tabi wrote: On Jul 9, 2008, at 1:22 PM, Grant Likely wrote: On Mon, Jun 30, 2008 at 5:01 PM, Jon Smirl [EMAIL PROTECTED] wrote: Convert i2c-mpc to an of_platform driver. Utilize

Re: [PATCH 1/2] Convert i2c-mpc from a platform driver into a of_platform driver, V4

2008-07-11 Thread Grant Likely
On Fri, Jul 11, 2008 at 10:45:56PM +0400, Anton Vorontsov wrote: On Fri, Jul 11, 2008 at 12:12:14PM -0600, Grant Likely wrote: On Thu, Jul 10, 2008 at 12:36:58PM -0400, Timur Tabi wrote: On Jul 9, 2008, at 1:22 PM, Grant Likely wrote: On Mon, Jun 30, 2008 at 5:01 PM, Jon Smirl

Re: [PATCH] of/i2c: don't pass -1 to irq_dispose_mapping, otherwise kernel will oops

2008-07-11 Thread Anton Vorontsov
On Fri, Jul 11, 2008 at 12:23:23PM -0600, Grant Likely wrote: On Fri, Jul 11, 2008 at 09:48:59PM +0400, Anton Vorontsov wrote: Firstly kernel warns at set_irq_chip, and then dies completely: Trying to install chip for IRQ-1 diff --git a/drivers/of/of_i2c.c b/drivers/of/of_i2c.c index

Re: [PATCH] of/i2c: don't pass -1 to irq_dispose_mapping, otherwise kernel will oops

2008-07-11 Thread Jochen Friedrich
Hi Grant, What is the reason that info.irq is set to -1 in the first place? This looks like another bug to me. Does something in the i2c layer depend on the -1 value? Nope, it was a bug in the i2c documentation fixed recently:

Re: [PATCH] of/i2c: don't pass -1 to irq_dispose_mapping, otherwise kernel will oops

2008-07-11 Thread Jochen Friedrich
Hi Anton, diff --git a/drivers/of/of_i2c.c b/drivers/of/of_i2c.c index b2ccdcb..95a24de 100644 --- a/drivers/of/of_i2c.c +++ b/drivers/of/of_i2c.c @@ -93,10 +93,8 @@ void of_register_i2c_devices(struct i2c_adapter *adap, if (info.irq == NO_IRQ) info.irq

Re: [PATCH] of/i2c: don't pass -1 to irq_dispose_mapping, otherwise kernel will oops

2008-07-11 Thread Anton Vorontsov
On Fri, Jul 11, 2008 at 09:01:10PM +0200, Jochen Friedrich wrote: Hi Grant, What is the reason that info.irq is set to -1 in the first place? This looks like another bug to me. Does something in the i2c layer depend on the -1 value? Nope, it was a bug in the i2c documentation fixed

Re: [PATCH] of/i2c: don't pass -1 to irq_dispose_mapping, otherwise kernel will oops

2008-07-11 Thread Anton Vorontsov
On Fri, Jul 11, 2008 at 09:11:02PM +0200, Jochen Friedrich wrote: Hi Anton, diff --git a/drivers/of/of_i2c.c b/drivers/of/of_i2c.c index b2ccdcb..95a24de 100644 --- a/drivers/of/of_i2c.c +++ b/drivers/of/of_i2c.c @@ -93,10 +93,8 @@ void of_register_i2c_devices(struct i2c_adapter

Re: [PATCH] of/i2c: don't pass -1 to irq_dispose_mapping, otherwise kernel will oops

2008-07-11 Thread Grant Likely
On Fri, Jul 11, 2008 at 11:19:30PM +0400, Anton Vorontsov wrote: On Fri, Jul 11, 2008 at 09:11:02PM +0200, Jochen Friedrich wrote: Shouldn't this be: if (info.irq != NO_IRQ) Maybe, maybe not. See http://lkml.org/lkml/2005/11/21/211 I.e. maybe we should use if (irq). Or

Re: [PATCH] of/i2c: don't pass -1 to irq_dispose_mapping, otherwise kernel will oops

2008-07-11 Thread Anton Vorontsov
On Fri, Jul 11, 2008 at 03:18:13PM -0600, Grant Likely wrote: On Fri, Jul 11, 2008 at 11:19:30PM +0400, Anton Vorontsov wrote: On Fri, Jul 11, 2008 at 09:11:02PM +0200, Jochen Friedrich wrote: Shouldn't this be: if (info.irq != NO_IRQ) Maybe, maybe not. See

Re: [PATCH] of/i2c: don't pass -1 to irq_dispose_mapping, otherwise kernel will oops

2008-07-11 Thread Grant Likely
On Sat, Jul 12, 2008 at 01:46:14AM +0400, Anton Vorontsov wrote: On Fri, Jul 11, 2008 at 03:18:13PM -0600, Grant Likely wrote: On Fri, Jul 11, 2008 at 11:19:30PM +0400, Anton Vorontsov wrote: On Fri, Jul 11, 2008 at 09:11:02PM +0200, Jochen Friedrich wrote: Shouldn't this be:

Re: Installation on a MPC5200 based custom board

2008-07-11 Thread Grant Likely
On Fri, Jul 11, 2008 at 06:07:54PM -0400, Sylvain Lamontagne wrote: Greetings We are currently trying to put a Kernel 2.6.26 on a custom board based on the MPC5200 processor and the designed of the board was based on the lite5200b evaluation board. We would like to have some advice

Installation on a MPC5200 based custom board

2008-07-11 Thread Sylvain Lamontagne
Greetings We are currently trying to put a Kernel 2.6.26 on a custom board based on the MPC5200 processor and the designed of the board was based on the lite5200b evaluation board. We would like to have some advice regarding the installation process for this kernel. The hardware currently work

[PATCH] powerpc: Modify MPC52xx maintainers entry to cover all MPC5xxx parts

2008-07-11 Thread Grant Likely
From: Grant Likely [EMAIL PROTECTED] Linux now supports the MPC5121 part and is handled by the same maintainer. Update MAINTAINERS to reflect this. Also remove URLs which do not work or contain out of date information. Signed-off-by: Grant Likely [EMAIL PROTECTED] --- MAINTAINERS |4 +---

[PATCH] powerpc: don't spin on sync

2008-07-11 Thread Sonny Rao
Push the sync below the secondary smp init hold loop and comment its purpose. This should speed up boot by reducing global traffic during the single-threaded portion of boot. Signed-off-by: Sonny Rao [EMAIL PROTECTED] Signed-off-by: Milton Miller [EMAIL PROTECTED] ---

[PATCH 1/6] Document Freescale power management nodes, and the sleep property.

2008-07-11 Thread Scott Wood
Signed-off-by: Scott Wood [EMAIL PROTECTED] --- Documentation/powerpc/booting-without-of.txt | 142 +--- Documentation/powerpc/dts-bindings/fsl/pmc.txt | 63 +++ 2 files changed, 163 insertions(+), 42 deletions(-) create mode 100644

[PATCH 4/6] Add fsl,magic-packet to, and clean up, the gianfar binding.

2008-07-11 Thread Scott Wood
Signed-off-by: Scott Wood [EMAIL PROTECTED] --- Documentation/powerpc/dts-bindings/fsl/tsec.txt | 31 +-- 1 files changed, 12 insertions(+), 19 deletions(-) diff --git a/Documentation/powerpc/dts-bindings/fsl/tsec.txt b/Documentation/powerpc/dts-bindings/fsl/tsec.txt index

[PATCH 5/6] gianfar: Add magic packet and suspend/resume support.

2008-07-11 Thread Scott Wood
Signed-off-by: Scott Wood [EMAIL PROTECTED] --- arch/powerpc/sysdev/fsl_soc.c |3 + drivers/net/gianfar.c | 118 - drivers/net/gianfar.h | 12 - drivers/net/gianfar_ethtool.c | 41 +- include/linux/fsl_devices.h |

[PATCH 6/6] mpc8313erdb: Add power management to the device tree.

2008-07-11 Thread Scott Wood
Signed-off-by: Scott Wood [EMAIL PROTECTED] --- arch/powerpc/boot/dts/mpc8313erdb.dts | 241 +++-- 1 files changed, 171 insertions(+), 70 deletions(-) diff --git a/arch/powerpc/boot/dts/mpc8313erdb.dts b/arch/powerpc/boot/dts/mpc8313erdb.dts index 3664fb5..2a94ae0

[PATCH 3/6] mpc83xx: Power Management support

2008-07-11 Thread Scott Wood
Basic PM support for 83xx. Standby is implemented as sleep. Suspend-to-RAM is implemented as deep sleep (with the processor turned off) on 831x. Signed-off-by: Scott Wood [EMAIL PROTECTED] --- arch/powerpc/Kconfig |2 +- arch/powerpc/platforms/83xx/Makefile |1

Re: Updates to powerpc.git

2008-07-11 Thread Benjamin Herrenschmidt
What is your intent with the 'master' branch? I hope you do NOT plan on ever rebasing it. I assume if a patch gets into master and we drop it you'll do a git-revert of it? I'll try as much as possible. But I'll keep the option open. next is the one that should never be rebased I'd say.

Re: [PATCH] powerpc: Fix problems with 32bit PPC's running with more than 2GB of RAM

2008-07-11 Thread Benjamin Herrenschmidt
Are you *sure* you can see all 4GB? I thought we lost some of the 32- bit PCI address space for PCI IO.. Disclaimer: I'm no expert on PCI :) You are right. I didn't think that through when I replied. We do lose some of it for MMIO (not IO). So we cannot really go all the way to 4G

Re: Updates to powerpc.git

2008-07-11 Thread Grant Likely
On Sat, Jul 12, 2008 at 01:30:58PM +1000, Benjamin Herrenschmidt wrote: What is your intent with the 'master' branch? I hope you do NOT plan on ever rebasing it. I assume if a patch gets into master and we drop it you'll do a git-revert of it? I'll try as much as possible. But

Re: Updates to powerpc.git

2008-07-11 Thread Benjamin Herrenschmidt
On Wed, 2008-07-09 at 09:18 -0400, Josh Boyer wrote: If you want to use your master branch as a place for experimental stuff, that's fine by me. But you'll want to keep next separate from it so it's as clean as possible for those trying to track what is definitely going into the next

Re: linux-next: manual merge of the powerpc tree

2008-07-11 Thread Benjamin Herrenschmidt
On Fri, 2008-07-11 at 21:01 +0200, Bartlomiej Zolnierkiewicz wrote: Since I haven't heard back from Ben [1] on ide-pmac/media-bay IRQ issue I took another look at ide-pmac patches and I think that it should be possible to rework them in such way that consecutive ide patches ( 100) won't

Re: [PATCH v2 4/5] spi: Add OF binding support for SPI busses

2008-07-11 Thread Grant Likely
On Wed, Jul 02, 2008 at 11:02:23PM -0400, Jon Smirl wrote: On 7/2/08, Grant Likely [EMAIL PROTECTED] wrote: From: Grant Likely [EMAIL PROTECTED] This patch adds support for populating an SPI bus based on data in the OF device tree. This is useful for powerpc platforms which use the