Re: [PATCH v3 2/2] powerpc: add support for new hcall H_BEST_ENERGY

2010-06-28 Thread Michael Neuling
In message 20100628053252.ga12...@dirshya.in.ibm.com you wrote: * Michael Neuling mi...@neuling.org [2010-06-28 11:44:31]: Vaidy, Create sysfs interface to export data from H_BEST_ENERGY hcall that can be used by administrative tools on supported pseries platforms for

Re: [PATCH 18/26] KVM: PPC: KVM PV guest stubs

2010-06-28 Thread Alexander Graf
On 28.06.2010, at 06:39, Matt Evans wrote: Howdy Alex! Alexander Graf wrote: We will soon start and replace instructions from the text section with other, paravirtualized versions. To ease the readability of those patches I split out the generic looping and magic page mapping code out.

Re: of-flash: Unable to ioremap() both 128MB NOR flashes on 32-bit system with 2GB+ RAM

2010-06-28 Thread Milton Miller
On Fri Jun 25 around 14:01:51 EST 2010 Kyle Moffett wrote: Oops... put the old linuxppc list on the CC, sorry! On Thu, Jun 24, 2010 at 23:45, Kyle Moffett kyle at moffetthome.net wrote: Hello, I've got a new P2020 (32bit mpc85xx family) board I'm working on a port for that includes 2

Re: [PATCH 18/26] KVM: PPC: KVM PV guest stubs

2010-06-28 Thread Avi Kivity
On 06/28/2010 09:33 AM, Alexander Graf wrote: Could you do something similar in module_finalize() to patch loaded modules' .text sections? I could, but do we need it? I objdump -d | grep'ed all my modules and didn't find any need to do so. You mean even kvm.ko doesn't use

Re: [PATCH 26/26] KVM: PPC: Add Documentation about PV interface

2010-06-28 Thread Alexander Graf
On 28.06.2010, at 10:13, Avi Kivity wrote: On 06/28/2010 10:49 AM, Alexander Graf wrote: I don't believe we support the kernel actually doing a syscall to itself anymore, at least on powerpc. The callers call the underlying system call function, or kernel_thread. That said, I would

Re: [PATCH 18/26] KVM: PPC: KVM PV guest stubs

2010-06-28 Thread Alexander Graf
On 28.06.2010, at 10:15, Avi Kivity wrote: On 06/28/2010 09:33 AM, Alexander Graf wrote: Could you do something similar in module_finalize() to patch loaded modules' .text sections? I could, but do we need it? I objdump -d | grep'ed all my modules and didn't find any need to do

Re: [PATCH] KVM: PPC: Add generic hpte management functions

2010-06-28 Thread Avi Kivity
On 06/26/2010 02:16 AM, Alexander Graf wrote: Currently the shadow paging code keeps an array of entries it knows about. Whenever the guest invalidates an entry, we loop through that entry, trying to invalidate matching parts. While this is a really simple implementation, it is probably the

Re: [PATCH 18/26] KVM: PPC: KVM PV guest stubs

2010-06-28 Thread Avi Kivity
On 06/28/2010 11:23 AM, Alexander Graf wrote: You mean even kvm.ko doesn't use privileged instructions? It does, but I don't think it's worth speeding those up. There are only a couple. Most of the privileged instructions in PPC KVM are statically compiled into the kernel because we

Re: [PATCH] KVM: PPC: Add generic hpte management functions

2010-06-28 Thread Alexander Graf
On 28.06.2010, at 10:28, Avi Kivity wrote: On 06/26/2010 02:16 AM, Alexander Graf wrote: Currently the shadow paging code keeps an array of entries it knows about. Whenever the guest invalidates an entry, we loop through that entry, trying to invalidate matching parts. While this is a

Re: [PATCH] KVM: PPC: Add generic hpte management functions

2010-06-28 Thread Avi Kivity
On 06/28/2010 11:55 AM, Alexander Graf wrote: + +static inline u64 kvmppc_mmu_hash_pte(u64 eaddr) { + return hash_64(eaddr PTE_SIZE, HPTEG_HASH_BITS_PTE); +} + +static inline u64 kvmppc_mmu_hash_vpte(u64 vpage) { + return hash_64(vpage 0xfULL, HPTEG_HASH_BITS_VPTE); +}

Re: [PATCH] KVM: PPC: Add generic hpte management functions

2010-06-28 Thread Alexander Graf
Am 28.06.2010 um 11:12 schrieb Avi Kivity a...@redhat.com: On 06/28/2010 11:55 AM, Alexander Graf wrote: + +static inline u64 kvmppc_mmu_hash_pte(u64 eaddr) { +return hash_64(eaddr PTE_SIZE, HPTEG_HASH_BITS_PTE); +} + +static inline u64 kvmppc_mmu_hash_vpte(u64 vpage) { +return

Re: [PATCH] KVM: PPC: Add generic hpte management functions

2010-06-28 Thread Alexander Graf
Avi Kivity wrote: On 06/28/2010 12:27 PM, Alexander Graf wrote: Am I looking at old code? Apparently. Check book3s_mmu_*.c I don't have that pattern. It's in this patch. +static void invalidate_pte(struct kvm_vcpu *vcpu, struct hpte_cache *pte) +{ + dprintk_mmu(KVM: Flushing SPT:

Re: [PATCH] KVM: PPC: Add generic hpte management functions

2010-06-28 Thread Avi Kivity
On 06/28/2010 12:55 PM, Alexander Graf wrote: Avi Kivity wrote: On 06/28/2010 12:27 PM, Alexander Graf wrote: Am I looking at old code? Apparently. Check book3s_mmu_*.c I don't have that pattern. It's in this patch. Yes. Silly me. +static void

Re: [PATCH] KVM: PPC: Add generic hpte management functions

2010-06-28 Thread Alexander Graf
Avi Kivity wrote: On 06/28/2010 12:55 PM, Alexander Graf wrote: Avi Kivity wrote: On 06/28/2010 12:27 PM, Alexander Graf wrote: Am I looking at old code? Apparently. Check book3s_mmu_*.c I don't have that pattern. It's in this patch. Yes. Silly

Re: [PATCH] KVM: PPC: Add generic hpte management functions

2010-06-28 Thread Avi Kivity
On 06/28/2010 04:25 PM, Alexander Graf wrote: Less and simpler code, better reporting through slabtop, less wastage of partially allocated slab pages. But it also means that one VM can spill the global slab cache and kill another VM's mm performance, no? What do you mean

Re: [PATCH] KVM: PPC: Add generic hpte management functions

2010-06-28 Thread Alexander Graf
Avi Kivity wrote: On 06/28/2010 04:25 PM, Alexander Graf wrote: Less and simpler code, better reporting through slabtop, less wastage of partially allocated slab pages. But it also means that one VM can spill the global slab cache and kill another VM's mm performance, no?

Re: BUG: scheduling while atomic: swapper/0/0x00000002

2010-06-28 Thread Paul E. McKenney
On Wed, Jun 09, 2010 at 06:08:54PM -0700, Paul E. McKenney wrote: On Thu, Jun 10, 2010 at 09:20:08AM +1000, Benjamin Herrenschmidt wrote: On Wed, 2010-06-09 at 14:52 -0700, Paul E. McKenney wrote: Hello! I get the following during boot on a 16 CPU Power box. Thoughts?

RE: JFFS2 corruption when mounting filesystem with filenamesoflength 7

2010-06-28 Thread Steve Deiters
I think there may be something weird going on with the memcpy in my build. If I use the following patch I no longer get errors when I mount the filesystem. All I did was replace the memcpy with a loop. I'm not sure what's special about this particular use of memcpy. I can't believe

Re: BUG: scheduling while atomic: swapper/0/0x00000002

2010-06-28 Thread Benjamin Herrenschmidt
On Mon, 2010-06-28 at 09:49 -0700, Paul E. McKenney wrote: And it does appear to be reproducible perhaps 50% of boots running CONFIG_PREEMPT on kernel-ml8. I have not yet seen it on any other system. Do you have a patch to instrument the interrupts so as to get the info you need, or should I

Re: JFFS2 corruption when mounting filesystem with filenamesoflength 7

2010-06-28 Thread Wolfgang Denk
Dear Steve Deiters, In message 181804936abc2349be503168465576460f20d...@exchserver.basler.com you wrote: I think there may be something weird going on with the memcpy in my build. If I use the following patch I no longer get errors when I mount the filesystem. All I did was replace

Re: [PATCH 39/40] trace syscalls: Clean confusing {s, r, }name and fix ABI breakage

2010-06-28 Thread Ian Munsie
Excerpts from Jason Baron's message of Thu Jun 24 04:03:54 +1000 2010: overall this patch is a major improvement! My question though is about the naming of the compat syscalls in the context of events. I believe this patch differeniates compat syscall event names as: sys32_enter_sname, and

Re: [PATCH 01/40] ftrace syscalls: don't add events for unmapped syscalls

2010-06-28 Thread Ian Munsie
Excerpts from Steven Rostedt's message of Thu Jun 24 01:02:19 +1000 2010: diff --git a/kernel/trace/trace_syscalls.c b/kernel/trace/trace_syscalls.c index 34e3580..82246ce 100644 --- a/kernel/trace/trace_syscalls.c +++ b/kernel/trace/trace_syscalls.c @@ -431,6 +431,14 @@ void

Re: [PATCH]460EX on-chip SATA driverkernel 2.6.33resubmission

2010-06-28 Thread Marek Vasut
Dne Pá 4. června 2010 14:26:17 Rupjyoti Sarmah napsal(a): This patch enables the on-chip DWC SATA controller of the AppliedMicro processor 460EX. Signed-off-by: Rupjyoti Sarmah rsar...@appliedmicro.com Signed-off-by: Mark Miesfeld mmiesf...@appliedmicro.com Signed-off-by: Prodyut Hazarika

[PATCH] sched: fix spelling of sibling

2010-06-28 Thread Michael Neuling
No logic changes, only spelling. Signed-off-by: Michael Neuling mi...@neuling.org --- arch/powerpc/kernel/process.c |2 +- include/linux/topology.h |2 +- kernel/sched_fair.c |2 +- 3 files changed, 3 insertions(+), 3 deletions(-) Index:

Re: Using devices trees on X86

2010-06-28 Thread Stephen Rothwell
Hi Stephen, On Mon, 28 Jun 2010 10:57:33 -0700 Stephen Neuendorffer stephen.neuendorf...@xilinx.com wrote: 2) config OF is currently implemented in the architecture code. This should be non-architecture dependent and selected by the arches that need it. Comments greatly appreciated, in

[PATCH 1/5] microblaze: turn CONFIG_OF into a select

2010-06-28 Thread Stephen Rothwell
so that we can make CONFIG_OF global and remove it from the architecture Kconfig files later. Signed-off-by: Stephen Rothwell s...@canb.auug.org.au --- arch/microblaze/Kconfig |5 +++-- 1 files changed, 3 insertions(+), 2 deletions(-) diff --git a/arch/microblaze/Kconfig

[PATCH 2/5] powerpc: turn CONFIG_OF into a select

2010-06-28 Thread Stephen Rothwell
so that we can make CONFIG_OF global and remove it from the architecture Kconfig files later. Signed-off-by: Stephen Rothwell s...@canb.auug.org.au --- arch/powerpc/Kconfig |5 +++-- 1 files changed, 3 insertions(+), 2 deletions(-) diff --git a/arch/powerpc/Kconfig b/arch/powerpc/Kconfig

[PATCH 3/5] sparc: turn CONFIG_OF into a select

2010-06-28 Thread Stephen Rothwell
so that we can make CONFIG_OF global and remove it from the architecture Kconfig files later. Signed-off-by: Stephen Rothwell s...@canb.auug.org.au --- arch/sparc/Kconfig |3 ++- 1 files changed, 2 insertions(+), 1 deletions(-) diff --git a/arch/sparc/Kconfig b/arch/sparc/Kconfig index

[PATCH 4/5] of: define CONFIG_OF globally so architectures can select it

2010-06-28 Thread Stephen Rothwell
Signed-off-by: Stephen Rothwell s...@canb.auug.org.au --- drivers/of/Kconfig |3 +++ 1 files changed, 3 insertions(+), 0 deletions(-) diff --git a/drivers/of/Kconfig b/drivers/of/Kconfig index 7cecc8f..1678dbc 100644 --- a/drivers/of/Kconfig +++ b/drivers/of/Kconfig @@ -1,3 +1,6 @@ +config

[PATCH 5/5] of: remove architecture CONFIG_OF definitions

2010-06-28 Thread Stephen Rothwell
now that CONFIG_OF is defined globally Signed-off-by: Stephen Rothwell s...@canb.auug.org.au --- arch/microblaze/Kconfig |3 --- arch/powerpc/Kconfig|3 --- arch/sparc/Kconfig |3 --- 3 files changed, 0 insertions(+), 9 deletions(-) diff --git a/arch/microblaze/Kconfig

Re: [PATCH 3/5] sparc: turn CONFIG_OF into a select

2010-06-28 Thread David Miller
From: Stephen Rothwell s...@canb.auug.org.au Date: Tue, 29 Jun 2010 12:44:50 +1000 so that we can make CONFIG_OF global and remove it from the architecture Kconfig files later. Signed-off-by: Stephen Rothwell s...@canb.auug.org.au Acked-by: David S. Miller da...@davemloft.net

Re: Using devices trees on X86

2010-06-28 Thread Grant Likely
On Mon, Jun 28, 2010 at 7:38 PM, Stephen Rothwell s...@canb.auug.org.au wrote: Hi Stephen, On Mon, 28 Jun 2010 10:57:33 -0700 Stephen Neuendorffer stephen.neuendorf...@xilinx.com wrote: 2) config OF is currently implemented in the architecture code.  This should be non-architecture