Re: [PATCH v8 2/5] powerpc/hv-24x7: Add rtas call in hv-24x7 driver to get processor details

2020-05-17 Thread kajoljain
On 5/12/20 2:37 AM, Nathan Lynch wrote: > Hi, > > Kajol Jain writes: >> diff --git a/arch/powerpc/perf/hv-24x7.c b/arch/powerpc/perf/hv-24x7.c >> index 48e8f4b17b91..8cf242aad98f 100644 >> --- a/arch/powerpc/perf/hv-24x7.c >> +++ b/arch/powerpc/perf/hv-24x7.c >> @@ -20,6 +20,7 @@ >> #include

Re: [PATCH V3 07/15] arch/kunmap_atomic: Consolidate duplicate code

2020-05-17 Thread Guenter Roeck
On Sun, May 17, 2020 at 08:49:39PM -0700, Ira Weiny wrote: > On Sat, May 16, 2020 at 03:33:06PM -0700, Guenter Roeck wrote: > > On Thu, May 07, 2020 at 07:59:55AM -0700, ira.we...@intel.com wrote: > > > From: Ira Weiny > > > > > > Every single architecture (including !CONFIG_HIGHMEM) calls... >

Re: [PATCH V3 07/15] arch/kunmap_atomic: Consolidate duplicate code

2020-05-17 Thread Ira Weiny
On Sat, May 16, 2020 at 03:33:06PM -0700, Guenter Roeck wrote: > On Thu, May 07, 2020 at 07:59:55AM -0700, ira.we...@intel.com wrote: > > From: Ira Weiny > > > > Every single architecture (including !CONFIG_HIGHMEM) calls... > > > > pagefault_enable(); > > preempt_enable(); > > > > ...

Re: [PATCH] powerpc/64s: Fix early_init_mmu section mismatch

2020-05-17 Thread Michael Ellerman
Christian Zigotzky writes: > Hi All, > > This patch wasn't included in the PowerPC fixes 5.7-4. Please add it. It's not an important bug. I'll take the patch for v5.8 cheers > On 29 April 2020 at 09:02 am, Nicholas Piggin wrote: >> Christian reports: >> >>MODPOST vmlinux.o >>WARNING:

Re: [PATCH v2 2/2] powerpc/configs: replace deprecated riva/nvidia with nouveau

2020-05-17 Thread Benjamin Herrenschmidt
On Sun, 2020-05-17 at 23:05 +0100, Emil Velikov wrote: > As mentioned in earlier commit, the riva and nvidia fbdev drivers > have > seen no love over the years, are short on features and overall below > par > > Users are encouraged to switch to the nouveau drm driver instead. > > v2: Split

Re: [PATCH v5 2/2] powerpc/rtas: Implement reentrant rtas call

2020-05-17 Thread Nicholas Piggin
Excerpts from Nicholas Piggin's message of May 16, 2020 5:36 pm: > Excerpts from Leonardo Bras's message of May 16, 2020 3:21 pm: >> @@ -202,6 +220,7 @@ void __init __nostackprotector initialise_paca(struct >> paca_struct *new_paca, int >> /* For now -- if we have threads this will be

[PATCH v2 2/2] powerpc/configs: replace deprecated riva/nvidia with nouveau

2020-05-17 Thread Emil Velikov
As mentioned in earlier commit, the riva and nvidia fbdev drivers have seen no love over the years, are short on features and overall below par Users are encouraged to switch to the nouveau drm driver instead. v2: Split configs to separate patch, enable nouveau (Bartlomiej) Cc: Antonino Daplas

Re: [PATCH V3 10/15] arch/kmap: Define kmap_atomic_prot() for all arch's

2020-05-17 Thread Guenter Roeck
Hi, On Thu, May 07, 2020 at 07:59:58AM -0700, ira.we...@intel.com wrote: > From: Ira Weiny > > To support kmap_atomic_prot(), all architectures need to support > protections passed to their kmap_atomic_high() function. Pass > protections into kmap_atomic_high() and change the name to >

Re: [PATCH v8 11/30] powerpc: Use a datatype for instructions

2020-05-17 Thread Jordan Niethe
mpe, this is to go with the fixup I posted for mmu_patch_addis() in [PATCH v8 12/30] powerpc: Use a function for reading instructions. Thanks to Christophe pointing it out. diff --git a/arch/powerpc/mm/nohash/8xx.c b/arch/powerpc/mm/nohash/8xx.c --- a/arch/powerpc/mm/nohash/8xx.c +++

Re: [PATCH v8 12/30] powerpc: Use a function for reading instructions

2020-05-17 Thread Jordan Niethe
On Sun, May 17, 2020 at 4:39 AM Christophe Leroy wrote: > > > > Le 06/05/2020 à 05:40, Jordan Niethe a écrit : > > Prefixed instructions will mean there are instructions of different > > length. As a result dereferencing a pointer to an instruction will not > > necessarily give the desired

Re: [PATCH] powerpc/64s: Fix early_init_mmu section mismatch

2020-05-17 Thread Christian Zigotzky
Hi All, This patch wasn't included in the PowerPC fixes 5.7-4. Please add it. Thanks, Christian On 29 April 2020 at 09:02 am, Nicholas Piggin wrote: Christian reports: MODPOST vmlinux.o WARNING: modpost: vmlinux.o(.text.unlikely+0x1a0): Section mismatch in reference from the

Re: [PATCH v8 08/30] powerpc: Use a function for getting the instruction op code

2020-05-17 Thread Jordan Niethe
On Sat, May 16, 2020 at 9:08 PM Michael Ellerman wrote: > > Jordan Niethe writes: > > mpe, as suggested by Christophe could you please add this. > > I did that and ... > > > diff --git a/arch/powerpc/include/asm/inst.h > > b/arch/powerpc/include/asm/inst.h > > ---