Re: [PATCH] selftest/vm: Use correct PAGE_SHIFT value for ppc64

2022-02-09 Thread Aneesh Kumar K.V
Aneesh Kumar K.V writes: > Shuah Khan writes: > >> On 2/9/22 8:43 AM, Aneesh Kumar K.V wrote: >> --- a/tools/testing/selftests/vm/transhuge-stress.c >>> +++ b/tools/testing/selftests/vm/transhuge-stress.c >>> @@ -16,8 +16,16 @@ >>> #include >>> #include >>> >>> +#ifdef __powerpc64__

Re: [PATCH] selftest/vm: Use correct PAGE_SHIFT value for ppc64

2022-02-09 Thread Aneesh Kumar K.V
Shuah Khan writes: > On 2/9/22 8:43 AM, Aneesh Kumar K.V wrote: >> Keep it simple by using a #define and limiting hugepage size to 2M. >> This keeps the test simpler instead of dynamically finding the page size >> and huge page size. >> >> Without this tests are broken w.r.t reading

Re: [RFC PATCH 2/3] powerpc/ftrace: Override ftrace_location_lookup() for MPROFILE_KERNEL

2022-02-09 Thread Steven Rostedt
On Wed, 09 Feb 2022 17:50:09 + "Naveen N. Rao" wrote: > However, I think we will not be able to use a fixed range. I would like > to reserve instructions from function entry till the branch to > _mcount(), and it can be two or four instructions depending on whether a > function has a

[PATCH v3 0/5] Improve KVM's interaction with CPU hotplug

2022-02-09 Thread Chao Gao
Changes from v2->v3: - rebased to the latest kvm/next branch. - patch 1: rename {svm,vmx}_check_processor_compat to follow the name convention - patch 3: newly added to provide more information when hardware enabling fails - patch 4: reset hardware_enable_failed if

Re: [PATCH] selftest/vm: Use correct PAGE_SHIFT value for ppc64

2022-02-09 Thread Shuah Khan
On 2/9/22 8:43 AM, Aneesh Kumar K.V wrote: Keep it simple by using a #define and limiting hugepage size to 2M. This keeps the test simpler instead of dynamically finding the page size and huge page size. Without this tests are broken w.r.t reading /proc/self/pagemap if

Re: [RFC PATCH 2/3] powerpc/ftrace: Override ftrace_location_lookup() for MPROFILE_KERNEL

2022-02-09 Thread Naveen N. Rao
Steven Rostedt wrote: On Mon, 7 Feb 2022 12:37:21 +0530 "Naveen N. Rao" wrote: --- a/arch/powerpc/kernel/trace/ftrace.c +++ b/arch/powerpc/kernel/trace/ftrace.c @@ -1137,3 +1137,14 @@ char *arch_ftrace_match_adjust(char *str, const char *search) return str; } #endif /*

[PATCH v2 6/7] soc: fsl: guts: drop platform driver

2022-02-09 Thread Michael Walle
This driver cannot be unloaded and it will be needed very early in the boot process because other driver (weakly) depend on it (eg. for chip errata handling). Drop all the platform driver and devres stuff and simply make it a core_initcall. Signed-off-by: Michael Walle ---

[PATCH v2 5/7] soc: fsl: guts: use of_root instead of own reference

2022-02-09 Thread Michael Walle
There is already a global of_root reference. Use that instead of getting one on our own. We don't need to care about the reference count either this way. Signed-off-by: Michael Walle --- drivers/soc/fsl/guts.c | 12 1 file changed, 4 insertions(+), 8 deletions(-) diff --git

[PATCH v2 7/7] soc: fsl: guts: add serial_number support

2022-02-09 Thread Michael Walle
Most layerscapes provide a security fuse processor where the vendor will store a unique id per part. Unfortunately, we cannot use the corresponding efuse driver because this driver needs to be ready early during the boot phase. To get the unique identifier, we just need to access two registers.

[PATCH v2 1/7] soc: fsl: guts: machine variable might be unset

2022-02-09 Thread Michael Walle
If both the model and the compatible properties are missing, then machine will not be set. Initialize it with NULL. Fixes: 34c1c21e94ac ("soc: fsl: fix section mismatch build warnings") Signed-off-by: Michael Walle --- drivers/soc/fsl/guts.c | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-)

[PATCH v2 4/7] soc: fsl: guts: allocate soc_dev_attr on the heap

2022-02-09 Thread Michael Walle
This is the last global static variable. Drop it and allocate the memory on the heap instead. Signed-off-by: Michael Walle --- drivers/soc/fsl/guts.c | 36 +++- 1 file changed, 19 insertions(+), 17 deletions(-) diff --git a/drivers/soc/fsl/guts.c

[PATCH v2 0/7] soc: fsl: guts: cleanups and serial_number support

2022-02-09 Thread Michael Walle
This series converts the guts driver from a platform driver to just an core_initcall. The driver itself cannot (or rather should never) be unloaded because others depends on detecting the current SoC revision to apply chip errata. Other SoC drivers do it the same way. Overall I got rid of all the

[PATCH v2 2/7] soc: fsl: guts: remove module_exit() and fsl_guts_remove()

2022-02-09 Thread Michael Walle
This driver will never be unloaded. Firstly, it is not available as a module, but more importantly, other drivers will depend on this one to apply possible chip errata. Signed-off-by: Michael Walle --- drivers/soc/fsl/guts.c | 15 +-- 1 file changed, 1 insertion(+), 14 deletions(-)

[PATCH v2 3/7] soc: fsl: guts: embed fsl_guts_get_svr() in probe()

2022-02-09 Thread Michael Walle
Move the reading of the SVR into the probe function as fsl_guts_get_svr() is the only user of the static guts variable and this lets us drop that as well as the malloc() for this variable. Also, we can unmap the memory region after we accessed it, which will simplify error handling later.

[PATCH] selftest/vm: Use correct PAGE_SHIFT value for ppc64

2022-02-09 Thread Aneesh Kumar K.V
Keep it simple by using a #define and limiting hugepage size to 2M. This keeps the test simpler instead of dynamically finding the page size and huge page size. Without this tests are broken w.r.t reading /proc/self/pagemap if (pread(pagemap_fd, ent, sizeof(ent),

Re: [PATCH v2 0/5] Allocate module text and data separately

2022-02-09 Thread Miroslav Benes
On Thu, 27 Jan 2022, Christophe Leroy wrote: > This series allow architectures to request having modules data in > vmalloc area instead of module area. > > This is required on powerpc book3s/32 in order to set data non > executable, because it is not possible to set executability on page >

RE: [PATCH v2 1/2] lib/raid6/test/Makefile: Use `$(pound)` instead of `\#` for Make 4.3

2022-02-09 Thread David Laight
From: David T-G > Sent: 09 February 2022 13:42 > > ...and then Wols Lists said... > % > % On 08/02/2022 15:21, Paul Menzel wrote: > ... > % > % As commented elsewhere, for the sake of us ENGLISH speakers, > % *PLEASE* make that $(hash). A pound sign is £. > > Or, even better, $(octothorpe) since

Re: [PATCH v2 1/2] lib/raid6/test/Makefile: Use `$(pound)` instead of `\#` for Make 4.3

2022-02-09 Thread David T-G
Paul, et al -- ...and then Wols Lists said... % % On 08/02/2022 15:21, Paul Menzel wrote: ... % % As commented elsewhere, for the sake of us ENGLISH speakers, % *PLEASE* make that $(hash). A pound sign is £. Or, even better, $(octothorpe) since that's merely a symbol rather than a food product

Re: [PATCH v5 2/6] powerpc/kexec_file: Add KEXEC_SIG support.

2022-02-09 Thread Michal Suchánek
Hello, On Wed, Feb 09, 2022 at 07:44:15AM +0100, Paul Menzel wrote: > Dear Michal, > > > Thank you for the patch. > > > Am 11.01.22 um 12:37 schrieb Michal Suchanek: > > Could you please remove the dot/period at the end of the git commit message > summary? Sure > > Copy the code from s390x

Re: [PATCH] ocxl: Make use of the helper macro LIST_HEAD()

2022-02-09 Thread Frederic Barrat
On 09/02/2022 04:24, Cai Huoqing wrote: Replace "struct list_head head = LIST_HEAD_INIT(head)" with "LIST_HEAD(head)" to simplify the code. Signed-off-by: Cai Huoqing --- Thanks! Acked-by: Frederic Barrat drivers/misc/ocxl/link.c | 2 +- 1 file changed, 1 insertion(+), 1

Re: [RFC PATCH 2/2] pseries: define sysfs interface to expose PKS variables

2022-02-09 Thread Dov Murik
Hi Nayna, On 22/01/2022 2:56, Nayna Jain wrote: > PowerVM guest secure boot intend to use Platform Keystore(PKS) for the > purpose of storing public keys to verify digital signature. > > Define sysfs interface to expose PKS variables to userspace to allow > read/write/add/delete operations.

[PATCH] powerpc: delete redundant conversion

2022-02-09 Thread Qing Wang
From: Wang Qing do_div() does a 64-by-32 division No need to transform gpt->ipb_freq to u64 Signed-off-by: Wang Qing --- arch/powerpc/platforms/52xx/mpc52xx_gpt.c | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-) diff --git a/arch/powerpc/platforms/52xx/mpc52xx_gpt.c