[PATCH] powerpc/sched: Cleanup vcpu_is_preempted()

2023-11-13 Thread Aneesh Kumar K.V
No functional change in this patch. A helper is added to find if vcpu is dispatched by hypervisor. Use that instead of opencoding. Also clarify some of the comments. Signed-off-by: Aneesh Kumar K.V --- arch/powerpc/include/asm/paravirt.h | 33 ++--- 1 file changed, 25

[PATCH v2] powerpc/book3s/hash: Drop _PAGE_PRIVILEGED from PAGE_NONE

2023-11-13 Thread Aneesh Kumar K.V
There used to be a dependency on _PAGE_PRIVILEGED with pte_savedwrite. But that got dropped by commit 6a56ccbcf6c6 ("mm/autonuma: use can_change_(pte|pmd)_writable() to replace savedwrite") With the change in this patch numa fault pte (pte_protnone()) gets mapped as regular user pte with RWX

RE: [PATCH 3/3] PCI: dwc: Add dw_pcie_ep_{read,write}_dbi[2] helpers

2023-11-13 Thread Yoshihiro Shimoda
Hello Serge, > From: Serge Semin, Sent: Monday, November 13, 2023 9:41 PM > > On Mon, Nov 13, 2023 at 10:33:00AM +0900, Yoshihiro Shimoda wrote: > > The current code calculated some dbi[2] registers' offset by calling > > dw_pcie_ep_get_dbi[2]_offset() in each function. To improve code > >

RE: [PATCH 0/3] PCI: dwc: Improve code readability

2023-11-13 Thread Yoshihiro Shimoda
Hello, > From: Krzysztof Wilczyński, Sent: Monday, November 13, 2023 9:22 PM > > [...] > > > > Now, while you are looking at things, can you also take care about the > > > > following: > > > > > > > > drivers/pci/controller/dwc/pcie-rcar-gen4.c:439:15: warning: cast to > > > > smaller

Fail to boot KCSAN-enabled kernel (Kernel panic - not syncing: Fatal exception, Unrecoverable FP Unavailable Exception 800 at c0000000022cafe0) on a PowerMac G5, kernel 6.6.1

2023-11-13 Thread Erhard Furtner
Greetings! Both my PowerMac G5 and my Talos II (running a BE kernel+system) fail to boot a KCSAN-enabled kernel. Same kernel without KSCAN enabled boots just fine. I tried to dig a little deeper with a stripped down .config on the G5 with CONFIG_KCSAN=y, CONFIG_KCSAN_STRICT=y and finally got

Re: [RFC PATCH] powerpc/book3s/hash: Drop _PAGE_PRIVILEGED from PAGE_NONE

2023-11-13 Thread Aneesh Kumar K V
On 11/13/23 5:17 PM, Nicholas Piggin wrote: > On Mon Nov 13, 2023 at 8:45 PM AEST, Aneesh Kumar K V wrote: diff --git a/arch/powerpc/mm/book3s64/hash_utils.c b/arch/powerpc/mm/book3s64/hash_utils.c index ad2afa08e62e..b2eda22195f0 100644 ---

Re: [PATCH v3 00/10] powerpc/pseries: New character devices for system parameters and VPD

2023-11-13 Thread Nathan Lynch
Michal Suchánek writes: > What's the status here? > > Can this move on with the 4th patch skipped, or is new revision > expected? I would like to get some feedback on the idea for coarse per-function locking in patch #2 "Facilitate high-level call sequences" since that is a core change to the

Re: [PATCH 0/3] PCI: dwc: Improve code readability

2023-11-13 Thread Krzysztof Wilczyński
Hello, [...] > > > I confirmed that the uintptr_t fixed the issue. > > > > We declined a similar fix in the past[1] ... > > > > > I also think that adding a new struct with the mode is overkill. > > > > ... with the hopes that a driver could drop the switch statements in place > > of using the

Re: Fbdev issue after the drm updates 'drm-next-2023-10-31-1'

2023-11-13 Thread Christian Zigotzky
On 13 November 2023 at 01:48 pm, Geert Uytterhoeven wrote: Hi Christian, On Sun, Nov 12, 2023 at 3:23 PM Christian Zigotzky wrote: On 07 November 2023 at 09:36 am, Christian Zigotzky wrote: I have found out that fbdev no longer works with virtio-gpu-pci and virtio-vga. It is not a problem

Re: [PATCH 0/3] PCI: dwc: Improve code readability

2023-11-13 Thread Geert Uytterhoeven
Hi Krzysztof, On Mon, Nov 13, 2023 at 1:22 PM Krzysztof Wilczyński wrote: > > > > Now, while you are looking at things, can you also take care about the > > > > following: > > > > > > > > drivers/pci/controller/dwc/pcie-rcar-gen4.c:439:15: warning: cast to > > > > smaller integer type 'enum

Re: [PATCH v9 10/15] media: uapi: Add V4L2_CTRL_TYPE_FIXED_POINT

2023-11-13 Thread Laurent Pinchart
Hi Hans, On Mon, Nov 13, 2023 at 01:05:12PM +0100, Hans Verkuil wrote: > On 13/11/2023 12:43, Laurent Pinchart wrote: > > On Mon, Nov 13, 2023 at 11:28:51AM +, Sakari Ailus wrote: > >> On Mon, Nov 13, 2023 at 12:24:14PM +0100, Hans Verkuil wrote: > >>> On 13/11/2023 12:07, Laurent Pinchart

Re: Fbdev issue after the drm updates 'drm-next-2023-10-31-1'

2023-11-13 Thread Geert Uytterhoeven
Hi Christian, On Sun, Nov 12, 2023 at 3:23 PM Christian Zigotzky wrote: > On 07 November 2023 at 09:36 am, Christian Zigotzky wrote: > > I have found out that fbdev no longer works with virtio-gpu-pci and > > virtio-vga. It is not a problem with the penguin logos. > > > > Could you please check

Re: [PATCH 3/3] PCI: dwc: Add dw_pcie_ep_{read,write}_dbi[2] helpers

2023-11-13 Thread Serge Semin
On Mon, Nov 13, 2023 at 10:33:00AM +0900, Yoshihiro Shimoda wrote: > The current code calculated some dbi[2] registers' offset by calling > dw_pcie_ep_get_dbi[2]_offset() in each function. To improve code > readability, add dw_pcie_ep_{read,write}_dbi[2} and some data-width > related helpers.

Re: [PATCH 0/3] PCI: dwc: Improve code readability

2023-11-13 Thread Krzysztof Wilczyński
Hello, [...] > > > Now, while you are looking at things, can you also take care about the > > > following: > > > > > > drivers/pci/controller/dwc/pcie-rcar-gen4.c:439:15: warning: cast to > > > smaller integer type 'enum dw_pcie_device_mode' > > from 'const void *'

Re: [PATCH v14 00/34] KVM: guest_memfd() and per-page attributes

2023-11-13 Thread Paolo Bonzini
On 11/5/23 17:30, Paolo Bonzini wrote: The "development cycle" for this version is going to be very short; ideally, next week I will merge it as is in kvm/next, taking this through the KVM tree for 6.8 immediately after the end of the merge window. The series is still based on 6.6 (plus KVM

Re: [PATCH v9 10/15] media: uapi: Add V4L2_CTRL_TYPE_FIXED_POINT

2023-11-13 Thread Hans Verkuil
On 13/11/2023 12:43, Laurent Pinchart wrote: > On Mon, Nov 13, 2023 at 11:28:51AM +, Sakari Ailus wrote: >> Hi Hans, >> >> On Mon, Nov 13, 2023 at 12:24:14PM +0100, Hans Verkuil wrote: >>> On 13/11/2023 12:07, Laurent Pinchart wrote: On Mon, Nov 13, 2023 at 11:56:49AM +0100, Hans Verkuil

RE: [PATCH 1/3] PCI: dwc: Rename to .init in struct dw_pcie_ep_ops

2023-11-13 Thread Yoshihiro Shimoda
Hi Serge, > From: Serge Semin, Sent: Monday, November 13, 2023 7:15 PM > > Hi Yoshihiro. > > On Mon, Nov 13, 2023 at 10:32:58AM +0900, Yoshihiro Shimoda wrote: > > Since the name of dw_pcie_ep_ops indicates that it's for ep obviously, > > rename a member .ep_init to .init. > > Thanks for the

Re: [RFC PATCH] powerpc/book3s/hash: Drop _PAGE_PRIVILEGED from PAGE_NONE

2023-11-13 Thread Nicholas Piggin
On Mon Nov 13, 2023 at 8:45 PM AEST, Aneesh Kumar K V wrote: > On 11/13/23 3:46 PM, Nicholas Piggin wrote: > > On Thu Nov 2, 2023 at 11:23 PM AEST, Aneesh Kumar K.V wrote: > >> There used to be a dependency on _PAGE_PRIVILEGED with pte_savedwrite. > >> But that got dropped by > >> commit

RE: [PATCH 0/3] PCI: dwc: Improve code readability

2023-11-13 Thread Yoshihiro Shimoda
Hi Krzysztof-san, Geert-san, > From: Geert Uytterhoeven, Sent: Monday, November 13, 2023 8:07 PM > > Hi Krzysztof, > > On Mon, Nov 13, 2023 at 11:09 AM Krzysztof Wilczyński wrote: > > > This patch series is based on the latest pci.git / next branch. > > [...] > > > > Thank you for following up

Re: [PATCH v9 10/15] media: uapi: Add V4L2_CTRL_TYPE_FIXED_POINT

2023-11-13 Thread Laurent Pinchart
On Mon, Nov 13, 2023 at 11:28:51AM +, Sakari Ailus wrote: > Hi Hans, > > On Mon, Nov 13, 2023 at 12:24:14PM +0100, Hans Verkuil wrote: > > On 13/11/2023 12:07, Laurent Pinchart wrote: > > > On Mon, Nov 13, 2023 at 11:56:49AM +0100, Hans Verkuil wrote: > > >> On 13/11/2023 11:42, Laurent

Re: [PATCH v9 10/15] media: uapi: Add V4L2_CTRL_TYPE_FIXED_POINT

2023-11-13 Thread Sakari Ailus
Hi Hans, On Mon, Nov 13, 2023 at 12:24:14PM +0100, Hans Verkuil wrote: > On 13/11/2023 12:07, Laurent Pinchart wrote: > > On Mon, Nov 13, 2023 at 11:56:49AM +0100, Hans Verkuil wrote: > >> On 13/11/2023 11:42, Laurent Pinchart wrote: > >>> On Mon, Nov 13, 2023 at 11:29:09AM +0100, Hans Verkuil

Re: [PATCH v9 10/15] media: uapi: Add V4L2_CTRL_TYPE_FIXED_POINT

2023-11-13 Thread Hans Verkuil
On 13/11/2023 12:07, Laurent Pinchart wrote: > On Mon, Nov 13, 2023 at 11:56:49AM +0100, Hans Verkuil wrote: >> On 13/11/2023 11:42, Laurent Pinchart wrote: >>> On Mon, Nov 13, 2023 at 11:29:09AM +0100, Hans Verkuil wrote: Hi Shengjiu, On 10/11/2023 06:48, Shengjiu Wang wrote: >

Re: [PATCH v9 10/15] media: uapi: Add V4L2_CTRL_TYPE_FIXED_POINT

2023-11-13 Thread Laurent Pinchart
On Mon, Nov 13, 2023 at 11:56:49AM +0100, Hans Verkuil wrote: > On 13/11/2023 11:42, Laurent Pinchart wrote: > > On Mon, Nov 13, 2023 at 11:29:09AM +0100, Hans Verkuil wrote: > >> Hi Shengjiu, > >> > >> On 10/11/2023 06:48, Shengjiu Wang wrote: > >>> Fixed point controls are used by the user to

Re: [PATCH 0/3] PCI: dwc: Improve code readability

2023-11-13 Thread Geert Uytterhoeven
Hi Krzysztof, On Mon, Nov 13, 2023 at 11:09 AM Krzysztof Wilczyński wrote: > > This patch series is based on the latest pci.git / next branch. > [...] > > Thank you for following up to tidy things up! Much appreciated. > > Now, while you are looking at things, can you also take care about the

Re: [PATCH v9 10/15] media: uapi: Add V4L2_CTRL_TYPE_FIXED_POINT

2023-11-13 Thread Hans Verkuil
On 13/11/2023 11:42, Laurent Pinchart wrote: > On Mon, Nov 13, 2023 at 11:29:09AM +0100, Hans Verkuil wrote: >> Hi Shengjiu, >> >> On 10/11/2023 06:48, Shengjiu Wang wrote: >>> Fixed point controls are used by the user to configure >>> a fixed point value in 64bits, which Q31.32 format. >>> >>>

Re: [PATCH v9 10/15] media: uapi: Add V4L2_CTRL_TYPE_FIXED_POINT

2023-11-13 Thread Laurent Pinchart
On Mon, Nov 13, 2023 at 11:29:09AM +0100, Hans Verkuil wrote: > Hi Shengjiu, > > On 10/11/2023 06:48, Shengjiu Wang wrote: > > Fixed point controls are used by the user to configure > > a fixed point value in 64bits, which Q31.32 format. > > > > Signed-off-by: Shengjiu Wang > > This patch adds

Re: [RFC PATCH] powerpc/book3s/hash: Drop _PAGE_PRIVILEGED from PAGE_NONE

2023-11-13 Thread Aneesh Kumar K V
On 11/13/23 3:46 PM, Nicholas Piggin wrote: > On Thu Nov 2, 2023 at 11:23 PM AEST, Aneesh Kumar K.V wrote: >> There used to be a dependency on _PAGE_PRIVILEGED with pte_savedwrite. >> But that got dropped by >> commit 6a56ccbcf6c6 ("mm/autonuma: use can_change_(pte|pmd)_writable() to >> replace

Re: [PATCH 2/3] PCI: dwc: Rename to .get_dbi_offset in struct dw_pcie_ep_ops

2023-11-13 Thread Serge Semin
On Mon, Nov 13, 2023 at 10:32:59AM +0900, Yoshihiro Shimoda wrote: > Since meaning of .func_conf_select is difficult to understand, > rename it to .get_dbi_offset. This change looks good. Thanks. Reviewed-by: Serge Semin There are redundant initializers will have been left after this patch is

Re: [PATCH v9 10/15] media: uapi: Add V4L2_CTRL_TYPE_FIXED_POINT

2023-11-13 Thread Hans Verkuil
Hi Shengjiu, On 10/11/2023 06:48, Shengjiu Wang wrote: > Fixed point controls are used by the user to configure > a fixed point value in 64bits, which Q31.32 format. > > Signed-off-by: Shengjiu Wang This patch adds a new control type. This is something that also needs to be tested by

Re: [PATCH 1/2] tty: hvc: Make hvc_remove() return no value

2023-11-13 Thread Nicholas Piggin
On Mon Nov 13, 2023 at 7:57 PM AEST, Uwe Kleine-König wrote: > On Mon, Nov 13, 2023 at 07:45:27PM +1000, Nicholas Piggin wrote: > > On Mon Nov 6, 2023 at 7:44 AM AEST, Uwe Kleine-König wrote: > > > The function hvc_remove() returns zero unconditionally. Make it return > > > void instead to make it

Re: [PATCH v2 29/37] powerpc/nohash: Replace pte_user() by pte_read()

2023-11-13 Thread Aneesh Kumar K.V
Christophe Leroy writes: > Le 07/11/2023 à 14:34, Aneesh Kumar K.V a écrit : >> Christophe Leroy writes: >> >>> Le 31/10/2023 à 11:15, Aneesh Kumar K.V a écrit : Christophe Leroy writes: >> >> >> We are adding the pte flags check not the map addr check there. Something >> like

Re: [RFC PATCH] powerpc/book3s/hash: Drop _PAGE_PRIVILEGED from PAGE_NONE

2023-11-13 Thread Nicholas Piggin
On Thu Nov 2, 2023 at 11:23 PM AEST, Aneesh Kumar K.V wrote: > There used to be a dependency on _PAGE_PRIVILEGED with pte_savedwrite. > But that got dropped by > commit 6a56ccbcf6c6 ("mm/autonuma: use can_change_(pte|pmd)_writable() to > replace savedwrite") > > With this change numa fault pte

Re: [PATCH 1/3] PCI: dwc: Rename to .init in struct dw_pcie_ep_ops

2023-11-13 Thread Serge Semin
Hi Yoshihiro. On Mon, Nov 13, 2023 at 10:32:58AM +0900, Yoshihiro Shimoda wrote: > Since the name of dw_pcie_ep_ops indicates that it's for ep obviously, > rename a member .ep_init to .init. Thanks for the series. This change particularly looks good. But since you are fixing the redundant

Re: Build regressions/improvements in v6.7-rc1

2023-11-13 Thread Geert Uytterhoeven
On Mon, 13 Nov 2023, Geert Uytterhoeven wrote: Below is the list of build error/warning regressions/improvements in v6.7-rc1[1] compared to v6.6[2]. Summarized: - build errors: +20/-7 - build warnings: +24/-8 Note that there may be false regressions, as some logs are incomplete. Still,

Re: [PATCH 0/3] PCI: dwc: Improve code readability

2023-11-13 Thread Krzysztof Wilczyński
Hi Yoshihiro! > This patch series is based on the latest pci.git / next branch. [...] Thank you for following up to tidy things up! Much appreciated. Now, while you are looking at things, can you also take care about the following: drivers/pci/controller/dwc/pcie-rcar-gen4.c:439:15:

Re: [PATCH 1/2] tty: hvc: Make hvc_remove() return no value

2023-11-13 Thread Uwe Kleine-König
On Mon, Nov 13, 2023 at 07:45:27PM +1000, Nicholas Piggin wrote: > On Mon Nov 6, 2023 at 7:44 AM AEST, Uwe Kleine-König wrote: > > The function hvc_remove() returns zero unconditionally. Make it return > > void instead to make it obvious that the caller doesn't need to do any > > error handling.

Re: [PATCH v9 07/15] media: v4l2: Add audio capture and output support

2023-11-13 Thread Hans Verkuil
Hi Shengjiu, On 10/11/2023 06:48, Shengjiu Wang wrote: > Audio signal processing has the requirement for memory to > memory similar as Video. > > This patch is to add this support in v4l2 framework, defined > new buffer type V4L2_BUF_TYPE_AUDIO_CAPTURE and > V4L2_BUF_TYPE_AUDIO_OUTPUT, defined

Re: [PATCH 2/2] tty: hvc: hvc_opal: Convert to platform remove callback returning void

2023-11-13 Thread Nicholas Piggin
On Mon Nov 6, 2023 at 7:44 AM AEST, Uwe Kleine-König wrote: > The .remove() callback for a platform driver returns an int which makes > many driver authors wrongly assume it's possible to do error handling by > returning an error code. However the value returned is ignored (apart > from emitting a

Re: [PATCH 1/2] tty: hvc: Make hvc_remove() return no value

2023-11-13 Thread Nicholas Piggin
On Mon Nov 6, 2023 at 7:44 AM AEST, Uwe Kleine-König wrote: > The function hvc_remove() returns zero unconditionally. Make it return > void instead to make it obvious that the caller doesn't need to do any > error handling. Accordingly drop the error handling from > hvc_opal_remove(). > >

Re: (subset) [PATCH v5 0/5] ppc, fbdev: Clean up fbdev mmap helper

2023-11-13 Thread Thomas Zimmermann
Am 13.11.23 um 03:45 schrieb Michael Ellerman: On Fri, 22 Sep 2023 10:04:54 +0200, Thomas Zimmermann wrote: Clean up and rename fb_pgprotect() to work without struct file. Then refactor the implementation for PowerPC. This change has been discussed at [1] in the context of refactoring fbdev's

Re: [PATCH v3 00/10] powerpc/pseries: New character devices for system parameters and VPD

2023-11-13 Thread Michal Suchánek
Hello, On Thu, Oct 26, 2023 at 06:56:36PM -0500, Nathan Lynch wrote: > Nathan Lynch via B4 Relay > writes: > > I have made changes to librtas to prefer the new interfaces and > > verified that existing clients work correctly with the new code. > > Unfortunately I made a mistake in testing this