Re: [RFC PATCH 1/3] powerpc/pseries/iommu: Bring back userspace view for single level TCE tables

2024-03-21 Thread Michael Ellerman
Jason Gunthorpe writes: > On Tue, Mar 12, 2024 at 01:14:20PM -0500, Shivaprasad G Bhat wrote: >> The commit 090bad39b237a ("powerpc/powernv: Add indirect levels to >> it_userspace") which implemented the tce indirect levels >> support for PowerNV ended up removing the single level support >>

Re: [PATCH 5/5] dt-bindings: hwmon: ibm,p8-occ-hwmon: move to trivial devices

2024-03-21 Thread Rob Herring
On Thu, 21 Mar 2024 19:43:46 +0100, Javier Carrasco wrote: > This binding meets the requirements to be converted to dtschema > via trivial-devices.yaml. > > Signed-off-by: Javier Carrasco > --- > .../devicetree/bindings/hwmon/ibm,p8-occ-hwmon.txt | 25 > -- >

Re: [PATCH 3/5] dt-bindings: hwmon: pwm-fan: drop text file

2024-03-21 Thread Rob Herring
On Thu, 21 Mar 2024 19:43:44 +0100, Javier Carrasco wrote: > This binding was converted to dtschema a year ago. > > Signed-off-by: Javier Carrasco > --- > Documentation/devicetree/bindings/hwmon/pwm-fan.txt | 1 - > 1 file changed, 1 deletion(-) > Acked-by: Rob Herring

Re: [PATCH 1/5] dt-bindings: hwmon: as370: convert to dtschema

2024-03-21 Thread Rob Herring
On Thu, 21 Mar 2024 19:43:42 +0100, Javier Carrasco wrote: > Convert existing binding to support validation. > > This is a straightforward conversion with now new properties. > > Signed-off-by: Javier Carrasco > --- > Documentation/devicetree/bindings/hwmon/as370.txt | 11 >

[PATCH v3 12/12] mm/gup: Handle hugetlb in the generic follow_page_mask code

2024-03-21 Thread peterx
From: Peter Xu Now follow_page() is ready to handle hugetlb pages in whatever form, and over all architectures. Switch to the generic code path. Time to retire hugetlb_follow_page_mask(), following the previous retirement of follow_hugetlb_page() in 4849807114b8. There may be a slight

[PATCH v3 11/12] mm/gup: Handle hugepd for follow_page()

2024-03-21 Thread peterx
From: Peter Xu Hugepd is only used in PowerPC so far on 4K page size kernels where hash mmu is used. follow_page_mask() used to leverage hugetlb APIs to access hugepd entries. Teach follow_page_mask() itself on hugepd. With previous refactors on fast-gup gup_huge_pd(), most of the code can be

[PATCH v3 10/12] mm/gup: Handle huge pmd for follow_pmd_mask()

2024-03-21 Thread peterx
From: Peter Xu Replace pmd_trans_huge() with pmd_leaf() to also cover pmd_huge() as long as enabled. FOLL_TOUCH and FOLL_SPLIT_PMD only apply to THP, not yet huge. Since now follow_trans_huge_pmd() can process hugetlb pages, renaming it into follow_huge_pmd() to match what it does. Move it

[PATCH v3 08/12] mm/gup: Cache *pudp in follow_pud_mask()

2024-03-21 Thread peterx
From: Peter Xu Introduce "pud_t pud" in the function, so the code won't dereference *pudp multiple time. Not only because that looks less straightforward, but also because if the dereference really happened, it's not clear whether there can be race to see different *pudp values if it's being

[PATCH v3 09/12] mm/gup: Handle huge pud for follow_pud_mask()

2024-03-21 Thread peterx
From: Peter Xu Teach follow_pud_mask() to be able to handle normal PUD pages like hugetlb. Rename follow_devmap_pud() to follow_huge_pud() so that it can process either huge devmap or hugetlb. Move it out of TRANSPARENT_HUGEPAGE_PUD and and huge_memory.c (which relies on CONFIG_THP). Switch to

[PATCH v3 07/12] mm/gup: Handle hugetlb for no_page_table()

2024-03-21 Thread peterx
From: Peter Xu no_page_table() is not yet used for hugetlb code paths. Make it prepared. The major difference here is hugetlb will return -EFAULT as long as page cache does not exist, even if VM_SHARED. See hugetlb_follow_page_mask(). Pass "address" into no_page_table() too, as hugetlb will

[PATCH v3 06/12] mm/gup: Refactor record_subpages() to find 1st small page

2024-03-21 Thread peterx
From: Peter Xu All the fast-gup functions take a tail page to operate, always need to do page mask calculations before feeding that into record_subpages(). Merge that logic into record_subpages(), so that it will do the nth_page() calculation. Reviewed-by: Jason Gunthorpe Signed-off-by: Peter

[PATCH v3 05/12] mm/gup: Drop folio_fast_pin_allowed() in hugepd processing

2024-03-21 Thread peterx
From: Peter Xu Hugepd format for GUP is only used in PowerPC with hugetlbfs. There are some kernel usage of hugepd (can refer to hugepd_populate_kernel() for PPC_8XX), however those pages are not candidates for GUP. Commit a6e79df92e4a ("mm/gup: disallow FOLL_LONGTERM GUP-fast writing to

[PATCH v3 04/12] mm: Introduce vma_pgtable_walk_{begin|end}()

2024-03-21 Thread peterx
From: Peter Xu Introduce per-vma begin()/end() helpers for pgtable walks. This is a preparation work to merge hugetlb pgtable walkers with generic mm. The helpers need to be called before and after a pgtable walk, will start to be needed if the pgtable walker code supports hugetlb pages. It's

[PATCH v3 02/12] mm/hugetlb: Declare hugetlbfs_pagecache_present() non-static

2024-03-21 Thread peterx
From: Peter Xu It will be used outside hugetlb.c soon. Signed-off-by: Peter Xu --- include/linux/hugetlb.h | 9 + mm/hugetlb.c| 4 ++-- 2 files changed, 11 insertions(+), 2 deletions(-) diff --git a/include/linux/hugetlb.h b/include/linux/hugetlb.h index

[PATCH v3 03/12] mm: Make HPAGE_PXD_* macros even if !THP

2024-03-21 Thread peterx
From: Peter Xu These macros can be helpful when we plan to merge hugetlb code into generic code. Move them out and define them even if !THP. We actually already defined HPAGE_PMD_NR for other reasons even if !THP. Reorganize these macros. Reviewed-by: Christoph Hellwig Reviewed-by: Jason

[PATCH v3 01/12] mm/Kconfig: CONFIG_PGTABLE_HAS_HUGE_LEAVES

2024-03-21 Thread peterx
From: Peter Xu Introduce a config option that will be selected as long as huge leaves are involved in pgtable (thp or hugetlbfs). It would be useful to mark any code with this new config that can process either hugetlb or thp pages in any level that is higher than pte level. Reviewed-by: Jason

[PATCH v3 00/12] mm/gup: Unify hugetlb, part 2

2024-03-21 Thread peterx
From: Peter Xu v3: - Rebased to latest mm-unstalbe (a824831a082f, of March 21th) - Dropped patch to introduce pmd_thp_or_huge(), replace such uses (and also pXd_huge() users) with pXd_leaf() [Jason] - Add a comment for CONFIG_PGTABLE_HAS_HUGE_LEAVES [Jason] - Use IS_ENABLED() in

Re: [PATCH 2/5] dt-bindings: hwmon: ibmpowernv: convert to dtschema

2024-03-21 Thread Javier Carrasco
chema with compatible: ['st,stts751'] > Obvious mistake, this compatible belongs to another patch of the series. Will be fixed for v2. > doc reference errors (make refcheckdocs): > > See > https://patchwork.ozlabs.org/project/devicetree-bindings/patch/20240321-hwmon_dtschema-v1-2-96c3810

[PATCH 5/5] dt-bindings: hwmon: ibm,p8-occ-hwmon: move to trivial devices

2024-03-21 Thread Javier Carrasco
This binding meets the requirements to be converted to dtschema via trivial-devices.yaml. Signed-off-by: Javier Carrasco --- .../devicetree/bindings/hwmon/ibm,p8-occ-hwmon.txt | 25 -- .../devicetree/bindings/trivial-devices.yaml | 2 ++ 2 files changed, 2

[PATCH 4/5] dt-bindings: hwmon: stts751: convert to dtschema

2024-03-21 Thread Javier Carrasco
Convert existing binding to support validation. This is a straightforward conversion with no new properties. Signed-off-by: Javier Carrasco --- .../devicetree/bindings/hwmon/st,stts751.yaml | 41 ++ .../devicetree/bindings/hwmon/stts751.txt | 15 2

[PATCH 3/5] dt-bindings: hwmon: pwm-fan: drop text file

2024-03-21 Thread Javier Carrasco
This binding was converted to dtschema a year ago. Signed-off-by: Javier Carrasco --- Documentation/devicetree/bindings/hwmon/pwm-fan.txt | 1 - 1 file changed, 1 deletion(-) diff --git a/Documentation/devicetree/bindings/hwmon/pwm-fan.txt b/Documentation/devicetree/bindings/hwmon/pwm-fan.txt

[PATCH 0/5] dt-bindings: hwmon: convert multiple devices to dtschema

2024-03-21 Thread Javier Carrasco
This series converts the following existing bindings to dtschema: - as370 - ibmpowernv - stts751 - ibm,p8-occ-hwmon (moved to trivial-devices.yaml) Additionally, pwm-fan.txt has been dropped because it was converted a year ago, and it is not mentioned anywhere in the tree. I could not find the

[PATCH 1/5] dt-bindings: hwmon: as370: convert to dtschema

2024-03-21 Thread Javier Carrasco
Convert existing binding to support validation. This is a straightforward conversion with now new properties. Signed-off-by: Javier Carrasco --- Documentation/devicetree/bindings/hwmon/as370.txt | 11 .../devicetree/bindings/hwmon/syna,as370.yaml | 32 ++ 2

[PATCH 2/5] dt-bindings: hwmon: ibmpowernv: convert to dtschema

2024-03-21 Thread Javier Carrasco
Convert existing binding to support validation. This is a straightforward conversion with now new properties. Signed-off-by: Javier Carrasco --- .../devicetree/bindings/hwmon/ibm,powernv.yaml | 37 ++ .../devicetree/bindings/hwmon/ibmpowernv.txt | 23

Re: [PATCH 4/5] dt-bindings: hwmon: stts751: convert to dtschema

2024-03-21 Thread Rob Herring
project/devicetree-bindings/patch/20240321-hwmon_dtschema-v1-4-96c3810c3...@gmail.com The base for the series is generally the latest rc1. A different dependency should be noted in *this* patch. If you already ran 'make dt_binding_check' and didn't see the above error(s), then make sure 'yamllint'

Re: [PATCH 2/5] dt-bindings: hwmon: ibmpowernv: convert to dtschema

2024-03-21 Thread Rob Herring
mllint warnings/errors: dtschema/dtc warnings/errors: Documentation/devicetree/bindings/hwmon/ibm,powernv.example.dtb: /example-0/sensor: failed to match any schema with compatible: ['st,stts751'] doc reference errors (make refcheckdocs): See https://patchwork.ozlabs.org/project/devicetree-bindi

Re: Cannot load wireguard module

2024-03-21 Thread Michael Ellerman
Michal Suchánek writes: > On Wed, Mar 20, 2024 at 11:41:32PM +1100, Michael Ellerman wrote: >> Michal Suchánek writes: >> > On Mon, Mar 18, 2024 at 06:08:55PM +0100, Michal Suchánek wrote: >> >> On Mon, Mar 18, 2024 at 10:50:49PM +1100, Michael Ellerman wrote: >> >> > Michael Ellerman writes:

Re: [PATCH] vdso: use CONFIG_PAGE_SHIFT in vdso/datapage.h

2024-03-21 Thread Michael Ellerman
Arnd Bergmann writes: > From: Arnd Bergmann > > Both the vdso rework and the CONFIG_PAGE_SHIFT changes were merged during > the v6.9 merge window, so it is now possible to use CONFIG_PAGE_SHIFT > instead of including asm/page.h in the vdso. > > This avoids the workaround for arm64 and addresses

Re: [RFC] sched/eevdf: sched feature to dismiss lag on wakeup

2024-03-21 Thread Tobias Huschle
On Wed, Mar 20, 2024 at 02:51:00PM +0100, Vincent Guittot wrote: > On Wed, 20 Mar 2024 at 08:04, Tobias Huschle wrote: > > There was no guarantee of course. place_entity was reducing the vruntime of > > woken up tasks though, giving it a slight boost, right?. For the scenario > > It was rather

Re: [PATCH] powerpc: ps3: mark ps3_notification_device static for stack usage

2024-03-21 Thread Geoff Levand
Hi Geert, On 3/21/24 17:32, Geert Uytterhoeven wrote: >> static int ps3_probe_thread(void *data) >> { >> - struct ps3_notification_device dev; >> + static struct ps3_notification_device dev; >> int res; >> unsigned int irq; >> u64 lpar; > > Making it static

Re: [PATCH] powerpc: ps3: mark ps3_notification_device static for stack usage

2024-03-21 Thread Geert Uytterhoeven
Hi Arnd, On Wed, Mar 20, 2024 at 7:03 PM Arnd Bergmann wrote: > From: Arnd Bergmann > > The device is way too large to be on the stack, causing a warning for > an allmodconfig build with clang: > > arch/powerpc/platforms/ps3/device-init.c:771:12: error: stack frame size > (2064) exceeds limit