Re: [PATCH 7/8] powerpc/5200: Refactor mpc5200 interrupt controller driver

2009-01-29 Thread Wolfram Sang
On Wed, Jan 21, 2009 at 01:55:41PM -0700, Grant Likely wrote: From: Grant Likely grant.lik...@secretlab.ca Rework the mpc5200-pic driver to simplify it and fix up the setting of desc-status when set_type is called for internal IRQs (so they are reported as level, not edge). The

Re: [PATCH 7/8] powerpc/5200: Refactor mpc5200 interrupt controller driver

2009-01-27 Thread Matt Sealey
On Wed, Jan 21, 2009 at 2:55 PM, Grant Likely grant.lik...@secretlab.ca wrote: From: Grant Likely grant.lik...@secretlab.ca Rework the mpc5200-pic driver to simplify it and fix up the setting of desc-status when set_type is called for internal IRQs (so they are reported as level, not edge).

Re: [PATCH 7/8] powerpc/5200: Refactor mpc5200 interrupt controller driver

2009-01-27 Thread Grant Likely
On Tue, Jan 27, 2009 at 10:52 AM, Matt Sealey m...@genesi-usa.com wrote: On Wed, Jan 21, 2009 at 2:55 PM, Grant Likely grant.lik...@secretlab.ca wrote: From: Grant Likely grant.lik...@secretlab.ca Rework the mpc5200-pic driver to simplify it and fix up the setting of desc-status when

Re: [PATCH 7/8] powerpc/5200: Refactor mpc5200 interrupt controller driver

2009-01-26 Thread Wolfgang Grandegger
Grant Likely wrote: On Sun, Jan 25, 2009 at 1:06 PM, Wolfgang Grandegger w...@grandegger.com wrote: Grant Likely wrote: From: Grant Likely grant.lik...@secretlab.ca Rework the mpc5200-pic driver to simplify it and fix up the setting of desc-status when set_type is called for internal IRQs

Re: [PATCH 7/8] powerpc/5200: Refactor mpc5200 interrupt controller driver

2009-01-26 Thread Wolfram Sang
Hi Grant, I chose to line them up because in my opinion it is easier to follow the pattern with them written in horizontal columns instead of in vertical blocks. I also think the original coding style is easier to read. Kind regards, Wolfram -- Dipl.-Ing. Wolfram Sang |

Re: [PATCH 7/8] powerpc/5200: Refactor mpc5200 interrupt controller driver

2009-01-26 Thread Matt Sealey
Well, I don't want to debate coding style rules. I also sometimes just shake my head. But this rules I actually find useful because it allows the GDB to point to the line == expression, apart from readability. If you don't stick to the coding style rules, you have to explain to the maintainer

Re: [PATCH 7/8] powerpc/5200: Refactor mpc5200 interrupt controller driver

2009-01-25 Thread Wolfgang Grandegger
Grant Likely wrote: From: Grant Likely grant.lik...@secretlab.ca Rework the mpc5200-pic driver to simplify it and fix up the setting of desc-status when set_type is called for internal IRQs (so they are reported as level, not edge). The simplification is due to splitting off the handling

Re: [PATCH 7/8] powerpc/5200: Refactor mpc5200 interrupt controller driver

2009-01-25 Thread Grant Likely
On Sun, Jan 25, 2009 at 1:06 PM, Wolfgang Grandegger w...@grandegger.com wrote: Grant Likely wrote: From: Grant Likely grant.lik...@secretlab.ca Rework the mpc5200-pic driver to simplify it and fix up the setting of desc-status when set_type is called for internal IRQs (so they are reported

Re: [PATCH 7/8] powerpc/5200: Refactor mpc5200 interrupt controller driver

2009-01-25 Thread Wolfgang Denk
Dear Grant Likely, In message fa686aa40901251622j542b6029u83c510f5b4e2...@mail.gmail.com you wrote: - case IRQF_TRIGGER_HIGH: - type = 0; - break; - case IRQF_TRIGGER_RISING: - type = 1; - break; - case

[PATCH 7/8] powerpc/5200: Refactor mpc5200 interrupt controller driver

2009-01-21 Thread Grant Likely
From: Grant Likely grant.lik...@secretlab.ca Rework the mpc5200-pic driver to simplify it and fix up the setting of desc-status when set_type is called for internal IRQs (so they are reported as level, not edge). The simplification is due to splitting off the handling of external IRQs into a