Re: [Mesa-dev] [PATCH] st/mesa: simplify initialization of light_twoside

2012-01-30 Thread Brian Paul
On 01/27/2012 06:45 PM, Marek Olšák wrote: Core Mesa does this for us, see update_two_size in state.c. --- src/mesa/state_tracker/st_atom_rasterizer.c | 24 +++- 1 files changed, 3 insertions(+), 21 deletions(-) diff --git a/src/mesa/state_tracker/st_atom_rasterizer.c

Re: [Mesa-dev] Help required in configuring mesa 3d in non X environment.

2012-01-30 Thread Matt Turner
On Mon, Jan 30, 2012 at 1:46 AM, Sanjoy Saha - ERS, HCL Tech sanjoy.s...@hcl.com wrote: checking pkg-config files for X11 are available... no checking for X... no configure: error: X11 development libraries needed for GLX I would try --disable-glx on the configure/autogen.sh line.

Re: [Mesa-dev] OSMesa glapi linlking

2012-01-30 Thread Kevin H. Hobbs
On 01/25/2012 05:20 PM, Jon TURNEY wrote: ... and reverting always build shared glapi didn't wrap this line above in ifeq ($(SHARED_GLAPI),1)/endif, since it wasn't there before. Sigh. I guess you could try the attached. $ git apply

Re: [Mesa-dev] [PATCH 1/2] glsl: Rename class variable_entry to ir_variable_refcount_entry.

2012-01-30 Thread Eric Anholt
On Sat, 28 Jan 2012 16:58:37 -0800, Kenneth Graunke kenn...@whitecape.org wrote: Exporting a publicly visible class with a generic name like variable_entry via ir_variable_refcount.h is kind of mean. Many IR transformers would like to define their own variable_entry class. If they

Re: [Mesa-dev] [PATCH] gallium: add PIPE_CAP_QUADS_FOLLOW_PROVOKING_VERTEX_CONVENTION

2012-01-30 Thread Jose Fonseca
Note that unless the draw module is updated to take PIPE_CAP_QUADS_FOLLOW_PROVOKING_VERTEX_CONVENTION == 1 in consideration this change will cause regressions for drivers that fallback to draw module for doing things like clipping, unfilled mode, etc w/ flat shadding. Can this happen in

Re: [Mesa-dev] [PATCH 5/5] src/glsl/glcpp: wire up glcpp-test to make check

2012-01-30 Thread Gaetan Nadon
On 12-01-30 11:53 AM, Gaetan Nadon wrote: On 12-01-30 01:09 AM, Matt Turner wrote: --- src/glsl/glcpp/Makefile.am |2 ++ src/glsl/glcpp/tests/glcpp-test |6 +- 2 files changed, 7 insertions(+), 1 deletions(-) diff --git a/src/glsl/glcpp/Makefile.am

Re: [Mesa-dev] OSMesa glapi linlking

2012-01-30 Thread Brian Paul
On 01/30/2012 08:56 AM, Kevin H. Hobbs wrote: On 01/25/2012 05:20 PM, Jon TURNEY wrote: ... and reverting always build shared glapi didn't wrap this line above in ifeq ($(SHARED_GLAPI),1)/endif, since it wasn't there before. Sigh. I guess you could try the attached. $ git apply

[Mesa-dev] [PATCH 5/6] glsl: Throw an error when faced with a duplicated switch() case label.

2012-01-30 Thread Eric Anholt
The error message I chose matches gcc's error. Fixes piglit switch-case-duplicated.vert. NOTE: This is a candidate for the 8.0 branch. --- src/glsl/ast_to_hir.cpp | 23 +++ src/glsl/glsl_parser_extras.h |4 2 files changed, 27 insertions(+), 0 deletions(-)

[Mesa-dev] [PATCH 3/6] glsl: Add missing location info to case labels.

2012-01-30 Thread Eric Anholt
Otherwise, the upcoming error messages said the location was 0:0(0). NOTE: This is a candidate for the 8.0 branch. --- src/glsl/glsl_parser.yy |2 ++ 1 files changed, 2 insertions(+), 0 deletions(-) diff --git a/src/glsl/glsl_parser.yy b/src/glsl/glsl_parser.yy index e774b46..8368d06 100644

[Mesa-dev] [PATCH 6/6] glsl: Add error case for switch() with two default cases.

2012-01-30 Thread Eric Anholt
Fixes piglit switch-case-duplicated.vert. NOTE: This is a candidate for the 8.0 branch. --- src/glsl/ast_to_hir.cpp | 15 +++ src/glsl/glsl_parser_extras.h |1 + 2 files changed, 16 insertions(+), 0 deletions(-) diff --git a/src/glsl/ast_to_hir.cpp

[Mesa-dev] [PATCH 2/6] glsl: Throw the required error when a case label is a non-constant.

2012-01-30 Thread Eric Anholt
It's not quite spelled out in the spec text, but the grammar indicates that only constant values are allowed as switch() case labels (and only constant values make sense, anyway). Fixes piglit glsl-1.30/compiler/switch-statement/switch-case-uniform-int.vert. NOTE: This is a candidate for the 8.0

[Mesa-dev] [PATCH 4/6] glsl: Add other missing error location information for switch statements.

2012-01-30 Thread Eric Anholt
NOTE: This is a candidate for the 8.0 branch. --- src/glsl/glsl_parser.yy |4 1 files changed, 4 insertions(+), 0 deletions(-) diff --git a/src/glsl/glsl_parser.yy b/src/glsl/glsl_parser.yy index 8368d06..d5e85ab 100644 --- a/src/glsl/glsl_parser.yy +++ b/src/glsl/glsl_parser.yy @@

Re: [Mesa-dev] Automaking src/glsl

2012-01-30 Thread Eric Anholt
On Mon, 30 Jan 2012 01:09:46 -0500, Matt Turner matts...@gmail.com wrote: Here's a patch series to convert the glsl directory to automake. I've worked out all the kinks I could find, and the meat of this series has been posted for review a couple of times already, so I plan to commit this

[Mesa-dev] [PATCH 1/6] glsl: Save and restore the whole switch state for nesting.

2012-01-30 Thread Eric Anholt
This stuffs them all in a struct for sanity. Fixes piglit glsl-1.30/execution/switch/fs-uniform-nested. NOTE: This is a candidate for the 8.0 branch. --- src/glsl/ast_to_hir.cpp | 497 +++ src/glsl/glsl_parser_extras.cpp |2 +-

Re: [Mesa-dev] [PATCH 0/4] Removal of point size clamping in st/mesa

2012-01-30 Thread Roland Scheidegger
Am 29.01.2012 03:02, schrieb Marek Olšák: On Sat, Jan 28, 2012 at 2:37 AM, Roland Scheidegger srol...@vmware.com wrote: Am 28.01.2012 01:38, schrieb Marek Olšák: Hi everyone, the subject says it all. This series fixes gl_PointSize with transform feedback. There is a new piglit test to

Re: [Mesa-dev] [PATCH 2/2] glsl: Rename variable_entry2 to variable_entry.

2012-01-30 Thread Kenneth Graunke
On 01/28/2012 04:58 PM, Kenneth Graunke wrote: This should be safe now that ir_variable_refcount.h doesn't expose a type with the same name. The only other type with the same name is in brw_fs_vector_splitting.cpp, but both of these should be file-scope, so I don't expect problems.

Re: [Mesa-dev] [PATCH] r600g: only claim integer support for GLSL130 enable

2012-01-30 Thread Marek Olšák
This generally looks good to me. Note that this is not required for st/mesa, because the GLSL cap covers it all (the GLSL cap also covers integer textures, texture arrays, shader_texture_lod, clip distances, shadow cube samplers etc.), though I guess other clients would like to make use of

Re: [Mesa-dev] [PATCH] Rename R300_NO_TCL envvar to RADEON_NO_TCL

2012-01-30 Thread Marek Olšák
This looks good to me. Marek On Mon, Jan 30, 2012 at 8:04 PM, Matt Turner matts...@gmail.com wrote: The envvar works for R100 and R200 too, and the classic R300 driver doesn't even exist anymore. RADEON_NO_TCL is already mentioned in the code and is the same envvar used for the R300g

Re: [Mesa-dev] Segmentation fault with VTK OffScreenRendering

2012-01-30 Thread Joshua Daniel Franklin (UW Seattle)
On 1/27/12 12:28 PM, Kevin H. Hobbs wrote: So you want to get OSMesa from Mesa-7.11.2 working with VTK-5.8.0 on Fedora 15? Yep, works great. I think I'll adapt your script for our users here too! http://lists.freedesktop.org/archives/mesa-dev/2012-January/018282.html So is it EGL that has

Re: [Mesa-dev] [PATCH 3/3] mesa: consolidate general ubyte texstore code

2012-01-30 Thread Eric Anholt
Cool, on seeing patch 2/3 I was going to ask for this 3/3. Series is: Reviewed-by: Eric Anholt e...@anholt.net pgpUvDc9AlWgO.pgp Description: PGP signature ___ mesa-dev mailing list mesa-dev@lists.freedesktop.org

Re: [Mesa-dev] Segmentation fault with VTK OffScreenRendering

2012-01-30 Thread Kevin H. Hobbs
On 01/30/2012 02:13 PM, Joshua Daniel Franklin (UW Seattle) wrote: On 1/27/12 12:28 PM, Kevin H. Hobbs wrote: So you want to get OSMesa from Mesa-7.11.2 working with VTK-5.8.0 on Fedora 15? So is it EGL that has trouble with offline rendering, since you did --disable-egl? No. it's just

[Mesa-dev] [PATCH] mesa: fix maximum allowed proxy texture size condition

2012-01-30 Thread Anuj Phogat
width, height parameter of glTexImage2D() includes: texture image width + 2 * border (if any). So when doing the texture size check in _mesa_test_proxy_teximage() width and height should not exceed maximum supported size for target texture type + 2 * border. i.e. 1 (ctx-Const.MaxTextureLevels -

Re: [Mesa-dev] Segmentation fault with VTK OffScreenRendering

2012-01-30 Thread Kevin H. Hobbs
On 01/30/2012 02:53 PM, Kevin H. Hobbs wrote: I'm trying that now but you can give it a shot before then. The VTK tests have the same pattern of failures with the Fedora 15 OSMesa package as with the custom built OSMesa library, that is : The following tests FAILED: 146 -

[Mesa-dev] [PATCH 00/15] R600g cleanup and rework of cache flushing

2012-01-30 Thread Marek Olšák
Hi everyone, This patch series is a follow-up to the previous one (Remove all uses of the register mask). First, it cleans up some code and merges r600_context into r600_pipe_context. The split of functionality between the two contexts made absolutely no sense. Next, it adds a new mechanism

[Mesa-dev] [PATCH 01/15] r600g: remove u8,u16,u32,u64 types

2012-01-30 Thread Marek Olšák
--- src/gallium/drivers/r600/evergreen_hw_context.c |6 +- src/gallium/drivers/r600/evergreen_state.c |6 +- src/gallium/drivers/r600/r600.h | 51 ++ src/gallium/drivers/r600/r600_asm.c |4 +- src/gallium/drivers/r600/r600_asm.h

[Mesa-dev] [PATCH 03/15] r600g: don't initialize the screen and winsys pointer twice

2012-01-30 Thread Marek Olšák
--- src/gallium/drivers/r600/evergreen_hw_context.c |7 ++- src/gallium/drivers/r600/r600.h |4 ++-- src/gallium/drivers/r600/r600_hw_context.c |7 ++- src/gallium/drivers/r600/r600_pipe.c|4 ++-- 4 files changed, 8 insertions(+), 14

[Mesa-dev] [PATCH 04/15] r600g: remove the now-useless internal flush callback

2012-01-30 Thread Marek Olšák
--- src/gallium/drivers/r600/r600_hw_context.c |2 +- src/gallium/drivers/r600/r600_pipe.c |2 -- src/gallium/drivers/r600/r600_pipe.h |3 --- 3 files changed, 1 insertions(+), 6 deletions(-) diff --git a/src/gallium/drivers/r600/r600_hw_context.c

[Mesa-dev] [PATCH 05/15] r600g: consolidate some context_draw code

2012-01-30 Thread Marek Olšák
--- src/gallium/drivers/r600/evergreen_hw_context.c | 25 -- src/gallium/drivers/r600/r600.h |3 ++ src/gallium/drivers/r600/r600_hw_context.c | 26 --- src/gallium/drivers/r600/r600_hw_context_priv.h |5

[Mesa-dev] [PATCH 06/15] r600g: remove redundant pm4 and pm4_cdwords in r600_context

2012-01-30 Thread Marek Olšák
These only mirrored radeon_winsys_cs. --- src/gallium/drivers/r600/evergreen_hw_context.c | 66 +++-- src/gallium/drivers/r600/r600_hw_context.c | 380 --- src/gallium/drivers/r600/r600_pipe.h|3 - 3 files changed, 234 insertions(+), 215 deletions(-)

[Mesa-dev] [PATCH 09/15] r600g: remove unused flush code

2012-01-30 Thread Marek Olšák
--- src/gallium/drivers/r600/r600_hw_context.c | 36 --- src/gallium/drivers/r600/r600_hw_context_priv.h |4 -- src/gallium/winsys/radeon/drm/radeon_drm_bo.h |4 -- src/gallium/winsys/radeon/drm/radeon_winsys.h | 10 +-- 4 files changed, 1

[Mesa-dev] [PATCH 10/15] r600g: remove dead code for tracking relocations

2012-01-30 Thread Marek Olšák
--- src/gallium/drivers/r600/evergreen_hw_context.c |7 --- src/gallium/drivers/r600/r600_hw_context.c | 13 - src/gallium/drivers/r600/r600_hw_context_priv.h | 10 +- src/gallium/drivers/r600/r600_pipe.h|3 --- 4 files changed, 1

[Mesa-dev] [PATCH 11/15] r600g: remove more dead code

2012-01-30 Thread Marek Olšák
--- src/gallium/drivers/r600/r600.h|2 -- src/gallium/drivers/r600/r600_hw_context.c |7 --- 2 files changed, 0 insertions(+), 9 deletions(-) diff --git a/src/gallium/drivers/r600/r600.h b/src/gallium/drivers/r600/r600.h index b5d2a89..d0f0b39 100644 ---

[Mesa-dev] [PATCH 13/15] r600g: fix computation of how many dwords is needed for a flush at the end of CS

2012-01-30 Thread Marek Olšák
--- src/gallium/drivers/r600/r600.h|1 - src/gallium/drivers/r600/r600_hw_context.c | 14 -- 2 files changed, 4 insertions(+), 11 deletions(-) diff --git a/src/gallium/drivers/r600/r600.h b/src/gallium/drivers/r600/r600.h index d0f0b39..229fa70 100644 ---

[Mesa-dev] [PATCH 15/15] r600g: use the new code for streamout flush as well

2012-01-30 Thread Marek Olšák
--- src/gallium/drivers/r600/r600_hw_context.c | 17 ++--- 1 files changed, 6 insertions(+), 11 deletions(-) diff --git a/src/gallium/drivers/r600/r600_hw_context.c b/src/gallium/drivers/r600/r600_hw_context.c index bdef830..f2cec1b 100644 ---

[Mesa-dev] Text rendering partly broken by commit f9874fee

2012-01-30 Thread Brad King
Hi Brian, Recently VTK's TestPieChartActor and similar tests started to fail on our test machines that use nightly Mesa. For example, one that I run: http://www.cdash.org/CDash/testDetails.php?test=133410913build=1960175 and one that Kevin Hobbs runs:

Re: [Mesa-dev] [PATCH 00/15] R600g cleanup and rework of cache flushing

2012-01-30 Thread Jerome Glisse
On Mon, Jan 30, 2012 at 09:23:03PM +0100, Marek Olšák wrote: Hi everyone, This patch series is a follow-up to the previous one (Remove all uses of the register mask). First, it cleans up some code and merges r600_context into r600_pipe_context. The split of functionality between the two

Re: [Mesa-dev] [PATCH 00/19] Remove all uses of the register mask

2012-01-30 Thread Alex Deucher
On Sun, Jan 29, 2012 at 2:51 PM, Marek Olšák mar...@gmail.com wrote: Hi everyone, This is a cleanup in a series of cleanups I am going to make to improve the horribly over-engineered and slow state management of r600g. This particular patch series brings nothing new or special, it's merely

Re: [Mesa-dev] [PATCH 00/15] R600g cleanup and rework of cache flushing

2012-01-30 Thread Alex Deucher
On Mon, Jan 30, 2012 at 3:23 PM, Marek Olšák mar...@gmail.com wrote: Hi everyone, This patch series is a follow-up to the previous one (Remove all uses of the register mask). First, it cleans up some code and merges r600_context into r600_pipe_context. The split of functionality between the

[Mesa-dev] [PATCH 2/2] dri: Add Unigine Tropics as an app that requires the GLSL warn workaround.

2012-01-30 Thread Eric Anholt
I wasn't seeing it be needed because of the previous bug. --- src/mesa/drivers/dri/common/drirc |3 +++ 1 files changed, 3 insertions(+), 0 deletions(-) diff --git a/src/mesa/drivers/dri/common/drirc b/src/mesa/drivers/dri/common/drirc index ac83a2d..59c00d7 100644 ---

[Mesa-dev] [PATCH 1/2] dri: Fix typo in xml file that made all applications use the workaround.

2012-01-30 Thread Eric Anholt
--- src/mesa/drivers/dri/common/drirc |2 +- 1 files changed, 1 insertions(+), 1 deletions(-) diff --git a/src/mesa/drivers/dri/common/drirc b/src/mesa/drivers/dri/common/drirc index 7abc646..ac83a2d 100644 --- a/src/mesa/drivers/dri/common/drirc +++ b/src/mesa/drivers/dri/common/drirc @@

[Mesa-dev] [PATCH 1/2] mesa: Fix bad-enum/no-buffer error handling for buffer object functions.

2012-01-30 Thread Eric Anholt
For all the extension entrypoints using the get_buffer() helper, they wanted the same error handling. In some cases, the error was doing the same error return whether target was a bad enum, or a user buffer wasn't bound. (Actually, GL_ARB_map_buffer_range doesn't specify the error for a zero

Re: [Mesa-dev] [PATCH 1/2] mesa: Fix bad-enum/no-buffer error handling for buffer object functions.

2012-01-30 Thread Brian Paul
On Mon, Jan 30, 2012 at 4:25 PM, Eric Anholt e...@anholt.net wrote: For all the extension entrypoints using the get_buffer() helper, they wanted the same error handling.  In some cases, the error was doing the same error return whether target was a bad enum, or a user buffer wasn't bound.

[Mesa-dev] [Bug 45420] New: undefined reference to `LLVMInitializeARMDisassembler'

2012-01-30 Thread bugzilla-daemon
https://bugs.freedesktop.org/show_bug.cgi?id=45420 Bug #: 45420 Summary: undefined reference to `LLVMInitializeARMDisassembler' Classification: Unclassified Product: Mesa Version: unspecified Platform: x86-64 (AMD64) OS/Version:

Re: [Mesa-dev] [PATCH 2/2] dri: Add Unigine Tropics as an app that requires the GLSL warn workaround.

2012-01-30 Thread Kenneth Graunke
On 01/30/2012 03:23 PM, Eric Anholt wrote: I wasn't seeing it be needed because of the previous bug. --- src/mesa/drivers/dri/common/drirc |3 +++ 1 files changed, 3 insertions(+), 0 deletions(-) diff --git a/src/mesa/drivers/dri/common/drirc b/src/mesa/drivers/dri/common/drirc index

[Mesa-dev] [PATCH] glsl: Fix optimization tests after converting src/glsl to automake.

2012-01-30 Thread Paul Berry
Commit 99476561 (automake: src/glsl and src/glsl/glcpp) changed the build system so that src/glsl/glsl_test is not built by default. This inadvertently broke make check, since the tests in src/glsl/tests/lower_jumps (which are run by make check) rely on glsl_test. This patch ensures that make

Re: [Mesa-dev] [PATCH] glsl: Fix optimization tests after converting src/glsl to automake.

2012-01-30 Thread Matt Turner
On Mon, Jan 30, 2012 at 10:28 PM, Paul Berry stereotype...@gmail.com wrote: Commit 99476561 (automake: src/glsl and src/glsl/glcpp) changed the build system so that src/glsl/glsl_test is not built by default.  This inadvertently broke make check, since the tests in src/glsl/tests/lower_jumps

Re: [Mesa-dev] [PATCH] gallium: add PIPE_CAP_QUADS_FOLLOW_PROVOKING_VERTEX_CONVENTION

2012-01-30 Thread Marek Olšák
BTW I am in favor of adding the CAP. r300 doesn't support the first-vertex convention for quads, but r600 does support it and it cannot be disabled for quads only. Because of that, the provoking vertex switch is currently part of the draw state instead of the rasterizer state in r600g. Adding the