[Mesa-dev] [PATCH shader-db 4/4] si-report.py: add completely new shader statistics reporting

2016-07-14 Thread Marek Olšák
From: Marek Olšák We can remove the old reporting if people are OK with that. The old reporting has a bug that it reports 0->N changes as 0 % in several places. (should be inf %) The new reporting shows: - VGPR spilling shaders and apps (from the second file only) - the

[Mesa-dev] [PATCH shader-db 1/4] si-report.py: show spilled SGPRs and VGPRs

2016-07-14 Thread Marek Olšák
From: Marek Olšák --- si-report.py | 7 ++- 1 file changed, 6 insertions(+), 1 deletion(-) diff --git a/si-report.py b/si-report.py index 69af89e..3e39350 100755 --- a/si-report.py +++ b/si-report.py @@ -58,6 +58,8 @@ class si_stats: metrics = [ ('sgprs',

[Mesa-dev] [PATCH shader-db 3/4] si-report.py: report % change correctly for 0->N

2016-07-14 Thread Marek Olšák
From: Marek Olšák not all places are fixed --- si-report.py | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-) diff --git a/si-report.py b/si-report.py index c5855ff..523c452 100755 --- a/si-report.py +++ b/si-report.py @@ -39,7 +39,7 @@ def get_str(value, suffix = '

Re: [Mesa-dev] [PATCH glx/glxglvnd] Avoid overflow in 'last' variable of FindGLXFunction(...)

2016-07-14 Thread Eric Engestrom
On Thu, Jul 14, 2016 at 03:21:20PM +0200, Stefan Dirsch wrote: > This 'last' variable used in FindGLXFunction(...) may become negative, > but has been defined as unsigned int resulting in an overflow, > finally resulting in a segfault when accessing _glXDispatchTableStrings[...]. > Fixed this by

Re: [Mesa-dev] [PATCH 1/2] glsl/types: Fix function type comparison function

2016-07-14 Thread Iago Toral
Both patches are: Reviewed-by: Iago Toral Quiroga On Wed, 2016-07-13 at 14:28 -0700, Jason Ekstrand wrote: > It was returning true if the function types have different lengths > rather > than false.  This was new with the SPIR-V to NIR pass and I thought > I'd > fixed it a

Re: [Mesa-dev] [PATCH 1/3] freedreno/a2xx: Fix sign compare warnings

2016-07-14 Thread Rob Clark
I've pushed 'em, thx On Wed, Jul 13, 2016 at 1:03 PM, Francesco Ansanelli wrote: > Yes, please. > > Cheers, > Francesco ___ mesa-dev mailing list mesa-dev@lists.freedesktop.org

Re: [Mesa-dev] [PATCH] Revert "gallium: Force blend color to 16-byte alignment"

2016-07-14 Thread Nicolai Hähnle
Thanks! In addition to Emil's suggestion, please be sure to definitely reference the bugreport in the commit message: Bugzilla: https://bugs.freedesktop.org/show_bug.cgi?id=96835 With that fixed, the patch is Reviewed-by: Nicolai Hähnle On 13.07.2016 17:39, Tim

Re: [Mesa-dev] [PATCH mesa] vl: fix memory leak

2016-07-14 Thread Eric Engestrom
On Wed, Jul 13, 2016 at 01:48:03PM +0200, Christian König wrote: > Good catch, since we need only 16 offsets I think we could simply allocate > it on the stack as well. > > Or am I missing something? You're entirely right, and that's a much better fix too. v2 coming in a few minutes. > >

Re: [Mesa-dev] mesa from git fails to compile

2016-07-14 Thread Pali Rohár
Any news? Or possible fix? On Sunday 10 July 2016 18:26:28 Jason Ekstrand wrote: > This smells like strange Python problems. Ccing the resident Python expert. > Hello, compiling mesa from git is failing on this error: > > Making all in isl > make[5]: Entering directory

Re: [Mesa-dev] [PATCH 0/4] RadeonSI: Multithreaded shader

2016-07-14 Thread Trek
On Sat Jul 9 23:24:35 UTC 2016, Marek Olšák wrote: > I'm open to having the on-disk shader cache for radeonsi just because > of Borderlands 2. I have yet to discover other games that would > benefit from it. it is possible that wined3d does on-demand compilation? I read it in

[Mesa-dev] [PATCH mesa v2] vl: fix memory leak

2016-07-14 Thread Eric Engestrom
CovID: 1363008 Signed-off-by: Eric Engestrom --- v2: avoid using malloc() altogether (Christian König) --- src/gallium/auxiliary/vl/vl_bicubic_filter.c | 8 +--- 1 file changed, 1 insertion(+), 7 deletions(-) diff --git a/src/gallium/auxiliary/vl/vl_bicubic_filter.c

[Mesa-dev] libglvnd support in Mesa 12

2016-07-14 Thread Stefan Dirsch
I've played around with libglvnd support in Mesa12. I'm using libglvnd from git master (commit id 1b30d15) and Mesa 12.0.1. It tries to open the last fallback libGLX_indirect. I workarounded this via setting __GLX_VENDOR_LIBRARY_NAME environment variable to "mesa". This resulted in a crash when

[Mesa-dev] [PATCH glx/glxglvnd] Avoid overflow in 'last' variable of FindGLXFunction(...)

2016-07-14 Thread Stefan Dirsch
This 'last' variable used in FindGLXFunction(...) may become negative, but has been defined as unsigned int resulting in an overflow, finally resulting in a segfault when accessing _glXDispatchTableStrings[...]. Fixed this by definining it as signed int. 'first' variable also needs to be defined

Re: [Mesa-dev] [PATCH] main: memcpy larger chunks in _mesa_propagate_uniforms_to_driver_storage

2016-07-14 Thread Nils Wallménius
Den 13 juli 2016 9:48 em skrev "Kenneth Graunke" : > > On Wednesday, July 13, 2016 1:53:26 PM PDT Nils Wallménius wrote: > > When possible, do the memcpy on larger blocks. This reduces cycles > > spent in _mesa_propagate_uniforms_to_driver_storage from > > 1.51 % to 0.62%

[Mesa-dev] [PATCH] mesa: standardize naming Mesa3D, MESA -> Mesa

2016-07-14 Thread Vedran Miletić
Signed-off-by: Vedran Miletić --- docs/xlibdriver.html| 2 +- src/gallium/docs/source/drivers/openswr/faq.rst | 4 ++-- src/gallium/include/pipe/p_defines.h| 2 +- src/mesa/main/version.c | 2 +- 4 files changed,

Re: [Mesa-dev] [PATCH 02/11] vl: add entry point

2016-07-14 Thread Christian König
Am 14.07.2016 um 00:51 schrieb Boyuan Zhang: Add entry point for encoding which previously hardcoded for decoding purpose only I still can't figure out why we would want this? The variable doesn't seem to be used in the whole patchset. Christian. Signed-off-by: Boyuan Zhang

[Mesa-dev] [PATCH 4/5] i965: Reduce the number of fs_reg(brw_reg) calls in LINTERP handling.

2016-07-14 Thread Kenneth Graunke
A bit tidier. Signed-off-by: Kenneth Graunke --- src/mesa/drivers/dri/i965/brw_fs.cpp | 8 1 file changed, 4 insertions(+), 4 deletions(-) diff --git a/src/mesa/drivers/dri/i965/brw_fs.cpp b/src/mesa/drivers/dri/i965/brw_fs.cpp index c6f193a..1f6ff59 100644 ---

[Mesa-dev] [PATCH 3/5] i965: Make a barycentric_mode() helper function.

2016-07-14 Thread Kenneth Graunke
This combines two copies of basically the same code. Signed-off-by: Kenneth Graunke --- src/mesa/drivers/dri/i965/brw_fs.cpp | 100 +-- 1 file changed, 49 insertions(+), 51 deletions(-) diff --git a/src/mesa/drivers/dri/i965/brw_fs.cpp

[Mesa-dev] [PATCH 2/5] i965: Rename brw_wm_barycentric_interp_mode to brw_barycentric_mode.

2016-07-14 Thread Kenneth Graunke
brw_wm_barycentric_interp_mode is wordy, brw_barycentric_mode is less typing and suffers from fewer line wrapping problems. The enum values themselves don't really benefit from "WM" in the name, either. Put "BARYCENTRIC" first instead of at the end and drop "WM". Generated by: for file in *.c

[Mesa-dev] [PATCH 1/5] i965: Handle default interpolation modes and locations in NIR.

2016-07-14 Thread Kenneth Graunke
This consolidates a bunch of hacks in a single place - by setting the interpolation modes and locations on variables appropriately, we can simply trust them in the rest of the code. This avoids having to handle INTERP_QUALIFIER_NONE, gl_Color overrides, sample-shading overrides, and Gen4-5

[Mesa-dev] [PATCH 5/5] i965: Remove the emit_linterp() helper.

2016-07-14 Thread Kenneth Graunke
Rather than computing the barycentric mode each time we emit a LINTERP, we can simply compute it once, as soon as we know we're doing non-flat interpolation. At that point, emit_linterp() doesn't do much, so fold it into the call sites and drop it. Signed-off-by: Kenneth Graunke

Re: [Mesa-dev] [PATCH 06/11] st/va: add copy function for yv12 image to nv12 surface

2016-07-14 Thread Christian König
Am 14.07.2016 um 00:51 schrieb Boyuan Zhang: Add function to copy from yv12 image to nv12 surface for VAAPI putimage call. Existing function only work for copying from yv12 surface to nv12 image. Signed-off-by: Boyuan Zhang Two nitpicks here, the subject should read

Re: [Mesa-dev] [PATCH 01/11] vl: add parameters for VAAPI encode

2016-07-14 Thread Christian König
Am 14.07.2016 um 00:51 schrieb Boyuan Zhang: Allow to specify more parameters in the encoding interface which previously just hardcoded in the encoder Signed-off-by: Boyuan Zhang I'm still not convinced what exactly this is_idr flag should do, but for now I've

Re: [Mesa-dev] [ANNOUNCE] mesa 12.0.1

2016-07-14 Thread Eero Tamminen
Hi, On 12.07.2016 18:43, Brian Paul wrote: Done. Thanks! I was going through the fixed bugs list from the release notes, and noticed that at least this one wasn't marked as fixed although claimed to: https://bugs.freedesktop.org/show_bug.cgi?id=93840 Is fixed bugs list generated

Re: [Mesa-dev] [PATCH 01/12] vl: add parameters for VAAPI encode

2016-07-14 Thread Christian König
Am 05.07.2016 um 13:17 schrieb Christian König: Am 01.07.2016 um 18:18 schrieb Andy Furniss: Christian König wrote: Am 01.07.2016 um 18:02 schrieb Andy Furniss: Christian König wrote: Am 01.07.2016 um 16:42 schrieb Andy Furniss: Boyuan Zhang wrote: Signed-off-by: Boyuan Zhang

Re: [Mesa-dev] i915: Enable EGL_KHR_{fence,wait}_sync

2016-07-14 Thread Mauro Rossi
2016-07-14 5:33 GMT+02:00 Mauro Rossi : > Sending patches to implement DRI2_Fence extension for i915, > to enable EGL_KHR_fence_sync and EGL_KHR_wait_sync. > > It is the step-by-step porting to i915 of i965/sync, > plus patch to support {server,client}_wait_sync without

<    1   2