Re: [Mesa-dev] [PATCH 04/23] glsl: Add image memory and layout qualifiers to ir_variable.

2013-12-11 Thread Paul Berry
On 26 November 2013 00:02, Francisco Jerez curroje...@riseup.net wrote: +* ARB_shader_image_load_store qualifiers. +*/ + struct { + bool read_only; + bool write_only; It's hard to come up with a good naming convention for read_only and write_only--should they have

[Mesa-dev] [PATCH 04/23] glsl: Add image memory and layout qualifiers to ir_variable.

2013-11-26 Thread Francisco Jerez
--- src/glsl/ir.cpp | 2 +- src/glsl/ir.h | 14 ++ src/glsl/ir_clone.cpp | 1 + 3 files changed, 16 insertions(+), 1 deletion(-) diff --git a/src/glsl/ir.cpp b/src/glsl/ir.cpp index 297..ae690ea 100644 --- a/src/glsl/ir.cpp +++ b/src/glsl/ir.cpp @@ -1587,7 +1587,7