Re: [Mesa-dev] [RFC] More ARB_arrays_of_arrays support

2015-03-22 Thread Timothy Arceri
On Sat, 2015-03-21 at 09:27 -0700, Jason Ekstrand wrote: On Mar 21, 2015 2:49 AM, Timothy Arceri t_arc...@yahoo.com.au wrote: This series adds most of the remaining glsl arrays of arrays support. Support for uniform blocks is still missing, I've played around with this but don't have

[Mesa-dev] [PATCH v2 04/15] gallium: replace pipe_driver_query_info::max_value by a union

2015-03-22 Thread Samuel Pitoiset
This allows queries to return different numeric types. Signed-off-by: Samuel Pitoiset samuel.pitoiset at gmail.com --- src/gallium/auxiliary/hud/hud_driver_query.c| 3 ++- src/gallium/drivers/freedreno/freedreno_query.c | 12 ++-- src/gallium/drivers/nouveau/nvc0/nvc0_query.c | 9

[Mesa-dev] [PATCH v2 00/15] GL_AMD_performance_monitor

2015-03-22 Thread Samuel Pitoiset
Hello, A series I have waited too long to re-submit, but I recently refactored the code and fixed some minor issues. This patchset enables GL_AMD_performance_monitor for svga, freedreno, r600, radeonsi and nvc0 drivers. This code has been tested with Nouveau (NVD9 and NVE7) but it should also

[Mesa-dev] [PATCH v2 08/15] svga: implement pipe_screen::get_driver_query_group_info

2015-03-22 Thread Samuel Pitoiset
This enables GL_AMD_performance_monitor for svga. Signed-off-by: Samuel Pitoiset samuel.pitoi...@gmail.com --- src/gallium/drivers/svga/svga_context.h | 1 + src/gallium/drivers/svga/svga_screen.c | 11 +++ 2 files changed, 12 insertions(+) diff --git

[Mesa-dev] [PATCH v2 02/15] gallium: add new fields to pipe_driver_query_info

2015-03-22 Thread Samuel Pitoiset
According to the spec of GL_AMD_performance_monitor, valid type values returned are UNSIGNED_INT, UNSIGNED_INT64_AMD, PERCENTAGE_AMD, FLOAT. This also introduces the new field group_id in order to categorize queries into groups. v2: add PIPE_DRIVER_QUERY_TYPE_BYTES Signed-off-by: Samuel Pitoiset

[Mesa-dev] [PATCH v2 09/15] freedreno: implement pipe_screen::get_driver_query_group_info

2015-03-22 Thread Samuel Pitoiset
This enables GL_AMD_performance_monitor for freedreno. Signed-off-by: Samuel Pitoiset samuel.pitoi...@gmail.com Reviewed-by: Rob Clark robcl...@freedesktop.org --- src/gallium/drivers/freedreno/freedreno_query.c | 9 + src/gallium/drivers/freedreno/freedreno_query.h | 1 + 2 files

[Mesa-dev] [PATCH v2 03/15] gallium: add new numeric types to pipe_query_result

2015-03-22 Thread Samuel Pitoiset
This will be used by GL_AMD_performance_monitor. Signed-off-by: Samuel Pitoiset samuel.pitoi...@gmail.com --- src/gallium/include/pipe/p_defines.h | 8 1 file changed, 8 insertions(+) diff --git a/src/gallium/include/pipe/p_defines.h b/src/gallium/include/pipe/p_defines.h index

[Mesa-dev] [PATCH v2 10/15] radeon: implement pipe_screen::get_driver_query_group_info

2015-03-22 Thread Samuel Pitoiset
This enables GL_AMD_performance_monitor for radeon. Signed-off-by: Samuel Pitoiset samuel.pitoi...@gmail.com Reviewed-by: Marek Olšák marek.ol...@amd.com --- src/gallium/drivers/radeon/r600_pipe_common.c | 9 + src/gallium/drivers/radeon/r600_pipe_common.h | 1 + 2 files changed, 10

[Mesa-dev] [PATCH v2 07/15] gallium: add util_get_driver_query_group_info

2015-03-22 Thread Samuel Pitoiset
This function can be used to get a generic group of driver-specific queries when a driver doesn't expose any groups. Signed-off-by: Samuel Pitoiset samuel.pitoi...@gmail.com --- src/gallium/auxiliary/Makefile.sources | 1 + src/gallium/auxiliary/util/u_query.c | 50

[Mesa-dev] [PATCH v2 05/15] gallium: make pipe_context::begin_query return a boolean

2015-03-22 Thread Samuel Pitoiset
GL_AMD_performance_monitor must return an error when a monitoring session cannot be started. Signed-off-by: Samuel Pitoiset samuel.pitoi...@gmail.com --- src/gallium/drivers/freedreno/freedreno_query.c| 4 ++-- src/gallium/drivers/freedreno/freedreno_query.h| 2 +-

[Mesa-dev] [PATCH v2 06/15] st/mesa: implement GL_AMD_performance_monitor

2015-03-22 Thread Samuel Pitoiset
From: Christoph Bumiller e0425...@student.tuwien.ac.at This is based on the original patch of Christoph Bumiller. (source: http://people.freedesktop.org/~chrisbmr/perfmon.diff) As for the Gallium HUD, we keep a list of busy queries in a ring buffer in order to prevent stalls when reading

[Mesa-dev] [PATCH v2 01/15] gallium: add pipe_screen::get_driver_query_group_info

2015-03-22 Thread Samuel Pitoiset
Driver queries are organized as a single hierarchy where queries are categorized into groups. Each goup has a list of queries and a maximum number of queries that can be sampled. The list of available groups can be obtained using pipe_screen::get_driver_query_group_info. This will be used by

[Mesa-dev] [PATCH v2 12/15] docs: mark GL_AMD_performance_monitor for the 10.6.0 release

2015-03-22 Thread Samuel Pitoiset
GL_AMD_performance_monitor is supported by nvc0, svga, freedreno, r600 and radeonsi. Signed-off-by: Samuel Pitoiset samuel.pitoi...@gmail.com --- docs/relnotes/10.6.0.html | 1 + 1 file changed, 1 insertion(+) diff --git a/docs/relnotes/10.6.0.html b/docs/relnotes/10.6.0.html index

[Mesa-dev] [PATCH v2 13/15] nvc0: expose more driver-specific query groups

2015-03-22 Thread Samuel Pitoiset
This patch exposes Driver statistics and MP counters groups. Signed-off-by: Samuel Pitoiset samuel.pitoi...@gmail.com --- src/gallium/drivers/nouveau/nvc0/nvc0_query.c | 61 -- src/gallium/drivers/nouveau/nvc0/nvc0_screen.h | 11 + 2 files changed, 69 insertions(+),

[Mesa-dev] [PATCH v2 11/15] nvc0: implement pipe_screen::get_driver_query_group_info

2015-03-22 Thread Samuel Pitoiset
This enables GL_AMD_performance_monitor for nvc0. Signed-off-by: Samuel Pitoiset samuel.pitoi...@gmail.com --- src/gallium/drivers/nouveau/nvc0/nvc0_query.c | 10 ++ src/gallium/drivers/nouveau/nvc0/nvc0_screen.c | 1 + src/gallium/drivers/nouveau/nvc0/nvc0_screen.h | 3 +++ 3 files

[Mesa-dev] [PATCH v2 15/15] nvc0: all queries use an unsigned 64-bits integer by default

2015-03-22 Thread Samuel Pitoiset
Signed-off-by: Samuel Pitoiset samuel.pitoi...@gmail.com --- src/gallium/drivers/nouveau/nvc0/nvc0_query.c | 12 +++- 1 file changed, 7 insertions(+), 5 deletions(-) diff --git a/src/gallium/drivers/nouveau/nvc0/nvc0_query.c b/src/gallium/drivers/nouveau/nvc0/nvc0_query.c index

[Mesa-dev] [PATCH v2 14/15] nvc0: make begin_query return false when all MP counters are used

2015-03-22 Thread Samuel Pitoiset
Signed-off-by: Samuel Pitoiset samuel.pitoi...@gmail.com --- src/gallium/drivers/nouveau/nvc0/nvc0_query.c | 13 - 1 file changed, 8 insertions(+), 5 deletions(-) diff --git a/src/gallium/drivers/nouveau/nvc0/nvc0_query.c b/src/gallium/drivers/nouveau/nvc0/nvc0_query.c index

Re: [Mesa-dev] [PATCH 17/18] i965/cs: Add max_cs_threads

2015-03-22 Thread Ben Widawsky
On Sat, Mar 14, 2015 at 09:54:27PM -0700, Jordan Justen wrote: Add some values for gen7 gen8. These are the number threads in a subslice. Signed-off-by: Jordan Justen jordan.l.jus...@intel.com Cc: Ben Widawsky b...@bwidawsk.net Cc: Kenneth Graunke kenn...@whitecape.org ---

[Mesa-dev] Correct behaviour of glDrawPixels and glBitmap when texturing is enabled.

2015-03-22 Thread Matthew Dawson
Hi all, I've been working fixing the piglit tests around glDrawPixels, and I'm not sure what the correct behaviour of glDrawPixels is when any texturing units are enabled (tested with the draw-pixel-with-texture piglit test). After asking on irc, imirkin suggested I bring the issue here as it

Re: [Mesa-dev] [RFC PATCH 10/12] glsl: add AoA support for an inteface with unsized array members

2015-03-22 Thread Timothy Arceri
On Sat, 2015-03-21 at 19:57 -0400, Ilia Mirkin wrote: On Sat, Mar 21, 2015 at 5:49 AM, Timothy Arceri t_arc...@yahoo.com.au wrote: Add support for setting the max access of an unsized member of an interface array of arrays. For example ifc[j][k].foo[i] where foo is unsized. ---

[Mesa-dev] [PATCH 3/4] gallium: implement get_device_vendor() for existing drivers

2015-03-22 Thread Giuseppe Bilotta
The only hackish ones are llvmpipe and softpipe, which currently return the same string as for get_vendor(), while ideally they should return the CPU vendor. Signed-off-by: Giuseppe Bilotta giuseppe.bilo...@gmail.com Reviewed-by: Tom Stellard thomas.stell...@amd.com ---

[Mesa-dev] [PATCH 4/4] clover: use get_device_vendor instead of get_vendor

2015-03-22 Thread Giuseppe Bilotta
The pipe's get_vendor method returns something more akin to a driver vendor string in most cases, instead of the actual device vendor. Use get_device_vendor instead, which was introduced specifically for this purpose. Signed-off-by: Giuseppe Bilotta giuseppe.bilo...@gmail.com Reviewed-by: Michel

[Mesa-dev] [PATCH 2/4] gallium: introduce get_device_vendor() entrypoint for pipes

2015-03-22 Thread Giuseppe Bilotta
This will be needed by Clover to return the correct information to CL_DEVICE_VENDOR info queries. Signed-off-by: Giuseppe Bilotta giuseppe.bilo...@gmail.com Reviewed-by: Michel Dänzer michel.daen...@amd.com --- src/gallium/docs/source/screen.rst | 6 ++ src/gallium/include/pipe/p_screen.h

[Mesa-dev] [PATCHv5 0/4] Separate device from driver vendor

2015-03-22 Thread Giuseppe Bilotta
OpenCL (as opposed to OpenGL) has separate vendor strings for the implementation/driver/platform and the device. CL_PLATFORM_VENDOR is akin to the GL_VENDOR string, while CL_DEVICE_VENDOR is supposed to return the actual device vendor. (For example, the AMD OpenCL platform returns GenuineIntel as

[Mesa-dev] [PATCH 1/4] gallium: remove trailing whitespace in p_screen.h

2015-03-22 Thread Giuseppe Bilotta
Signed-off-by: Giuseppe Bilotta giuseppe.bilo...@gmail.com Reviewed-by: Michel Dänzer michel.daen...@amd.com --- src/gallium/include/pipe/p_screen.h | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-) diff --git a/src/gallium/include/pipe/p_screen.h b/src/gallium/include/pipe/p_screen.h

[Mesa-dev] [Bug 89705] lp_bld_debug.cpp:280:54: error: no matching function for call to ‘llvm?=::TargetMachine::getSubtargetImpl()=?UTF-8?Q?’

2015-03-22 Thread bugzilla-daemon
https://bugs.freedesktop.org/show_bug.cgi?id=89705 Vinson Lee v...@freedesktop.org changed: What|Removed |Added Keywords||bisected --- Comment

Re: [Mesa-dev] [RFC] More ARB_arrays_of_arrays support

2015-03-22 Thread Timothy Arceri
On Sat, 2015-03-21 at 20:06 -0400, Ilia Mirkin wrote: Patches 1, 2, 3, 4, 8, and 11 are Reviewed-by: Ilia Mirkin imir...@alum.mit.edu The rest I sent comments on, although even if you address my feedback, I'm not sufficiently familiar to r-b at least some of them. Thanks for the reviews.

[Mesa-dev] [PATCH 00/11] Initial glsl + i965 barrier support

2015-03-22 Thread Jordan Justen
git://people.freedesktop.org/~jljusten/mesa i965-barrier-v1 These have been tested with CS on gen7 gen8. There is more glsl barrer() work with regards to control flow requirements, but I think Chris already has some support for this in his TS branch. (CS will require some tweaks to that as

[Mesa-dev] [PATCH 04/11] i965: Add GATEWAY_SFID definitions

2015-03-22 Thread Jordan Justen
Signed-off-by: Jordan Justen jordan.l.jus...@intel.com Reviewed-by: Chris Forbes chr...@ijw.co.nz --- src/mesa/drivers/dri/i965/brw_defines.h | 8 1 file changed, 8 insertions(+) diff --git a/src/mesa/drivers/dri/i965/brw_defines.h b/src/mesa/drivers/dri/i965/brw_defines.h index

[Mesa-dev] [PATCH 10/11] i965/fs: Implement support for ir_barrier

2015-03-22 Thread Jordan Justen
Signed-off-by: Jordan Justen jordan.l.jus...@intel.com Reviewed-by: Chris Forbes chr...@ijw.co.nz --- src/mesa/drivers/dri/i965/brw_defines.h| 5 + src/mesa/drivers/dri/i965/brw_fs.h | 3 +++ src/mesa/drivers/dri/i965/brw_fs_generator.cpp | 11 +++

[Mesa-dev] [PATCH 02/11] glsl: Add builtin barrier() function

2015-03-22 Thread Jordan Justen
From: Chris Forbes chr...@ijw.co.nz [jordan.l.jus...@intel.com: Add CS support] Signed-off-by: Jordan Justen jordan.l.jus...@intel.com --- src/glsl/builtin_functions.cpp | 29 + 1 file changed, 29 insertions(+) diff --git a/src/glsl/builtin_functions.cpp

[Mesa-dev] [PATCH 11/11] i965/nir: Support barrier intrinsic function

2015-03-22 Thread Jordan Justen
Signed-off-by: Jordan Justen jordan.l.jus...@intel.com Reviewed-by: Chris Forbes chr...@ijw.co.nz --- src/mesa/drivers/dri/i965/brw_fs_nir.cpp | 4 1 file changed, 4 insertions(+) diff --git a/src/mesa/drivers/dri/i965/brw_fs_nir.cpp b/src/mesa/drivers/dri/i965/brw_fs_nir.cpp index

[Mesa-dev] [PATCH 01/11] glsl: Add ir node for barrier

2015-03-22 Thread Jordan Justen
From: Chris Forbes chr...@ijw.co.nz [jordan.l.jus...@intel.com: Add nir support] Signed-off-by: Jordan Justen jordan.l.jus...@intel.com --- src/glsl/ir.h | 24 src/glsl/ir_hierarchical_visitor.cpp | 9 +

[Mesa-dev] [PATCH 06/11] i965: Disassemble Gateway SEND messages

2015-03-22 Thread Jordan Justen
Signed-off-by: Jordan Justen jordan.l.jus...@intel.com Reviewed-by: Chris Forbes chr...@ijw.co.nz --- src/mesa/drivers/dri/i965/brw_disasm.c | 16 1 file changed, 16 insertions(+) diff --git a/src/mesa/drivers/dri/i965/brw_disasm.c b/src/mesa/drivers/dri/i965/brw_disasm.c index

[Mesa-dev] [PATCH 07/11] i965: Add notification register

2015-03-22 Thread Jordan Justen
This will be used by the wait instruction when implementing the barrier() function. Signed-off-by: Jordan Justen jordan.l.jus...@intel.com Reviewed-by: Chris Forbes chr...@ijw.co.nz --- src/mesa/drivers/dri/i965/brw_reg.h | 16 1 file changed, 16 insertions(+) diff --git

[Mesa-dev] [PATCH 05/11] i965/inst: Add notify and gateway_subfuncid fields

2015-03-22 Thread Jordan Justen
These fields will be used when emitting a send for the barrier function. Reference: IVB PRM Volume 4, Part 2, Section 1.1.1 Message Descriptor Signed-off-by: Jordan Justen jordan.l.jus...@intel.com Reviewed-by: Chris Forbes chr...@ijw.co.nz --- src/mesa/drivers/dri/i965/brw_inst.h | 18

[Mesa-dev] [PATCH 08/11] i965: Add brw_wait to emit wait instruction

2015-03-22 Thread Jordan Justen
This will be used to implement the barrier function. Signed-off-by: Jordan Justen jordan.l.jus...@intel.com Reviewed-by: Chris Forbes chr...@ijw.co.nz --- src/mesa/drivers/dri/i965/brw_eu.h | 2 ++ src/mesa/drivers/dri/i965/brw_eu_emit.c | 23 +++ 2 files changed, 25

[Mesa-dev] [PATCH 03/11] nir: Add barrier intrinsic function

2015-03-22 Thread Jordan Justen
Signed-off-by: Jordan Justen jordan.l.jus...@intel.com Reviewed-by: Chris Forbes chr...@ijw.co.nz --- src/glsl/nir/glsl_to_nir.cpp | 4 +++- src/glsl/nir/nir_intrinsics.h | 1 + 2 files changed, 4 insertions(+), 1 deletion(-) diff --git a/src/glsl/nir/glsl_to_nir.cpp

Re: [Mesa-dev] [PATCH 01/11] glsl: Add ir node for barrier

2015-03-22 Thread Matt Turner
On Sun, Mar 22, 2015 at 6:49 PM, Jordan Justen jordan.l.jus...@intel.com wrote: From: Chris Forbes chr...@ijw.co.nz [jordan.l.jus...@intel.com: Add nir support] Signed-off-by: Jordan Justen jordan.l.jus...@intel.com --- src/glsl/ir.h | 24

Re: [Mesa-dev] [PATCH 07/11] i965: Add notification register

2015-03-22 Thread Matt Turner
On Sun, Mar 22, 2015 at 6:49 PM, Jordan Justen jordan.l.jus...@intel.com wrote: This will be used by the wait instruction when implementing the barrier() function. Signed-off-by: Jordan Justen jordan.l.jus...@intel.com Reviewed-by: Chris Forbes chr...@ijw.co.nz ---

Re: [Mesa-dev] [PATCH 08/11] i965: Add brw_wait to emit wait instruction

2015-03-22 Thread Matt Turner
On Sun, Mar 22, 2015 at 6:49 PM, Jordan Justen jordan.l.jus...@intel.com wrote: This will be used to implement the barrier function. Signed-off-by: Jordan Justen jordan.l.jus...@intel.com Reviewed-by: Chris Forbes chr...@ijw.co.nz --- src/mesa/drivers/dri/i965/brw_eu.h | 2 ++

Re: [Mesa-dev] [PATCH 09/11] i965: Add brw_barrier to emit a Gateway Barrier SEND

2015-03-22 Thread Matt Turner
On Sun, Mar 22, 2015 at 6:49 PM, Jordan Justen jordan.l.jus...@intel.com wrote: This will be used to implement the Gateway Barrier SEND needed to implement the barrier function. Signed-off-by: Jordan Justen jordan.l.jus...@intel.com Reviewed-by: Chris Forbes chr...@ijw.co.nz ---

Re: [Mesa-dev] [PATCH 03/11] nir: Add barrier intrinsic function

2015-03-22 Thread Connor Abbott
Reviewed-by: Connor Abbott cwabbo...@gmail.com On Sun, Mar 22, 2015 at 9:49 PM, Jordan Justen jordan.l.jus...@intel.com wrote: Signed-off-by: Jordan Justen jordan.l.jus...@intel.com Reviewed-by: Chris Forbes chr...@ijw.co.nz --- src/glsl/nir/glsl_to_nir.cpp | 4 +++-

Re: [Mesa-dev] [PATCH 10/11] i965/fs: Implement support for ir_barrier

2015-03-22 Thread Chris Forbes
Jordan, You also need to set m0.2:15 (Barrier count enable) and m0.2:14-9 (Barrier count) to have the message gateway actually collect the proper number of threads, right? - Chris On Mon, Mar 23, 2015 at 2:49 PM, Jordan Justen jordan.l.jus...@intel.com wrote: Signed-off-by: Jordan Justen

Re: [Mesa-dev] [PATCH v3 5/7] i965: Add a NIR analysis pass for determining when a boolean resolve is needed

2015-03-22 Thread Connor Abbott
On Fri, Mar 20, 2015 at 5:23 PM, Jason Ekstrand ja...@jlekstrand.net wrote: v2: Fix the spelling of analyze and re-arrange code for better readability as per Connor's comments. v3: Make the naming of things more consistent and add a pile of comments ---

Re: [Mesa-dev] [PATCH v3 5/7] i965: Add a NIR analysis pass for determining when a boolean resolve is needed

2015-03-22 Thread Jason Ekstrand
On Mar 22, 2015 8:48 PM, Connor Abbott cwabbo...@gmail.com wrote: On Fri, Mar 20, 2015 at 5:23 PM, Jason Ekstrand ja...@jlekstrand.net wrote: v2: Fix the spelling of analyze and re-arrange code for better readability as per Connor's comments. v3: Make the naming of things more

Re: [Mesa-dev] [PATCH 17/18] i965/cs: Add max_cs_threads

2015-03-22 Thread Kenneth Graunke
On Sunday, March 22, 2015 12:39:25 PM Ben Widawsky wrote: On Sat, Mar 14, 2015 at 09:54:27PM -0700, Jordan Justen wrote: [snip] @@ -225,7 +229,8 @@ static const struct brw_device_info brw_device_info_hsw_gt3 = { .max_hs_threads = 504, \ .max_ds_threads =