RFC: DFA::StateMachine

2004-12-14 Thread David E . Wheeler
Hi All, Ovid and I were getting fed up with the horrible DFA::Simple module, so I wrote a new module, DFA::StateMachine, to take its place in our work. But I'm no computer scientist, so I'm not even sure whether the name is right or if the module functions the way a DFA state machine is

Re: DFA::StateMachine

2004-12-15 Thread David E . Wheeler
On Dec 15, 2004, at 11:00 AM, David Coppit wrote: Yes, but not in the traditional sense. Traditionally, you can only have 1 transition from a state for a given input. i.e. the model all by itself defines a deterministic behavior. What you actually have is model+algorithm defining a deterministic

ANN: FSA::Rules

2004-12-15 Thread David E . Wheeler
On Dec 15, 2004, at 12:43 PM, David E. Wheeler wrote: D'oh! I've already renamed it DFA::Rules in Subversion. Ah, well, at least it's easy to change. Look for the new module to be on CPAN later today. And here it is: The following report has been written by the PAUSE namespace indexer. Please

Re: DFA::StateMachine

2004-12-15 Thread David E . Wheeler
On Dec 15, 2004, at 12:00 PM, [EMAIL PROTECTED] wrote: - get_next_state() returns a new DFA object, which is in the next state. If there is no next state, it returns undef. What's that from? In version 2 I'll make the states objects. But this will do for now. :-) Regards, David

Re: RFC: DFA::StateMachine

2004-12-15 Thread David E . Wheeler
On Dec 15, 2004, at 3:56 PM, Paul Hoffman wrote: It seems to me that your code could be used to implement either a DFA or an NFA, so you might want to call it it an FSM. Algorithm::FSM, perhaps? Or maybe Decision::FSM?? I went with FSM::Rules. I think it's a good name, and falls in line, I

Re: DFA::StateMachine

2004-12-15 Thread David E . Wheeler
On Dec 15, 2004, at 9:42 AM, David E. Wheeler wrote: - Then define check() to be { self-attempt_transition() || croak ... } But a better name than check() would also be good. Ah, I guess you like the idea of attempt_transition() returning undef on failure but not die'ing, eh? I guess it'd

Re: DFA::StateMachine

2004-12-15 Thread David E . Wheeler
On Dec 15, 2004, at 12:02 PM, Ken Williams wrote: It short-circuits and there's no backtracking? That's odd. Seems like that should be stated in the docs somewhere, since that's how most people expect an FSA to work. I'm expanding the docs now, even as I incorporate people's suggestions. In

Re: DFA::StateMachine

2004-12-16 Thread David E . Wheeler
On Dec 16, 2004, at 4:16 AM, [EMAIL PROTECTED] wrote: In version 2 I'll make the states objects. But this will do for now. :-) I mean making the whole DFA an object. Once you can return a whole DFA, you could easily explore states and do backtracking in a higher level of abstraction. Yes, I had

Re: [RESEND] Machine-Manipulatable Arguments for Module::Build

2008-08-03 Thread David E. Wheeler
On Aug 2, 2008, at 13:40, David E. Wheeler wrote: 2. Not capabale of being manipulated by an external program - Only perl can understand Perl, etc.. It looks like M::B does not current put the keywords into the META.yml file when you run `make distmeta`. It ought to. Actually, I

Re: [RESEND] Machine-Manipulatable Arguments for Module::Build

2008-08-03 Thread David E. Wheeler
On Aug 3, 2008, at 05:19, Shlomi Fish wrote: Hmmm... that's interesting. Sounds useful. Is it supported in search.cpan.org/kobesearch yet? Of course, I'd also like to have Freshmeat-like categories: http://freshmeat.net/browse/18/ You would need to get them into the META spec, I think.

Re: [RESEND] Machine-Manipulatable Arguments for Module::Build

2008-08-03 Thread David E. Wheeler
On Aug 2, 2008, at 07:17, Shlomi Fish wrote: http://xrl.us/bi6n9 (link to svn.berlios.de) is a functional spec for a way to tag and classify CPAN modules. Those tags and catgories should end up in the META.yml. However, inserting them by hand by editing the Build.PL will be: You are

Re: Distributing the CPAN

2010-04-01 Thread David E. Wheeler
On Apr 1, 2010, at 1:12 PM, Tim Bunce wrote: Yes, I was envisaging something like gitPAN. Though if this took off then moving the tarball-git import logic to the PAUSE server would probably be a good idea. /me stashes these ideas away for PGANā€¦