Re: [MSEide-MSEgui-talk] MSElang, procedures and functions

2013-11-25 Thread Michael Schnell
On 11/22/2013 06:25 PM, August Oktobar wrote: What about multiple return values (e.g. in Golang)? ... In effect making function results out variables. With that you also could vote for deamons (the previous value of the variable to be set by a function can be seen within a function, in

Re: [MSEide-MSEgui-talk] MSElang, procedures and functions

2013-11-25 Thread Michael Schnell
On 11/22/2013 06:52 PM, Ivanko B wrote: How looks the call of the function? == Smth like in Python: (var1,var2):= MultResFunc(arg1,arg2); In Python, the (var1,var2) syntax has other effects on it's own, as well IIRC, in a language I used some 100 years ago (called PLZ

Re: [MSEide-MSEgui-talk] MSElang, objects

2013-11-25 Thread Martin Schreiber
On Monday 25 November 2013 09:30:36 Michael Schnell wrote: On 11/22/2013 06:55 PM, Martin Schreiber wrote: {$rtti on} property prop1: int32 read fprop1 write fprop1; //streamed {$rtti off} To me this looks worse than just published (it does not make much sense to allow for rtti

Re: [MSEide-MSEgui-talk] MSElang, procedures and functions

2013-11-25 Thread Michael Schnell
On 11/25/2013 09:36 AM, Michael Schnell wrote: With that you also could vote for deamons (the previous value of the variable to be set by a function can be seen within a function, in effect making function results var variables. Sorry, this was incorrect. Daemons in this context are

Re: [MSEide-MSEgui-talk] MSElang, procedures and functions

2013-11-25 Thread Michael Schnell
On 11/24/2013 08:44 AM, Martin Schreiber wrote: On Saturday 23 November 2013 21:23:11 Ivanko B wrote: := 'The string result: '+avalue; = := instead of exposing Result ? Looks interesting. It is mandatory and allowed as last statement only. I also think this is a nice idea.

Re: [MSEide-MSEgui-talk] MSElang, procedures and functions

2013-11-25 Thread Michael Schnell
On 11/24/2013 02:48 PM, Marcos Douglas wrote: But if 'return' exists, why I will use ':= value'??? Two ways to do the same? ...like in C ? return lvalue; might be a synonym for := lrvalue; return; -Michael -- Shape

Re: [MSEide-MSEgui-talk] MSElang, procedures and functions

2013-11-25 Thread Michael Schnell
.. or := lrvalue; exit; -Michael -- Shape the Mobile Experience: Free Subscription Software experts and developers: Be at the forefront of tech innovation. Intel(R) Software Adrenaline delivers strategic insight and

Re: [MSEide-MSEgui-talk] MSElang, procedures and functions

2013-11-25 Thread Michael Schnell
On 11/24/2013 05:21 PM, Marcos Douglas wrote: I disagree that a program without 'return' or 'exit' uses a more safe coding style. +1; you often would need to use break and/or clumsy constructs using flags or even goto. IMHO, each of this makes the code less readable. -Michael

Re: [MSEide-MSEgui-talk] MSElang, procedures and functions

2013-11-25 Thread Michael Schnell
On 11/24/2013 05:41 PM, Ivanko B wrote: Also how about BREAK(nesting_level) NEXT(nesting_level) ? Some languages provide that and one is quite handy. Nesting levels are just horrible, as you will regularly forget to change them appropriately when you add a new nesting level to your code.

Re: [MSEide-MSEgui-talk] MSElang, procedures and functions

2013-11-25 Thread Martin Schreiber
On Monday 25 November 2013 10:24:40 Michael Schnell wrote: On 11/24/2013 05:21 PM, Marcos Douglas wrote: I disagree that a program without 'return' or 'exit' uses a more safe coding style. +1; you often would need to use break and/or clumsy constructs using flags or even goto. IMHO,

Re: [MSEide-MSEgui-talk] MSElang, procedures and functions

2013-11-25 Thread Michael Schnell
On 11/25/2013 10:43 AM, Martin Schreiber wrote: You and Marcos probably never had to debug code with common necessary cleanup at procedure end and a deeply nested sometimes triggered 'exit' which bypassed the cleanup accidentally. It happened several times to me... I do see the argument

Re: [MSEide-MSEgui-talk] MSElang, procedures and functions

2013-11-25 Thread Marcos Douglas
On Mon, Nov 25, 2013 at 7:12 AM, Michael Schnell mschn...@lumino.de wrote: On 11/25/2013 10:43 AM, Martin Schreiber wrote: You and Marcos probably never had to debug code with common necessary cleanup at procedure end and a deeply nested sometimes triggered 'exit' which bypassed the cleanup

[MSEide-MSEgui-talk] MSEide: including into MFM files

2013-11-25 Thread Ivanko B
A project maintained via a GIT repository. WORK: IDE DB-setup variant 1 HOME: IDE DB-setup variant 2 which differs from the WORK To avoid GIT insonsistence (overiding the DB-setup in MFM-file at other workplace on GIT PULL), and to avoid errors on loading the project to IDE, we could put the

Re: [MSEide-MSEgui-talk] MSEide: including into MFM files

2013-11-25 Thread Martin Schreiber
On Monday 25 November 2013 14:22:00 Ivanko B wrote: A project maintained via a GIT repository. WORK: IDE DB-setup variant 1 HOME: IDE DB-setup variant 2 which differs from the WORK To avoid GIT insonsistence (overiding the DB-setup in MFM-file at other workplace on GIT PULL), and to avoid

Re: [MSEide-MSEgui-talk] MSEide: including into MFM files

2013-11-25 Thread Ivanko B
Try to make a local branch with the HOME DB-setup. === Any suggesion how to share GIT PUSH GIT PULL for the two versions provided that really only a single MFM file needs the special handling ? --

Re: [MSEide-MSEgui-talk] MSEide: including into MFM files

2013-11-25 Thread Ivanko B
a single MFM file needs the special handling == BTW, this file is largest most complicated file in the project (DMMAINMO in the PODPISKA). Editing checking it twice is boring error-prone :) -- Shape

Re: [MSEide-MSEgui-talk] MSEide: including into MFM files

2013-11-25 Thread Martin Schreiber
On Monday 25 November 2013 16:44:50 Ivanko B wrote: Try to make a local branch with the HOME DB-setup. === Any suggesion how to share GIT PUSH GIT PULL for the two versions provided that really only a single MFM file needs the special handling ? I don't know, I use

Re: [MSEide-MSEgui-talk] MSEide: including into MFM files

2013-11-25 Thread Ivanko B
a unit for the connection component only. == Or MFM-including :) -- Shape the Mobile Experience: Free Subscription Software experts and developers: Be at the forefront of tech innovation. Intel(R) Software