[Spice-devel] [PATCH v2 04/11] drm/atomic: Pass the full state to planes atomic_check

2021-01-21 Thread Maxime Ripard
@ no_include depends on !include && adds_new_state @ @@ + #include #include Reviewed-by: Laurent Pinchart Signed-off-by: Maxime Ripard --- Changes from v1: - Rewording and removal of a coccinelle rule suggested by Laurent --- drivers/gpu/drm/amd/display/amdgpu_dm/amdgpu_dm.c |

[Spice-devel] [PATCH v2 07/11] drm: Store new plane state in a variable for atomic_update and disable

2021-01-21 Thread Maxime Ripard
s; @@ func(struct drm_plane *plane, struct drm_plane_state *old_s) { + struct drm_plane_state *new_s = plane->state; <+... - plane->state + new_s ...+> } Reviewed-by: Laurent Pinchart Signed-off-by: Maxime Ripard --- Changes from v1: - Wrapping cha

[Spice-devel] [PATCH v2 02/11] drm: Rename plane atomic_check state names

2021-01-21 Thread Maxime Ripard
} Reviewed-by: Laurent Pinchart Signed-off-by: Maxime Ripard --- Changes from v1: - Updated the variable name in the comment in omapdrm --- .../gpu/drm/amd/display/amdgpu_dm/amdgpu_dm.c | 13 +++--- .../gpu/drm/arm/display/komeda/komeda_plane.c | 11 ++--- drivers/gpu/drm/arm/hdlcd_crtc.c

[Spice-devel] [PATCH v2 10/11] drm: Use state helper instead of the plane state pointer

2021-01-21 Thread Maxime Ripard
e Signed-off-by: Maxime Ripard --- drivers/gpu/drm/arc/arcpgu_crtc.c | 4 +++- drivers/gpu/drm/arm/hdlcd_crtc.c| 3 ++- drivers/gpu/drm/arm/malidp_planes.c | 3 ++- drivers/gpu/drm/armada/armada_overlay.c | 3 ++- drivers/gpu/drm/armada/armada_plane.c

[Spice-devel] [PATCH v2 09/11] drm/atomic: Pass the full state to planes atomic disable and update

2021-01-21 Thread Maxime Ripard
t;state + state ...+> } Signed-off-by: Maxime Ripard --- Changes from v1: - Reintroduce the old_plane_state check in zynqmp_disp_crtc_atomic_disable --- drivers/gpu/drm/arc/arcpgu_crtc.c | 2 +- drivers/gpu/drm/arm/display/komeda/komeda_plane.c | 2 +- drive

[Spice-devel] [PATCH 07/10] drm: Store new plane state in a variable for atomic_update and disable

2021-01-15 Thread Maxime Ripard
s; @@ func(struct drm_plane *plane, struct drm_plane_state *old_s) { + struct drm_plane_state *new_s = plane->state; <+... - plane->state + new_s ...+> } Signed-off-by: Maxime Ripard --- drivers/gpu/drm/arc/arcpgu_crtc.c | 7 ++-- dr

[Spice-devel] [PATCH 02/10] drm: Rename plane atomic_check state names

2021-01-15 Thread Maxime Ripard
Signed-off-by: Maxime Ripard --- .../gpu/drm/amd/display/amdgpu_dm/amdgpu_dm.c | 13 +++--- .../gpu/drm/arm/display/komeda/komeda_plane.c | 11 ++--- drivers/gpu/drm/arm/hdlcd_crtc.c | 18 drivers/gpu/drm/arm/malidp_planes.c | 36 drivers/gp

[Spice-devel] [PATCH 04/10] drm/atomic: Pass the full state to planes atomic_check

2021-01-15 Thread Maxime Ripard
!include && adds_new_state @ @@ + #include #include Signed-off-by: Maxime Ripard --- drivers/gpu/drm/amd/display/amdgpu_dm/amdgpu_dm.c | 4 +++- drivers/gpu/drm/arm/display/komeda/komeda_plane.c | 4 +++- drivers/gpu/drm/arm/hdlcd_crtc.c | 4 +++- drivers/gpu/drm/arm

[Spice-devel] [PATCH 09/10] drm/atomic: Pass the full state to planes atomic disable and update

2021-01-15 Thread Maxime Ripard
.. - plane_state->state + state ...+> } Signed-off-by: Maxime Ripard --- drivers/gpu/drm/arc/arcpgu_crtc.c | 2 +- .../gpu/drm/arm/display/komeda/komeda_plane.c | 2 +- drivers/gpu/drm/arm/hdlcd_crtc.c | 2 +- drivers/gpu/drm/arm/malidp_planes.c |

[Spice-devel] [PATCH 10/10] drm: Use state helper instead of the plane state pointer

2021-01-15 Thread Maxime Ripard
e Signed-off-by: Maxime Ripard --- drivers/gpu/drm/arc/arcpgu_crtc.c | 4 +++- drivers/gpu/drm/arm/hdlcd_crtc.c| 3 ++- drivers/gpu/drm/arm/malidp_planes.c | 3 ++- drivers/gpu/drm/armada/armada_overlay.c | 3 ++- drivers/gpu/drm/armada/armada_plane.c

Re: [Spice-devel] [PATCH 0/4] drm: Generic dumb_map_offset for TTM-based drivers

2021-04-08 Thread Maxime Ripard
On Tue, Apr 06, 2021 at 10:29:38AM +0200, Thomas Zimmermann wrote: > The implementation of drm_driver.dumb_map_offset is the same for several > TTM-based drivers. Provide a common function in GEM-TTM helpers. For the series: Acked-by: Maxime Ripard Maxime signature.asc Descriptio

[Spice-devel] [PATCH v3 04/11] drm/atomic: Pass the full state to planes atomic_check

2021-02-19 Thread Maxime Ripard
@ no_include depends on !include && adds_new_state @ @@ + #include #include Reviewed-by: Laurent Pinchart Signed-off-by: Maxime Ripard --- Changes from v1: - Rewording and removal of a coccinelle rule suggested by Laurent --- drivers/gpu/drm/amd/display/amdgpu_dm/amdgpu_dm.c |

[Spice-devel] [PATCH v3 07/11] drm: Store new plane state in a variable for atomic_update and disable

2021-02-19 Thread Maxime Ripard
s; @@ func(struct drm_plane *plane, struct drm_plane_state *old_s) { + struct drm_plane_state *new_s = plane->state; <+... - plane->state + new_s ...+> } Reviewed-by: Laurent Pinchart Signed-off-by: Maxime Ripard --- Changes from v1: - Wrapping cha

[Spice-devel] [PATCH v3 02/11] drm: Rename plane atomic_check state names

2021-02-19 Thread Maxime Ripard
} Reviewed-by: Laurent Pinchart Signed-off-by: Maxime Ripard --- Changes from v1: - Updated the variable name in the comment in omapdrm --- .../gpu/drm/amd/display/amdgpu_dm/amdgpu_dm.c | 13 +++--- .../gpu/drm/arm/display/komeda/komeda_plane.c | 11 ++--- drivers/gpu/drm/arm/hdlcd_crtc.c

[Spice-devel] [PATCH v3 09/11] drm/atomic: Pass the full state to planes atomic disable and update

2021-02-19 Thread Maxime Ripard
state + state ...+> } Reviewed-by: Laurent Pinchart Signed-off-by: Maxime Ripard --- Changes from v1: - Reintroduce the old_plane_state check in zynqmp_disp_crtc_atomic_disable --- drivers/gpu/drm/arc/arcpgu_crtc.c | 2 +- drivers/gpu/drm/arm/display/k

[Spice-devel] [PATCH v3 10/11] drm: Use state helper instead of the plane state pointer

2021-02-19 Thread Maxime Ripard
ude Reviewed-by: Ville Syrjälä Signed-off-by: Maxime Ripard --- drivers/gpu/drm/arc/arcpgu_crtc.c | 4 +++- drivers/gpu/drm/arm/hdlcd_crtc.c| 3 ++- drivers/gpu/drm/arm/malidp_planes.c | 3 ++- drivers/gpu/drm/armada/armada_overlay.c | 3 ++- drivers/

Re: [Spice-devel] [PATCH v3 02/11] drm: Rename plane atomic_check state names

2021-02-19 Thread Maxime Ripard
Hi Thomas, Thanks for your review! On Fri, Feb 19, 2021 at 03:49:22PM +0100, Thomas Zimmermann wrote: > > diff --git a/drivers/gpu/drm/imx/ipuv3-plane.c > > b/drivers/gpu/drm/imx/ipuv3-plane.c > > index 075508051b5f..1873a155bb26 100644 > > --- a/drivers/gpu/drm/imx/ipuv3-plane.c > > +++

Re: [Spice-devel] [RFT PATCH 2/6] drm: Call drm_atomic_helper_shutdown() at shutdown time for misc drivers

2023-09-04 Thread Maxime Ripard
anly powered off at system shutdown time. > > > [ ... ] Acked-by: Maxime Ripard Thanks! Maxime

Re: [Spice-devel] [RESEND PATCH] drm/qxl: prevent memory leak

2023-11-06 Thread Maxime Ripard
On Tue, 01 Aug 2023 10:53:09 +0800, Zongmin Zhou wrote: > The allocated memory for qdev->dumb_heads should be released > in qxl_destroy_monitors_object before qxl suspend. > otherwise,qxl_create_monitors_object will be called to > reallocate memory for qdev->dumb_heads after qxl resume, > it will

Re: [Spice-devel] [PATCH RFC v1 00/52] drm/crtc: Rename struct drm_crtc::dev to drm_dev

2023-07-12 Thread Maxime Ripard
On Wed, Jul 12, 2023 at 01:02:53PM +0200, Uwe Kleine-König wrote: > > Background is that this makes merge conflicts easier to handle and detect. > > Really? FWIW, I agree with Christian here. > Each file (apart from include/drm/drm_crtc.h) is only touched once. So > unless I'm missing something

Re: [Spice-devel] [PATCH RFC v1 00/52] drm/crtc: Rename struct drm_crtc::dev to drm_dev

2023-07-12 Thread Maxime Ripard
On Wed, Jul 12, 2023 at 03:38:03PM +0200, Uwe Kleine-König wrote: > Hello Maxime, > > On Wed, Jul 12, 2023 at 02:52:38PM +0200, Maxime Ripard wrote: > > On Wed, Jul 12, 2023 at 01:02:53PM +0200, Uwe Kleine-König wrote: > > > > Background is that this makes merge

Re: [Spice-devel] [Freedreno] [PATCH RFC v1 00/52] drm/crtc: Rename struct drm_crtc::dev to drm_dev

2023-07-16 Thread Maxime Ripard
On Thu, Jul 13, 2023 at 04:14:55PM +0100, Tvrtko Ursulin wrote: > > On 13/07/2023 16:09, Thomas Zimmermann wrote: > > Hi > > > > Am 13.07.23 um 16:41 schrieb Sean Paul: > > > On Thu, Jul 13, 2023 at 9:04 AM Uwe Kleine-König > > > wrote: > > > > > > > > hello Sean, > > > > > > > > On Wed, Jul

Re: [Spice-devel] [PATCH] drm/qxl: remove unused declaration

2023-12-05 Thread Maxime Ripard
On Fri, 10 Nov 2023 13:50:31 +0800, heminhong wrote: > Some functions are never used by the driver, > removing the functions declaration, it can be reducing program size, > and improving code readability and maintainability. > > Applied to drm/drm-misc (drm-misc-next). Thanks! Maxime

Re: (subset) [PATCH v2 1/1] Revert "drm/qxl: simplify qxl_fence_wait"

2024-04-06 Thread Maxime Ripard
On Thu, 04 Apr 2024 19:14:48 +0100, Alex Constantino wrote: > This reverts commit 5a838e5d5825c85556011478abde708251cc0776. > > Changes from commit 5a838e5d5825 ("drm/qxl: simplify qxl_fence_wait") would > result in a '[TTM] Buffer eviction failed' exception whenever it reached a > timeout. > Due

Re: [PATCH 1/1] drm/qxl: fixes qxl_fence_wait

2024-03-28 Thread Maxime Ripard
Hi, On Wed, Mar 20, 2024 at 04:25:48PM +0100, Linux regression tracking (Thorsten Leemhuis) wrote: > On 08.03.24 02:08, Alex Constantino wrote: > > Fix OOM scenario by doing multiple notifications to the OOM handler through > > a busy wait logic. > > Changes from commit 5a838e5d5825 ("drm/qxl:

Re: [PATCH 1/2] drm/qxl: remove unused `count` variable from `qxl_surface_id_alloc()`

2024-03-28 Thread Maxime Ripard
On Wed, Mar 27, 2024 at 07:14:12PM +0100, Miguel Ojeda wrote: > On Wed, Mar 27, 2024 at 6:56 PM Miguel Ojeda wrote: > > > > Closes: > > https://lore.kernel.org/lkml/caniq72mjc5t4n25sqvysroehxxpxypz4ppznesjhenc3qap...@mail.gmail.com/ > > Should have a [1] at the end. I added it while committing

Re: drivers/gpu/drm/qxl/qxl_cmd.c:424:6: error: variable 'count' set but not used

2024-03-27 Thread Maxime Ripard
Hi Miguel, On Tue, Mar 26, 2024 at 07:04:34PM +0100, Miguel Ojeda wrote: > Hi, > > In today's next, I got: > > drivers/gpu/drm/qxl/qxl_cmd.c:424:6: error: variable 'count' set > but not used [-Werror,-Wunused-but-set-variable] > > `count` seems to be there since commit f64122c1f6ad ("drm: