Re: fix arm64 format strings

2017-08-08 Thread Mark Kettenis
> Date: Wed, 9 Aug 2017 14:01:25 +1000 > From: Jonathan Gray > > Make the kernel build on arm64 again after the recent kprintf changes > in clang. ok kettenis@ > Index: arm64/cpu.c > === > RCS file:

fix arm64 format strings

2017-08-08 Thread Jonathan Gray
Make the kernel build on arm64 again after the recent kprintf changes in clang. Index: arm64/cpu.c === RCS file: /cvs/src/sys/arch/arm64/arm64/cpu.c,v retrieving revision 1.5 diff -u -p -r1.5 cpu.c --- arm64/cpu.c 6 May 2017 11:27:34

Re: ifstated: add handing of departed interfaces

2017-08-08 Thread Rob Pierce
On Tue, Aug 08, 2017 at 12:12:43AM +0200, Jeremie Courreges-Anglas wrote: > On Sun, Aug 06 2017, Rob Pierce wrote: > > The following diff adds support for detecting the state change of a departed > > interface. ifstated is not a very verbose daemon, so this diff quietly does > >

faq/ports/guide: Remove stray comment

2017-08-08 Thread Klemens Nanni
Index: guide.html === RCS file: /cvs/www/faq/ports/guide.html,v retrieving revision 1.73 diff -u -p -r1.73 guide.html --- guide.html 8 Aug 2017 15:48:56 - 1.73 +++ guide.html 9 Aug 2017 00:13:22 - @@ -808,7 +808,7 @@

reach dwc2_debug via usb.c

2017-08-08 Thread Artturi Alm
Hi, small diff below for what the subject suggests. Now i'm unsure if arm64 does really ever use the uhci it has on pci*, but something like this would work for atleast octeon && armv7 i think? -Artturi diff --git a/sys/dev/usb/usb.c b/sys/dev/usb/usb.c index 8139db6a4ae..f4462fe71fe 100644 ---

we are no longer generating privacy addresses in the kernel

2017-08-08 Thread Florian Obser
OK? diff --git sys/netinet6/nd6.c sys/netinet6/nd6.c index 245b64c6155..77bcd1c5fda 100644 --- sys/netinet6/nd6.c +++ sys/netinet6/nd6.c @@ -969,9 +969,6 @@ nd6_ioctl(u_long cmd, caddr_t data, struct ifnet *ifp) switch (cmd) { case SIOCGIFINFO_IN6: ndi->ndi =

nd6_rtr.c no longer needs nd6_recalc_reachtm_interval

2017-08-08 Thread Florian Obser
OK? diff --git sys/netinet6/nd6_rtr.c sys/netinet6/nd6_rtr.c index 886436ae863..3542964215d 100644 --- sys/netinet6/nd6_rtr.c +++ sys/netinet6/nd6_rtr.c @@ -59,8 +59,6 @@ int rt6_deleteroute(struct rtentry *, void *, unsigned int); -extern int nd6_recalc_reachtm_interval; - /* * Receive

Re: fstat output

2017-08-08 Thread Theo de Raadt
> $ fstat -f /tmp > USER CMDPID FD MOUNTINUM MODE R/W > SZ|DV > mpi fstat571461 /tmp 23 -rw-r--r--w > 16 Well that won't work. Try it a standard 80-wide console. Every line wraps, reducing the visible context

faq/ports/guide: Improve wording

2017-08-08 Thread Klemens Nanni
This way it's feels much more natural to say. Feedback? Index: guide.html === RCS file: /cvs/www/faq/ports/guide.html,v retrieving revision 1.72 diff -u -p -r1.72 guide.html --- guide.html 7 Aug 2017 22:27:51 - 1.72 +++

Re: fstat output

2017-08-08 Thread Martin Pieuchot
On 02/08/17(Wed) 09:34, Todd C. Miller wrote: > On Wed, 02 Aug 2017 11:01:38 +0200, Alexander Bluhm wrote: > > > On Wed, Aug 02, 2017 at 09:56:50AM +0200, Martin Pieuchot wrote: > > > Simple diff to improved readability. Before: > > > > There are situations where you want a full match on the

Re: Improve the accuracy of the TSC frequency calibration (Was: Calculate the frequency of the tsc timecounter)

2017-08-08 Thread Mike Belopuhov
On Tue, Aug 08, 2017 at 08:18 +0800, Adam Steen wrote: > On Mon, Jul 31, 2017 at 3:58 PM, Mike Belopuhov wrote: > > On Mon, Jul 31, 2017 at 09:48 +0800, Adam Steen wrote: > >> Ted Unangst wrote: > >> > we don't currently export this info, but we could add some sysctls. > >>

Re: [diff] httpd: tls client cert & CRL checks

2017-08-08 Thread Jack Burton
On Tue, 8 Aug 2017 15:10:36 +0930 Jack Burton wrote: > On Tue, 08 Aug 2017 14:23:02 +1000 > Joel Sing wrote: > > On Saturday 29 July 2017 20:49:18 Jan Klemkow wrote: > > > In the End, I found and fixed the real bug here: > > > > > > @@ -430,7 +438,11 @@

Re: ip local input queue length

2017-08-08 Thread Claudio Jeker
On Tue, Aug 08, 2017 at 01:27:27PM +0200, Alexander Bluhm wrote: > On Tue, Aug 08, 2017 at 12:00:58AM +0200, Alexander Bluhm wrote: > > By increasing this value from 256 to 2048 I get much better results. > > Now with a define instead of a magic value. > > I think the if_congestion algorithm is

Re: ip local input queue length

2017-08-08 Thread Alexander Bluhm
On Tue, Aug 08, 2017 at 12:00:58AM +0200, Alexander Bluhm wrote: > By increasing this value from 256 to 2048 I get much better results. Now with a define instead of a magic value. I think the if_congestion algorithm is not compatible with the way the network stack works now. But to make

rtadvd: simplify route message handling

2017-08-08 Thread Jeremie Courreges-Anglas
So rtadvd has this complex code that tries to parse multiple routing messages, when it actually reads only one message at a time from the routing socket. The diff below attempts to acknowledge this and tries to be as mechanical as possible, variable renaming/gc'ing can happen later. Better use

Re: rtadvd: reschedule timer when a new prefix is added

2017-08-08 Thread Florian Obser
OK florian@ On Tue, Aug 08, 2017 at 03:12:14AM +0200, Jeremie Courreges-Anglas wrote: > > ra_timer_update() just updates rai->timer.tm, we need to call > evtimer_add(3) for the new timeout to be scheduled. I missed > this one when converting rtadvd to libevent. ok? > > > Index: config.c >

Re: run nd6_expire when needed

2017-08-08 Thread Florian Obser
On Mon, Aug 07, 2017 at 06:29:25PM +0200, Alexander Bluhm wrote: > On Mon, Aug 07, 2017 at 02:30:19PM +, Florian Obser wrote: > > On Mon, Aug 07, 2017 at 03:51:00PM +0200, Alexander Bluhm wrote: > > > On Mon, Aug 07, 2017 at 08:07:33AM +, Florian Obser wrote: > > > > index