[U-Boot] [PATCH] blackfin: Move machine specific gpio_port_t structure back to blackfin arch folder.

2013-10-23 Thread Sonic Zhang
From: Steven Miao real...@gmail.com The gpio register mappings are different among blackfin processors. Signed-off-by: Steven Miao real...@gmail.com Signed-off-by: Sonic Zhang sonic.zh...@analog.com --- arch/blackfin/cpu/Makefile | 2 +- arch/blackfin/cpu/gpio.c | 17

[U-Boot] Fwd: [PATCH 1/6] exynos_fb: Remove usage of static defines

2013-10-23 Thread Ajay kumar
Hi Simon, On Wed, Oct 16, 2013 at 10:04 PM, Simon Glass s...@chromium.org wrote: Hi Ajay, [once more from the right address] On Mon, Sep 30, 2013 at 5:20 AM, Ajay Kumar ajaykumar...@samsung.com wrote: Previously, we used to statically assign values for vl_col, vl_row and vl_bpix

[U-Boot] [PATCH 03/15] pcnet: s/le16_to_cpu/cpu_to_le16/ in pcnet_send

2013-10-23 Thread Paul Burton
This should cause no change to the generated code, but is semantically correct. Signed-off-by: Paul Burton paul.bur...@imgtec.com --- drivers/net/pcnet.c | 4 ++-- 1 file changed, 2 insertions(+), 2 deletions(-) diff --git a/drivers/net/pcnet.c b/drivers/net/pcnet.c index a30a0bc..843a6fc

[U-Boot] [PATCH 02/15] pcnet: code style cleanup

2013-10-23 Thread Paul Burton
Fix up the code to match Documentation/CodingStyle. This is mostly removing extraneous spaces. No functional change is intended. Signed-off-by: Paul Burton paul.bur...@imgtec.com --- drivers/net/pcnet.c | 248 ++-- 1 file changed, 123

[U-Boot] [PATCH 00/15] MIPS Malta board support

2013-10-23 Thread Paul Burton
This series adds support for booting on a physical MIPS Malta board using a coreFPGA6 core card. The first 6 patches lay some groundwork, then the next 8 genericise the existing qemu-malta board to also function on a physical Malta. In the final patch I stake my claim upon, errm I mean step up

[U-Boot] [PATCH 04/15] pcnet: add cache flushing invalidation

2013-10-23 Thread Paul Burton
Ensure that the view of memory from the CPU the ethernet controller is coherent at the various points where they exchange data. This prevents stale data from being transmitted or received, and prevents the driver from getting stuck waiting for the ethernet controller to update descriptors when in

[U-Boot] [PATCH 01/15] mips32: detect L1 cache sizes if they're not defined

2013-10-23 Thread Paul Burton
For boards such as the MIPS Malta with an FPGA core card it is desirable to be able to detect the L1 cache sizes at runtime, since they are not dependant upon the board but on the FPGA bitstream in use. This patch performs that detection when the CONFIG_SYS_[DI]CACHE_SIZE macros are not defined by

[U-Boot] [PATCH 06/15] pci.h: allow inclusion in assembly source

2013-10-23 Thread Paul Burton
This patch simply #ifdef's out the C-specific parts of pci.h when it is included by an assembly file. This will allow the macros it contains to be used from assembly source as will be done in a followup commit adding support for more modern MIPS Malta boards. Signed-off-by: Paul Burton

[U-Boot] [PATCH 08/15] malta: setup super I/O UARTs

2013-10-23 Thread Paul Burton
On a real Malta the Super I/O needs to be configured before we are able to access the UARTs. This patch performs that configuration, setting up the UARTs in the same way that YAMON would. Signed-off-by: Paul Burton paul.bur...@imgtec.com --- board/malta/Makefile | 2 +- board/malta/malta.c |

[U-Boot] [PATCH 05/15] pcnet: enable the NOUFLO feature

2013-10-23 Thread Paul Burton
On relatively slow boards (such as the MIPS Malta with an FPGA core card) it can be extremely common for transmits to underflow - to the point where it appears they simply do not work at all. Setting the NOUFLO bit causes the ethernet controller to not begin transmission on the wire until a

[U-Boot] [PATCH 09/15] malta: support for coreFPGA6 boards

2013-10-23 Thread Paul Burton
This patch adds support for running on Malta boards using coreFPGA6 core cards, including support for the msc01 system controller used with them. The system controller is detected at runtime allowing one U-boot binary to run on a Malta with either. Due to the PCI I/O base differing between Maltas

[U-Boot] [PATCH 07/15] qemu-malta: rename to just malta

2013-10-23 Thread Paul Burton
This is in preparation for adapting this board to function correctly on a physical MIPS Malta board. Signed-off-by: Paul Burton paul.bur...@imgtec.com --- arch/mips/lib/bootm.c| 12 ++--- board/malta/Makefile | 29 ++ board/malta/lowlevel_init.S | 69

[U-Boot] [PATCH 11/15] malta: enable CONFIG_PCNET_79C973, PCNET_HAS_PROM, CONFIG_CMD_DHCP

2013-10-23 Thread Paul Burton
This model of the pcnet is used in current Malta boards, at least in the Malta-R rev 3. Enable support for it. The Malta also has the ethernet controller PROM containing its MAC address, so enable support for that in order to read that MAC address. DHCP is a very useful feature to have available

[U-Boot] [PATCH 10/15] malta: display U-boot on the LCD screen

2013-10-23 Thread Paul Burton
Displaying a message on the LCD screen is a simple yet effective way to show the user that the board has booted successfully. Signed-off-by: Paul Burton paul.bur...@imgtec.com --- arch/mips/include/asm/malta.h | 10 ++ board/malta/malta.c | 19 +++ 2 files

[U-Boot] [PATCH 12/15] malta: remove cache size definitions

2013-10-23 Thread Paul Burton
These will now be detected at runtime, allowing a single U-boot configuration to function correctly with different bitstreams. Without this you may need to re-configure, re-build and re-flash U-boot to your Malta if you flash a new bitstream with a different cache configuration to your old

[U-Boot] [PATCH 14/15] malta: add script instructions to flash U-boot

2013-10-23 Thread Paul Burton
This patch adds a script which may be used with MIPS Navigator Console and a MIPS Nagivator Probe in order to flash U-boot to a MIPS Malta development board. Please see the newly added board/malta/README for usage instructions. Signed-off-by: Paul Burton paul.bur...@imgtec.com ---

[U-Boot] [PATCH 13/15] malta: disable L2 caches

2013-10-23 Thread Paul Burton
Malta boards may be used with cores which support L2 caches, however U-boot does not yet support L2 cache for MIPS. Thus for the moment we'll disable L2 caches by setting the L2B bit in Config2. This is specific to MTI/Imagination MIPS cores which is why this is done for the Malta board rather

[U-Boot] [PATCH 15/15] malta: add myself to maintainers

2013-10-23 Thread Paul Burton
This patch adds me as a maintainer of the malta(el) board(s). I have access to physical Malta boards and the desire for U-boot to run well on them. Signed-off-by: Paul Burton paul.bur...@imgtec.com --- boards.cfg | 4 ++-- 1 file changed, 2 insertions(+), 2 deletions(-) diff --git a/boards.cfg

[U-Boot] [PATCH] boards.cfg: remove trailing whitespace

2013-10-23 Thread Paul Burton
Commit 93e14596 Coding Style cleanup: replace leading SPACEs by TABs added trailing whitespace to a single line of boards.cfg. I presume this was unintentional, and it causes the file to change after running it through the reformat.py script. Remove the offending character. Signed-off-by: Paul

[U-Boot] [PATCH v2 0/5] USB: UMS: code refactoring and usage improvement

2013-10-23 Thread Przemyslaw Marczak
Quick summary: - introduce board definable parameters: UMS_START_BLOCK and UMS_PART_SIZE - remove ums unnecessary code - move ums structures to just one generic ums structure - add mmc device num as one of ums parameter - fix ums capacity miscalculation - move ums initialization code to Samsung

[U-Boot] [PATCH v2 1/5] usb: ums: code refactoring to improve reusability on other boards.

2013-10-23 Thread Przemyslaw Marczak
This patch introduces some cleanups to ums code. Changes: ums common: - introduce UMS_START_SECTOR and UMS_NUM_SECTORS as defined in usb_mass_storage.h both default values as 0 if board config doesn't define them common cleanup changes: - change name of struct ums_board_info to ums -

[U-Boot] [PATCH v2 3/5] usb: ums: fix disk capacity miscalculation and code cleanup

2013-10-23 Thread Przemyslaw Marczak
This patch prevents: - ums disk capacity miscalculation because of integer overflow Changes v2: - Prevents passing zero size disk capacity to ums gadget driver - Change function ums_get_capacity() to ums_disk_init() and do ums disk initialization before gadget init - Remove unnecessary code

[U-Boot] [PATCH v2 2/5] usb: ums: allows using every mmc device with ums.

2013-10-23 Thread Przemyslaw Marczak
Before this change ums command only allowed use of mmc 0. Now this argument can be set. Changes: - remove mmc device number checking because it is always positive number - remove printing no such device - it is done by find_mmc_device() Change-Id: I767e45151ad515c7bef19e6c13087374f5e23c11

[U-Boot] [PATCH v2 5/5] usb: ums: add ums exit feature by ctrl+c or by detach usb cable

2013-10-23 Thread Przemyslaw Marczak
This patch allows exiting from UMS mode to u-boot prompt by detaching usb cable or by pressing ctrl+c. Add new config: CONFIG_USB_CABLE_CHECK. If defined then board file should provide function: usb_cable_connected() (include/usb.h) that return 1 if cable is connected and 0 otherwise. Changes

[U-Boot] [PATCH v2 4/5] usb: ums: move ums code from trats to Samsung common directory

2013-10-23 Thread Przemyslaw Marczak
UMS init was implemented in trats board file but mostly it comprises common code. Due to that it has been moved to common/ums.c to avoid code duplication in the future. Changes: - move ums initialization code from trats to common/ums.c - remove unused CONFIG_USB_GADGET_MASS_STORAGE from trats.h

Re: [U-Boot] Bad Linux ARM zImage magic

2013-10-23 Thread Robert Nelson
On Tue, Oct 22, 2013 at 11:11 PM, claus anders cytroni...@yahoo.de wrote: Due to this patch: 0001-omap3_beagle-uEnv.txt-bootz-n-fixes.patch, u-boot for my beagleboard seems to need always a zImage. Up to now, I used uImage just fine. Correct, that's exactly one of the features that my out of

Re: [U-Boot] Fwd: [PATCH 1/6] exynos_fb: Remove usage of static defines

2013-10-23 Thread Simon Glass
On Oct 23, 2013 9:28 AM, Ajay kumar ajayn...@gmail.com wrote: Hi Simon, On Wed, Oct 16, 2013 at 10:04 PM, Simon Glass s...@chromium.org wrote: Hi Ajay, [once more from the right address] On Mon, Sep 30, 2013 at 5:20 AM, Ajay Kumar ajaykumar...@samsung.com wrote: Previously, we used

Re: [U-Boot] [PATCH] cmd_nvedit.c: Add env exists command

2013-10-23 Thread James Chargin
Dear Andrew Ruder, On 10/22/2013 05:07 PM, Andrew Ruder wrote: env exists is a way to test (in hush) if an environment variable exists. A workaround existed using printenv but this new command doesn't require all the stdout/stderr redirection to prevent printing information to the screen. I

[U-Boot] [PATCH] powerpc/t4240: set pcie liodn in the correct register

2013-10-23 Thread Laurentiu Tudor
The liodn for the T4240's PCIE controller is no longer set through a register in the guts register block but with one in the PCIE register block itself. Use the already existing SET_PCI_LIODN_BASE macro that puts the liodn in the correct register. Signed-off-by: Laurentiu Tudor

[U-Boot] [PATCH] powerpc/t4240: fix per pci endpoint liodn offsets

2013-10-23 Thread Laurentiu Tudor
Update the code that builds the pci endpoint liodn offset list so that it doesn't overlap with other liodns and doesn't generate negative offsets like: fsl,liodn-offset-list = 0 0xffcd 0xffcf 0xffd1 0xffd3 0xffd5

[U-Boot] [PATCH] powerpc/85xx: fix broken cpu clock-frequency property

2013-10-23 Thread Laurentiu Tudor
When indexing freqProcessor[] we use the first value in the cpu's reg property, which on new e6500 cores IDs the threads. But freqProcessor[] should be indexed with a core index so, when fixing the clock-frequency cpu node property, access the freqProcessor[] with the core index derived from the

Re: [U-Boot] [PATCH] cmd_nvedit.c: Add env exists command

2013-10-23 Thread Andrew Ruder
On Wed, Oct 23, 2013 at 06:55:02AM -0700, James Chargin wrote: I have, more recently, been using scripting of the form if test X != X${var}; then echo defined else echo undefined fi Thanks for the feedback. I was attempting to do something

[U-Boot] Fat write problem

2013-10-23 Thread Ruud Commandeur
Hi Everyone, After about half a year without problems for fatwrite, I have some new problem. The fatwrites for the u-boot are used to write the uimage and dtb file to a 32 MB FAT16 partition on an SD-card. Since this morning, the writing of a new file keeps failing. I still can write files that

Re: [U-Boot] [PATCH 1/2] ARM: bcm2835: add missing mbox overscan response field

2013-10-23 Thread Stephen Warren
On 10/22/2013 09:27 PM, Andre Heider wrote: Add the missing right field to struct bcm2835_mbox_tag_overscan. This one patch, Acked-by: Stephen Warren swar...@wwwdotorg.org You need to send/cc this patch to Albert Aribauld, since he applies ARM patches. Or, perhaps just make sure the patch gets

Re: [U-Boot] [PATCH 2/2] video: bcm2835: fix various output modes

2013-10-23 Thread Stephen Warren
On 10/22/2013 09:27 PM, Andre Heider wrote: Depending on the firmware's video options [1] the active SDTV or HDTV mode can yield a framebuffer with noncontiguous horizontal lines, giving a messed up display, for both, u-boot and the loaded kernel. To always archive the required

[U-Boot] [PATCH v2] usb: ohci-hcd: submit_common_msg: report actual_length properly

2013-10-23 Thread Mateusz Kulikowski
submit_common_msg should report amount of data passed from/to device. Instead, it always returned size requested by Host. Signed-off-by: Mateusz Kulikowski mateusz.kulikow...@gmail.com --- drivers/usb/host/ohci-hcd.c | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-) diff --git

Re: [U-Boot] SPDX License IDs - moving forward

2013-10-23 Thread Meier, Roger
Hi Wolfgang! -Original Message- From: Wolfgang Denk [mailto:w...@denx.de] Sent: Donnerstag, 10. Oktober 2013 12:49 To: u-boot@lists.denx.de Cc: Meier, Roger Subject: SPDX License IDs - moving forward Hallo, while working on converting more files to SPDX license IDs and

Re: [U-Boot] [PATCH 1/2] ARM: bcm2835: add missing mbox overscan response field

2013-10-23 Thread Andre Heider
On Wed, Oct 23, 2013 at 05:54:13PM +0100, Stephen Warren wrote: On 10/22/2013 09:27 PM, Andre Heider wrote: Add the missing right field to struct bcm2835_mbox_tag_overscan. This one patch, Acked-by: Stephen Warren swar...@wwwdotorg.org You need to send/cc this patch to Albert Aribauld,

Re: [U-Boot] [PATCH 2/2] video: bcm2835: fix various output modes

2013-10-23 Thread Andre Heider
On Wed, Oct 23, 2013 at 05:57:53PM +0100, Stephen Warren wrote: On 10/22/2013 09:27 PM, Andre Heider wrote: Depending on the firmware's video options [1] the active SDTV or HDTV mode can yield a framebuffer with noncontiguous horizontal lines, giving a messed up display, for both, u-boot

Re: [U-Boot] [PATCH 09/15] malta: support for coreFPGA6 boards

2013-10-23 Thread Daniel Schwierzeck
2013/10/23 Paul Burton paul.bur...@imgtec.com: This patch adds support for running on Malta boards using coreFPGA6 core cards, including support for the msc01 system controller used with them. The system controller is detected at runtime allowing one U-boot binary to run on a Malta with

Re: [U-Boot] [PATCH 07/15] qemu-malta: rename to just malta

2013-10-23 Thread Daniel Schwierzeck
2013/10/23 Paul Burton paul.bur...@imgtec.com: This is in preparation for adapting this board to function correctly on a physical MIPS Malta board. do you plan to add support for other MIPS boards? In that case it would be better to move malta to a vendor directory like mips or imagination.

Re: [U-Boot] [PATCH 14/15] malta: add script instructions to flash U-boot

2013-10-23 Thread Daniel Schwierzeck
2013/10/23 Paul Burton paul.bur...@imgtec.com: This patch adds a script which may be used with MIPS Navigator Console and a MIPS Nagivator Probe in order to flash U-boot to a MIPS Malta development board. Please see the newly added board/malta/README for usage instructions. Signed-off-by:

Re: [U-Boot] [PATCH 1/1] usb: rename board_usb_init_type to usb_init_type

2013-10-23 Thread Tom Rini
On Tue, Oct 22, 2013 at 02:39:25PM -0700, Troy Kisky wrote: commit bba679144d25b91bcd7befff5a96728a30875f54 usb: rename board_usb_init_type to usb_init_type missed xhci-omap.c So, fix that patch here, and fix a checkpatch warning. WARNING: Avoid unnecessary line continuations

Re: [U-Boot] [PULL] u-boot-usb/master

2013-10-23 Thread Tom Rini
On Sun, Oct 20, 2013 at 11:54:20PM +0200, Marek Vasut wrote: Dear Marek Vasut, please CC UBoot ML. Done, thanks The following changes since commit 183acb700378a8cfc5d50a01a65de93fb2c24586: Prepare v2013.10 (2013-10-16 13:08:12 -0400) are available in the git repository at:

Re: [U-Boot] [U-Boot, v2, 3/4] arm: rmobile: kzm9g: Change clock definition of SCIF from CONFIG_SYS_CLK_FREQ to CONFIG_SH_SCIF_CLK_FREQ

2013-10-23 Thread Tom Rini
On Mon, Sep 30, 2013 at 10:30:40AM +0900, Nobuhiro Iwamatsu wrote: Signed-off-by: Nobuhiro Iwamatsu nobuhiro.iwamatsu...@renesas.com CC: Nobuhiro Iwamatsu iwama...@nigauri.org CC: Albert Aribaud albert.u.b...@aribaud.net --- v2: no changes. re-send as further series. Applied to

Re: [U-Boot] Pull request: u-boot-mpc85xx/master

2013-10-23 Thread Tom Rini
On Wed, Oct 16, 2013 at 05:30:34PM -0700, York Sun wrote: Tom, The following changes since commit 183acb700378a8cfc5d50a01a65de93fb2c24586: Prepare v2013.10 (2013-10-16 13:08:12 -0400) are available in the git repository at: git://git.denx.de/u-boot-mpc85xx.git master for you

Re: [U-Boot] [i2c] Pull request

2013-10-23 Thread Tom Rini
On Thu, Oct 17, 2013 at 08:48:50AM +0200, Heiko Schocher wrote: Hello Tom, please pull from u-boot-i2c.git: The following changes since commit 183acb700378a8cfc5d50a01a65de93fb2c24586: Prepare v2013.10 (2013-10-16 13:08:12 -0400) are available in the git repository at:

Re: [U-Boot] Pull request: u-boot-sh/master

2013-10-23 Thread Tom Rini
On Thu, Oct 17, 2013 at 09:51:05AM +0900, Nobuhiro Iwamatsu wrote: Hi Tom, Please pull u-boot-sh master branch. Best regards, Nobuhiro The following changes since commit 183acb700378a8cfc5d50a01a65de93fb2c24586: Prepare v2013.10 (2013-10-16 13:08:12 -0400) are available in the

Re: [U-Boot] [U-Boot, v2, 4/4] arm: rmobile: armadillo-800eva: Change clock definition of SCIF and TMU

2013-10-23 Thread Tom Rini
On Mon, Sep 30, 2013 at 10:30:41AM +0900, Nobuhiro Iwamatsu wrote: This changes clock definition of SCIF from CONFIG_SYS_CLK_FREQ to CONFIG_SH_SCIF_CLK_FREQ, and clock definition of TMU from CONFIG_SYS_CLK_FREQ to CONFIG_SH_TMU_CLK_FREQ, Signed-off-by: Nobuhiro Iwamatsu