Re: [whatwg] Adding a property to navigator for getting device model

2014-09-24 Thread Jussi Kalliokoski
On Wed, Sep 24, 2014 at 10:38 AM, Nils Dagsson Moskopp n...@dieweltistgarnichtso.net wrote: Jonas Sicking jo...@sicking.cc writes: In some cases websites uses the UA strings for bad reasons (this is how we've always done it), in other cases because it's literally the best way for them to

Re: [whatwg] Proposal: navigator.launchURL

2014-07-14 Thread Jussi Kalliokoski
On Mon, Jul 14, 2014 at 5:44 PM, Anne van Kesteren ann...@annevk.nl wrote: On Mon, Jul 14, 2014 at 3:47 PM, Konstantin Welke konstantin.we...@citrix.com wrote: How we use it: * We try to launch our native application using a custom URI scheme * If successful, we show some “success” UI *

[whatwg] Fetch: use separate methods instead of one `to` method in FetchBodyStream

2014-06-16 Thread Jussi Kalliokoski
Reading the Fetch spec, the only major issue I have with the API is the `to()` method on the FetchBodyStream. Having different kinds of behavior behind one function that takes a string that determines the actual underlying implementation is bad enough as it is (think about canvas's `getContext()`

Re: [whatwg] Fetch: use separate methods instead of one `to` method in FetchBodyStream

2014-06-16 Thread Jussi Kalliokoski
On Mon, Jun 16, 2014 at 3:00 PM, Anne van Kesteren ann...@annevk.nl wrote: On Mon, Jun 16, 2014 at 12:57 PM, Jussi Kalliokoski jussi.kallioko...@gmail.com wrote: Another bad example of using strings for these kind of things, from much closer, is XHR's responseType where it's excruciatingly

Re: [whatwg] Questions regarding Path object

2013-11-13 Thread Jussi Kalliokoski
On Nov 13, 2013 6:41 PM, Dirk Schulze dschu...@adobe.com wrote: On Nov 13, 2013, at 2:53 PM, Rik Cabanier caban...@gmail.com wrote: [resending because of a bounced message] DrawingPath is saying the same thing twice. Maybe DOMDrawing is better? (with drawing the definition of

Re: [whatwg] Proposal: Adding methods like getElementById and getElementsByTagName to DocumentFragments

2013-07-24 Thread Jussi Kalliokoski
On Thu, Jul 25, 2013 at 3:39 AM, Ryosuke Niwa rn...@apple.com wrote: getElementById is okay but we want to discourage authors from using methods like getElementsByTagName and getElementsByClassName that return live NodeList objects. They incur a lot of implementation cost in WebKit and hurts

Re: [whatwg] Proposal: Adding methods like getElementById and getElementsByTagName to DocumentFragments

2013-07-03 Thread Jussi Kalliokoski
(I've used querySelector exclusively for quite some time, and I find arguments that querySelector isn't readable or the wrong tool to simply not hold up. I find it more readable, actually, since I don't have to change interfaces depending on whether I'm searching for an ID or a class.) I

Re: [whatwg] Proposal: Adding methods like getElementById and getElementsByTagName to DocumentFragments

2013-06-30 Thread Jussi Kalliokoski
On Sat, Jun 29, 2013 at 5:01 AM, Boris Zbarsky bzbar...@mit.edu wrote: This is actually false. For example, getElementById(foo:bar) is just querySelector(#foo\\:bar), which is ... nonobvious. It gets worse if you don't control the id that's passed in, because getElementById(arg) becomes

Re: [whatwg] Canvas: dash list API

2012-12-22 Thread Jussi Kalliokoski
On Sat, Dec 22, 2012 at 8:04 PM, Ian Hickson i...@hixie.ch wrote: On Sat, 22 Dec 2012, Anne van Kesteren wrote: Is there not some way we can have a lineDash attribute that returns a manipulatable object that inherits from Array rather than the current Java-like API? I remember this was

Re: [whatwg] Provide data chunk with the ProgressEvent

2012-11-21 Thread Jussi Kalliokoski
There is something like this cooking in the form of responseType = chunked-text and responseType = chunked-arraybuffer For reference, see [1] and [2]. Would be cool to hear a status update on specifying these. Anyway, apparently the right forum of discussion for this is the webapps mailing list.

Re: [whatwg] Real-time thread support for workers

2012-10-30 Thread Jussi Kalliokoski
On Sat, Oct 27, 2012 at 3:14 AM, Ian Hickson i...@hixie.ch wrote: On Thu, 9 Aug 2012, Jussi Kalliokoski wrote: On W3C AudioWG we're currently discussing the possibility of having web workers that run in a priority/RT thread. This would be highly useful for example to keep audio from

Re: [whatwg] [canvas] matrix based changes on bitmaps

2012-09-21 Thread Jussi Kalliokoski
Please see the DSP API [1]. It's currently developed unofficially under the W3C Audio WG [2], so if you have input, please post it to the audiowg public mailing list. This should scratch your itch and more. ;) Cheers, Jussi [1] http://people.opera.com/mage/dspapi/ [2]

Re: [whatwg] Hardware accelerated canvas

2012-09-04 Thread Jussi Kalliokoski
This might be a silly idea, but what about this: When all references to the context are lost (garbage collected), simply store the image on the canvas and make it behave like it was just an image. This would lose all the state of the context, but since the problem seems to be mostly with things

Re: [whatwg] Hardware accelerated canvas

2012-09-04 Thread Jussi Kalliokoski
Hmm... Is it visible to the page outside getContext() ? On Tue, Sep 4, 2012 at 10:21 PM, Boris Zbarsky bzbar...@mit.edu wrote: On 9/4/12 3:17 PM, Jussi Kalliokoski wrote: When all references to the context are lost (garbage collected) That never happens while the canvas itself is alive

Re: [whatwg] Hardware accelerated canvas

2012-09-04 Thread Jussi Kalliokoski
, 2012 at 11:03 PM, Boris Zbarsky bzbar...@mit.edu wrote: On 9/4/12 3:31 PM, Jussi Kalliokoski wrote: Hmm... Is it visible to the page outside getContext() ? No. Why does that matter? -Boris

Re: [whatwg] Should editable elements have placeholder attribute?

2012-08-30 Thread Jussi Kalliokoski
It's pretty simple to make a naive placeholder for contenteditable elements with CSS: [contenteditable]:not(:focus):empty::after { content: attr(data-placeholder); color: #ccc; } I call it a bit naive because it turns out that if you have insert a line break in the box, there

Re: [whatwg] Should editable elements have placeholder attribute?

2012-08-30 Thread Jussi Kalliokoski
On Thu, Aug 30, 2012 at 11:43 AM, Jussi Kalliokoski jussi.kallioko...@gmail.com wrote: It's pretty simple to make a naive placeholder for contenteditable elements with CSS: [contenteditable]:not(:focus):empty::after { content: attr(data-placeholder); color: #ccc; } I

[whatwg] Binary Streaming with XHR

2012-08-24 Thread Jussi Kalliokoski
Hello, I've got a little proposal to solve a problem we're facing with one of our codebases ( aurora.js [1], i.e. audio codecs in JavaScript ). We need to stream the audio files (you don't want to store a 2 hour long live stream in the memory or wait until a whole file is loaded before playing).

Re: [whatwg] Binary Streaming with XHR

2012-08-24 Thread Jussi Kalliokoski
On Fri, Aug 24, 2012 at 3:04 PM, Nils Dagsson Moskopp n...@dieweltistgarnichtso.net wrote: Jussi Kalliokoski jussi.kallioko...@gmail.com schrieb am Fri, 24 Aug 2012 13:23:03 +0300: […] My first idea was that if you set a property called chunkSize on the XHR, it would start dispatching

Re: [whatwg] Binary Streaming with XHR

2012-08-24 Thread Jussi Kalliokoski
Good idea! I'm not attached to the semantics, only to the functionality. Cheers, Jussi On Fri, Aug 24, 2012 at 3:46 PM, Simon Pieters sim...@opera.com wrote: On Fri, 24 Aug 2012 14:19:43 +0200, Jussi Kalliokoski jussi.kallioko...@gmail.com wrote: On Fri, Aug 24, 2012 at 3:04 PM, Nils

Re: [whatwg] Binary Streaming with XHR

2012-08-24 Thread Jussi Kalliokoski
/2012 12:23 PM, Jussi Kalliokoski a écrit : Hello, I've got a little proposal to solve a problem we're facing with one of our codebases ( aurora.js [1], i.e. audio codecs in JavaScript ). We need to stream the audio files (you don't want to store a 2 hour long live stream in the memory

Re: [whatwg] Binary Streaming with XHR

2012-08-24 Thread Jussi Kalliokoski
go to WebApps WG) In Gecko there is support for moz-chunked-arraybuffer response type. On 08/24/2012 03:23 AM, Jussi Kalliokoski wrote: Hello, I've got a little proposal to solve a problem we're facing with one of our codebases ( aurora.js [1], i.e. audio codecs in JavaScript ). We

Re: [whatwg] Real-time thread support for workers

2012-08-12 Thread Jussi Kalliokoski
On Sun, Aug 12, 2012 at 6:48 AM, Jonas Sicking jo...@sicking.cc wrote: On Sat, Aug 11, 2012 at 3:22 PM, Jussi Kalliokoski jussi.kallioko...@gmail.com wrote: On Fri, Aug 10, 2012 at 11:07 PM, Glenn Maynard gl...@zewt.org wrote: On Thu, Aug 9, 2012 at 1:20 AM, Jussi Kalliokoski

Re: [whatwg] Real-time thread support for workers

2012-08-11 Thread Jussi Kalliokoski
On Fri, Aug 10, 2012 at 11:07 PM, Glenn Maynard gl...@zewt.org wrote: On Thu, Aug 9, 2012 at 1:20 AM, Jussi Kalliokoski jussi.kallioko...@gmail.com wrote: On W3C AudioWG we're currently discussing the possibility of having web workers that run in a priority/RT thread. This would be highly

Re: [whatwg] Real-time thread support for workers

2012-08-09 Thread Jussi Kalliokoski
Hello David, On Thu, Aug 9, 2012 at 3:54 PM, David Bruant bruan...@gmail.com wrote: Le 09/08/2012 02:20, Jussi Kalliokoski a écrit : Hello there! On W3C AudioWG we're currently discussing the possibility of having web workers that run in a priority/RT thread. This would be highly useful

Re: [whatwg] Real-time thread support for workers

2012-08-09 Thread Jussi Kalliokoski
On Thu, Aug 9, 2012 at 6:09 PM, David Bruant bruan...@gmail.com wrote: Le 09/08/2012 09:59, Jussi Kalliokoski a écrit : Hello David, Hi Jussi, On Thu, Aug 9, 2012 at 3:54 PM, David Bruant bruan...@gmail.com wrote: * The last source is your own content competing with itself for CPU