Re: [whatwg] Text support in canvas

2005-11-08 Thread Vladimir Vukicevic
On 11/3/05, James Graham [EMAIL PROTECTED] wrote: Allowing text in canvas has serious accessibility problems. Presumably such text would not be resizable and encouraging authors to use non-resizable text in their web-apps is not a good idea. I guess there would also be (separate) issues with

Re: [whatwg] [canvas-developers] Opera with support for getPixel/setPixel

2006-03-29 Thread Vladimir Vukicevic
Hi, On 3/29/06, Arve Bersvendsen [EMAIL PROTECTED] wrote: Some of you have requested getPixel and setPixel for the bitmap canvas. Well, we have some news for you -- Opera has actually had this support all along, but we haven't been able to talk about it until now. Interesting stuff! What are

[whatwg] proposed canvas 2d API additions

2006-04-21 Thread Vladimir Vukicevic
Hi folks, I'd like to suggest extending the HTML canvas 2d context with a few additions. These are variations on some of the methods added to Opera's opera-2dgame context. The methods are intended to give content authors direct pixel access to the canvas, as well as provide some basic

Re: [whatwg] proposed canvas 2d API additions

2006-04-21 Thread Vladimir Vukicevic
On 4/21/06, Ian Hickson [EMAIL PROTECTED] wrote: On Fri, 21 Apr 2006, Vladimir Vukicevic wrote: boolean pointInPathFill(in float x, in float y); This sounds fine to me (though it means you have to spin through creating many paths for hit testing, instead of just hanging

Re: [whatwg] proposed canvas 2d API additions

2006-04-24 Thread Vladimir Vukicevic
. [ Vladimir Vukicevic ] I'm not sure what you mean -- the coordinates here are explicit canvas pixels, and they specifically ignore the current canvas transform. So, given canvas width=100 height=200/canvas the coordinates would be 0..99, 0..199. Without expressing any other opinion

Re: [whatwg] Audio Interface

2006-04-24 Thread Vladimir Vukicevic
On 4/21/06, Jeff Schiller [EMAIL PROTECTED] wrote: 2) Can you clarify the mechanism to determine if a user agent supports a particular content type? Otherwise, as a developer do I just assume that every browser will support .wav or .mp3 or .ogg or .mid or ? What about a static method on

Re: [whatwg] proposed canvas 2d API additions

2006-04-28 Thread Vladimir Vukicevic
On 4/26/06, Ian Hickson [EMAIL PROTECTED] wrote: On Mon, 24 Apr 2006, Vladimir Vukicevic wrote: The use case that I'm thinking of is essentially: pixels = c.getPixels(x, y, width, height); /* manipulate pixels here */ c.putPixels(pixels, x, y, width, height); That is, direct pixel

Re: [whatwg] proposed canvas 2d API additions

2006-05-04 Thread Vladimir Vukicevic
On 4/28/06, Vladimir Vukicevic [EMAIL PROTECTED] wrote: interface ImageData { readonly attribute string format; /* only rgba is valid for now */ readonly attribute long int width; readonly attribute long int height; readonly attribute Array data; } Actually, let's step back a second

Re: [whatwg] proposed canvas 2d API additions

2006-05-16 Thread Vladimir Vukicevic
On 4/26/06, Ian Hickson [EMAIL PROTECTED] wrote: ImageData getImageData(in float x, in float y, in float w, in float h); void drawImageData(in float x, in float y, in ImageData d); I'm about to implement this as suggested; however, I'd call the second function here putImageData instead

Re: [whatwg] strokeRect() with zero heights or widths

2006-05-28 Thread Vladimir Vukicevic
Doesn't a zero-width (or zero-height, as long as it's only one) degenerate into a vertical (horizontal) line when stroked, due to the line width? A filled rectangle doesn't, because the area to fill is defined exactly by the rectangular path (which has 0 thickness), whereas a stroked path takes

Re: [whatwg] Canvas 2d methods

2006-07-01 Thread Vladimir Vukicevic
On 7/1/06, Benjamin Joffe [EMAIL PROTECTED] wrote: Each of the methods defined for the canvas 2d context return null. I think it would be very convenient if instead they would return a reference to the 2d context for that canvas. This would allow writing such code as ctx.fill ().stroke() or

Re: [whatwg] Canvas 2d methods

2006-07-03 Thread Vladimir Vukicevic
Even without using |with|, why not just create a simple JS wrapper for the context object that can have return-this or any other desired semantics? This would avoid a change that would have some apps require canvas 2D 2.0 or some such, and require authors to do version checks to see which

Re: [whatwg] Video proposals

2007-03-19 Thread Vladimir Vukicevic
HÃ¥kon Wium Lie wrote: Also sprach Robert Brodrecht: As I said before, I think we have a lot better chance at getting a common, cross-browser, cross-platform format with MPEG 4. The reason WHAT WG proposed Theora is *because* it is FOSS, not for quality, size, ease of implementation, or

Re: [whatwg] Comments on the video element

2007-03-19 Thread Vladimir Vukicevic
Martin Atkins wrote: Mihai Sucan wrote: For Youtube, a site which provides bloggers an easy way to integrate videos, this would prove even ... hard. Here's the simple code users have to copy/paste: object width=425 height=350 param name=movie value=http://www.youtube.com/v/id;/param param

Re: [whatwg] on codecs in a 'video' tag.

2007-04-04 Thread Vladimir Vukicevic
If video supports fallback though, that 20% is enough to bootstrap and build support, especially as we all hope that that 20% continues to grow. However, I do agree that the codec discussion should be tabled and that we should get back to the spec discussion... I've been ignoring much of

Re: [whatwg] Canvas - globalCompositeOperation

2007-04-04 Thread Vladimir Vukicevic
Philip Taylor wrote: [...] Cool stuff! I'll look through your tests and fix up the mozilla implementation as much as possible. I would be happy if darker was removed from the spec - there isn't an obvious definition for it, and it's not interoperably implemented at all and it sounds like

Re: [whatwg] Apple Proposal for Timed Media Elements

2007-04-04 Thread Vladimir Vukicevic
Maciej Stachowiak wrote: CSS Timed Media Module proposal - http://webkit.org/specs/ Timed_Media_CSS.html Some feedback on my initial reading.. the CSS properties specified seem like a good set that will cover most common functionality. Some comments about the spec, though: 1.

Re: [whatwg] Apple Proposal for Timed Media Elements

2007-04-05 Thread Vladimir Vukicevic
Maciej Stachowiak wrote: On Apr 4, 2007, at 7:31 PM, Vladimir Vukicevic wrote: 1. 'media-loop-count' is an awkward name, especially with The default value of 1 means the item will play through once but will not loop. We went through this with APNG, and ended up renaming that member. I

[whatwg] canvas 2d context additions proposal (fillRule, lineDash)

2007-05-24 Thread Vladimir Vukicevic
Howdy, I'd like to propose adding a few simple 2D canvas context methods/parameters: attribute string fillRule; Specifies the algorithm used for filling paths. The options are winding or even-odd; the default is winding. Good descriptions for these are in the SVG spec:

Re: [whatwg] Compatibility problems with HTML5 Canvas spec.

2007-09-25 Thread Vladimir Vukicevic
Hi, Oliver Hunt wrote: Hi All, We've encountered a number of website compatibility issues in WebKit due to our adherence to the new Canvas specifications -- a good example of this is rect drawing at http://canvaspaint.org The most obvious issues can be shown if you use the draw rect tool

Re: [whatwg] Compatibility problems with HTML5 Canvas spec.

2007-09-26 Thread Vladimir Vukicevic
Oliver Hunt wrote: On 25/09/2007, at 2:19 PM, Philip Taylor wrote: On 25/09/2007, Oliver Hunt [EMAIL PROTECTED] wrote: Firefox 2/3 and Safari 2 clear the context's path on strokeRect/ fillRect, this violates the spec -- but there are many websites that now rely on such behaviour despite the

Re: [whatwg] Geolocation API Proposal

2008-03-17 Thread Vladimir Vukicevic
Hi Aaron, On Mar 7, 2008, at 1:03 AM, Aaron Boodman wrote: I've posted this to the W3C WebAPI mailing list as well. Still looking forward to feedback on the actual content of the proposal, in either place. I agree with the previously stated comments that this probably doesn't belong in

Re: [whatwg] Text APIs on canvas

2008-05-09 Thread Vladimir Vukicevic
On May 5, 2008, at 8:10 PM, Ian Hickson wrote: I have introduced the following APIs: context.font I think this should be textStyle -- both to match existing fillStyle/ strokeStyle, and for consistency with the rest of the text functions. I haven't provided a way to render text to or

Re: [whatwg] createImageData

2008-05-10 Thread Vladimir Vukicevic
On May 9, 2008, at 5:53 PM, Ian Hickson wrote: On Fri, 9 May 2008, Vladimir Vukicevic wrote: I don't think the restriction that putImageData must only work with objects returned by create/get is a good one This restriction was made because it allows for dramatic (many orders of magnitude

Re: [whatwg] createImageData

2008-05-10 Thread Vladimir Vukicevic
On May 10, 2008, at 5:44 PM, Oliver Hunt wrote: On May 10, 2008, at 4:53 PM, Vladimir Vukicevic wrote: Another approach would be to not try to solve this in canvas at all, and instead specify that by default, all canvas elements are 96dpi, and provide authors a way to explicitly override

Re: [whatwg] createImageData

2008-05-13 Thread Vladimir Vukicevic
On May 10, 2008, at 4:53 PM, Vladimir Vukicevic wrote: I would amend the spec to state that if an object is passed to putImageData with the necessary properties, but without having been created by create/getImageData beforehand, that its dimensions are aways in device pixels. Some

Re: [whatwg] createImageData

2008-05-13 Thread Vladimir Vukicevic
On May 13, 2008, at 2:58 PM, Oliver Hunt wrote: On May 13, 2008, at 1:53 PM, Vladimir Vukicevic wrote: The first argument to the method must be an ImageData object returned by createImageData(), getImageData(), or an object constructed with the necessary properties by the user

Re: [whatwg] createImageData

2008-05-13 Thread Vladimir Vukicevic
On May 13, 2008, at 3:37 PM, Oliver Hunt wrote: That said I still don't believe custom objects should be allowed, aside from the resolution (which may or may not be relevant) and performance issues, a custom object with a generic JS array, rather than an ImageData object will have

Re: [whatwg] createImageData

2008-05-13 Thread Vladimir Vukicevic
On May 13, 2008, at 4:10 PM, Oliver Hunt wrote: My experience implementing this in WebKit showed a pure byte array backing store was significantly faster than using boxed values. Faster for which operation, though? The put, or the actual manipulation? It's a tradeoff, really; if you're

Re: [whatwg] createImageData

2008-06-02 Thread Vladimir Vukicevic
Sorry it took me a bit to respond here... so, ok, based on the discussion, I'd suggest: - user-created ImageData-like objects should be supported, e.g. with language such as: The first argument to the method must be an ImageData object returned by createImageData(), getImageData(), or

[whatwg] [canvas] imageRenderingQuality property

2008-06-02 Thread Vladimir Vukicevic
I'd like to propose adding an imageRenderingQuality property on the canvas 2D context to allow authors to choose speed vs. quality when rendering images (especially transformed ones). This is modeled on the SVG image-rendering property, at

Re: [whatwg] [canvas] imageRenderingQuality property

2008-06-02 Thread Vladimir Vukicevic
issues in Canvas that cannot be almost directly attributed to JavaScript itself rather than the canvas. --Oliver On Jun 2, 2008, at 12:19 PM, Vladimir Vukicevic wrote: I'd like to propose adding an imageRenderingQuality property on the canvas 2D context to allow authors to choose speed vs

Re: [whatwg] [canvas] imageRenderingQuality property

2008-06-02 Thread Vladimir Vukicevic
, 2008, at 4:15 PM, Vladimir Vukicevic wrote: Sure; bilinear filtering is slower than nearest neighbour sampling, and in many cases the app author would like to be able to decide that tradeoff (or, at least, to be able to say I want this to go as fast as possible, regardless of quality

Re: [whatwg] [canvas] imageRenderingQuality property

2008-06-02 Thread Vladimir Vukicevic
small, you're going to want to be able to have that control. If they're not, then you should just be using 'auto' and let the UA handle it. - Vlad On Jun 2, 2008, at 2:15 PM, Vladimir Vukicevic wrote: Sure; bilinear filtering is slower than nearest neighbour sampling, and in many

Re: [whatwg] Audio canvas?

2008-07-23 Thread Vladimir Vukicevic
On Jul 16, 2008, at 11:25 AM, Dave Singer wrote: At 20:18 +0200 16/07/08, Dr. Markus Walther wrote: get/setSample(samplePoint t, sampleValue v, channel c). For the sketched use case - in-browser audio editor -, functions on sample regions from {cut/add silence/amplify/fade} would be nice

Re: [whatwg] canvas shadow compositing oddities

2008-08-04 Thread Vladimir Vukicevic
On Aug 4, 2008, at 2:29 PM, Eric Butler wrote: Philip Taylor wrote: On Sun, Jul 27, 2008 at 8:06 PM, Eric Butler [EMAIL PROTECTED] wrote: [...] However, following the spec's drawing model, there are a few operators that behave rather unexpectedly if the shadow color is left at its

Re: [whatwg] Canvas performance issue: setting colors

2008-11-10 Thread Vladimir Vukicevic
On 10/3/08 4:37 PM, Oliver Hunt wrote: thinking out loud Just had a thought (no idea how original) -- how about if fillStyle were able to accept a 3 or 4 number array? eg. fillStyle = [0, 0.3, 0.6, 1.0] ? That might work well if people are using arrays as vectors/colours /thinking out loud I

Re: [whatwg] Offscreen canvas (or canvas for web workers).

2010-03-15 Thread Vladimir Vukicevic
On 3/15/2010 4:22 AM, Maciej Stachowiak wrote: On Mar 15, 2010, at 3:46 AM, Philip Taylor wrote: On Mon, Mar 15, 2010 at 7:05 AM, Maciej Stachowiak m...@apple.com wrote: Copying from one canvas to another is much faster than copying to/from ImageData. To make copying to a Worker worthwhile

[whatwg] [canvas] getContext multiple contexts

2010-04-29 Thread Vladimir Vukicevic
Hey folks, A while ago questions came up in the WebGL WG about using a canvas with multiple rendering contexts, and synchronization issues that arise there. Here's our suggested change to getContext. It essentially allows for multiple contexts but adds no synchronization primitives other

Re: [whatwg] I believe source rectangles for HTML5 Canvas drawImage are specified incorrectly

2012-09-10 Thread Vladimir Vukicevic
This is pretty tricky to get right -- there's just a general graphics problem in this case. There are valid use cases for both sampling outside and not sampling outside the source rectangle, as well as implementation issues for being able to do source rectangle clamping. For example, should you

Re: [whatwg] canvas tag and animations ?

2005-06-20 Thread Vladimir Vukicevic
On 6/15/05, Charles Iliya Krempeaux [EMAIL PROTECTED] wrote: So then what do you do if your code is not amenable to the event drive way of programming. What if you have an event loop approach. How then do you signify the ending so that things can actually happen? I'm confused -- if you're