[PATCH 3/3] Move pixmap size limit checking to CreatePixmap, from screen hooks.

2011-10-02 Thread Jamey Sharp
Commit by Jamey Sharp and Josh Triplett. Signed-off-by: Jamey Sharp ja...@minilop.net Signed-off-by: Josh Triplett j...@joshtriplett.org --- dix/pixmap.c |7 ++- exa/exa_classic.c|3 --- exa/exa_driver.c |5 - exa/exa_mixed.c |5 -

[PATCH 2/3] Introduce CreatePixmap, allocating a header and calling screen hooks.

2011-10-02 Thread Jamey Sharp
This replaces AllocatePixmap, which was previously called by the screen hooks. Commit by Jamey Sharp and Josh Triplett. Signed-off-by: Jamey Sharp ja...@minilop.net Signed-off-by: Josh Triplett j...@joshtriplett.org --- Xext/shm.c |5 +-- composite/compalloc.c

[PATCH 0/3] simplify pixmap create/free hooks

2011-10-02 Thread Jamey Sharp
During last year's XDS, I started an experiment to see if resource allocation and freeing could lose the horrible wrap/unwrap boilerplate. As I recall, I got the idea from something keithp said: Create and Free hooks could be implemented with callbacks.h instead. I didn't finish that experiment,

Re: Maintaining backwards compatibility with swap macros

2011-10-02 Thread Jeremy Huddleston
ping. I didn't see anything as a followup to my comments below. I'm fine with either approach, but I'd like to get this in soon. On Sep 25, 2011, at 11:22 AM, Jeremy Huddleston wrote: On Sep 25, 2011, at 10:50, Matt Turner wrote: Dave pointed out that there are a couple drivers (sis,

Re: [PATCH 3/3] Move pixmap size limit checking to CreatePixmap, from screen hooks.

2011-10-02 Thread Jeremy Huddleston
Looks like the right way to me Reviewed-by: Jeremy Huddleston jerem...@apple.com On Oct 1, 2011, at 11:08 PM, Jamey Sharp wrote: Commit by Jamey Sharp and Josh Triplett. Signed-off-by: Jamey Sharp ja...@minilop.net Signed-off-by: Josh Triplett j...@joshtriplett.org --- dix/pixmap.c

Re: [PATCH 2/3] Introduce CreatePixmap, allocating a header and calling screen hooks.

2011-10-02 Thread Jeremy Huddleston
This makes things look much cleaner too... Reviewed-by: Jeremy Huddleston jerem...@apple.com On Oct 1, 2011, at 11:08 PM, Jamey Sharp wrote: This replaces AllocatePixmap, which was previously called by the screen hooks. Commit by Jamey Sharp and Josh Triplett. Signed-off-by: Jamey Sharp

Re: [PATCH 1/3] Have FreePixmap call screen hooks, not the other way around.

2011-10-02 Thread Jeremy Huddleston
Reviewed-by: Jeremy Huddleston jerem...@apple.com I think this series needs a Tested-by: though. I'll give it a go on Monday if nobody beats me to it. --Jeremy On Oct 1, 2011, at 11:08 PM, Jamey Sharp wrote: In the process, move reference counting into FreePixmap instead of doing it

Re: [PULL] bus cleanup, darwin hw/xfree86, build regression fixes

2011-10-02 Thread Jeremy Huddleston
On Sep 26, 2011, at 1:18 PM, Keith Packard wrote: On Fri, 23 Sep 2011 13:14:57 -0700, Jeremy Huddleston jerem...@apple.com wrote: Thanks for more eyes! As always, I'm looking for rough consensus about this before I merge it in; please let me know what you're looking for before it can

[PATCH 1/4] XAA: Delete redundant open-coded SYNC_CHECK in XAACopy{Area, Plane}Pixmap.

2011-10-02 Thread Jamey Sharp
Since commit 59f9fb4b8c031df69b3592a26b77e744ff4a556e, when Luc Verhaegen added an unconditional SYNC_CHECK in XAA_PIXMAP_OP_PROLOGUE, these open-coded versions of SYNC_CHECK have been redundant. In CopyPlane, NeedToSync was guaranteed to be FALSE, because if it wasn't so on entry,

[PATCH 3/4] XAA: Move SYNC_CHECK into XAA_GC_OP_PROLOGUE.

2011-10-02 Thread Jamey Sharp
Since every fallback checks whether it needs to sync, just do it in the prologue, like the pixmap ops do. Signed-off-by: Jamey Sharp ja...@minilop.net --- hw/xfree86/xaa/xaaFallback.c | 20 hw/xfree86/xaa/xaawrap.h |6 -- 2 files changed, 4 insertions(+), 22

[PATCH 2/4] XAA: Unconditionally SYNC_CHECK in XAACopy{Area, Plane}Fallback.

2011-10-02 Thread Jamey Sharp
These are the only fallbacks that were ever choosing not to sync. This patch makes them consistent with not only the other fallbacks, but also with the pixmap fallbacks as of Luc Verhaegen's commit in 2008, 59f9fb4b8c031df69b3592a26b77e744ff4a556e. Signed-off-by: Jamey Sharp ja...@minilop.net ---

[PATCH 0/4] XAA cleanups

2011-10-02 Thread Jamey Sharp
I wrote these patches as part of an effort to make GC funcs and ops per-screen instead of per-GC, but several people hated that plan. I still think these particular patches are a good idea, though. They should have no behavioral effect except the small changes mentioned in the commit messages.

[PATCH 4/4] XAA: Merge pixmap GC ops into fallback GC ops.

2011-10-02 Thread Jamey Sharp
They were already doing nearly identical work, although now the ops may short-circuit in the pixmap case if pGC-pCompositeClip is an empty region; before, only the fallback ops could do that. Signed-off-by: Jamey Sharp ja...@minilop.net --- hw/xfree86/xaa/xaaFallback.c | 67 ++---

Re: [PULL] bus cleanup, darwin hw/xfree86, build regression fixes

2011-10-02 Thread Matthieu Herrb
On Sat, Oct 01, 2011 at 11:26:38PM -0700, Jeremy Huddleston wrote: On Sep 26, 2011, at 1:18 PM, Keith Packard wrote: On Fri, 23 Sep 2011 13:14:57 -0700, Jeremy Huddleston jerem...@apple.com wrote: Thanks for more eyes! As always, I'm looking for rough consensus about this

Re: Last chance: FOSDEM2012 speakers due today.

2011-10-02 Thread Matthieu Herrb
On Sat, Oct 01, 2011 at 03:14:12PM +0200, Luc Verhaegen wrote: So far we have: * Martin Peres - Nouveau * Alon Levy - Xspice * Chris Wilson - Cairo * Kai Uwe Behrmann - Colormanagement with compositors. * Daniel Vetter - DRM futures. Only a single speaker is still lacking, and because I

Re: [PULL] bus cleanup, darwin hw/xfree86, build regression fixes

2011-10-02 Thread Jamey Sharp
On Sat, Oct 01, 2011 at 11:26:38PM -0700, Jeremy Huddleston wrote: On Sep 26, 2011, at 1:18 PM, Keith Packard wrote: On Fri, 23 Sep 2011 13:14:57 -0700, Jeremy Huddleston jerem...@apple.com wrote: Thanks for more eyes! As always, I'm looking for rough consensus about this before I

[PATCH] test: .gitignore the binary for xfree86.c.

2011-10-02 Thread Jamey Sharp
5aa826cdd1f2e768bedf23d399703a5d0b6302be introduced this new test without ignoring the build product. Signed-off-by: Jamey Sharp ja...@minilop.net --- test/.gitignore |1 + 1 files changed, 1 insertions(+), 0 deletions(-) diff --git a/test/.gitignore b/test/.gitignore index 0e1ed42..4c0a231

Re: [PATCH 1/3] Have FreePixmap call screen hooks, not the other way around.

2011-10-02 Thread Jamey Sharp
On Sat, Oct 01, 2011 at 11:20:25PM -0700, Jeremy Huddleston wrote: Reviewed-by: Jeremy Huddleston jerem...@apple.com I think this series needs a Tested-by: though. I'll give it a go on Monday if nobody beats me to it. I'll hold off on requesting a pull, then. Thanks for the reviews! Jamey

Re: [PULL] bus cleanup, darwin hw/xfree86, build regression fixes

2011-10-02 Thread Jeremy Huddleston
On Oct 2, 2011, at 00:10, Matthieu Herrb wrote: Was the libpciaccess issue solved ? You're referring to the missing support from libpciaccess, yes? I'm still waiting on comments from my comments on those patches. http://lists.x.org/archives/xorg-devel/2011-September/025663.html

Re: [PATCH libXi] 1UL may be 4 bytes, force to 1ULL

2011-10-02 Thread Jeremy Huddleston
Peter, any thoughts on this? On Sep 20, 2011, at 10:01, Jeremy Huddleston wrote: I just realized I made (at least one) error in the inline functions I wrote below. s/ 0/ 1/ ... there're probably others, but that just emphasizes my point that there should be conversion routines rather than

Re: [PULL] bus cleanup, darwin hw/xfree86, build regression fixes

2011-10-02 Thread Matthieu Herrb
On Sun, Oct 02, 2011 at 01:11:50AM -0700, Jeremy Huddleston wrote: On Oct 2, 2011, at 00:10, Matthieu Herrb wrote: Was the libpciaccess issue solved ? You're referring to the missing support from libpciaccess, yes? I'm still waiting on comments from my comments on those patches.

Re: [RFC] Xdummy standalone binary or -dummy switch

2011-10-02 Thread Jamey Sharp
On Fri, Sep 30, 2011 at 08:53:25AM +1000, Peter Hutterer wrote: On Thu, Sep 29, 2011 at 12:10:29PM -0700, Jamey Sharp wrote: I use these settings in my nested/dummy testing, which seem to suffice for me: Section ServerFlags Option AutoEnableDevices false Option AutoAddDevices

Re: [PATCH 1/3] Have FreePixmap call screen hooks, not the other way around.

2011-10-02 Thread Jeremy Huddleston
On Oct 2, 2011, at 00:49, Jamey Sharp wrote: On Sat, Oct 01, 2011 at 11:20:25PM -0700, Jeremy Huddleston wrote: Reviewed-by: Jeremy Huddleston jerem...@apple.com I think this series needs a Tested-by: though. I'll give it a go on Monday if nobody beats me to it. I'll hold off on

Re: [Mesa-dev] Last chance: FOSDEM2012 speakers due today.

2011-10-02 Thread Arthur Huillet
On Sat, 1 Oct 2011 18:51:39 +0200 Luc Verhaegen l...@skynet.be wrote: A Mesa/Gallium state of the art and perspectives would be awesome! ... but who will step up to do it? The only way I can help: I hereby pledge to pay beer to any person who steps up to talk about Gallium3D or Wayland at

Re: Last chance: FOSDEM2012 speakers due today.

2011-10-02 Thread Daniel Stone
Hi, On 2 October 2011 08:17, Matthieu Herrb matthieu.he...@laas.fr wrote: On Sat, Oct 01, 2011 at 03:14:12PM +0200, Luc Verhaegen wrote: If you know that you are coming to FOSDEM, but for some reason think that someone else should step up instead, then think again, and reply ASAP. Luc, I

[PULL] some cleanups

2011-10-02 Thread Alexandr Shadchin
The following changes since commit afb1fe695d197187a301c19863a128a65389b15c: Merge remote-tracking branch 'whot/next' (2011-09-26 20:24:15 -0700) are available in the git repository at: g...@github.com:Koba/xserver.git reviewed Alexandr Shadchin (8): bsd: Remove unused macros KBD_FD

Re: [PULL] bus cleanup, darwin hw/xfree86, build regression fixes

2011-10-02 Thread Mark Kettenis
From: Jeremy Huddleston jerem...@apple.com Date: Sun, 2 Oct 2011 01:11:50 -0700 On Oct 2, 2011, at 00:10, Matthieu Herrb wrote: Was the libpciaccess issue solved ? You're referring to the missing support from libpciaccess, yes? I'm still waiting on comments from my comments on

[PATCH evdev] Support smooth scrolling on wheel emulation

2011-10-02 Thread Max Schwarz
This adds support for the new smooth-scrolling valuator system to the wheel emulation code. Caveats: - Enabling wheel emulation at runtime does not work if the device does not provide the necessary axes already. - Horizontal scrolling is always reported on the REL_HWHEEL axis, ignoring a

Re: Maintaining backwards compatibility with swap macros

2011-10-02 Thread Matt Turner
On Sun, Oct 2, 2011 at 2:15 AM, Jeremy Huddleston jerem...@freedesktop.org wrote: ping.  I didn't see anything as a followup to my comments below.  I'm fine with either approach, but I'd like to get this in soon. On Sep 25, 2011, at 11:22 AM, Jeremy Huddleston wrote: On Sep 25, 2011, at

Re: [PATCH] test: .gitignore the binary for xfree86.c.

2011-10-02 Thread Gaetan Nadon
On Sun, 2011-10-02 at 00:38 -0700, Jamey Sharp wrote: 5aa826cdd1f2e768bedf23d399703a5d0b6302be introduced this new test without ignoring the build product. Signed-off-by: Jamey Sharp ja...@minilop.net --- test/.gitignore |1 + 1 files changed, 1 insertions(+), 0 deletions(-) diff

Re: [PATCH libXi] 1UL may be 4 bytes, force to 1ULL

2011-10-02 Thread Daniel Stone
Hi, On 2 October 2011 09:19, Jeremy Huddleston jerem...@apple.com wrote: Peter, any thoughts on this? I think using * (1 16) * (1 16) is a better idea than (1ULL 32). Cheers, Daniel ___ xorg-devel@lists.x.org: X.Org development Archives:

Re: [PATCH libXi] 1UL may be 4 bytes, force to 1ULL

2011-10-02 Thread Jamey Sharp
On 10/2/11, Daniel Stone dan...@fooishbar.org wrote: On 2 October 2011 09:19, Jeremy Huddleston jerem...@apple.com wrote: Peter, any thoughts on this? I think using * (1 16) * (1 16) is a better idea than (1ULL 32). And I think ldexp is a much better idea than either. :-) It's more clear,

[PATCH libXft] Remove an extraneous FcPatternDestroy in XftFontOpenInfo

2011-10-02 Thread Jeremy Huddleston
https://bugs.freedesktop.org/show_bug.cgi?id=5745 Signed-off-by: Jeremy Huddleston jerem...@apple.com --- src/xftfreetype.c |1 - 1 files changed, 0 insertions(+), 1 deletions(-) diff --git a/src/xftfreetype.c b/src/xftfreetype.c index 3f8dfef..1c5967a 100644 --- a/src/xftfreetype.c +++

Re: [PATCH] dix: add valuator_mask_fetch_double()

2011-10-02 Thread Peter Hutterer
On Fri, Sep 30, 2011 at 11:55:35PM +0100, Daniel Stone wrote: Hi, On 30 September 2011 17:18, Chase Douglas chase.doug...@canonical.com wrote: On 09/29/2011 09:29 PM, Peter Hutterer wrote: Using this call simplifies callers that don't know if the mask bit is set. Before:   if

Re: [PATCH] Add #include inpututils.h to xkbAccessX.c for init_device_event

2011-10-02 Thread Peter Hutterer
On Sat, Oct 01, 2011 at 08:43:52AM -0700, Alan Coopersmith wrote: Fixes Sun compiler warning: xkbAccessX.c, line 128: warning: implicit function declaration: init_device_event Signed-off-by: Alan Coopersmith alan.coopersm...@oracle.com --- xkb/xkbAccessX.c |1 + 1 files changed, 1

Re: [PULL] XI 2.1 - raw events and smooth scrolling

2011-10-02 Thread Peter Hutterer
I've added Alan's compiler warning fix to this branch. New tip: 524e5445c0b6df5247d4aac5368470bb89ef4080 On Fri, Sep 30, 2011 at 09:51:38AM +1000, Peter Hutterer wrote: This is the now finally reviewed smooth scrolling branch and the raw events, along with the new input ABI changes (which are

Re: [PATCH RESEND xserver 1/3] Xserver-spec: add release information

2011-10-02 Thread Peter Hutterer
On Fri, Sep 30, 2011 at 06:59:39AM -0400, Gaetan Nadon wrote: On Fri, 2011-09-30 at 08:55 +1000, Peter Hutterer wrote: Reviewed-by: Peter Hutterer peter.hutte...@who-t.net for the patch but I wonder if this is really useful. With modular releases the katamari version doesn't mean that

Re: [PATCH libXi] 1UL may be 4 bytes, force to 1ULL

2011-10-02 Thread Peter Hutterer
On Sun, Oct 02, 2011 at 10:52:03AM -0700, Jamey Sharp wrote: On 10/2/11, Daniel Stone dan...@fooishbar.org wrote: On 2 October 2011 09:19, Jeremy Huddleston jerem...@apple.com wrote: Peter, any thoughts on this? I think using * (1 16) * (1 16) is a better idea than (1ULL 32). And I

Re: [PATCH RESEND xserver 1/3] Xserver-spec: add release information

2011-10-02 Thread Gaetan Nadon
On Mon, 2011-10-03 at 09:25 +1000, Peter Hutterer wrote: The majorversion of 7 is pretty meaningless and the minor is partially meaningless since we have releases that don't end up in a katamari. So if in doubt, I'd just go with the module name + release version and add the release date for

Re: [PATCH RESEND xserver 1/3] Xserver-spec: add release information

2011-10-02 Thread Peter Hutterer
On Sun, Oct 02, 2011 at 09:18:54PM -0400, Gaetan Nadon wrote: On Mon, 2011-10-03 at 09:25 +1000, Peter Hutterer wrote: The majorversion of 7 is pretty meaningless and the minor is partially meaningless since we have releases that don't end up in a katamari. So if in doubt, I'd just go

Re: [PATCH libXi] 1UL may be 4 bytes, force to 1ULL

2011-10-02 Thread Jeremy Huddleston
On Oct 2, 2011, at 16:30, Peter Hutterer wrote: On Sun, Oct 02, 2011 at 10:52:03AM -0700, Jamey Sharp wrote: On 10/2/11, Daniel Stone dan...@fooishbar.org wrote: On 2 October 2011 09:19, Jeremy Huddleston jerem...@apple.com wrote: Peter, any thoughts on this? I think using * (1 16) * (1

Re: Maintaining backwards compatibility with swap macros

2011-10-02 Thread Jeremy Huddleston
On Oct 2, 2011, at 07:51, Matt Turner wrote: On Sun, Oct 2, 2011 at 2:15 AM, Jeremy Huddleston jerem...@freedesktop.org wrote: ping. I didn't see anything as a followup to my comments below. I'm fine with either approach, but I'd like to get this in soon. On Sep 25, 2011, at 11:22 AM,

Re: Maintaining backwards compatibility with swap macros

2011-10-02 Thread Keith Packard
On Sun, 2 Oct 2011 22:16:42 -0700, Jeremy Huddleston jerem...@freedesktop.org wrote: Ok, given your agreement here, I'll go ahead with this if you don't beat me to it. Thanks. I definitely prefer fixing the macros the 'right' way and then making drivers deal with the API change. Leaving API

Re: [RFC] Xdummy standalone binary or -dummy switch

2011-10-02 Thread Antoine Martin
[snip] Others will have an easier time reviewing and merging your patch if you follow these guidelines: http://wiki.x.org/wiki/Development/Documentation/SubmittingPatches Will do, I just thought this would be ok for the RFC stage. The only other patch required to make this useful for non-root

Re: [RFC] Xdummy standalone binary or -dummy switch

2011-10-02 Thread Antoine Martin
On 01/10/11 04:12, Alan Coopersmith wrote: if ( (geteuid() != getuid()) ) { It's not that simple to check for elevated privs in a world with saved setids and other forms of privilege manipulation - issetugid() is useful if it's available - for instance see: