Hi guys,

I have difficulties using spamdyke-qrv in combination with aliases on aliased domains with vpopmail. For example when I'm creating a new domain original-domain.com with alias domain alias-domain.com and then after creating forward al...@original-domain.com I expect to be receiving email on al...@alias-domain.com as well. But spamdyke-qrv filters it. :(


In example below you can see how spamdyke rejects email to al...@alias-domain.com, but not to al...@original-domain.com

mail # vadddomain original-domain.com test
mail # vaddaliasdomain original-domain.com alias-domain.com
mail # valias -i postmas...@original-domain.com al...@original-domain.com
mail # telnet localhost 25
Trying 127.0.0.1...
Connected to localhost.
Escape character is '^]'.
220 mail.some-domain.com ESMTP
HELO mail
250 mail.some-domain.com
mail from: tes...@another-domain.com
250 ok
rcpt to: al...@alias-domain.com
554 Refused. The recipient address does not exist.
rcpt to: al...@original-domain.com
250 ok
quit
221 mail.some-domain.com
Connection closed by foreign host.

My current spamdyke version is 5.0.0+TLS+CONFIGTEST+DEBUG

mail # cat /etc/spamdyke/spamdyke.conf
log-level=verbose
qmail-rcpthosts-file=/var/qmail/control/rcpthosts
tls-certificate-file=/var/qmail/control/servercert.pem
graylist-level=always-create-dir
graylist-dir=/var/tmp/spamdyke/graylist
graylist-exception-rdns-dir=/etc/spamdyke/never-graylist
graylist-exception-ip-file=/etc/spamdyke/graylist-exception-ip-file
graylist-exception-rdns-file=/etc/spamdyke/graylist-exception-rdns-file
graylist-max-secs=3369600
graylist-min-secs=50
reject-empty-rdns
reject-unresolvable-rdns
reject-sender=no-mx
rejection-text-recipient-same-as-sender
rhs-blacklist-entry=sbl-xbl.spamhaus.org
greeting-delay-secs=0
max-recipients=100
connection-timeout-secs=1800
idle-timeout-secs=120
config-dir=/etc/spamdyke/config.d
rdns-blacklist-file=/etc/spamdyke/rdns-keyword-blacklist-file
reject-recipient=invalid
recipient-validation-command=/usr/local/bin/spamdyke-qrv

spamdyke-qrv was configured using vpopmail:
./configure --with-vpopmail-support VALIAS_PATH=/path/to/valias VUSERINFO_PATH=/path/to/vuserinfo

Any ideas how to fix it?

--
BR,
Konstantin
_______________________________________________
spamdyke-users mailing list
spamdyke-users@spamdyke.org
http://www.spamdyke.org/mailman/listinfo/spamdyke-users

Reply via email to