Jonathan Smith wrote:

> sorry for the long time between replies. i've been busy on other things :)
> 
> Nikolai Weibull wrote:
>  > Well, the rpm spec file-type has been with us a long time, well before
>  > we knew better.  Try to give your file-type an as specific name as
>  > possible.  You will not be getting the name "recipe"; it's way too
>  > generic in this day and age.  Go with "conrecipe" or something
>  > similar.  Remember: Bram has his own build system, called Aap, which
>  > also uses recipes.  Also, if Vim will never edit a (Conary) changeset,
>  > then why will we have to worry about a name-clash between different
>  > conary file-types?
> 
> done - changed to conaryRecipe.

No other filetype has an uppercase letter.  I would call it
conaryrecipe.  It's a bit long, but clear.

Now all items in the syntax file need to start with "conaryrecipe" to
avoid any confusion with other syntax files and highlighting items.
"b:current_syntax" also needs to be set to the same name.

>  > Nitpick: remove the empty comment.
> 
> done
> 
>  > Just do
>  >
>  > if exists("b:current_syntax")
>  >  finish
>  > endif
>  >
>  > No one will be using your syntax definition with vim 5 anyway.  Let's
>  > keep new files clean from (now) unnecessary cruft.
> 
> done
> 
>  >> syn match   conaryUse           "Use\.[a-z0-9.]*" contains=conaryUseFlag
>  >
>  > Sure that * shouldn't be a \+?  And can you have a sequence of dots,
>  > as in Use...?
> 
> done
> 
>  > A better way of doing this is to do (substitute \w with whatever
>  > pattern your parser actually allows)
>  >
>  > syn match conaryUse
>  > \ "Use\.\w\+"
>  > \ nextgroup=conaryUseFlag
>  >
>  > syn keyword conaryUseFlag
>  > \ contained
>  > \ nextgroup=conaryUseFlagSeparator
>  > \ pcre
>  > \ tcpwrappers
>  > \ ...
>  >
>  > syn match conaryUseFlagSeparator
>  > \ contained
>  > \ nextgroup=conaryUseFlag
>  > \ '\.'
> 
> that didn't work for me for some reason. perhaps i'm misunderstanding?
> 
>  >> "syn match   conaryR            "r\.\w*" contains=conaryFunction
>  >
>  > Leftover?
> 
> yes. axed.
> 
>  >> if version >= 508 || !exists("did_python_syn_inits")
>  >>   if version <= 508
>  >>    let did_python_syn_inits = 1
>  >>     command -nargs=+ HiLink hi link <args>
>  >>   else
>  >>     command -nargs=+ HiLink hi def link <args>
>  >>   endif
>  >
>  > Just skip this.  No one will be using your syntax definition with Vim 5.
> 
> yep, removed. as i said, rPath has been maintaining this for a long time. :)

You might as well use "hi def link" instead of HiLink.

>  >>   "HiLink pythonStatement       Statement
>  >>   "HiLink pythonFunction        Function
>  >>   "HiLink pythonConditional     Conditional
>  >>   "HiLink pythonRepeat          Repeat
>  >>   "HiLink pythonString          String
>  >>   "HiLink pythonRawString       String
>  >>   "HiLink pythonEscape          Special
>  >>   "HiLink pythonOperator                Operator
>  >>   "HiLink pythonPreCondit       PreCondit
>  >>   "HiLink pythonComment         Comment
>  >>   "HiLink pythonTodo            Todo
>  >
>  > ?
> 
> all wacked. just crufty.

But the "python" syntax items are still there.  This doesn't look right.

>  >> " vim: ts=8
>  >
>  > This is the default setting.
> 
> removed
> 
> new version attached, as before. thanks for the feedback. further feedback 
> requested :)

-- 
hundred-and-one symptoms of being an internet addict:
27. You refer to your age as 3.x.

 /// Bram Moolenaar -- [EMAIL PROTECTED] -- http://www.Moolenaar.net   \\\
///        sponsor Vim, vote for features -- http://www.Vim.org/sponsor/ \\\
\\\        download, build and distribute -- http://www.A-A-P.org        ///
 \\\            help me help AIDS victims -- http://ICCF-Holland.org    ///

Reply via email to