Thank you Luis-san.

I have three points to want to discuss with you.
But those are not serious,
 so I won't mind if you had rejected those. ;-)
And I agree with you about all other points
 which I didn't mention in this mail.

>>   Q1. upvalue is available on 5.1 too. Why don't you use it for 5.1?
>
> It is being used.

Ah sorry, it's my fault.

After that, this is some little things,
I wonder why keep using LUAVIM_ENVIRONINDEX keyword yet.
You have defined two new macros luaV_get/setvalue,
and just those are using LUAVIM_ENVIRONINDEX only.
How about rename those to luaV_get/setenvvalue,
and remove LUAVIM_ENVIRONINDEX keyword.
Like this:

> #define luaV_getenvvalue(L, v) \
>     lua_pushlightuserdata(L, (void *) (v)); \
>     lua_rawget(L, lua_upvalueindex(1))
> #define luaV_setenvvalue(L, v) \
>     lua_pushlightuserdata(L, (void *) (v)); \
>     lua_pushvalue(L, -2); \
>     lua_rawset(L, lua_upvalueindex(1))


And next this is a small thing too...

> That's a valid reason, but it doesn't fix bugs.

But it will reduce the probabiry of new bugs in future.


> The first solution was in my last patch; I'll try and come up
> with another patch for the second solution by the end of the day,
> and we can compare them.

I like the first solution.
It is simple and enough powerful.


Thanks again.
-- 
MURAOKA Taro <koron.kaor...@gmail.com>

-- 
You received this message from the "vim_dev" maillist.
Do not top-post! Type your reply below the text you are replying to.
For more information, visit http://www.vim.org/maillist.php

Raspunde prin e-mail lui