Well..  i find this a bit weird.  I was using /lib/namespace.httpd
without any changes whatsoever.  I appended the bind /usr/glenda/web
/usr/web/ to /lib/namespace.httpd.  Killed (Kill httpd | rc) and restarted 
httpd with
ip/httpd/httpd and it worked.  But i' m confused anyway since,
afterwards, i removed the /usr/glenda/web and it works anyway.  I
removed the bind from the namespace.httpd and it works anyway.

Bottom line: it's working with the /sys/lib/httpd.rewrite and
/lib/namespace.httpd unaltered (with the same content as installed in the 
raspberry pi img), and by creating the directory
/usr/web, and the file /usr/web/index.html.  Next stop is installing
werc! :) 
Thanks for the help.  I' m sure i will bother you soon
with aditional problems.

João Reis

> what is in your /lib/namespace.httpd? how do you start httpd?
>> Hello!  I just re-installed plan9 in a raspberry pi, and this time
>> around, i´m trying to play with the httpd web server, for creating a
>> small site.
>> I created /usr/web/index.html and tried to run ip/httpd/httpd which
>> produces the following error page (via browser, and for the intended
>> ip):
>> "
>> Object not found 
>> The object /usr/glenda/web/index.html does not exist on this server. 
>> errstr: '/usr/web/usr' does not exist 
>> uri host:  
>> header host: 
>> actual host: who cares
>> "
>> I also created /usr/glenda/web/index.html but the results are the
>> same.  I know that the /sys/lib/httpd.rewrite and namespace.httpd are
>> important files for configuring but i´m not sure how.  I didn´t, i´m
>> afraid, get less cofused by reading httpd man page, but i´m sure it is
>> my fault :).
>> My objective is the to run the web server for a index.html basic file
>> on a directory, somewhere in plan9.  Does anyone have any ideas where
>> the problem might lie?
>> Thanks!
>> João Reis

Reply via email to