Bug ID: 212443
           Summary: Random hang at shutdown/poweroff - Sun Microsystems
                    Ultra 24 Workstation (Ursa)
           Product: ACPI
           Version: 2.5
    Kernel Version: Linux devuan 4.19.0-14-amd64 #1 SMP Debian 4.19.171-2
                    (2021-01-30) x86_64 GNU/Linux
          Hardware: Intel
                OS: Linux
              Tree: Mainline
            Status: NEW
          Severity: high
          Priority: P1
         Component: BIOS
        Regression: No

I have a 'bad shutdown' problem with a Sun Microsystems Ultra 24 WS.

The workstation has an Intel Core2 Q9550 CPU + 8Gb RAM and the BIOS verson
1.56, the last one available from the OEM, from which there's no possible
update, upgrade, support, etc.

Sun Microsystems has been dead for years now and Oracle lists it as EOL.

It runs on Devuan Beowulf 3.1.0.
ie: Linux devuan 4.19.0-14-amd64 #1 SMP Debian 4.19.171-2 (2021-01-30) x86_64

I have modified the BIOS' original DSDT table using information gathered from
MS based utilities used to patch BIOSes to run OSx on non OSx hardware.

As a result I managed to reduce the original 'Error' count on recompilation
from '30' to '0', with only '9' 'Warnings'.

Intel ACPI Component Architecture
ASL+ Optimizing Compiler/Disassembler version 20181213
Copyright (c) 2000 - 2018 Intel Corporation

ASL Input:     dsdt.dsl - 6179 lines, 198990 bytes, 2846 keywords
AML Output:    dsdt.aml - 22065 bytes, 751 named objects, 2095 executable

Compilation complete. 0 Errors, 9 Warnings, 39 Remarks, 65 Optimizations

That is the DSDT table I am using now, injecting it at boot time via
`/boot/acpi_override` in `grub` but the problem subsists.


On shutdown the box will do one of two things:

1. shut down properly -> 99.9% of the time
2. freeze during the shutdown with the screen showing this output:

e1000e: EEE Tx LPI Timer
Preparing to enter sleep state S5
Reboot: Power Down

... with the fans blowing at full speed.

The keyboard becomes unresponsive and the only way out is a hard shut down via
the PWR button.

Whenever it occurrs, the screen output before the freeze is the same.

See attached file `scrshot_U24.jpg`.

Unfortunately, I have not been able to reproduce it or link it to anything in

It just happens every so many shutdowns and the number can go from 3 to 20 with
no discernible pattern.

None of the /var/log files (syslog, kern.log, faillog, messages) show anything
relevant, which is not a surprise as all filesystems are in RO state.

See attached file `ultra24_syslog.txt`. 

I have tried using a wide variety of kernel boot parameters and scripts at
shutdown to unload the e1000e driver module prior to shutdown or use
/proc/sysrq-trigger instead of the usual command/s.

Upon reading about similar issues, I also tried blacklisting the acpi_cpufreq
module, to no avail.

This problem has happened across many kernel versions and also seems to be
distribution agnostic, from a skeleton TCLinux installation on a USB stick to
Ubuntu, Mint, PCLinuxOS and now Devuan: all distributions have sufferd the same

Attaching files:


Please advise or ask for addiitonal information if required.

Thanks in advance.


You may reply to this email to add a comment.

You are receiving this mail because:
You are watching the assignee of the bug.

acpi-bugzilla mailing list

Reply via email to