Hi there,

There was a post (http://www.mail-archive.com/alsa-user%
40lists.sourceforge.net/msg10844.html) suggesting a possible test/fix for 
getting ALSA to work on an ATI Radeon 9100 IGP system a short time ago, and 
as nobody had replied to say they had tried it I thought I would.

I tried adding the following line to intel8x0.c (as part of snd_intel8x0_ids) 
and it didn't seem to work:

 { 0x1002, 0x4341, PCI_ANY_ID, PCI_ANY_ID, 0, 0, DEVICE_INTEL },

This resulted in the following kernel messages:

------- snip -------
ALSA sound/pci/intel8x0.c:2442: unable to grab ports 0xdc105000-0xdc1050ff
Intel ICH: probe of 0000:00:14.5 failed with error -16
ALSA sound/pci/intel8x0.c:2782: joystick(s) found
------- snip -------

This was with the ALSA version built into the 2.6.3 kernel. My system is a 
Shuttle ST62K, which has the ATI Radeon 9100 IGP (RS300 + IXP150) chipset.

BTW, in case anyone else is trying to get Linux working on an ST62K, ST61G4 
(or any other 9100 IGP based system, for that matter), you may find the page 
I have set up useful:



SF.Net is sponsored by: Speed Start Your Linux Apps Now.
Build and deploy apps & Web services for Linux with
a free DVD software kit from IBM. Click Now!
Alsa-user mailing list

Reply via email to