I also have the same error.

I've tried creating the AVD on the command line and via the gui in the
Eclipse plugin.  Both created the AVD with no problems, but the
emulator still cannot find it.

I've tried running with the configuration set to Automatic, and to
Manual and manually selecting Launch a new Android Virtual Device and
checking the box next to 'my_avd', and the emulator still cannot find
it.  I know it exists, I can see it in "S:Documents and Settings

I've tried stopping and re-starting the ADB server, stopping and re-
starting Eclipse... nothing has fixed it.

This is on a new setup, just set up today.  Eclipse Galileo, Android
SDK 1.5_r3 for Windows, on XP.

The complete console:
[2009-08-25 06:11:11 - HelloAndroid] ------------------------------
[2009-08-25 06:11:11 - HelloAndroid] Android Launch!
[2009-08-25 06:11:11 - HelloAndroid] adb is running normally.
[2009-08-25 06:11:11 - HelloAndroid] Performing
com.example.helloandroid.HelloAndroid activity launch
[2009-08-25 06:11:11 - HelloAndroid] Automatic Target Mode: Preferred
AVD 'my_avd' is not available. Launching new emulator.
[2009-08-25 06:11:11 - HelloAndroid] Launching a new emulator with
Virtual Device 'my_avd'
[2009-08-25 06:11:12 - Emulator] emulator: ERROR: unknown virtual
device name: 'my_avd'
[2009-08-25 06:11:12 - Emulator] emulator: could not find virtual
device named 'my_avd'

You received this message because you are subscribed to the Google
Groups "Android Beginners" group.
To post to this group, send email to android-beginners@googlegroups.com
To unsubscribe from this group, send email to
For more options, visit this group at

Reply via email to