CVE-2018-1312: Weak Digest auth nonce generation in mod_auth_digest

Severity: Low

Vendor: The Apache Software Foundation

Versions Affected:
httpd 2.2.0 to 2.4.29

When generating an HTTP Digest authentication challenge, the nonce
sent to prevent reply attacks was not correctly generated using a
pseudo-random seed.  In a cluster of servers using a common Digest
authentication configuration, HTTP requests could be replayed across
servers by an attacker without detection.
All httpd users should upgrade to 2.4.30 or later.

The issue was discovered by Nicolas Daniels.


Reply via email to